Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 158262 - sci-libs/geos-3.0.0_rc3 failed
Summary: sci-libs/geos-3.0.0_rc3 failed
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Sci-geo Project
Depends on:
Reported: 2006-12-16 00:07 UTC by Grégoire Favre
Modified: 2006-12-17 11:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Grégoire Favre 2006-12-16 00:07:33 UTC
make[4]: Entering directory `/var/tmp/portage/sci-libs/geos-3.0.0_rc3/work/geos-3.0.0rc3/swig/python'
if /bin/sh ../../libtool --tag=CXX --mode=compile x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../source/headers -I../../source/headers/geos  -I/usr/include/python2.4 -I../../capi   -O2 -march=k8 -pipe -DGEOS_INLINE -Wall -ansi -pedantic -Wno-long-long -MT _geos_la-geos_wrap.lo -MD -MP -MF ".deps/_geos_la-geos_wrap.Tpo" -c -o _geos_la-geos_wrap.lo `test -f 'geos_wrap.cxx' || echo './'`geos_wrap.cxx; \
        then mv -f ".deps/_geos_la-geos_wrap.Tpo" ".deps/_geos_la-geos_wrap.Plo"; else rm -f ".deps/_geos_la-geos_wrap.Tpo"; exit 1; fi
mkdir .libs
 x86_64-pc-linux-gnu-g++ -DHAVE_CONFIG_H -I. -I. -I../../source/headers -I../../source/headers/geos -I/usr/include/python2.4 -I../../capi -O2 -march=k8 -pipe -DGEOS_INLINE -Wall -ansi -pedantic -Wno-long-long -MT _geos_la-geos_wrap.lo -MD -MP -MF .deps/_geos_la-geos_wrap.Tpo -c geos_wrap.cxx  -fPIC -DPIC -o .libs/_geos_la-geos_wrap.o
geos_wrap.cxx: In function 'void checkCoordSeqBounds(GEOSCoordSequence*, size_t)':
geos_wrap.cxx:3003: error: cannot convert 'size_t*' to 'unsigned int*' for argument '2' to 'int GEOSCoordSeq_getSize(const GEOSCoordSequence*, unsigned int*)'
geos_wrap.cxx: In function 'int GeosCoordinateSequence_getSize(GeosCoordinateSequence*)':
geos_wrap.cxx:3074: error: cannot convert 'size_t*' to 'unsigned int*' for argument '2' to 'int GEOSCoordSeq_getSize(const GEOSCoordSequence*, unsigned int*)'
geos_wrap.cxx: In function 'int GeosCoordinateSequence_getDimensions(GeosCoordinateSequence*)':
geos_wrap.cxx:3080: error: cannot convert 'size_t*' to 'unsigned int*' for argument '2' to 'int GEOSCoordSeq_getDimensions(const GEOSCoordSequence*, unsigned int*)'
geos_wrap.cxx: In function 'PyObject* _wrap_geomFromWKB(PyObject*, PyObject*)':
geos_wrap.cxx:8081: warning: dereferencing type-punned pointer will break strict-aliasing rules
geos_wrap.cxx: In function 'PyObject* _wrap_geomFromHEX(PyObject*, PyObject*)':
geos_wrap.cxx:8201: warning: dereferencing type-punned pointer will break strict-aliasing rules
make[4]: *** [_geos_la-geos_wrap.lo] Error 1
make[4]: Leaving directory `/var/tmp/portage/sci-libs/geos-3.0.0_rc3/work/geos-3.0.0rc3/swig/python'
make[3]: *** [all-recursive] Error 1
make[3]: Leaving directory `/var/tmp/portage/sci-libs/geos-3.0.0_rc3/work/geos-3.0.0rc3/swig/python'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/sci-libs/geos-3.0.0_rc3/work/geos-3.0.0rc3/swig/python'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/sci-libs/geos-3.0.0_rc3/work/geos-3.0.0rc3/swig'
make: *** [all-recursive] Error 1

!!! ERROR: sci-libs/geos-3.0.0_rc3 failed.
Call stack:, line 1576:   Called dyn_compile, line 945:   Called src_compile
  geos-3.0.0_rc3.ebuild, line 36:   Called die

Portage 2.1.2_rc3-r5 (default-linux/amd64/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.19 x86_64)
System uname: 2.6.19 x86_64 AMD Athlon(tm) 64 Processor 3000+
Gentoo Base System version 1.12.7
Last Sync: Sat, 16 Dec 2006 07:30:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [disabled]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
CFLAGS="-O2 -march=k8 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=k8 -pipe"
FEATURES="autoconfig distlocks fixpackages metadata-transfer parallel-fetch sandbox sfperms strict userfetch userpriv usersandbox"
LDFLAGS="-Wl,-O1 "
LINGUAS="en ko"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/portage/local/layman/science /usr/portage/local/layman/gentoo-de /usr/portage/local/layman/vdr-testing /usr/local/portage /usr/portage/local/layman/portage-xgl"
USE="amd64 3dnowex 64bit 7zip X Xaw3d a52 aac aalib acl acpi aim aio alsa amr ansi aotuv apache2 apm asf async atlas auctex audacious audiofile avahi bash-completion batch berkdb bidi bitmap-fonts blas bonjour bonobo browserplugin buffysize buttons bzip2 bzlib cairo caps cardclient cdda cddb cdio cdparanoia cdr cg chm chroot cli conax constcw corba cracklib crypt cryptoworks cscope css csv ctype cups curl curlwrappers daap dar64 dbus dga dio directfb divx divx4linux djbfft djvu dlloader doc dri dts dv dvb dvd dvdr dvdread dvi dynagraph ecc effects elibc_glibc encode exif expat exscalibar ext-doc ext-dvi ext-gnumeric ext-koffice ext-kpresenter ext-kspread ext-kword ext-lyx ext-man ext-openoffice ext-pdf ext-ppt ext-ps ext-rpm ext-rtf ext-tex ext-xls fame fasttrack fat fbcon ffmpeg fftw firefox flac flood fltk fontconfig foomaticdb fortran fping fpx freetext freetype2 gb gcl gd gdal gdbm general gg ggi gif gimp gimpprint ginac glibc-omitfp glitz glut glx gmedia gmp gmtfull gmthigh gmtsuppl gmttria gnome gnutella gnutls gopher gpgme gpm grammar graphviz grass gs gstreamer gtalk gtk gtk2 gtkhtml guile h323 hal hdf5 httpd iconv icq id3 idn ieee1394 imagemagick imlib input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 irc irdeto isdnlog ithreads jabber java javascript jbig jikes jp2 jpeg jpeg2k kernel_linux kig-scripting kqemu lame lapack latex lcms ldap libcaca libedit libg++ libnotify libsamplerate libtommath libvisual libwww linguas_en linguas_ko live lj lm_sensors lnbsharing logitech-mouse logrotate lzo mad matroska mbox mikmod mime mimencode mjpeg mng mod mono motif moznocompose moznoirc moznomail moznoroaming mozsvg mozxmlterm mp3 mp4 mp4live mpeg mpeg2 mplayer msn msnextras musepack mysql mythtv nagra nautilus ncurses nethack netpbm network nfs nls nntp normalizemime nptl nptlonly nsplugin nvidia nvram nvtv offensive ogg oggvorbis ole on-the-fly-crypt openexr opengl openssl oscar pam pcre pda pdf perl player plotutils png posix ppds pppd preview-latex pulseaudio python pyzor qhull qt3 qt4 quicktime rar readline recode reflection reiser4 reiserfs rss rtc rtsp sasl screen sdl seca session shl shout sid silc slang slp smime sms sndfile sox speex spell spl srt sse-filters ssl stream subtitles svg svgz szip tcl tcltk tcpd tetex theora thesaurus threads tiff tk tomsfastmath tools transcode truetype truetype-fonts type1-fonts udev unicode usb userland_GNU userlocales utf8 uudeview v4l v4l2 vcd vcdimager vdr viaccess video_cards_ati video_cards_fbdev video_cards_nv video_cards_nvidia video_cards_v4l video_cards_vesa video_cards_vga vim vim-pager vim-with-x vlm vorbis webdav wma wma123 wmf wmp wordperfect wv wxgtk1 wxwindows x264 xanim xattr xext xfs xine xinerama xinetd xml xml2 xorg xpm xprint xv xvid xvmc yahoo zlib"

Thank :)
Comment 1 Tiziano Müller (RETIRED) gentoo-dev 2006-12-16 03:17:01 UTC
Thanks for reporting the issue. Fixed in CVS, please give it some time to hit the mirrors, resync and emerge. Patch has been sent upstream.

sci-geo herd: Since postgresql-herd is also in metadata and we had a request for the bump, I did it. And since this bug-report is about the bump, I fixed it :-)
Comment 2 Grégoire Favre 2006-12-17 11:06:18 UTC
Thank : it worked great :)