Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 158003 - net-mail/mailwrapper removal request
Summary: net-mail/mailwrapper removal request
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Net-Mail Packages
: 281825 (view as bug list)
Depends on:
Blocks: 82772 222157
  Show dependency tree
Reported: 2006-12-13 03:13 UTC by Wolfram Schlich (RETIRED)
Modified: 2013-08-31 12:41 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Wolfram Schlich (RETIRED) gentoo-dev 2006-12-13 03:13:26 UTC
As talked about on IRC, we want to fix the whole mailwrapper thing:

app-admin/eselect: mailer module

Guys in Cc: please remove yourself if you're not interested in progress on this topic. Thanks!
Comment 1 Andre Hinrichs 2007-12-27 09:50:18 UTC
I ran into a mailwrapper problem when I tried to compile mailutils-1.2.
The email.eclass requires >=mailwrapper-0.2.1-r1 when the mailwrapper use flag is given. But unfortunately mailwrapper-0.2.1-r1 is hard masked.

Changing this dependency to >=mailwrapper-0.2.1 (without -r1), it seems to work. But of course I haven't done all necessary tests...

So, I like to ask, if there is any progress here, or if I should open a new bug for this (which was obviously introduced in August 2005!)?
Comment 2 Andrej Kacian (RETIRED) gentoo-dev 2007-12-28 14:06:57 UTC
(In reply to comment #1)
> I ran into a mailwrapper problem when I tried to compile mailutils-1.2.

Uhh, mailutils-1.2 is not even in the tree as far as I can see...
Comment 3 Andre Hinrichs 2007-12-28 19:11:47 UTC
Well, you are right! It's not in the tree. I fetched it from bug #158501 and I'm currently trying to get mailutils work with other software. As there is currently no maintainer for mailutils I'm afraid, it would otherwise take another year to get a stable ebuild. As I'm not very experienced in writing ebuilds, this could be my introduction to gentoo ebuild writing/maintaining.

But the mailutils package is not the point. The point is, that an eclass is referencing to a masked ebuild. In my opinion this should never hapen, should it?

But I'm also ready to get disabused if there is a reason for this reference.
Comment 4 Andrej Kacian (RETIRED) gentoo-dev 2007-12-29 14:44:49 UTC
There's also no email.eclass in official tree. Only eclass that's related here is mailer.eclass, which doesn't even mention mailutils package.

This eclass is currently only used by masked versions of MTA ebuilds, as mailer-config framework was supposed to replace current mailwrapper (with similar functionality as other *-config tools, like gcc-config, ruby-config, ...).

This (both mailwrapper and mailer-config) was designed to allow easier switching of MTAs (without having to unmerge old MTA before merging and configuring a new one due to portage blocks), but many think the usefulness doesn't outweigh the complexity to have each individual MTA installation adapted to this scheme.

Therefore it will probably be removed, although noone seems to be too eager to touch the stuff now.
Comment 5 Tobias Scherbaum (RETIRED) gentoo-dev 2008-06-10 19:05:19 UTC
ping - any progress, news or whatsoever?
Comment 6 Fabian Groffen gentoo-dev 2009-07-24 08:28:15 UTC
hmmm, yeah, status?  It seems bug #82772 at least suffers from mailwrapper-0.2.1-r1 being maked, since no symlinks are created at all.
Comment 7 Torsten Veller (RETIRED) gentoo-dev 2009-07-24 08:37:35 UTC
Current status: mailwrapper will be removed. 

I'd like to investigate if we can use the alternatives implementation from exh*rb* as a replacement. I already spend some time on it and have it installed locally. But i don't have the motivation to fight for an inclusion in eselect.
Comment 8 Fabian Groffen gentoo-dev 2009-07-24 08:40:23 UTC
Ohw.  In that case, mailwrapper support will be removed from Exim.

Please open a bug against Exim once is it known how to provide the right files/structure to have an {e,u}selectneclectable MTA.
Comment 9 Matus UHLAR - fantomas 2009-07-24 09:14:26 UTC
removed? mailwrapper is currently the only way how can I have msmtp and other mail package installed. Not even ssmtp, since newest versions don't support mailwrapper...
I hope mailwrapper won't get removed before any alternative way will be available.
Comment 10 Samuli Suominen (RETIRED) gentoo-dev 2009-08-17 18:37:31 UTC
*** Bug 281825 has been marked as a duplicate of this bug. ***
Comment 11 Samuli Suominen (RETIRED) gentoo-dev 2009-08-17 18:38:57 UTC
dertobi123: plain simple: doesn't work, lots of bugs, deprecated.
ssuominen: in short: the IUSE should be removed from affected ebuilds and
mailwrapper masked for removal?
dertobi123: that's a partially happening for quite some time, i've been
slacking on getting mailwrapper removed for quite some time though ;)

qa/treecleaners: Let's see if we can make this transition a bit more faster?
Comment 12 the_mgt 2010-10-26 22:56:07 UTC
I started writing an ebuild for a MTA not long ago, and since upstream provides for different methods to (additionally) use it with postfix on the same machine, I added mailwrapper support. I can clearly see why the mailwrapper concept was seen as plain ugly by so many people, since each mta ebuild overwrites/owns mailer.conf. But I stumbled upon a blog post or something from about 2005 proposing a method like this one:

So each mta installs one config and eselect (or mailer-config) switches the symlink. Pretty straight forward in my oppinion. Then I found mailwrapper support gone with postfix-2.6 and I read rumors, that mailwrapper is now finally going to die. But the mailwrapper ebuild is still in the tree, as is the mailer-config ebuild. Also, postfix-2.6 ebuilds still have the commented lines for mailer-config (they used to have commented lines with "mailwrapper" when postfix 2.5 was still in tree)

I see that this bug has been open for almost 4 years, but mailwrapper still didnt completely vanish, although it is currently unusable.

What is the current state? Will it definetly die? Are you planning a new approach and thats why the postfix ebuilds still have the comments? What would be needed to get the eselect/symlink approach into a working state? Is it a useless concept? If not, whats stopping it and how much work will be needed? What can I do to help?

Sorry for the length and amount of questions, but I am interested in this concept. Greetings
Comment 13 Tobias Scherbaum (RETIRED) gentoo-dev 2010-10-31 15:10:33 UTC
(In reply to comment #12)
> Sorry for the length and amount of questions, but I am interested in this
> concept. Greetings

It's dead, just not yet completely removed.

Comment 14 Eray Aslan gentoo-dev 2011-03-29 06:33:21 UTC
Mailwrapper support is gone from the tree.  Closing related bugs and some ebuild cleanup will wait until removal.

Please mask and remove:
Comment 15 Diego Elio Pettenò (RETIRED) gentoo-dev 2011-03-29 13:39:51 UTC
Eras, you can easily mask the packages yourself... QA only masks packages when nobody cares about them, and treecleaners take care of unmaintained packages.
Comment 16 Eray Aslan gentoo-dev 2011-03-30 04:55:06 UTC
# Eray Aslan <> (29 Mar 2011)
# Abandoned project.  Last release in 2005.  Bugs #158003, #97589,
# #359411.
# Removal in 90 days
Comment 17 Samuli Suominen (RETIRED) gentoo-dev 2011-04-29 14:01:37 UTC
no more mailwrapper in portage