Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 1574 - xemacs runs when emerge is running, otherwise it segfaults.
Summary: xemacs runs when emerge is running, otherwise it segfaults.
Status: RESOLVED DUPLICATE of bug 1501
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Matthew Kennedy (RETIRED)
: 1728 (view as bug list)
Depends on:
Reported: 2002-04-06 11:27 UTC by Sloan Poe
Modified: 2005-07-17 13:06 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Sloan Poe 2002-04-06 11:27:44 UTC
I was posting this under the othe xemacs bug report, but I think this is a
seperate bug.  

It seems that xemacs-21.1.14 will not run for me at all.  It segfaults
everytime.. EXCEPT when I'm emerging something.  I've tested this 7 times.  Its
the weirdest thing I've seen in a while, but whenever I'm emerging something,
xemacs will run.
Comment 1 Daniel Robbins (RETIRED) gentoo-dev 2002-04-07 00:23:37 UTC
When you're emerging something, xemacs is running through the sandbox. 
Forwarding to Bevin for comment/investigation.
Comment 2 Geert Bevin 2002-04-07 05:15:05 UTC
I suspect this has something to do with the glibs relocation bug. The problem is
that I can't keep the bug applied since it apparently breaks binary
compatibility with some binary packages (win4lin, accurev, ...).
Comment 3 Sloan Poe 2002-04-08 15:26:21 UTC
well it looks as though 21.4.6-r1 got unmasked.. though when I tried to merge it the 
configure script fails complaining about nas.. I commented all the sound stuff out, 
then it started complaining about gnudbm..  
Comment 4 jseng 2002-04-09 10:42:32 UTC
21.4.6-r1 seems to be working for me.  I added --with-msw=no to the configure
flags, since I have wine installed.  There is a little delay at startup where
the window appears, but none of the text shows up - I haven't figured that out
yet.  One additional error to report:

# emerge --verbose

 * Regenerating GNU info directory index...
install-info: warning: no info dir entry in `/usr/share/info/'
 * Processed 90 info files; 1 errors.
Comment 5 Arcady Genkin (RETIRED) gentoo-dev 2002-04-09 11:17:43 UTC
What do you mean by "none of the text shows up"?
Can you try "xemacs -debug-init" and "xemacs -vanilla" and see if the former
will report anything useful, and if the latter will fix the slowness?

As to the missing info dir entry, you might want to report it as a separate bug
(if it hasn't been already), since AFAIK this has nothing to do with xemacs (or
am I wrong?).
Comment 6 Sloan Poe 2002-04-09 16:58:55 UTC
 so I added the --with-msw=no line in as well and miraculously 24.4.6-r1 compiled for 
me.  Though I still seem to be having the segmentation fault problem...  
Comment 7 Matt Pharr 2002-04-12 18:36:20 UTC
I'm seeing this bug as well.  (Core dump is below.)  Interestingly
enough, I am also seeing the behavior where it runs ok if emerge
is running, but otherwise it just dumps core.

(gdb) where
#0  0x404aea8f in malloc () from /lib/
#1  0x404ae8e4 in malloc () from /lib/
#2  0x08084a6f in xmalloc ()
#3  0x080aa3d0 in xemacs_21_4_6_i686_pc_linux ()
#4  0x080a97ca in xemacs_21_4_6_i686_pc_linux ()
#5  0x080ac055 in main ()
#6  0x404553c1 in __libc_start_main () from /lib/
Comment 8 Pierre-Henri Jondot 2002-04-14 11:53:24 UTC
For my part, xemacs did always segfault, even when emerging. 

But the binary generated with

SANDBOX_DISABLED="1" emerge xemacs

does work fine...
Comment 9 Sloan Poe 2002-04-14 18:43:43 UTC
I tried this and it solved my problem totoally..

SANDBOX_DISABLED="1" emerge xemacs
Comment 10 Matthew Kennedy (RETIRED) gentoo-dev 2002-04-15 02:44:52 UTC
*** Bug 1728 has been marked as a duplicate of this bug. ***
Comment 11 Matthew Kennedy (RETIRED) gentoo-dev 2002-04-16 23:21:58 UTC

*** This bug has been marked as a duplicate of 1501 ***