Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 157307 - vmware-modules-1.0.0.1{3,5}-r1 fails on kernel 2.6.19-rc{5,6}-mm{1,2}
Summary: vmware-modules-1.0.0.1{3,5}-r1 fails on kernel 2.6.19-rc{5,6}-mm{1,2}
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
: 158694 165972 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-12-06 04:09 UTC by Rafael Fortes
Modified: 2007-03-16 09:38 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
new compat_kernel.h (compat_kernel.h,1.21 KB, text/plain)
2006-12-07 09:09 UTC, Florian Demski
Details
script to build modules (build.sh,605 bytes, text/plain)
2006-12-07 09:10 UTC, Florian Demski
Details
Patch for compat_kernel.h (compat_kernel.h.patch,1.08 KB, patch)
2006-12-17 08:30 UTC, Robert Wruck
Details | Diff
corrected script to build modules (vmware.sh,662 bytes, text/plain)
2007-01-02 03:29 UTC, JG
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Rafael Fortes 2006-12-06 04:09:18 UTC
User-Agent:       Mozilla/5.0 (Windows; U; Windows NT 5.1; pt-BR; rv:1.8.1) Gecko/20061010 Firefox/2.0
Build Identifier: 

As reported on this thread http://bugs.gentoo.org/show_bug.cgi?id=152322
vmware-modules won't compile on mm-sources, and give this error:

>> Emerging (1 of 1) app-emulation/vmware-modules-1.0.0.15-r1 to /
--13:46:20-- 
http://distfiles.gentoo.org/distfiles/vmware-any-any-update105.tar.gz
           => `/usr/portage/distfiles/vmware-any-any-update105.tar.gz'
Resolving distfiles.gentoo.org... 216.165.129.135, 156.56.247.195,
64.50.236.52, ...
Connecting to distfiles.gentoo.org|216.165.129.135|:80... connected.
HTTP request sent, awaiting response... 200 OK
Length: 296,970 (290K) [application/x-gzip]

100%[=================================================================================================>]
296,970      131.10K/s

13:46:23 (130.70 KB/s) -
`/usr/portage/distfiles/vmware-any-any-update105.tar.gz' saved [296970/296970]

 * Determining the location of the kernel source code
 * Found kernel source directory:
 *     /usr/src/linux
 * Found sources for kernel version:
 *     2.6.19-rc6-mm2
 * Applying various patches (bugfixes/updates) ...
 *   000_all_makefile-include-directory.patch ...                              
                                                       [ ok ]
 * Done with patching
 * Converting vmmon-only/Makefile to use M= instead of SUBDIRS= ...            
                                                       [ ok ]
 * Applying various patches (bugfixes/updates) ...
 *   000_all_makefile-include-directory.patch ...                              
                                                       [ ok ]
 * Done with patching
 * Converting vmnet-only/Makefile to use M= instead of SUBDIRS= ...            
                                                       [ ok ]
 * Preparing vmmon module
Using 2.6.x kernel build system.
make -C /usr/src/linux/include/.. M=$PWD SRCROOT=$PWD/. modules
make[1]: Entering directory `/usr/src/linux-2.6.19-rc6-mm2'
make[1]: warning: jobserver unavailable: using -j1.  Add `+' to parent make
rule.
  CC [M] 
/var/tmp/portage/vmware-modules-1.0.0.15-r1/work/vmmon-only/linux/driver.o
In file included from
/var/tmp/portage/vmware-modules-1.0.0.15-r1/work/vmmon-only/linux/driver.c:85:
/var/tmp/portage/vmware-modules-1.0.0.15-r1/work/vmmon-only/./include/compat_kernel.h:21:
error: expected declaration specifiers or '...' before 'compat_exit'
/var/tmp/portage/vmware-modules-1.0.0.15-r1/work/vmmon-only/./include/compat_kernel.h:21:
error: expected declaration specifiers or '...' before 'exit_code'
/var/tmp/portage/vmware-modules-1.0.0.15-r1/work/vmmon-only/./include/compat_kernel.h:21:
warning: type defaults to 'int' in declaration of '_syscall1'
make[3]: ***
[/var/tmp/portage/vmware-modules-1.0.0.15-r1/work/vmmon-only/linux/driver.o]
Error 1
make[2]: ***
[_module_/var/tmp/portage/vmware-modules-1.0.0.15-r1/work/vmmon-only] Error 2
make[1]: *** [modules] Error 2
make[1]: Leaving directory `/usr/src/linux-2.6.19-rc6-mm2'
make: *** [vmmon.ko] Error 2

!!! ERROR: app-emulation/vmware-modules-1.0.0.15-r1 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  ebuild.sh, line 1255:   Called linux-mod_src_compile
  linux-mod.eclass, line 510:   Called die

!!! Unable to make   auto-build VMWARE_VER=VME_S1B1 KERNEL_DIR=/usr/src/linux
KBUILD_OUTPUT=/usr/src/linux.
!!! If you need support, post the topmost build error, and the call stack if
relevant.

!!! This ebuild is from an overlay: '/usr/portage/local/layman/vmware'

I'm creating a new bug report because the last one was closed (the bug reported
there made reference to vanilla-sources and was solved, so it was asked to
someone create a new report).

Reproducible: Always

Steps to Reproduce:
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-12-06 04:14:21 UTC
Kindly review http://bugs.gentoo.org/page.cgi?id=fields.html#bug_severity; mm-sources is not a supported kernel.

http://www.gentoo.org/doc/en/gentoo-kernel.xml#doc_chap2
Comment 2 Florian Demski 2006-12-07 09:09:27 UTC
Created attachment 103549 [details]
new compat_kernel.h
Comment 3 Florian Demski 2006-12-07 09:10:06 UTC
Created attachment 103551 [details]
script to build modules
Comment 4 Florian Demski 2006-12-07 09:12:02 UTC
Copy compat_kernel.h and build.sh to a new directory and run the script.

This builds the modules on my AMD64 machine.

If vmware-workstation works --- we'll see. I am still downloading the package.

Cheers,

Florian
Comment 5 Florian Demski 2006-12-07 09:55:45 UTC
In order to get vmware running correctly, I had to modify /etc/vmware/init.d/vmware

In vmware_load_module() I had to change the extension from o to ko:
   /sbin/insmod -s -f "/lib/modules/`uname -r`/misc/$1.ko" || exit 1

Also the ping test did not work, so I commented it out:

   #if lookForHostOnlyNetwork "$ifIp"; then
   # echo 'Host-only networking disabled because '"$ifIp"
   # echo 'appears to be a real, physical, existing address.'
   # echo 'Please run "'"$vmdb_answer_BINDIR"'/vmware-config.pl" to'
   # echo 'modify your host-only network configuration.'
   # exit 1
   #fi

Besides, /etc/init.d/vmware restart does not work, so issue stop and then start.

Cheers,

Florian
Comment 6 Robert Wruck 2006-12-17 08:30:42 UTC
Created attachment 104214 [details, diff]
Patch for compat_kernel.h

A better way than just commenting out _syscall1 would be to move it down into the #else clause.
This bug seems to affect all newer kernels (2.6.20-rc1 in my case).
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-12-20 20:51:14 UTC
*** Bug 158694 has been marked as a duplicate of this bug. ***
Comment 8 JG 2007-01-02 03:29:03 UTC
Created attachment 105147 [details]
corrected script to build modules

the script from comment #3 didn't work for me as it has specified the wrong paths, e.g. "/var/tmp/portage/vmware-modules-..." => should be "/var/tmp/portage/app-emulation/vmware-modules-".
after the change the vmware modules build fine on my vanilla 2.6.20-rc2.

JG
Comment 9 Marc Doughty 2007-01-11 02:59:45 UTC
Any movement here? This is affecting anyone using kernels 2.6.19 or newer and a lot of brand-new hardware is forcing the issue. I know I have an Intel Q965 board that requires 2.6.20-RCx for the CD-ROM to work. I'm not too keen on deciding at boot time between VMWare or CD-ROM.
Comment 10 Erik R. Jensen 2007-01-11 05:12:52 UTC
I hadn't seen any progress on the issue either, so I created a simple portage overlay with a patch I created that allowed me to get the vmware-modules built with 2.6.20 mm kernel I'm using.

http://backups.netradius.com/portage-vmware-modules.tgz
Comment 11 Mike Auty gentoo-dev 2007-01-11 10:09:32 UTC
Hi guys,

First off, thanks for providing that overlay tarball, I hope it works as an interim fix before we're able to get a working version out and available.

Secondly, I'm afraid that we're all waiting.  The situation is that we're making use of a third party version of the module sources which are far more compatible with the various kernels than those provided directly within the vmware source itself.  This single set of sources works with all vmware products and often supports the latest kernels sooner than the official sources.  The problem however, is that they do not tend to release new versions for fixes in RC kernels, or in -mm kernels.  That in turn makes it very difficult for us to be able to support experimental and -mm kernels ourselves, *whilst still maintaining backwards compatibility* for all the other people using previous kernel versions.

What this unfortunately means is that we're not going to be able to update the vmware modules any time soon, until the next vmware-any-any source package becomes available.  You can watch the sources at http://ftp.cvut.cz/vmware/ and when it goes up from 105 to 106, that may well include fixes for compiling on 2.6.20 kernels (and 2.6.19-mm kernels).  If it does feel free to poke me on IRC or drop me an email or something.  Until then I'm afraid it will have to be a specific workaround such as the overlay that Erik very kindly posted.

I'm sorry I can't give you any better news...  5:(
Comment 12 Marc Doughty 2007-01-30 19:05:06 UTC
(In reply to comment #11)
> You can watch the sources at http://ftp.cvut.cz/vmware/ and
> when it goes up from 105 to 106, that may well include fixes for compiling on
> 2.6.20 kernels (and 2.6.19-mm kernels).  If it does feel free to poke me on IRC
> or drop me an email or something.  Until then I'm afraid it will have to be a
> specific workaround such as the overlay that Erik very kindly posted.
> 
> I'm sorry I can't give you any better news...  5:(

Good News! version 107 seems to be out! Please, save me from QEMU!
Comment 13 Mike Auty gentoo-dev 2007-01-31 08:26:12 UTC
Hi guys,

I've bumped the version in the overlay for testing for a few days, so please could you give that a test?

To install the overlay, emerge layman, follow the instructions and then do "layman -a vmware".

Please note, this will only work with vmware-server, vmware-workstation will probably start complaining about broken digests, because there isn't a version of it in the overlay.  You can either emerge with the --digest flag, or wait for it to hit the main tree.

Please report any bugs with it back here for now, and hopefully we'll be able to finally close off this bug...  5:)
Comment 14 Marc Doughty 2007-02-02 17:22:35 UTC
(In reply to comment #13)
> I've bumped the version in the overlay for testing for a few days, so please
> could you give that a test?

I emerged it, then removed the overlay and used it with vmware-workstation 5.5 just fine. Let's get this thing into portage!
Comment 15 Mike Auty gentoo-dev 2007-02-05 10:26:13 UTC
Ok, since 2.6.20 just went stable it was time to get this into the main tree.  I just pushed the any-any107 update out so give the servers a couple of hours and then resync and please let me know if there are any problems.  If there are feel free to reopen this bug.  Sorry for the delay...  5:)
Comment 16 Jakub Moc (RETIRED) gentoo-dev 2007-02-08 19:13:53 UTC
*** Bug 165972 has been marked as a duplicate of this bug. ***