Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 157201 - hal-0.5.7.1-r2 configure fails to detect dbus-glib
Summary: hal-0.5.7.1-r2 configure fails to detect dbus-glib
Status: VERIFIED DUPLICATE of bug 1343
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Project Gentopia
URL:
Whiteboard:
Keywords:
: 157235 157767 161013 162838 163169 186564 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-12-05 02:49 UTC by Alexander Jenisch
Modified: 2007-07-25 11:48 UTC (History)
9 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
hal-0.5.7.1-r2 config.log (config.log,49.22 KB, text/plain)
2006-12-05 02:50 UTC, Alexander Jenisch
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Alexander Jenisch 2006-12-05 02:49:56 UTC
checking for PACKAGE... configure: error: Package requirements (glib-2.0 >= 2.6.0, gobject-2.0 >= 2.6.0, dbus-glib-1 >= 0.33, dbus-1 >= 0.33) were not met:

No package 'dbus-glib-1' found

root@enti $ emerge --info
Portage 2.1.2_rc2-r5 (default-linux/amd64/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r3 x86_64)
=================================================================
System uname: 2.6.18-gentoo-r3 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.12.6
Last Sync: Tue, 05 Dec 2006 09:00:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r2
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -O2 -pipe -ftracer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O2 -pipe -ftracer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache cvs distlocks fixpackages metadata-transfer prelink sandbox sfperms strict"
GENTOO_MIRRORS="http://ftp.club-internet.fr/pub/mirrors/gentoo ftp://gentoo.imj.fr/pub/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X Xaw3d a52 acpi aiglx airo alsa apache2 asf audiofile automount avi bash-completion berkdb bitmap-fonts bzip2 bzlib cairo cdda cdparanoia cli cpudetection cracklib crypt ctype cups curl cvs dbus dga dir divx4linux dlloader dri dts dvd dvdread elibc_glibc encode fam ffmpeg foomaticdb fortran freetype ftp gcc64 gd gdbm gif gimpprint glx gphoto2 gpm gtk gtk2 hal iconv icq imagemagick imap imlib input_devices_keyboard input_devices_mouse ipv6 isdnlog ithreads java javascript jpeg jpeg2k kde kdeenablefinal kernel_linux ldap libg++ lm_sensors logitech-mouse lzo mad maildir mikmod mime modplug mp3 mp4 mpeg musicbrainz mysql ncurses nls nocd nptl nptlonly nsplugin nvidia offensive ogg oggvorbis openal opengl openntpd oss pam pcre pdf pdflib perl php png posix ppds pppd python qt qt3 quicktime rdesktop readline reflection rowserplugin rtc samba sasl scenarios sdl server session slp sndfile sockets spamassassin speex spell spl sql ssl stream subversion svg swat syslog tcltk tcpd tetex tga theora threads tiff timidity truetype truetype-fonts type1-fonts udev unicode usb userland_GNU video_cards_nv video_cards_nvidia video_cards_vesa videos visualization vorbis webdav wma x264 xft xine xml xml2 xorg xosd xpm xv xvid xvmc zeroconf zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alexander Jenisch 2006-12-05 02:50:41 UTC
Created attachment 103384 [details]
hal-0.5.7.1-r2 config.log
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-12-05 02:53:46 UTC
Which dbus version? Do you have dbus-glib installed?
Comment 3 Alexander Jenisch 2006-12-05 03:40:02 UTC
actually, a "revdep-rebuild" solved it. sorry for the noise.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-12-05 03:57:20 UTC
Well, it's noted in big bold letters in upgrade instructions. Thanks, closing. ;)
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-12-05 12:12:25 UTC
*** Bug 157235 has been marked as a duplicate of this bug. ***
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-12-05 12:16:07 UTC
Reopen to resolve properly...
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-12-05 12:16:30 UTC
If we tell you to run revdep-rebuild, we really mean it.
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-12-10 14:23:46 UTC
*** Bug 157767 has been marked as a duplicate of this bug. ***
Comment 9 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2006-12-10 14:36:12 UTC
I got my bug marked as dupe, but your comments about revdep-rebuild are singularlly unhelpful.

revdep-rebuild does NOT provide anything relevant here, and hal still fails until dbus-glib is present.

grubbs-int ~ # revdep-rebuild -p -v
Configuring search environment for revdep-rebuild

Checking reverse dependencies...

Packages containing binaries and libraries broken by a package update
will be emerged.

Collecting system binaries and libraries... done.
  (/root/.revdep-rebuild.1_files)

Collecting complete LD_LIBRARY_PATH... done.
  (/root/.revdep-rebuild.2_ldpath)

Checking dynamic linking consistency...
  broken /usr/lib/python2.4/site-packages/_audit.la (requires /lib/libaudit.la)
  broken /usr/lib64/python2.4/site-packages/_audit.la (requires /lib/libaudit.la)
 done.
  (/root/.revdep-rebuild.3_rebuild)

Assigning files to ebuilds... done.
  (/root/.revdep-rebuild.4_ebuilds)

Evaluating package order... done.
  (/root/.revdep-rebuild.5_order)

All prepared. Starting rebuild...
emerge --oneshot -p -v =sys-process/audit-1.2.9 

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] sys-process/audit-1.2.9  0 kB 

Total: 1 packages (1 reinstalls), Size of downloads: 0 kB
Now you can remove -p (or --pretend) from arguments and re-run revdep-rebuild.
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-12-10 14:40:44 UTC
(In reply to comment #9)
> I got my bug marked as dupe, but your comments about revdep-rebuild are
> singularlly unhelpful.
> 
> revdep-rebuild does NOT provide anything relevant here, and hal still fails
> until dbus-glib is present.

Eh, what do you mean "until dbus-glib is present"? It already depends on it...

<snip>
 || ( >=dev-libs/dbus-glib-0.71 <sys-apps/dbus-0.90 )
</snip>
Comment 11 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2006-12-10 14:45:54 UTC
grubbs-int ~ # emerge --unmerge hal dbus-glib
...
grubbs-int ~ # emerge -pv hal

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild  N    ] sys-apps/hal-0.5.7.1-r2  USE="acpi crypt -debug -dmi -doc -pcmcia (-selinux)" 0 kB 

Total: 1 packages (1 new), Size of downloads: 0 kB

Moving the dbus-glib depend outside of the conditional || resolves this.
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2006-12-10 14:48:12 UTC
(In reply to comment #11)
> Moving the dbus-glib depend outside of the conditional || resolves this.

Well, that's absolutely not an option... Which dbus version you have installed?

Comment 13 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2006-12-10 15:20:04 UTC
dbus-1.0.1-r2 here, but there seems to be a blip with the deptree, read on.

I played with this some more, and I can provide one reliable means to reproduce this so far.

1. Downgrade yourself to the old dbus.
2. remove hal, dbus-glib and anything else you have depending on dbus and hal.
3. at this point, 'emerge -pv dbus hal' shows this:
Calculating dependencies... done!
[ebuild     U ] sys-apps/dbus-1.0.1-r2 [0.62-r1] USE="-X -debug -doc (-selinux) (-gtk%) (-mono%) (-python%*) (-qt3%) (-qt4%)" 0 kB 
[ebuild  N    ] sys-apps/hal-0.5.7.1-r2  USE="acpi crypt -debug -dmi -doc -pcmcia (-selinux)" 0 kB 

This deptree is obviously wrong, as if you install dbus-1.0.1* first, then hal wants to bring in dbus-glib. 

If you happen to have something else that actually uses dbus-glib already installed, then revdep-rebuild should help you, but if you don't then you end up in this weird situtation.
Comment 14 Jakub Moc (RETIRED) gentoo-dev 2006-12-10 15:24:00 UTC
(In reply to comment #13)
> dbus-1.0.1-r2 here, but there seems to be a blip with the deptree, read on.

Looks like dupe of Bug 1343

Anyway, in earlier hal version, it used to state:

<snip>
||      (
                >=dev-libs/dbus-glib-0.71
                ( <sys-apps/dbus-0.90 >=sys-apps/dbus-0.60 )
        )
</snip>

Does that help in any way?
Comment 15 Doug Goldstein gentoo-dev 2006-12-10 15:36:44 UTC
Yeah. It's a 1343 dup. The situation is interesting enough in the fact that if you have multiple things that consume the bindings, you will find that it will inject the dbus-glib depend in there. But if you only have 1 dbus consumer in your deptree, then you'll get the issue. 

revdep-rebuild will actually solve it how you have it, Robin. Because hal emerge should (and will fail). you'll run revdep-rebuild, it will go to rebuild hal, which will then check the dbus version, which is now 1.0.1-r2 and depend on dbus-glib and pull it in. If you had something like ivman installed, and it needed upgrade as well, it would have actually had dbus-glib in your original deptree and it will have continued on happily then you would have had to revdep-rebuild to fix the other apps.

I don't really see a solution other then fixing bug #1343.
Comment 16 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2006-12-10 19:28:12 UTC
yeah, bug 1343 is the source of it :-(.

cardoe: I don't see how revdep-rebuild will solve that, look at the revdep-rebuild -p output I posted that shows it not rebuilding hal at all.
Comment 17 Doug Goldstein gentoo-dev 2006-12-11 17:33:18 UTC
well then something is grossly wrong with your system. dbus-0.62 provides libdbus.so.2 and dbus-1.0 provides libdbus.so.3. All dbus using applications will 100% require a relink. dbus-0.62 also provides libdbus-glib.so.1 and dbus-1.0 does not provide any glib. So installing dbus 1.0 from dbus 0.62 (or any version before) would cause the hal binary to have a broken link on libdbus-glib.so.1 and revdep-rebuild should pick up dev-libs/dbus-glib as the provider. Also, it will see the soversion increase on libdbus.so and cause hal to rebuild.
Comment 18 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2006-12-11 18:28:40 UTC
My system may be weird, but the deptree is still broken per bug 1343.
How about bringing dbus-glib in as a PDEPEND of dbus?
Comment 19 Doug Goldstein gentoo-dev 2006-12-11 19:33:02 UTC
It's not a PDEPEND though. I have a machine here that doesn't use glib bindings to talk to dbus at all.
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2006-12-12 02:32:31 UTC
(In reply to comment #18)
> My system may be weird, but the deptree is still broken per bug 1343.
> How about bringing dbus-glib in as a PDEPEND of dbus?

Uhm, we already have a dbus/qt/cups circular dependency; this could make it way worse. So, bad idea IMO. 

Comment 21 Doug Goldstein gentoo-dev 2006-12-14 14:16:14 UTC
Can we just mark this as a dup of 1343?
Comment 22 Jakub Moc (RETIRED) gentoo-dev 2006-12-14 14:19:20 UTC
Was about to suggest this... :)

*** This bug has been marked as a duplicate of 1343 ***
Comment 23 Alexander Skwar 2007-01-06 11:10:40 UTC
I don't quite understand - what's the solution to fix this problem? I've got the following output after running emerge -Duvat world:


These are the packages that would be merged, in reverse order:

Calculating world dependencies /
!!! Multiple versions within a single package slot have been
!!! pulled into the dependency graph:

('ebuild', '/', 'sys-apps/dbus-1.0.2', 'merge') pulled in by
   ('ebuild', '/', 'dev-libs/dbus-glib-0.72', 'merge')

('ebuild', '/', 'sys-apps/dbus-0.62-r2', 'nomerge') pulled in by
   ('ebuild', '/', 'x11-libs/libnotify-0.4.3', 'nomerge')
   ('ebuild', '/', 'sys-apps/hal-0.5.7.1-r2', 'nomerge')
   ('ebuild', '/', 'x11-misc/notification-daemon-0.3.6-r1', 'nomerge')
   ('ebuild', '/', 'gnome-base/gnome-panel-2.16.2', 'nomerge')
   ('ebuild', '/', 'media-video/totem-2.16.4', 'nomerge')
   ('ebuild', '/', 'gnome-base/gnome-mount-0.4-r5', 'nomerge')
   ('ebuild', '/', 'gnome-base/gnome-vfs-2.16.3', 'nomerge')
   ('ebuild', '/', 'gnome-extra/nautilus-cd-burner-2.16.2', 'nomerge')

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

!!! Depgraph creation failed.



alexander@blatt ~ $ ls -lad /var/db/pkg/*/*{hal,dbus}*
drwxr-xr-x 2 root root 4096 21. Nov 07:30 /var/db/pkg/app-crypt/hashalot-0.3-r2
drwxr-xr-x 2 root root 4096  9. Sep 23:57 /var/db/pkg/games-misc/fortune-mod-simpsons-chalkboard-0.1
drwxr-xr-x 2 root root 4096 17. Dec 12:06 /var/db/pkg/sys-apps/dbus-0.62-r2
drwxr-xr-x 2 root root 4096 17. Dec 12:09 /var/db/pkg/sys-apps/hal-0.5.7.1-r2

This means, that I've got hal-0.5.7.1-r2 and dbus-062-r2 installed. dbus 1.x isn't installed. And also not dbus-glib.


alexander@blatt ~ $ emerge --info
Portage 2.1.2_rc4-r4 (default-linux/x86/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.19-suspend2-r1.045 i686)
=================================================================
System uname: 2.6.19-suspend2-r1.045 i686 Intel(R) Celeron(R) M processor         1.50GHz
Gentoo Base System version 1.12.8
Last Sync: Sat, 06 Jan 2007 10:20:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.19
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mtune=pentium-m -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -mtune=pentium-m -pipe -fomit-frame-pointer"
DISTDIR="/Gentoo/Portage/distfiles"
EMERGE_DEFAULT_OPTS="--alphabetical"
FEATURES="autoconfig buildpkg ccache collision-protect distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="        http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/   http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/      ftp://ftp.tu-clausthal.de/pub/linux/gentoo/     http://distro.ibiblio.org/pub/linux/distributions/gentoo/ ftp://distro.ibiblio.org/pub/linux/distributions/gentoo         http://distfiles.gentoo.org/ "
LANG="de_DE.UTF-8"
LINGUAS="de"
PKGDIR="/Gentoo/Portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/Gentoo/Portage/build"
PORTDIR="/Gentoo/Portage/tree"
PORTDIR_OVERLAY="/Gentoo/Portage/local-tree/misc"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="alsa berkdb bitmap-fonts cli cracklib crypt dlloader dri esd fortran gdbm gnome gstreamer hal iconv isdnlog kdeenablefinal kdehiddenvisibility libedit libg++ libnotify ncurses nls nptl nptlonly pcre perl ppds pppd python readline reflection session spl ssl tcpd truetype-fonts type1-fonts udev unicode x86 xorg zlib" ALSA_CARDS="loopback usb-audio via82xx" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LINGUAS="de" USERLAND="GNU" VIDEO_CARDS="fbdev vesa vga via"
Unset:  CTARGET, INSTALL_MASK, LC_ALL, LDFLAGS, MAKEOPTS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 24 Jakub Moc (RETIRED) gentoo-dev 2007-01-06 11:15:57 UTC
(In reply to comment #23)
> I don't quite understand - what's the solution to fix this problem?

Fix portage as in go read bug 1343. Meanwhile, emerge --oneshot dbus.
Comment 25 Alexander Skwar 2007-01-06 11:24:26 UTC
(In reply to comment #24)
> (In reply to comment #23)
> > I don't quite understand - what's the solution to fix this problem?
> 
> Fix portage as in go read bug 1343. Meanwhile, emerge --oneshot dbus.
> 

So the solution is to manually upgrade dbus followed by a revdep-rebuild? Afterwards, depgraph creation should work?
Comment 26 Doug Goldstein gentoo-dev 2007-01-06 15:17:53 UTC
Well when you upgrade dbus it tells you to immediately run revdep-rebuild. It's not a suggestion. It's a must.
Comment 27 Alexander Skwar 2007-01-06 15:53:52 UTC
(In reply to comment #26)
> Well when you upgrade dbus it tells you to immediately run revdep-rebuild.

Ah, I see. I didn't want to upgrade dbus, though. And emerge did not show that message, as emerge died earlier with the error message I pasted in comment #23.

> It's
> not a suggestion. It's a must.

Thanks.
Comment 28 Jakub Moc (RETIRED) gentoo-dev 2007-01-08 22:00:37 UTC
*** Bug 161013 has been marked as a duplicate of this bug. ***
Comment 29 Matthew Schultz 2007-01-08 22:53:55 UTC
(In reply to comment #24)
> (In reply to comment #23)
> > I don't quite understand - what's the solution to fix this problem?
> 
> Fix portage as in go read bug 1343. Meanwhile, emerge --oneshot dbus.
> 

I did the oneshot on dbus and then attempted to do a revdep-rebuild.  Any solutions?

All prepared. Starting rebuild...
emerge --oneshot  =sys-apps/hal-0.5.7-r3 =net-print/cups-1.2.6 =gnome-base/gnome-vfs-2.16.3 =gnome-base/libgnome-2.16.0 =gnome-base/libbonoboui-2.16.0 =gnome-base/gnome-mount-0.4-r5 =kde-base/kdebase-kioslaves-3.5.5-r1 =net-im/gaim-2.0.0_beta5-r3 =sys-apps/pmount-0.9.9 =sys-apps/ivman-0.6.12 =x11-plugins/beryl-dbus-0.1.4
..........
Calculating dependencies -
!!! All ebuilds that could satisfy "dev-libs/dbus-qt3-old" have been masked.
!!! One of the following masked packages is required to complete your request:
- dev-libs/dbus-qt3-old-0.70 (masked by: ~amd64 keyword)

For more information, see MASKED PACKAGES section in the emerge man page or
refer to the Gentoo Handbook.
(dependency required by "kde-base/kdebase-kioslaves-3.5.5-r1" [ebuild])


revdep-rebuild failed to emerge all packages
you have the following choices:

- if emerge failed during the build, fix the problems and re-run revdep-rebuild
    or
- use -X or --package-names as first argument (trys to rebuild package, not exact
  ebuild)
    or
- set ACCEPT_KEYWORDS="~<your platform>" and/or /etc/portage/package.unmask
  (and remove /root/.revdep-rebuild.5_order to be evaluated again)
    or
- modify the above emerge command and run it manually
    or
- compile or unmerge unsatisfied packages manually, remove temporary files and
  try again (you can edit package/ebuild list first)

To remove temporary files, please run:
rm /root/.revdep-rebuild*.?_*
Comment 30 Matthew Schultz 2007-01-08 22:57:53 UTC
After keywording the package it was complaining about.  I have a new error. Wow this is quite a pain in the ass.  Who'd have known that gaim-2.0.0-r3 could cause such a headache and break a bunch of stuff?


checking for PACKAGE... configure: error: Package requirements (glib-2.0 >= 2.6.0, gobject-2.0 >= 2.6.0, dbus-glib-1 >= 0.33, dbus-1 >= 0.33) were not met:

No package 'dbus-glib-1' found

Consider adjusting the PKG_CONFIG_PATH environment variable if you
installed software in a non-standard prefix.

Alternatively, you may set the environment variables PACKAGE_CFLAGS
and PACKAGE_LIBS to avoid the need to call pkg-config.
See the pkg-config man page for more details.


!!! Please attach the following file when filing a report to bugs.gentoo.org:
!!! /var/tmp/portage/hal-0.5.7-r3/work/hal-0.5.7/config.log

!!! ERROR: sys-apps/hal-0.5.7-r3 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_compile
  ebuild.sh, line 937:   Called src_compile
  hal-0.5.7-r3.ebuild, line 128:   Called econf '--with-doc-dir=/usr/share/doc/hal-0.5.7-r3' '--with-os-type=gentoo' '--with-pid-file=/var/run/hald.pid' '--enable-hotplug-map' '--disable-verbose-mode' '--disable-pcmcia-support' '--disable-acpi-proc' '--disable-docbook-docs' '--disable-doxygen-docs' '--disable-selinux'
  ebuild.sh, line 540:   Called die

!!! econf failed
!!! If you need support, post the topmost build error, and the call stack if relevant.


revdep-rebuild failed to emerge all packages
you have the following choices:

- if emerge failed during the build, fix the problems and re-run revdep-rebuild
    or
- use -X or --package-names as first argument (trys to rebuild package, not exact
  ebuild)
    or
- set ACCEPT_KEYWORDS="~<your platform>" and/or /etc/portage/package.unmask
  (and remove /root/.revdep-rebuild.5_order to be evaluated again)
    or
- modify the above emerge command and run it manually
    or
- compile or unmerge unsatisfied packages manually, remove temporary files and
  try again (you can edit package/ebuild list first)

To remove temporary files, please run:
rm /root/.revdep-rebuild*.?_*
Comment 31 Matthew Schultz 2007-01-08 23:00:46 UTC
This is retarded.  Screw it.  I'm taking removing dbus functionality entirely.
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2007-01-08 23:27:55 UTC
(In reply to comment #31)
> This is retarded.  Screw it.  I'm taking removing dbus functionality entirely.

Here's a suggestion: stop messing with ~arch stuff if you are unable to handle trivial things like sticking a dependency into package.keywords (Comment #29)

Comment 33 Matthew Schultz 2007-01-08 23:50:39 UTC
(In reply to comment #32)
> (In reply to comment #31)
> > This is retarded.  Screw it.  I'm taking removing dbus functionality entirely.
> 
> Here's a suggestion: stop messing with ~arch stuff if you are unable to handle
> trivial things like sticking a dependency into package.keywords (Comment #29)
> 

I know how keywords work.  The next problem arose in comment #30 after I added the keyword.  The error in comment #30 says nothing about a dependency.  I do apologize for posting the keyword comment though since it doesn't help with the situation.
Comment 34 Jakub Moc (RETIRED) gentoo-dev 2007-01-19 20:59:26 UTC
*** Bug 162838 has been marked as a duplicate of this bug. ***
Comment 35 Alejandro Wainzinger 2007-01-20 01:52:22 UTC
(In reply to comment #30)

I'm getting this:

Calculating world dependencies |
!!! Multiple versions within a single package slot have been 
!!! pulled into the dependency graph:

('ebuild', '/', 'sys-apps/dbus-0.62-r2', 'merge') pulled in by
   ('ebuild', '/', 'net-dns/avahi-0.6.16-r1', 'merge')

('ebuild', '/', 'sys-apps/dbus-1.0.2', 'merge') pulled in by
   ('ebuild', '/', 'net-print/cups-1.2.7', 'merge')

It may be possible to solve this problem by using package.mask to
prevent one of those packages from being selected. However, it is also
possible that conflicting dependencies exist such that they are
impossible to satisfy simultaneously. If such a conflict exists in the
dependencies of two different packages, then those packages can not be
installed simultaneously.

For more information, see MASKED PACKAGES section in the emerge man page
or refer to the Gentoo Handbook.

!!! Depgraph creation failed.
Comment 36 Jakub Moc (RETIRED) gentoo-dev 2007-01-20 08:48:58 UTC
(In reply to comment #35)

Upgrade dbus first; again see bug 1343
Comment 37 Richard 2007-01-21 17:23:15 UTC
i solved this exact same bug by removing dbus-glib
and reemerging it again : 
emerge --unmerge dbus-glib && emerge dbus-glib 
when that got done .. 
emerge hal 

all compiled just fine. 

hope this simple solution helps someone 
Comment 38 Jakub Moc (RETIRED) gentoo-dev 2007-01-22 07:26:28 UTC
*** Bug 163169 has been marked as a duplicate of this bug. ***
Comment 39 Jakub Moc (RETIRED) gentoo-dev 2007-07-25 11:48:13 UTC
*** Bug 186564 has been marked as a duplicate of this bug. ***