Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 156705 - sys-kernel/gentoo-sources-2.6.19 fails to compile drivers/video/fbsplash.c
Summary: sys-kernel/gentoo-sources-2.6.19 fails to compile drivers/video/fbsplash.c
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Unspecified (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Daniel Drake (RETIRED)
URL:
Whiteboard:
Keywords:
: 156868 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-11-30 10:24 UTC by Petteri Räty (RETIRED)
Modified: 2006-12-02 03:52 UTC (History)
14 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
kernel config (.config,34.66 KB, text/plain)
2006-11-30 10:24 UTC, Petteri Räty (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Petteri Räty (RETIRED) gentoo-dev 2006-11-30 10:24:17 UTC
CC      drivers/video/console/dummycon.o
  CC      drivers/video/console/vgacon.o
  CC      drivers/video/console/fbcon.o
  CC      drivers/video/console/bitblit.o
  CC      drivers/video/console/fonts.o
  CC      drivers/video/console/font_8x8.o
  CC      drivers/video/console/font_8x16.o
  LD      drivers/video/console/font.o
  CC      drivers/video/console/softcursor.o
  LD      drivers/video/console/built-in.o
  CC      drivers/video/fbsplash.o
drivers/video/fbsplash.c:20:26: error: linux/config.h: No such file or directory
make[2]: *** [drivers/video/fbsplash.o] Error 1
make[1]: *** [drivers/video] Error 2
make: *** [drivers] Error 2
pena linux-2.6.19-gentoo # ls
Comment 1 Petteri Räty (RETIRED) gentoo-dev 2006-11-30 10:24:48 UTC
Created attachment 103054 [details]
kernel config
Comment 2 Petteri Räty (RETIRED) gentoo-dev 2006-11-30 10:27:47 UTC
pena rome # emerge --info
Portage 2.1.2_rc2-r3 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r3 i686)
=================================================================
System uname: 2.6.18-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 2.40GHz
Gentoo Base System version 1.13.0_alpha7
Last Sync: Unknown
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4, 2.5-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe -mfpmath=sse -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -pipe -mfpmath=sse -fomit-frame-pointer"
DISTDIR="/var/distfiles"
FEATURES="autoaddcvs autoconfig ccache collision-protect cvs distlocks fixpackages java-strict parallel-fetch sandbox sfperms sign strict stricter userpriv usersandbox verify-rdepend"
GENTOO_MIRRORS=" http://trumpetti.atm.tut.fi/gentoo  http://lame.lut.fi/linux/gentoo "
LANG="en_US.utf8"
LC_ALL="en_US.utf8"
LDFLAGS="-Wl,--as-needed"
LINGUAS="fi"
MAKEOPTS="-j2"
PKGDIR="/home/pkg/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/mnt/checkouts/overlays/betelgeuse /mnt/checkouts/overlays/migrated-java /mnt/checkouts/overlays/java-experimental /mnt/checkouts/overlays/voip /mnt/checkouts/overlays/einit"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 aac acl acpi alsa arts audiofile bash-completion berkdb bitmap-fonts bluetooth bzip2 cairo cdb cddb cdparanoia cdr cli cracklib crypt cups dbus dlloader dri dts dvd dvdr dvdread elibc_glibc emboss esd fam ffmpeg firefox gif gstreamer hal iconv input_devices_evdev input_devices_keyboard input_devices_mouse isdnlog java jpeg kde kdeenablefinal kdehiddenvisibility kernel_linux libg++ linguas_fi logitech-mouse mad mikmod mjpeg mmx mp3 mpeg ncurses network nptl nptlonly nsplugin nvidia offensive ogg opengl pam pcre png ppds pppd qt3 quicktime readline real reflection rtc samba session spell spl sse sse2 ssl subversion svg symlink theora threads truetype truetype-fonts type1-fonts udev unicode usb userland_GNU userlocales video_cards_none video_cards_nvidia vim-syntax vorbis xcomposite xinerama xml xorg xv xvid xvmc zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_RSYNC_EXTRA_OPTS

Sorry about forgetting --info
Comment 3 Daniel Drake (RETIRED) gentoo-dev 2006-11-30 10:44:30 UTC
Hmm, wonder why I didn't see this in my allyesconfig compile. Anyway you can safely remove the line that includes that file, and assuming that is the only problem, you should be good to go.

Comment 4 Gerte Hoogewerf 2006-11-30 11:54:35 UTC
It isn't the only problem. Vesafb-tng doesn't compile either.
Comment 5 Daniel Drake (RETIRED) gentoo-dev 2006-11-30 12:48:46 UTC
Please file a new bug for vesafb-tng
Comment 6 Michal Januszewski (RETIRED) gentoo-dev 2006-11-30 12:52:44 UTC
Daniel,

could we please upgrade to:

http://dev.gentoo.org/~spock/projects/vesafb-tng/archive/vesafb-tng-1.0-rc2-2.6.19-rc2.patch
http://dev.gentoo.org/~spock/projects/gensplash/archive/fbsplash-0.9.2-r5-2.6.19-rc2.patch

in gentoo-sources? This should fix any problems related to linux/config.h.
Comment 7 Davide Pesavento gentoo-dev 2006-11-30 14:08:08 UTC
Exactly the same error here.


Portage 2.1.2_rc2-r3 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r3 i686)
=================================================================
System uname: 2.6.18-gentoo-r3 i686 Intel(R) Pentium(R) 4 CPU 3.00GHz
Gentoo Base System version 1.12.6
Last Sync: Thu, 30 Nov 2006 18:50:01 +0000
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/splash /etc/terminfo"
CXXFLAGS="-O2 -march=pentium4 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/ ftp://ftp.unina.it/pub/linux/distributions/gentoo"
LANG="it_IT.UTF-8"
LC_ALL="it_IT.UTF-8"
LINGUAS="it"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/xeffects /usr/portage/local/layman/pro-audio"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X aac acpi alsa arts audiofile avahi bash-completion bitmap-fonts bzip2 cairo caps cdinstall cdparanoia cdr cli cracklib crypt cups curl curlwrappers dbus dlloader dri dts dv dvd dvdr dvdread eds elibc_glibc emacs emboss encode expat fam fbcon ffmpeg firefox flac fuse gd gdbm gif glut gnutls gpm gstreamer hal iconv icq ieee1394 imagemagick imlib innodb input_devices_keyboard input_devices_mouse ipv6 isdnlog jabber jack java javascript jbig jpeg jpeg2k kde kdeenablefinal kdexdeltas kernel_linux libg++ linguas_it lua mad matroska mikmod mmx mng mp3 mpeg msn mule mysql mysqli ncurses nls nptl nptlonly nsplugin offensive ogg opengl oscar oss pam pcre pdf perl png ppds pppd python qt3 qt4 quicktime readline reflection ruby sasl sdl session slang spell spl sqlite sqlite3 sse sse2 ssl subversion svg svga symlink tcpd theora tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU vcd video_cards_nv video_cards_nvidia vorbis win32codecs wmf xcb xcomposite xine xml xorg xpm xscreensaver xv xvid yahoo zeroconf zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 Waldo 2006-11-30 14:59:17 UTC
Same  fbsplash.c error, amd64
Comment 9 Daniel Drake (RETIRED) gentoo-dev 2006-11-30 15:05:00 UTC
No need to confirm this bug, it will happen for all users who compile fbsplash into their kernels.

Solution is to remove the "#include <linux/config.h>" line, or remove fbsplash from your kernel. You could also wait a few days for 2.6.19-r1 but I'd prefer to see you helping with 2.6.19 testing before that point :)
Comment 10 Joshua Baergen (RETIRED) gentoo-dev 2006-11-30 15:10:56 UTC
This problem also affects some external driver packages.  ieee80211-1.1.13-r1 fails with the same problem.
Comment 11 Daniel Drake (RETIRED) gentoo-dev 2006-11-30 15:40:08 UTC
No matter how similar the bug may appear, if it's not a bug in compiling the fbsplash code then please file a NEW bug for it (assuming nobody beat you to it).

To clarify, 2.6.19-r1 will be fixed in that fbsplash will not attempt to include linux/config.h (as opposed to config.h magically reappearing - that's not going to happen)
Comment 12 Erik Zeek 2006-11-30 15:50:11 UTC
(In reply to comment #9)
> No need to confirm this bug, it will happen for all users who compile fbsplash
> into their kernels.
> 
> Solution is to remove the "#include <linux/config.h>" line, or remove fbsplash
> from your kernel. You could also wait a few days for 2.6.19-r1 but I'd prefer
> to see you helping with 2.6.19 testing before that point :)
> 

Removing the "#include <linux/config.h>" lines is insufficient.  After doing that (several files) I get:

 make bzImage
  CHK     include/linux/version.h
  CHK     include/linux/utsrelease.h
  CHK     include/linux/compile.h
  CC      drivers/video/vesafb-thread.o
drivers/video/vesafb-thread.c: In function 'ioperm':
drivers/video/vesafb-thread.c:42: error: 'errno' undeclared (first use in this function)
drivers/video/vesafb-thread.c:42: error: (Each undeclared identifier is reported only once
drivers/video/vesafb-thread.c:42: error: for each function it appears in.)
drivers/video/vesafb-thread.c: In function 'vm86old':
drivers/video/vesafb-thread.c:43: error: 'errno' undeclared (first use in this function)
make[2]: *** [drivers/video/vesafb-thread.o] Error 1
make[1]: *** [drivers/video] Error 2
make: *** [drivers] Error 2
Comment 13 Paul Taylor 2006-11-30 15:51:34 UTC
The source files in /usr/src/linux-2.6.19-gentoo referring to linux/config.h are:
   drivers/video/cfbsplash.c
   drivers/video/fbsplash.c
   drivers/video/vesafb-thread.c
   drivers/char/speakup/speakup_drvcommon.c
   drivers/char/speakup/spk_priv.h
 
Comment 14 Daniel Drake (RETIRED) gentoo-dev 2006-11-30 16:12:31 UTC
(In reply to comment #12)
> Removing the "#include <linux/config.h>" lines is insufficient.  After doing
> that (several files) I get:
> 
>   CC      drivers/video/vesafb-thread.o
> drivers/video/vesafb-thread.c: In function 'ioperm':

Please!! Thats NOT fbsplash! This bug is about fbsplash and fbsplash ONLY
Comment 15 Vlastimil Babka (Caster) (RETIRED) gentoo-dev 2006-11-30 19:29:50 UTC
(In reply to comment #5)
> Please file a new bug for vesafb-tng
> 

bug 156750, for everyone
Comment 16 Gianluca Parmiggiani 2006-12-01 03:21:38 UTC
same problem here, removing #include <linux/config.h> from fbsplash.c and cfbspah.c fixed it
Comment 17 Neil Bothwick 2006-12-01 04:34:29 UTC
Confirmed on amd64. Removing the line from fbsplash.c and cfbsplash.c fixed it.
Comment 18 Petteri Räty (RETIRED) gentoo-dev 2006-12-01 09:59:37 UTC
(In reply to comment #13)
> The source files in /usr/src/linux-2.6.19-gentoo referring to linux/config.h
> are:
>    drivers/video/cfbsplash.c
>    drivers/video/fbsplash.c
>    drivers/video/vesafb-thread.c
>    drivers/char/speakup/speakup_drvcommon.c
>    drivers/char/speakup/spk_priv.h
> 
> 

quick fix egrep "^#include <linux/config.h>" -r drivers/ -l | xargs sed -i -e "s:^#include <linux/config.h>::"

Comment 19 Paul Taylor 2006-12-01 18:50:09 UTC
(In reply to comment #13)
> The source files in /usr/src/linux-2.6.19-gentoo referring to linux/config.h
> are:
>    drivers/video/cfbsplash.c
>    drivers/video/fbsplash.c
>    drivers/video/vesafb-thread.c
>    drivers/char/speakup/speakup_drvcommon.c
>    drivers/char/speakup/spk_priv.h

I should have mentioned that these files aren't part of the 2.6.19 kernel source - they're added by genpatches-2.6.19-1.extras.tar.bz2

Comment 20 Daniel Drake (RETIRED) gentoo-dev 2006-12-01 20:14:36 UTC
Fixed in gentoo-sources-2.6.19-r1. Sorry for the bad initial release.
Comment 21 Jakub Moc (RETIRED) gentoo-dev 2006-12-02 01:34:51 UTC
*** Bug 156868 has been marked as a duplicate of this bug. ***