Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 156188 - Broken gtk+ font antialiasing after x11-libs/cairo upgrade to 1.2.4 from 1.0.4
Summary: Broken gtk+ font antialiasing after x11-libs/cairo upgrade to 1.2.4 from 1.0.4
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Doug Goldstein
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-11-25 02:18 UTC by Boris Dusek
Modified: 2007-04-13 23:41 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Gimp screenshot (gimp-gtk-cairo-font-no-antialias.png,38.75 KB, image/png)
2006-11-25 02:22 UTC, Boris Dusek
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Boris Dusek 2006-11-25 02:18:59 UTC
Hi,

I upgraded recently cairo from 1.0.4 to 1.2.4, after it was stabilised in #155544. After the upgrade fonts are no more antialiased in gtk+ (my version 2.8.19 - stable as well), neither pure gtk+ or gnome. I will attach a screenshot.

Regards,
Boris Dušek
Comment 1 Boris Dusek 2006-11-25 02:22:02 UTC
Created attachment 102696 [details]
Gimp screenshot
Comment 2 Boris Dusek 2006-11-25 02:24:54 UTC
Gentoo Base System version 1.12.6
Portage 2.1.1-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.18-gentoo-r1 i686)
=================================================================
System uname: 2.6.18-gentoo-r1 i686 Mobile AMD Athlon(tm) XP 2400+
Last Sync: Tue, 21 Nov 2006 16:30:02 +0000
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.3.5-r2, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/alias /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=athlon-xp -fomit-frame-pointer -pipe -fvisibility-inlines-hidden"
DISTDIR="/usr/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.chello.cz/mirrors/gentoo-mirror ftp://ftp.sh.cvut.cz/MIRRORS/gentoo http://gentoo.ynet.sk/pub"
LC_ALL="en_US.UTF-8"
LDFLAGS="-Wl,-O1"
LINGUAS="en cs sk ru he hi ar zh_TW zh_CN"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--timeout=500"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/home/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage/mine"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow X a52 aac acl acpi alsa arts atlas audiofile bash-completion berkdb bitmap-fonts bonobo bzip2 cairo cdparanoia cdr cjk cli cracklib crypt cups curl dbus dlloader dri dv dvd eds elibc_glibc emacs emboss encode exif expat fam fbcon ffmpeg firefox flac fortran gcj gdbm gif ginac glut gphoto2 gpm gstreamer gtk gtk2 guile hal iconv icq idn ieee1394 imagemagick immqt-bc input_devices_keyboard input_devices_mouse input_devices_synaptics ipv6 irc isdnlog jack jpeg kde kdeenablefinal kdehiddenvisibility kdexdeltas kernel_linux lcms ldap libcaca libg++ linguas_ar linguas_cs linguas_en linguas_he linguas_hi linguas_ru linguas_sk linguas_zh_CN linguas_zh_TW lua mad maildir mikmod mmx mng mp3 mpeg ncurses nls nptl nptlonly nsplugin ogg openexr opengl oss pam pcre perl pic png ppds pppd python qt3 qt4 readline reflection ruby samba scanner sdl session speex spl sqlite sse ssl subversion symlink tcpd tetex threads tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU video_cards_via vorbis win32codecs wmf xinerama xml xml2 xorg xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG
Comment 3 Doug Goldstein gentoo-dev 2006-11-25 07:07:45 UTC
revdep-rebuild like the ebuild tells you to.
Comment 4 Boris Dusek 2006-11-25 10:05:18 UTC
(In reply to comment #3)
> revdep-rebuild like the ebuild tells you to.

I did; but it did not help, probably because the only 2 packages revdep-rebuild wanted to reemerge were gcc and fontforge, both unrelated to the problem.
Comment 5 Boris Dusek 2006-11-26 01:39:18 UTC
Problem solved (I hope):
I went to KDE Control Center, adjusted some settings for antialiasing and applied, then deleted the generated .fonts.conf file and it started to work. Don't know how KDE configuration could influence gtk+ other way that with .fonts.conf, but it works now.

Nevertheless, antialiasing worked before the upgrade and stopped working after the upgrade, don't know why such tricks as the above one are necessary to make antialiasing running again in gtk+ apps.
Comment 6 David Brown 2006-11-28 14:16:30 UTC
To confirm.  After upgrading to x11-libs/cairo-1.2.4, anti aliasing in gtk+ applications stopped working.

I was able to fix it by opening the KDE control center, deselecting, applying, then selecting and applying the anti-alias setting.  I did not need to delete any files.

Perhaps some cache file is not getting updated properly?
Comment 7 Boris Dusek 2006-11-28 14:33:58 UTC
(In reply to comment #6)
> I did not need to delete any files.

Neither did I, I just wanted to keep all font configuration in the global /etc/fonts/fonts.conf & friends, and not do it on a per-user basis with ~/.fonts.conf
Comment 8 Doug Goldstein gentoo-dev 2007-04-13 23:41:27 UTC
This was a cracked out KDE issue.. I think it's done and go with now days...