Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 15453 - Mirrorselect hangs upon execution under step 11 of install
Summary: Mirrorselect hangs upon execution under step 11 of install
Status: RESOLVED DUPLICATE of bug 15445
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2003-02-10 16:06 UTC by Mike
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Mike 2003-02-10 16:06:37 UTC
I follow the gentoo instruction to the letter and then when i reach part 11, and
it tells me to "emerge mirrorselect" and then execute it, it emerges fine, but
then hangs upon execution.

I've tested all different settings with /etc/make.conf (to see if i had built it
wrong), but nothing works.  These changes include, no changes, setting the
architecture to "pentium4" and to "i686" (as i have a pentium 4 - 1400MHz CPU,
with an intel i850 motherboard).

Reproducible: Always
Steps to Reproduce:
1.  emerge mirrorselect
2.  mirrorselect

Actual Results:  
Nothing.  It just hangs until i press control-c.

Expected Results:  
It should have brought up a text GUI for me to select the appropriate mirror.

I aplogise but I only have one PC and because this error occurs during the boot
process I can't paste the problem here.

I mean I think I can get around it for now by using:

But I would really like to know why this is happening to me, when no-one else
has ever had this problem?
Comment 1 Mark Guertin 2003-02-10 16:27:55 UTC
I'll take a quick look at things. 
Curious, do you have dialog installed? 
Comment 2 Mike 2003-02-10 16:45:22 UTC
yes, dialog gets automatically installed as part of the mirrorselect dependencies.
Comment 3 Mike 2003-02-10 19:17:37 UTC
I just tried installing gentoo on a compaq evo desktop (P4-1.7 - another computer at work) and I have the same mirrorselect problem

I checked /var/log/emerge.log and it says everything completed and installed successfully with no errors.  This is really wierd.  I tried it on a different compaq evo desktop (P4-2.4) yesterday and it worked fine.  What could be causing this?  Does this program connect to a server to get this list of mirrors?  Could it be that this server is down or timing out? (I'm connecting from Australia)
Comment 4 Mark Guertin 2003-02-24 14:33:59 UTC
Sorry, I lost this bug from my list for some reason :/

This has been mostly taken care of.  THe issue was a dialog/livecd one, screen size and stdout+stderr being tied together somehow.  It doesn't connect to anything, I think the hang was waiting for output to stdout that never happens.  THis is known to be a problem from the livecd enviroment and can't really be fixed in mirrorselect aside from not using it until you are booted from a real system :(
Comment 5 Martin Holzer (RETIRED) gentoo-dev 2003-10-14 13:59:53 UTC

*** This bug has been marked as a duplicate of 15445 ***