Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 15451 - openoffice won't start
Summary: openoffice won't start
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Seth Chandler
Depends on:
Reported: 2003-02-10 15:46 UTC by Martin Filip
Modified: 2003-02-16 02:01 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Martin Filip 2003-02-10 15:46:46 UTC
I've emerged openoffice 1.0.1 (I've tried 1.0.2 also). Everything emerges OK.
When I want to run it after 7 or 8 hours of compiling, it dies with this error:
/opt/OpenOffice.org1.0.1/program/soffice.bin: relocation error:
/opt/OpenOffice.org1.0.1/program/ symbol
_ZN22XFillBmpPosOffsetYItemC1Et, version UDK_3_0_0 not defined in file with link time reference

do you have any idea, where the problem is?

Reproducible: Always
Steps to Reproduce:
1. emerge openoffice
2. run ooffice

Actual Results:  
it died with:
/opt/OpenOffice.org1.0.1/program/soffice.bin: relocation error:
/opt/OpenOffice.org1.0.1/program/ symbol
_ZN22XFillBmpPosOffsetYItemC1Et, version UDK_3_0_0 not defined in file with link time reference

Expected Results:  
start openoffice :))

Portage 2.0.46-r12 (default-x86-1.4, gcc-which: no gcc in
sh: line 1: -dumpversion: command not found, glibc-2.3.1-r2)
System uname: 2.4.20 i686 AuthenticAMD
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/kde/3/share/config
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss apm avi crypt cups encode gif jpeg kde gnome libg++ mikmod mmx mpeg
ncurses pdflib png qtmt quicktime spell truetype xml2 xmms xv zlib gtkhtml gdbm
berkdb slang readline tetex bonobo svga tcltk java guile X sdl gpm tcpd pam
libwww ssl perl python esd imlib oggvorbis gtk qt motif opengl cdr -3dnow acpi
alsa -arts dvd gphoto2 ipv6 mozilla -nls samba"
CFLAGS="-mcpu=athlon-xp -pipe"
CXXFLAGS="-mcpu=athlon-xp -pipe"
FEATURES="sandbox ccache"
Comment 1 SpanKY gentoo-dev 2003-02-10 16:10:27 UTC
did you prelink ? 
did you upgrade from 1.2 to 1.4 ? (in other words, a gcc/glibc upgrade) 
Comment 2 Martin Filip 2003-02-10 17:07:44 UTC
emerge -p said nothing bad...
I use emerge -u world regulary, so I think, I have most recent versions of gcc/glibc
Comment 3 Seth Chandler 2003-02-11 13:49:54 UTC
did you prelink?  i know mike already asked this but it really looks lik ea prelinking error...

you should try openoffice-bin 1.0.2, 
Comment 4 Martin Filip 2003-02-11 13:59:43 UTC
in my bug report:
(I've tried 1.0.2 also). Everything emerges OK.
Comment 5 Seth Chandler 2003-02-11 15:22:26 UTC
in my responce 
you should try openoffice-bin 1.0.2 
the -bin is the key part there 
Comment 6 Seth Chandler 2003-02-11 15:23:16 UTC
and am i get an answer to the prelink question? 
Comment 7 Seth Chandler 2003-02-11 15:23:27 UTC
and am i get an answer to the prelink question? 
Comment 8 Martin Filip 2003-02-11 15:34:18 UTC
prelink? do you mean emerge -p? I'm not sure, what do you mean with prelink
Comment 9 Seth Chandler 2003-02-11 19:08:35 UTC
prelinking is using the program `prelink`...if you don't know what it is, you probably didn't do it =)

how long have you had this installed?  did you upgrade a 1.2 install to a 1.4 install?  i'd also like to see what version of gcc you have...
Comment 10 Martin Filip 2003-02-12 12:22:38 UTC
yes.. I don't know it :)) I've installed system with oo as 1.4-rc1 I think... It worked, but one day I've used emerge -u --deep world and something new caused this error. I really do not know, where to search for the reason of the problem... :(
Comment 11 Seth Chandler 2003-02-12 15:11:40 UTC
so openoffice worked, and now it doesnt? 
try this 
root@sbc:~# ACCEPT_KEYWORDS="~x86" emerge openoffice-bin 
that should install the newest openoffice binaries.... 
they tend to be less fickle than the compile... 
Comment 12 Martin Filip 2003-02-14 11:17:36 UTC
openoffice-1.0.2-bin works... thx.. but I don't think this is a good - use precompiled if compiled by me do not work...
Comment 13 Seth Chandler 2003-02-16 02:01:33 UTC
yes, but i can't really figure out how to fix the openoffice one.... 
if you can somehow figure out where the openoffice one breaks, reopen this bug...i'll 
DEFINATELY take a look at it...obviously my box isn't the same as yours...sorry...