Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 15407 - app-text/docbook-sgml-utils-0.6.11-r2 fails to emerge; /bin/install: cannot stat `./api.html': No such file or directory
Summary: app-text/docbook-sgml-utils-0.6.11-r2 fails to emerge; /bin/install: cannot s...
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High major (vote)
Assignee: Text-Markup Team (OBSOLETE)
Depends on:
Reported: 2003-02-09 22:22 UTC by Nathan Sharfi
Modified: 2003-09-17 05:28 UTC (History)
6 users (show)

See Also:
Package list:
Runtime testing required: ---

tarbal with ebuild packahe install logs (docbook-util.tar.gz,359.08 KB, application/gzip)
2003-02-24 05:45 UTC, Henti Smith
OpenEXR-1.0.5.ebuild (OpenEXR-1.0.5.ebuild,886 bytes, text/plain)
2003-03-24 03:04 UTC, Henti Smith
The output from attempting to emerge in app-text/docbook-sgml-utils-0.6.11-r2 (openjade_132_catalog,117.54 KB, text/plain)
2003-06-24 06:59 UTC, Jason Pfeil

Note You need to log in before you can comment on or make changes to this bug.
Description Nathan Sharfi 2003-02-09 22:22:17 UTC
app-text/docbook-sgml-utils-0.6.11-r2 doesn't emerge, and it's stopping my KDE
upgrade halfway through. See the "Actual Results" section for the interesting
part of the bug report.

Reproducible: Always
Steps to Reproduce:
# emerge -u docbook-sgml-utils
Actual Results:  
After seeing multiple copies of the GFDL fly by, I saw this:

If your document contains nontrivial examples of program code, we
recommend releasing these examples in parallel under your choice of
free software license, such as the GNU General Public License,
to permit their use in free software.

    /bin/sh ../../mkinstalldirs
mkdir -p --
 /bin/install -c -m 644 ./api.html
/bin/install: cannot stat `./api.html': No such file or directory
 /bin/install -c -m 644 ./backend-spec.html
/bin/install: cannot stat `./backend-spec.html': No such file or directory
 /bin/install -c -m 644 ./docbook2man.html
/bin/install: cannot stat `./docbook2man.html': No such file or directory
 /bin/install -c -m 644 ./docbook2texi.html
/bin/install: cannot stat `./docbook2texi.html': No such file or directory
 /bin/install -c -m 644 ./fdl.html
/bin/install: cannot stat `./fdl.html': No such file or directory
 /bin/install -c -m 644 ./frontend-spec.html
/bin/install: cannot stat `./frontend-spec.html': No such file or directory
 /bin/install -c -m 644 ./helpers.html
/bin/install: cannot stat `./helpers.html': No such file or directory
 /bin/install -c -m 644 ./index.html
/bin/install: cannot stat `./index.html': No such file or directory
 /bin/install -c -m 644 ./introduction.html
/bin/install: cannot stat `./introduction.html': No such file or directory
 /bin/install -c -m 644 ./intro-jw.html
/bin/install: cannot stat `./intro-jw.html': No such file or directory
 /bin/install -c -m 644 ./intro-sgmldiff.html
/bin/install: cannot stat `./intro-sgmldiff.html': No such file or directory
 /bin/install -c -m 644 ./jw.html
/bin/install: cannot stat `./jw.html': No such file or directory
 /bin/install -c -m 644 ./sgmldiff.html
/bin/install: cannot stat `./sgmldiff.html': No such file or directory
make[3]: *** [install-htmlDATA] Error 1
make[3]: Leaving directory
make[2]: *** [install-am] Error 2
make[2]: Leaving directory
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory
make: *** [install-recursive] Error 1

!!! ERROR: app-text/docbook-sgml-utils-0.6.11-r2 failed.
!!! Function einstall, Line 8, Exitcode 2
!!! einstall failed

Expected Results:  
It should have emerged.

Portage 2.0.46-r12 (default-1.0, gcc-2.95.3, glibc-2.2.5-r2,2.2.5-r7)
System uname: 2.4.19-gentoo-r7 i686 AMD Athlon(TM) XP 1500+
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config
/usr/X11R6/lib/X11/xkb /usr/kde/3/share/config /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss 3dnow apm avi crypt cups encode jpeg libg++ mikmod mmx mpeg ncurses
pdflib qtmt quicktime spell truetype xml2 xmms xv arts berkdb cdr esd gdbm 
gif gnome-libs gpm gtk guile imlib java kde libwww motif mozilla nls oggvorbis
opengl pam perl png python qt readline scanner sdl slang ssl svga tcpd tetex tiff X"
CFLAGS="-O2 -mcpu=i686 -pipe"
FEATURES="sandbox ccache"
Comment 1 Matthew Turk (RETIRED) gentoo-dev 2003-02-10 01:56:56 UTC
Looks like you need the SGML fix... 
Comment 2 Heikki Rauhala 2003-02-21 16:24:10 UTC
I get the exact same log, the emerge fails due to sgmldiff.html not being found. The SGML fix doesn't fix the problem.
Comment 3 Henti Smith 2003-02-24 05:39:10 UTC
This seems to be a problem during install in /var/tmp/portage/docbook-sgml-utils-0.6.12/work/docbook-utils-0.6.12/doc/HTML
from what I can see in the dir the files get pushed to stdout instead of the acuall files. I'll attache the ebuild install output here

Comment 4 Henti Smith 2003-02-24 05:45:49 UTC
Created attachment 8668 [details]
tarbal with ebuild packahe install logs

This is the log from running "ebuild package install" 
note the masses of documentation output to sdtout.
Comment 5 Matthew Turk (RETIRED) gentoo-dev 2003-03-01 15:11:53 UTC
Which version(s) of docbook-dsssl-stylesheet do you have installed? 
Comment 6 Matthew Turk (RETIRED) gentoo-dev 2003-03-01 15:12:28 UTC
Er, docbook-xsl-stylesheets, I mean. 
Comment 7 Matthew Turk (RETIRED) gentoo-dev 2003-03-02 13:36:48 UTC
Ok, I think the problem is a missing docbook-xml-dtd.  Try 
# emerge "=docbook-xml-dtd-4.1.2-r3" 
and let me know if it fixes it. 
Comment 8 Henti Smith 2003-03-24 03:04:45 UTC
Created attachment 9752 [details]

This updates the ebuild to 1.0.5 and adds the IlmImf example program as well.
Will get working on the NVSDK

Comment 9 Henti Smith 2003-03-24 03:07:53 UTC
ARG !! 

appologies .... wrong bug ;P 

Comment 10 Eric Ball 2003-04-21 11:02:10 UTC
I just had the same initial problem when installing something that had a bunch of sgml stuff as dependencies, but following the sgml fix instructions solved it. libgnome & gconf had to be reemerged.
Comment 11 Martin Holzer (RETIRED) gentoo-dev 2003-05-09 16:41:42 UTC
run revdep-rebuild from gentoolkit
Comment 12 Eric Ball 2003-05-12 23:59:28 UTC
Not sure if you are talking to me Martin, but here goes:

# revdep-rebuild


Checking dynamic linking consistency...
  broken /usr/lib/ (requires
  broken /usr/bin/ccexample (requires
  broken /usr/X11R6/bin/uil (requires
  broken /usr/X11R6/bin/xmanimate (requires
  broken /usr/X11R6/bin/fileview (requires
  broken /usr/X11R6/bin/hellomotif (requires
  broken /usr/X11R6/bin/periodic (requires
  broken /usr/X11R6/bin/helloint (requires

Assigning files to ebuilds... done.

All prepared. Starting rebuild...
emerge --oneshot --nodeps  =dev-libs/pilot-link-0.11.5-r2 =media-gfx/imagemagick-5.5.6 =x11-libs/openmotif-2.2.2-r1


# revdep-rebuild


Dynamic linking on your system is consistent... All done.
Comment 13 Kris Verbeeck 2003-06-01 06:09:05 UTC
I remerged docbook-dsssl-stylesheets (1.77-r2) which created the file /etc/sgml/ that was missing before.  This fixed the 'No such file or directory' problem described in this bug.  Now the docbook-sgml-utils package merges without any problems.

I have no idea why that .cat file was missing in the first place.
Comment 14 Jason Pfeil 2003-06-24 06:56:18 UTC
Same result, different error.  Witness the attachment named openjade_132_catalog complaining that a certain file, /usr/share/sgml/openjade-1.3.2/catalog, does not exist.  This is true and this is because I have openjade-1.3.1 installed:

go root # epm -q openjade

This is stopping my emerge -u world from bringing my system to the latest stable version from the bleeding edge.  Here is what my emerge -up world returns:

go root # emerge -up world
These are the packages that I would merge, in order:
Calculating world dependencies ...done!
[ebuild  N   ] app-text/docbook-sgml-utils-0.6.11-r2
[ebuild    UD] dev-util/intltool-0.25 [0.26]
[ebuild    UD] app-text/scrollkeeper-0.3.11-r1 [0.3.12]
[ebuild    UD] dev-libs/libIDL-0.8.1 [0.8.2]
[ebuild    UD] net-libs/linc-1.0.1 [1.0.2]
[ebuild    UD] gnome-base/ORBit2-2.6.1 [2.6.2]
[ebuild    UD] gnome-base/gconf-2.2.0 [2.2.1]
[ebuild    UD] gnome-base/bonobo-activation- [2.2.2]
[ebuild    UD] gnome-base/libbonobo-2.2.2 [2.2.3]
[ebuild    UD] media-libs/libart_lgpl-2.3.11 [2.3.12]
[ebuild    UD] gnome-base/libgnomecanvas- [2.2.1]
[ebuild    UD] media-sound/esound-0.2.29 [0.2.29-r1]
[ebuild    UD] gnome-base/gnome-mime-data-2.2.0 [2.2.1]
[ebuild    UD] net-nds/portmap-5b-r6 [5b-r7]
[ebuild    UD] app-admin/fam-oss-2.6.9-r1 [2.6.10]
[ebuild    UD] gnome-base/gnome-vfs-2.2.4 [2.2.5]
[ebuild    UD] gnome-base/libgnome-2.2.1 [2.2.2]
[ebuild    UD] gnome-base/libbonoboui- [2.2.2]
[ebuild    UD] gnome-base/libgnomeui- [2.2.1]
[ebuild    UD] gnome-base/gdm- []
[ebuild    UD] x11-themes/gnome-icon-theme-1.0.4 [1.0.5]
[ebuild    UD] x11-themes/gnome-themes-2.2.1 [2.2.2]
[ebuild    UD] sys-apps/pam-login-3.10 [3.11]
[ebuild    UD] sys-apps/util-linux-2.11y [2.11z-r4]
[ebuild    UD] sys-devel/bin86-0.16.0 [0.16.11]
[ebuild    UD] sys-apps/net-tools-1.60-r6 [1.60-r7]
[ebuild    UD] media-libs/svgalib-1.4.3-r4 [1.9.17-r1]
[ebuild    UD] net-www/links-2.1_pre9 [2.1_pre11]
[ebuild    UD] dev-util/strace-4.4-r1 [4.4.98]
[ebuild    UD] net-libs/pam_ldap-156 [161]
[ebuild    UD] gnome-base/gail-1.2.1 [1.2.2]
[ebuild    UD] gnome-base/eel-2.2.3 [2.2.4]
[ebuild    UD] gnome-base/gnome-desktop-2.2.1-r1 [2.2.2]
[ebuild    UD] gnome-base/nautilus-2.2.3 [2.2.4]
[ebuild    UD] sys-apps/psmisc-21.2-r1 [21.2-r2]
[ebuild    UD] net-misc/rsync-2.5.6-r1 [2.5.6-r2]
[ebuild    UD] sys-apps/debianutils-1.16.7-r1 [1.16.7-r2]
[ebuild    UD] sys-libs/slang-1.4.5-r2 [1.4.9]
[ebuild    UD] net-mail/mutt-1.4.1-r1 [1.5.4-r1]
[ebuild    UD] x11-libs/vte-0.10.27 [0.10.29]
[ebuild    UD] x11-terms/gnome-terminal-2.2.1 [2.2.2]
[ebuild    UD] gnome-base/gnome-session-2.2.1 [2.2.2]
[ebuild    UD] app-editors/vim-6.1-r21 [6.2]

Thanks for a great product and all your hard work!

Comment 15 Jason Pfeil 2003-06-24 06:59:11 UTC
Created attachment 13774 [details]
The output from attempting to emerge in app-text/docbook-sgml-utils-0.6.11-r2
Comment 16 David Mitchell 2003-09-10 18:41:40 UTC
The fix provided by Kris in comment #13 worked for me as well. I have no idea 
why the original emerge of docbook-dssl-stylesheets didn't work as expected. 
Comment 17 Mike Gardiner (RETIRED) gentoo-dev 2003-09-15 04:06:45 UTC
it's when things go funny with the catalogs :) (that's the technical description) Okay it can be causes by a few things, like packages trying to add to /etc/xml/catalog before that catalog is xmlcatalog --create 'd and other assorted problems, leaving the catalog inconsistent. are we all done here? who's still not fixed ?
Comment 18 Mike Gardiner (RETIRED) gentoo-dev 2003-09-17 05:28:05 UTC
i guess this should really be marked fixed/invalid, but we'll be optimistic for once.