Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 15287 - emerge media-video/mjpegtools-1.6.0-r7 failed
Summary: emerge media-video/mjpegtools-1.6.0-r7 failed
Status: RESOLVED DUPLICATE of bug 11153
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: x86 Linux
: High blocker (vote)
Assignee: Gentoo Linux Gnome Desktop Team
: 15388 (view as bug list)
Depends on:
Reported: 2003-02-07 14:41 UTC by Aniruddha Shankar
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Aniruddha Shankar 2003-02-07 14:41:44 UTC
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.0\" -I/usr/include -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/local/include -I /var/tmp/portage/mjpegtools-1.6.0-r7/work/quicktime4linux-1.4-patch -I/usr/X11R6/include -I /usr/X11R6/include -I../utils -I/usr/include/avifile -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -mcpu=i686 -march=i686 -mcpu=i686 -O3 -pipe -Wall -Wunused -c jpegutils.c -Wp,-MD,.deps/jpegutils.TPlo -o jpegutils.o >/dev/null 2>&1
mv -f .libs/jpegutils.lo jpegutils.lo
source='liblavrec.c' object='liblavrec.lo' libtool=yes \
depfile='.deps/liblavrec.Plo' tmpdepfile='.deps/liblavrec.TPlo' \
depmode=gcc /bin/sh ../depcomp \
/bin/sh ../libtool --mode=compile gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.0\" -I/usr/include -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/local/include -I /var/tmp/portage/mjpegtools-1.6.0-r7/work/quicktime4linux-1.4-patch -I/usr/X11R6/include -I /usr/X11R6/include -I../utils -I/usr/include/avifile -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include    -mcpu=i686 -march=i686 -mcpu=i686 -O3 -pipe -Wall -Wunused -c -o liblavrec.lo `test -f liblavrec.c || echo './'`liblavrec.c
lav_io.c: In function `check_DV2_input':
lav_io.c:1385: too few arguments to function `dv_decoder_new'
make[2]: *** [lav_io.lo] Error 1
make[2]: *** Waiting for unfinished jobs....
rm -f .libs/liblavrec.lo
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.0\" -I/usr/include -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/local/include -I /var/tmp/portage/mjpegtools-1.6.0-r7/work/quicktime4linux-1.4-patch -I/usr/X11R6/include -I /usr/X11R6/include -I../utils -I/usr/include/avifile -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -mcpu=i686 -march=i686 -mcpu=i686 -O3 -pipe -Wall -Wunused -c liblavrec.c -Wp,-MD,.deps/liblavrec.TPlo  -fPIC -DPIC -o liblavrec.o
mv -f liblavrec.o .libs/liblavrec.lo
gcc -DHAVE_CONFIG_H -I. -I. -I.. -I.. -I/usr/include -DG_LOG_DOMAIN=\"lavtools\" -DLAVPLAY_VERSION=\"1.6.0\" -I/usr/include -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/local/include -I /var/tmp/portage/mjpegtools-1.6.0-r7/work/quicktime4linux-1.4-patch -I/usr/X11R6/include -I /usr/X11R6/include -I../utils -I/usr/include/avifile -I/usr/include/gtk-1.2 -I/usr/include/glib-1.2 -I/usr/lib/glib/include -I/usr/X11R6/include -mcpu=i686 -march=i686 -mcpu=i686 -O3 -pipe -Wall -Wunused -c liblavrec.c -Wp,-MD,.deps/liblavrec.TPlo -o liblavrec.o >/dev/null 2>&1
mv -f .libs/liblavrec.lo liblavrec.lo
make[2]: Leaving directory `/var/tmp/portage/mjpegtools-1.6.0-r7/work/mjpegtools-1.6.0/lavtools'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/mjpegtools-1.6.0-r7/work/mjpegtools-1.6.0'
make: *** [all] Error 2

!!! ERROR: media-video/mjpegtools-1.6.0-r7 failed.
!!! Function src_compile, Line -225, Exitcode 2
!!! (no error message)

Reproducible: Always
Steps to Reproduce:
1. emerge media-video/mjpegtools-1.6.0-r7

Actual Results:  
emerge failed.

Expected Results:  
built mjpegtools.

Portage 2.0.46-r11 (default-1.0, gcc-2.95.3, glibc-2.2.5-r7)
System uname: 2.4.20-lolo-r1 i686 Celeron (Coppermine)
CONFIG_PROTECT="/etc /var/qmail/control /usr/kde/2/share/config /usr/kde/3/share/config /usr/X11R6/lib/X11/xkb /usr/kde/3.1/share/config /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
USE="x86 oss avi crypt cups encode jpeg libg++ mikmod mmx mpeg ncurses pdflib qtmt quicktime spell truetype xml2 xmms xv arts berkdb bonobo cdr gdbm gif gnome-libs gpm gtk guile imlib java kde libwww motif nls oggvorbis opengl pam png python qt readline scanner sdl slang ssl svga tcltk tcpd X -3dnow aalib acpi alsa -apm dga directfb doc esd fbcon flash gd ggi ggz gnome gtkhtml imap lcms ldap mozilla nas nocardbus perl samba slp sse tetex tiff wmf xml zlib"
CFLAGS="-mcpu=i686 -O3 -pipe"
CXXFLAGS="-mcpu=i686 -O3 -pipe"
FEATURES="sandbox ccache buildpkg"
Comment 1 foser (RETIRED) gentoo-dev 2003-02-07 15:16:44 UTC
try with MAKEOPTS="-j1" , lower optimizations

this is not a gnome bug, do not assign it to us
Comment 2 Aniruddha Shankar 2003-02-07 16:10:17 UTC
My apologies. I assigned it to gnome because I encountered this bug during emerge -up --deep gnome. I have tried it with lower optimisations  -j1 and "-mcpu=i686 -pipe" and it gives me the same error. Could you please reassign this to bugwranglers so that it gets reassigned, ultimately, to the right person ?
Comment 3 Peter Penkala gentoo-dev 2003-02-07 16:49:54 UTC
Looks an awful lot like 11153.
Comment 4 SpanKY gentoo-dev 2003-02-09 02:02:40 UTC

*** This bug has been marked as a duplicate of 11153 ***
Comment 5 foser (RETIRED) gentoo-dev 2003-02-09 16:47:58 UTC
*** Bug 15388 has been marked as a duplicate of this bug. ***