Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 152576 - Circular dependancies when trying to install gnome and other packages on a fresh gentoo install
Summary: Circular dependancies when trying to install gnome and other packages on a fr...
Status: RESOLVED DUPLICATE of bug 175808
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-23 11:26 UTC by Nicola Tuveri
Modified: 2007-07-08 14:58 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
Complete output of emerge -DuNav gnome (gnome_circdep.txt,26.96 KB, text/plain)
2006-10-23 11:29 UTC, Nicola Tuveri
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Nicola Tuveri 2006-10-23 11:26:38 UTC
+++ This bug was initially created as a clone of Bug #149463 +++

I've got the same problem but in different architecture:
just installed a fresh clean new gentoo amd64 on my pc. But there are many packages I cannot install due to huge lists of circular dependencies (among these there's gnome):

itaca ~ # emerge -DuNav gnome-base/gnome
These are the packages that would be merged, in order:

Calculating dependencies  ........ done!
!!! Error: circular dependencies:

ebuild / x11-libs/libxklavier-3.0 merge depends on
   ebuild / app-doc/doxygen-1.4.6 merge (hard)
ebuild / media-plugins/gst-plugins-esd-0.10.3 merge depends on
   ebuild / media-sound/esound-0.2.36-r2 merge (hard)
ebuild / gnome-extra/gconf-editor-2.16.0 merge depends on
   ebuild / gnome-base/libgnome-2.16.0 merge (hard)
   ebuild / gnome-base/libgnomeui-2.16.1 merge (hard)
ebuild / dev-dotnet/libgdiplus-1.1.18 merge depends on
   ebuild / media-libs/libexif-0.6.13-r1 merge (hard)
ebuild / media-sound/esound-0.2.36-r2 merge depends on
   ebuild / media-libs/alsa-lib-1.0.13 merge (hard)
ebuild / net-dns/libidn-0.6.5-r1 merge depends on
   ebuild / dev-lang/mono-1.1.18 merge (hard)
   ebuild / dev-java/gjdoc-0.7.7-r1 merge (hard)
ebuild / gnome-extra/gnome-media-2.16.1 merge depends on
   ebuild / media-sound/esound-0.2.36-r2 merge (hard)
   ebuild / gnome-base/libgnomeui-2.16.1 merge (hard)
   ebuild / gnome-extra/nautilus-cd-burner-2.16.1 merge (hard)
   ebuild / gnome-base/gnome-vfs-2.16.1 merge (hard)
ebuild / app-text/ghostscript-gpl-8.54 merge depends on
   ebuild / net-print/cups-1.2.5 merge (hard)
ebuild / net-print/gnome-cups-manager-0.31-r1 merge depends on
   ebuild / net-print/libgnomecups-0.2.2 merge (hard)
   ebuild / gnome-base/libgnome-2.16.0 merge (hard)
   ebuild / gnome-base/libgnomeui-2.16.1 merge (hard)
   ebuild / x11-libs/gksu-2.0.0 merge (medium)
ebuild / dev-dotnet/gtk-sharp-2.10.0 merge depends on
   ebuild / dev-util/monodoc-1.1.18 merge (hard)
   ebuild / dev-lang/mono-1.1.18 merge (hard)
ebuild / net-print/foomatic-filters-3.0.20060720 merge depends on
   ebuild / net-print/cups-1.2.5 merge (hard)
   ebuild / virtual/ghostscript-0 merge (hard)
ebuild / media-libs/flac-1.1.2-r8 merge depends on
   ebuild / app-doc/doxygen-1.4.6 merge (hard)
ebuild / x11-libs/libnotify-0.4.3 merge depends on
   ebuild / sys-apps/dbus-0.62-r1 merge (hard)
   ebuild / x11-misc/notification-daemon-0.3.6 merge (hard)
ebuild / gnome-extra/libgsf-1.14.0 merge depends on
   ebuild / media-libs/libwmf-0.2.8.4 merge (hard)
   ebuild / gnome-base/gnome-vfs-2.16.1 merge (hard)
   ebuild / media-gfx/imagemagick-6.2.9.5-r1 merge (hard)
ebuild / app-doc/doxygen-1.4.6 merge depends on
   ebuild / media-gfx/graphviz-2.8-r2 merge (hard)
   ebuild / virtual/ghostscript-0 merge (hard)

## cutted at the 50th line but goes on for 514 lines ##

itaca ~ # emerge --info
Portage 2.1.2_pre3-r7 (default-linux/amd64/2006.1, gcc-4.1.1, glibc-2.5-r0, 2.6.18-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.18-gentoo-r1 x86_64 AMD Athlon(tm) 64 Processor 3200+
Gentoo Base System version 1.12.5
Last Sync: Mon, 23 Oct 2006 17:30:01 +0000
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-O3 -march=k8 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/share/X11/xkb"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O3 -march=k8 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://www.die.unipd.it/pub/Linux/distributions/gentoo-sources/                 ftp://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/            http://gentoo.modulix.net/gentoo/                http://gentoo.inode.at/        ftp://gentoo.inode.at/source/            http://ftp.belnet.be/mirror/rsync.gentoo.org/gentoo/            ftp://ftp.unina.it/pub/linux/distributions/gentoo      ftp://ftp.solnet.ch/mirror/Gentoo                http://gentoo.mirror.solnet.ch"
LINGUAS="it"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X a52 aac acpi aiglx alsa avahi bash-completion berkdb bitmap-fonts bluetooth bzip2 cdr cli cracklib crypt cups dbus directfb dlloader doc dri dts dvb dvd dvdr dvdread elibc_glibc encode esd exif fbcon ffmpeg firefox flac fortran ftp gdbm gif gnome gpm gtk hal ieee1394 imagemagick input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog jabber java javascript joystick jpeg jpeg2k kernel_linux libg++ linguas_it lirc lm_sensors lzo mad matroska mime mmap mono mp3 mpeg msn musicbrainz ncurses network nls nptl nptlonly nsplugin offensive ogg opengl pam pcre pdf perl php plotutils png ppds pppd python quicktime readline reflection samba session speex spl ssl svg tcpd theora tiff truetype truetype-fonts type1-fonts udev unicode usb userland_GNU v4l v4l2 vcd video_cards_fbdev video_cards_nv video_cards_nvidia video_cards_v4l video_cards_vesa vorbis wmf wxwindows xinerama xinetd xml xorg xosd xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Nicola Tuveri 2006-10-23 11:29:30 UTC
Created attachment 100304 [details]
Complete output of emerge -DuNav gnome

This is the full output of the

emerge -DuNav gnome

command
Comment 2 Daniel Gryniewicz (RETIRED) gentoo-dev 2006-11-08 10:54:46 UTC
Okay, I've analyzed this dump, and the recursions limited to the following packages:

Recursion: app-doc/doxygen-1.4.6
Recursion: app-text/ghostscript-gpl-8.54
Recursion: dev-dotnet/libgdiplus-1.1.18
Recursion: dev-lang/mono-1.1.18
Recursion: dev-lang/swig-1.3.29-r1
Recursion: dev-util/monodoc-1.1.18
Recursion: media-gfx/graphviz-2.8-r2
Recursion: media-libs/libexif-0.6.13-r1
Recursion: net-print/cups-1.2.5
Recursion: sys-apps/dbus-0.62-r1
Recursion: virtual/ghostscript-0


These all seem to be related to the doc use flag; try emerging USE=-doc (doc in gnome is developer docs, not user docs).

Later on, you can add doc back in and emerge -auvDN world safely, I believe.

I don't believe any of these recursions are fixable, and they certainly aren't fixable by the gnome team.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2007-07-08 14:58:17 UTC
Remove USE=doc on initial install.

*** This bug has been marked as a duplicate of bug 175808 ***