Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 152176 - media-libs/libmpeg3-1.5.2 fails to emerge
Summary: media-libs/libmpeg3-1.5.2 fails to emerge
Status: RESOLVED DUPLICATE of bug 135560
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: media-video herd
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-20 16:26 UTC by John Bartoszewski
Modified: 2006-10-21 00:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
emerge output (gentoo1,5.49 KB, text/plain)
2006-10-20 16:27 UTC, John Bartoszewski
Details
emerge --info (gentoo2,3.68 KB, text/plain)
2006-10-20 16:28 UTC, John Bartoszewski
Details

Note You need to log in before you can comment on or make changes to this bug.
Description John Bartoszewski 2006-10-20 16:26:01 UTC
User-Agent:       Mozilla/5.0 (X11; U; Linux x86_64; en-US; rv:1.8.0.7) Gecko/20060919 Firefox/1.5.0.7
Build Identifier: 

I was doing a emerge -eav world, got 320 packages in and hit media-libs/libmpeg3
which failed:

...
gcc -c `cat i686/c_flags`  video/output.c -o i686/video/output.o
video/output.c:210: warning: integer constant is too large for 'long' type
video/output.c:212: warning: integer constant is too large for 'long' type
video/output.c:214: warning: integer constant is too large for 'long' type
video/output.c:301: warning: integer constant is too large for 'long' type
video/output.c:303: warning: integer constant is too large for 'long' type
video/output.c: In function 'mpeg3video_ditherframe':
video/output.c:722: error: invalid lvalue in increment
video/output.c:747: error: invalid lvalue in increment
video/output.c:787: error: invalid lvalue in increment
video/output.c:812: error: invalid lvalue in increment
make: *** [i686/video/output.o] Error 1


Reproducible: Always
Comment 1 John Bartoszewski 2006-10-20 16:27:51 UTC
Created attachment 100110 [details]
emerge output
Comment 2 John Bartoszewski 2006-10-20 16:28:56 UTC
Created attachment 100111 [details]
emerge --info
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-10-21 00:28:31 UTC
Fixed in 1.5.2-r3 which is stable everywhere, emerge --sync please.


*** This bug has been marked as a duplicate of 135560 ***