Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 151695 - dev-python/python-docs env.d entry incorrect
Summary: dev-python/python-docs env.d entry incorrect
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: High trivial (vote)
Assignee: Python Gentoo Team
Depends on:
Blocks: 183470
  Show dependency tree
Reported: 2006-10-17 06:05 UTC by tenoften
Modified: 2009-06-12 21:32 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description tenoften 2006-10-17 06:05:36 UTC
In file /etc/env.d/50python-docs belonging to the python-docs package,
should be

This so the "MODULES DOCS" path in e.g. "pydoc shlex" points right.
Comment 1 Bryan Østergaard (RETIRED) gentoo-dev 2007-05-07 07:54:51 UTC
Thanks, fixed in latest versions.
Comment 2 Daniel LaMotte 2007-12-17 19:00:02 UTC
this is fixed for 2.5, but not for 2.5.1 or 2.4
Comment 3 Rick Morra 2009-06-11 17:27:57 UTC
Still not fixed in LATEST STABLE python-docs (2.5.4)!!!!!!!!!!
Comment 4 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-06-12 14:12:29 UTC
(In reply to comment #3)
> Still not fixed in LATEST STABLE python-docs (2.5.4)

You're wrong.
Comment 5 Rick Morra 2009-06-12 18:00:36 UTC
I just executed this session:

# emerge --info
Portage (default/linux/x86/2008.0/desktop, gcc-4.3.2, glibc-2.8_p20080602-r1, 2.6.29-gentoo-r5 i686)
System uname: Linux-2.6.29-gentoo-r5-i686-Intel-R-_Core-TM-2_Duo_CPU_E8400_@_3.00GHz-with-glibc2.0
Timestamp of tree: Fri, 12 Jun 2009 08:20:01 +0000
app-shells/bash:     3.2_p39
dev-java/java-config: 2.1.7
dev-lang/python:     2.5.4-r2
dev-util/cmake:      2.6.4
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.63
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10.2
sys-devel/binutils:  2.18-r3
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.27-r2
CFLAGS="-O2 -march=native -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/config /var/lib/hsqldb"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=native -pipe"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
LINGUAS="en_US en"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
USE="X acl acpi alsa arts bash-completion berkdb bluetooth branding bzip2 cairo caps cdr cli cracklib crypt cscope cups dbus dri dvd dvdr dvdread eds emboss encode epydoc esd evo exif fam fax fbcon firefox fortran gcrypt gif gimp gmp gnome gphoto2 gpm gstreamer gtk gtkhtml hal hardenedphp iconv idn imagemagick innodb ipv6 isdnlog java javascript jpeg jpeg2k junit kde kerberos laptop latex lcms ldap libnotify lzo mad mailwrapper mhash midi mikmod mmx mng mozilla mp3 mpeg mplayer mudflap mysql mysqli ncurses nls nptl nptlonly nsplugin ntp nvidia ogg opengl openmp oss pam pch pcre pdf perl php pic plotutils png posix ppds pppd python qt3 qt3support qt4 quicktime readline reflection samba sasl scanner sdl session slang snmp spell spl sse sse2 ssl ssse3 startup-notification svg swat sysfs tcl tcpd tidy tiff toolbar truetype unicode usb utils vim-pager vim-syntax vorbis win32codecs wmf wmp x86 xml xorg xulrunner xv zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" CAMERAS="canon" ELIBC="glibc" INPUT_DEVICES="keyboard mouse evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en_US en" USERLAND="GNU" VIDEO_CARDS="nvidia nv vesa"

# grep python-docs /etc/portage/package*
# emerge -av1 python-docs

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild   R   ] dev-python/python-docs-2.5.4  0 kB

Total: 1 package (1 reinstall), Size of downloads: 0 kB

Would you like to merge these packages? [Yes/No] y
--- replaced dir /usr
>>> Original instance of package unmerged safely.
>>> Auto-cleaning packages...

>>> No outdated packages were found on your system.

 * GNU info directory index is up-to-date.

# ls -l /etc/env.d/50python-docs
-rw-r--r-- 1 root wheel 53 2009-06-12 13:20 /etc/env.d/50python-docs

### Notice this file date is today!!! ###

# cat /etc/env.d/50python-docs
# env-update

Then I opened a new shell. In this shell:

$ pydoc print | cat

Sorry, topic and keyword documentation is not available because the Python
HTML documentation files could not be found.  If you have installed them,
please set the environment variable PYTHONDOCS to indicate their location.

On the Microsoft Windows operating system, the files can be built by
running "hh -decompile . PythonNN.chm" in the C:\PythonNN\Doc> directory.

$ export PYTHONDOCS=/usr/share/doc/python-docs-2.5.4/html
$ pydoc print | cat

  6.6 The print statement

        print_stmt       ::=     "print" ([expression[1] ("," expression[2])* [","]
                        | ">>" expression[3] [("," expression[4])+ [","])

  Download entire grammar as text.[5]

  print evaluates each expression in turn and writes the resulting object
  to standard output (see below). If an object is not a string, it is
  first converted to a string using the rules for string conversions. The
  (resulting or original) string is then written. A space is written
  before each object is (converted and) written, unless the output system
  believes it is positioned at the beginning of a line. This is the case
  (1) when no characters have yet been written to standard output, (2)
  when the last character written to standard output is "\n", or (3) when
  the last write operation on standard output was not a print statement.
  (In some cases it may be functional to write an empty string to standard
  output for this reason.) Note: Objects which act like file objects but
  which are not the built-in file objects often do not properly emulate
  this aspect of the file object's behavior, so it is best not to rely on

  A "\n" character is written at the end, unless the print statement ends
  with a comma. This is the only action if the statement contains just the
  keyword print.

  Standard output is defined as the file object named stdout in the
  built-in module sys. If no such object exists, or if it does not have a
  write() method, a RuntimeError exception is raised.

  print also has an extended form, defined by the second portion of the
  syntax described above. This form is sometimes referred to as ``print
  chevron.'' In this form, the first expression after the >> must evaluate
  to a ``file-like'' object, specifically an object that has a write()
  method as described above. With this extended form, the subsequent
  expressions are printed to this file object. If the first expression
  evaluates to None, then sys.stdout is used as the file for output.

  Release 2.5.4, documentation updated on 23rd December, 2008.

### Comment #4 says I'm wrong and it is fixed. But its not fixed for me! ###

Comment 6 Arfrever Frehtes Taifersar Arahesis (RETIRED) gentoo-dev 2009-06-12 21:32:19 UTC
(In reply to comment #5)

OK. Fixed in 2.4.4-r1 and 2.5.4-r1.