Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 150909 - GNOME Settings Daemon fails to start
Summary: GNOME Settings Daemon fails to start
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] GNOME (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux Gnome Desktop Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-10-11 10:07 UTC by b52
Modified: 2009-04-10 17:04 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description b52 2006-10-11 10:07:57 UTC
Hi
When I start gnome and log in I get the following error, the sound mixer applet doesn't start and I lost my desktop background picture:
------------------------------------
There was an error starting the GNOME Settings Daemon.
Some things, such as themes, sounds, or background settings may not work correctly.
The Settings Daemon restarted too many times.
The last error message was:
System exception: IDL:Bonobo/GeneralError:1.0 : Child process did not give an error message, unknown failure occurred
GNOME will still try to restart the Settings Daemon next time you log in.
---------------------------------------

I tried already to rebuild all the gnome stuff, pango, libbonobo, libbonoboui and revdep-rebuild but still lose the mixer applet, my background pic and get that error message.

Thanks for any help guys.

Portage 2.1.1 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.17-gentoo-r8 i686)
=================================================================
System uname: 2.6.17-gentoo-r8 i686 Intel(R) Pentium(R) M processor 1300MHz
Gentoo Base System version 1.12.5
Last Sync: Tue, 10 Oct 2006 18:50:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.2.11-r1
dev-lang/python:     2.3.5, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.17-r1
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium3 -O2 -pipe -fomit-frame-pointer -funroll-loops"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=pentium3 -O2 -pipe -fomit-frame-pointer -funroll-loops"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distcc distlocks fixpackages metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.inode.at ftp://gentoo.inode.at/source rsync://rsync.fhh.opensource-mirror.de/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ rsync://linux.rz.ruhr-uni-bochum.de/gentoo/ http://mirrors.sec.informatik.tu-darmstadt.de/gentoo rsync://mirrors.sec.informatik.tu-darmstadt.de/gentoo http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo rsync://ftp.join.uni-muenster.de/gentoo/ ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo"
LINGUAS=""
MAKEOPTS="-j4"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 X acpi alsa apache2 apm arts berkdb bitmap-fonts cdr cli crypt cups dlloader dri dvd dvdr eds elibc_glibc emboss encode esd foomaticdb fortran gdbm gif gnome gpm gstreamer gtk gtk2 imlib input_devices_evdev input_devices_keyboard input_devices_mouse ipv6 isdnlog jpeg kde kernel_linux libg++ libwww mad mikmod mmx motif mp3 mpeg ncurses nls nptl ogg opengl oss pam pcre perl png pppd python qt3 qt4 quicktime readline reflection sdl session spell spl sse sse2 ssl tcpd truetype truetype-fonts type1-fonts udev unicode userland_GNU video_cards_i810 video_cards_i830 vorbis xml xmms xorg xv zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY
Comment 1 Stian Skjelstad 2006-11-05 12:29:41 UTC
I'm seeing this too. Sideeffects seens so far is that my desktop background is gone, and all the icons in evolutions is gone.
Comment 2 Stian Skjelstad 2006-11-05 12:32:00 UTC
Just saw the problem here:

stian@localhost ~ $ /usr/libexec/gnome-settings-daemon
/usr/libexec/gnome-settings-daemon: error while loading shared libraries: libesd.so.0: cannot open shared object file: No such file or directory

revdep-rebuild should fetch this issue. Why gnome-settings-deamon has esd linked into it in the first place is a mistery of its own.
Comment 3 Daniel Gryniewicz (RETIRED) gentoo-dev 2006-11-05 12:34:42 UTC
The other common reason why gnome-settings-daemon won't start is lack of a session dbus.  gdm/gnome-session starts it for you, but if you use startx or some other XDM, then you'll need to start your session bus yourself like so:

eval `dbus-launch --sh-syntax --exit-with-session`
Comment 4 b52 2006-11-07 11:12:27 UTC
Well revdep-rebuild did not fix the problem and dbus is running.
I discovered that the gnome-settings-daemon crashes on gnome startup, but restarts itself immediately and keeps up running in background. But anyway I get that error message, lose the mixer-applet, the "show desktop"-applet and my background picture. Sometimes also the bottom panel disapears, sometimes not.

I killed the running gnome-settings-daemon and started it manualy in a terminal. I got the following output:
-------------------------------------------------------------
[1162926110,000,xklavier.c:XklStartListen/]     The backend does not require man
ual layout management - but it is provided by the application
ERROR: Caught a segmentation fault while loading plugin file:
/usr/lib/gstreamer-0.10/libgstaudioresample.so

Please either:
- remove it and restart.
- run with --gst-disable-segtrap and debug.

** (gnome-settings-daemon:7929): WARNING **: Failed to send buffer

** (gnome-settings-daemon:7929): WARNING **: Failed to send buffer

(gnome-settings-daemon:7929): Bonobo-Activation-WARNING **: Strange exception (I
DL:omg.org/CORBA/COMM_FAILURE:1.0) from active server registration

** (gnome-settings-daemon:7929): WARNING **: Encountered problems registering th
e settings daemon with bonobo-activation. Clients may not detect that the settin
gs daemon is already running.
xrdb:  "*Label.background" on line 243 overrides entry on line 170
xrdb:  "*Text.background" on line 249 overrides entry on line 211
xrdb:  "*Label.foreground" on line 255 overrides entry on line 171
xrdb:  "*Text.foreground" on line 261 overrides entry on line 212
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
Xlib:  extension "GLX" missing on display ":0.0".
--------------------------------------------------

I will investigate to see if libgstaudioresample.so is responsible for that.
Any help is still appreciated.
Comment 5 Gilles Dartiguelongue gentoo-dev 2007-08-02 07:12:17 UTC
@b52, any news on this ?
Comment 6 Rémi Cardona gentoo-dev 2007-09-02 17:34:28 UTC
It's been 10 months since last comment, don't hesitate to reopen if this bug is still an issue.

Thanks :)
Comment 7 Christopher Friedt 2009-03-18 23:06:20 UTC
Thanks Daniel!

(In reply to comment #3)
> eval `dbus-launch --sh-syntax --exit-with-session`

In a completely (?) unrelated problem, I was right in the middle of upgrading from ~gnome-2.22 to ~gnome-2.24, which is still unstable, and couldn't get my gnome-session back with everything I tried. 

For the time being, I was using fluxbox. e.g. startx, and my ~/.xinitrc was 'exec startfluxbox'. It was ok, and helped me debug the gnome desktop problems a bit. Then I came across this bug. 

I was using the following commands to test out a gnome desktop with Xnest.

MYDISPLAY=:1
MCOOKIE=$(mcookie)
xauth add localhost/unix$MYDISPLAY . $MCOOKIE
xauth add $(hostname)$MYDISPLAY . $MCOOKIE
xinit -- /usr/X11R6/bin/Xnest $MYDISPLAY
xauth remove $(hostname)$MYDISPLAY

Then, I added your line to my ~/.xinitrc

eval `dbus-launch --sh-syntax --exit-with-session`

and my gnome-session started (almost perfectly) in the nested X session.

Cheers,

Chris



Comment 8 jessy cowan-sharp 2009-04-03 05:11:44 UTC
this worked for me as well using kernel 2.6.27-r8. i have been starting gnome manually with startx, and previously i had only 'exec gnome-session' in my .xinitrc. i added the line:
eval `dbus-launch --sh-syntax --exit-with-session`
before the exec gnome-session line, and now the settings daemon does not throw an error on start. 

thank you!