Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 150410 - php-4.4.4-r4 won't compile with USE="java"
Summary: php-4.4.4-r4 won't compile with USE="java"
Status: RESOLVED DUPLICATE of bug 23579
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-10-07 13:07 UTC by Dave
Modified: 2006-10-07 13:25 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge --info (info,18.59 KB, text/plain)
2006-10-07 13:08 UTC, Dave
config.log (config.log,169.29 KB, text/plain)
2006-10-07 13:11 UTC, Dave

Note You need to log in before you can comment on or make changes to this bug.
Description Dave 2006-10-07 13:07:28 UTC
I've seen similiar bugs with solutions (I also have run revdep-rebuild and everything is good), but I've tried everything and I still get this error,

checking whether to enable xslt support... yes, shared
checking for XSLT Sablotron backend... shared
checking for libexpat dir for Sablotron XSL support... no
checking for iconv dir for Sablotron XSL support... no
checking for JavaScript for Sablotron XSL support... no
checking for Sablotron libraries in the default path... found in /usr
checking for sablot-config... found
checking for Sablotron version... configure: error: Sablotron version 0.96 or greater required.

!!! ERROR: dev-lang/php-4.4.4-r4 failed.
Call stack:, line 1546:   Called dyn_compile, line 937:   Called src_compile
  php-4.4.4-r4.ebuild, line 173:   Called src_compile_normal
  php-4.4.4-r4.ebuild, line 330:   Called php4_4-sapi_src_compile
  php4_4-sapi.eclass, line 533:   Called die

!!! configure failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
Comment 1 Dave 2006-10-07 13:08:19 UTC
Created attachment 99070 [details]
emerge --info
Comment 2 Dave 2006-10-07 13:11:41 UTC
Created attachment 99071 [details]
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-10-07 13:25:52 UTC
configure:127971: ./conftest
./conftest: error while loading shared libraries: cannot open shared object file: No such file or directory

Has nothing to do with sablotron version, your java is messed up.

*** This bug has been marked as a duplicate of 23579 ***