Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 15022 - libgd 1.8.6-r6 ebuild should not require sed >= 4
Summary: libgd 1.8.6-r6 ebuild should not require sed >= 4
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2003-02-03 01:46 UTC by Rajiv Aaron Manglani (RETIRED)
Modified: 2003-02-04 13:16 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Rajiv Aaron Manglani (RETIRED) gentoo-dev 2003-02-03 01:46:21 UTC
the media-libs/libgd-1.8.3-r6 ebuild should not require sed >= 4.0.
sed is only used in the ebuild and is not a dependency of libdg.
users should not be forced to upgrade/install to sed 4 just to emerge libgd.
Comment 1 Mark Guertin 2003-02-03 01:49:57 UTC
Also wanted to add that this build (set to ~ppc) is currently a blocker for anyone on ppc trying to do emerge -u world

sed 4.x does not yet run properly on ppc and is set as -ppc.  Please be cautios to check the dependancies when setting any non native arches.  Builds should _really_ be tested at the very least on the arch in question before getting a ~arch KEYWORD.
Comment 2 Seemant Kulleen (RETIRED) gentoo-dev 2003-02-04 13:16:20 UTC
fixed in cvs