Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 147558 - etc-update is broken with emacs
Summary: etc-update is broken with emacs
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Core - Configuration (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Portage team
Keywords: InVCS
: 172982 (view as bug list)
Depends on:
Blocks: 181949 187293
  Show dependency tree
Reported: 2006-09-14 05:23 UTC by John Altstadt
Modified: 2007-06-29 02:52 UTC (History)
2 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description John Altstadt 2006-09-14 05:23:37 UTC
etc-update no longer works with emacs selected as the diff tool.

I have the lines:

diff_command="eval emacs --eval=\(ediff\ \"%file1\"\ \"%file2\"\)"

in /etc/etc-update.conf. After upgrading portage, when I run etc-update, I get error messages that look like:

Beginning of differences between /etc/ssl/openssl.cnf and /etc/ssl/._cfg0000_openssl.cnf
/usr/sbin/etc-update: eval: line 304: syntax error near unexpected token `('
/usr/sbin/etc-update: eval: line 304: `emacs --eval=(ediff "/etc/ssl/openssl.cnf" "/etc/ssl/._cfg0000_openssl.cnf")'
End of differences between /etc/ssl/openssl.cnf and /etc/ssl/._cfg0000_openssl.cnf


~ # emerge --info
Portage 2.1.1 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.15-gentoo-r1 i686)
System uname: 2.6.15-gentoo-r1 i686 AMD Athlon(tm) XP 1700+
Gentoo Base System version 1.12.4
Last Sync: Sun, 10 Sep 2006 18:30:07 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.2.3-r6, 2.3.5-r2, 2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
CFLAGS="-O3 -march=athlon-xp -funroll-loops -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O3 -march=athlon-xp -funroll-loops -pipe"
FEATURES="autoconfig ccache distcc distlocks fixpackages metadata-transfer parallel-fetch sandbox severe sfperms strict userpriv"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="x86 3dfx 3dnow 3dnowext X a52 aac adns alsa apache2 arts artswrappersuid asf avi bcmath berkdb bitmap-fonts bl browserplugin cairo calendar cdda cdparanoia cdr cli corba crypt cups curl dbus dga directfb divx4linux dlloader dmx doc dri dts dv dvb dvd dvdr dvdread edl eds elibc_glibc emacs emboss encode esd ethereal exif fam fastcgi fbcon firefox foomaticdb fortran gb gcj gd gdbm ggi gif gnome gnustep gnutls gpm gstreamer gtk gtk2 gtkhtml guile hal imagemagick imap imlib innodb input_devices_keyboard input_devices_mouse insecure-savers ipv6 isdnlog ithreads jack java jpeg kde kernel_linux libg++ linguas_en live lua lzo mad maildir mailwrapper math matroska mikmod mmx mmx2 mmxext mod modelock mp3 mpeg mysql mythtv nas ncurses network nls nptl nptlonly nsplugin objc odbc offensive ofx ogg oggvorbis opengl oss pam pam_console pcntl pcre pda pdflib perl pic plugin png ppds pppd python qt3 qt4 quicktime quotes readline real reflection rtc samba sasl sdk sdl session sharedext skins slp snmp speex spell spl sse ssl stream svg svga tcltk tcpd tetex tga theora threads tidy tiff tk truetype truetype-fonts type1-fonts udev unicode usb userland_GNU vcd video_cards_fbdev video_cards_mach64 video_cards_vesa video_cards_vga vorbis win32codecs wmf wxwindows xanim xml xmms xorg xosd xv xvid zeo zlib"

~ #
Comment 1 John Altstadt 2006-09-14 05:37:15 UTC
Or is this a problem with emacs itself? It also seems to have changed during the upgrade to 2006.1.
Comment 2 frank paulsen 2006-09-15 03:05:55 UTC
> diff_command="eval emacs --eval=\(ediff\ \"%file1\"\ \"%file2\"\)"
> using_editor=1

there are some quotes missing. i got i to work with:

diff_command="eval emacs --eval=\'\(ediff\ \"%file1\"\ \"%file2\"\)\'"
Comment 3 John Altstadt 2006-09-15 05:46:09 UTC
That works perfectly.

It looks like only the default etc-update.conf file supplied by portage needs to change.
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2007-04-01 09:55:14 UTC
*** Bug 172982 has been marked as a duplicate of this bug. ***
Comment 5 thierry volpiatto 2007-04-01 11:08:29 UTC
Ok i tried with the lisp expression quoted and it's work:
diff_command="eval emacs -nw --eval=\'\(ediff\ \"%file1\"\ \"%file2\"\)\'"
thank you
Comment 6 Christian Faulhammer (RETIRED) gentoo-dev 2007-06-01 08:55:35 UTC
Portage team, this fix seems sane to me.
Comment 7 Zac Medico gentoo-dev 2007-06-29 02:52:36 UTC
This has been released in 2.1.3_rc6.