Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 147234 - savage driver crashes / freezes on xorg 7.0 or greater on amilo k7600
Summary: savage driver crashes / freezes on xorg 7.0 or greater on amilo k7600
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo X packagers
Depends on:
Reported: 2006-09-11 14:30 UTC by Eero Volotinen
Modified: 2006-10-02 20:55 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

xorg.0.log (Xorg.0.log,33.11 KB, text/plain)
2006-09-11 14:57 UTC, Eero Volotinen
xorg.conf (backup.xorg.conf-71,2.93 KB, text/plain)
2006-09-11 14:58 UTC, Eero Volotinen
xorg-config-works. (xorg.conf,3.05 KB, text/plain)
2006-10-01 14:51 UTC, Eero Volotinen

Note You need to log in before you can comment on or make changes to this bug.
Description Eero Volotinen 2006-09-11 14:30:22 UTC
savage driver crashes / freezes on xorg 7.0 or greater


Portage 2.1-r2 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.1                                                                             7-gentoo-r8 i686)
System uname: 2.6.17-gentoo-r8 i686 mobile AMD Athlon(tm) XP-M 2600+
Gentoo Base System version 1.12.1
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -march=i686 -pipe"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shu                                                                             tdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe"
FEATURES="autoconfig candy distlocks metadata-transfer prelink sandbox sfperms s                                                                             trict"
GENTOO_MIRRORS="                                                                             entoo/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress                                                                              --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/d                                                                             istfiles' --exclude='/local' --exclude='/packages'"
USE="3dnow X acpi alsa arts avi berkdb bitmap-fonts cairo cdparanoia cdr cli cry                                                                             pt cups dbus divx divx4linux dlloader dri dvd dvdr dvdread eds emboss encode esd                                                                              fam firefox font-server fortran freetype gcj gdbm gif gimpprint gphoto2 gpm gst                                                                             reamer hal isdnlog java jpeg jpeg2k kde kdeenablefinal ldap libg++ logitech-mous                                                                             e mad mikmod mmx mozilla mp3 mpeg ncurses nls nomalloccheck nptl nptlonly ogg op                                                                             engl oss pam pcmcia pcre pda pdf pdflib perl pic png ppds pppd python qt3 qt4 qu                                                                             icktime readline reflection samba scanner sdl session slp spell spl sse ssl tcpd                                                                              truetype truetype-fonts type1 type1-fonts udev usb vorbis wifi win32codecs x86                                                                              xine xml xorg xprint xv xvid zlib elibc_glibc input_devices_keyboard input_devic                                                                             es_mouse input_devices_evdev kernel_linux userland_GNU video_cards_savage"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGU                                                                             AS, PORTAGE_RSYNC_EXTRA_OPTS, PORTDIR_OVERLAY

This is clean install from 2006.1 cd almost.


00:00.0 Host bridge: VIA Technologies, Inc. P/KN266 Host Bridge
00:01.0 PCI bridge: VIA Technologies, Inc. VT8633 [Apollo Pro266 AGP]
00:09.0 CardBus bridge: ENE Technology Inc CB-710/2/4 Cardbus Controller (rev 01)
00:10.0 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.1 USB Controller: VIA Technologies, Inc. VT82xxxxx UHCI USB 1.1 Controller (rev 80)
00:10.3 USB Controller: VIA Technologies, Inc. USB 2.0 (rev 82)
00:11.0 ISA bridge: VIA Technologies, Inc. VT8235 ISA Bridge
00:11.1 IDE interface: VIA Technologies, Inc. VT82C586A/B/VT82C686/A/B/VT823x/A/C PIPC Bus Master IDE (rev 06)
00:11.5 Multimedia audio controller: VIA Technologies, Inc. VT8233/A/8235/8237 AC97 Audio Controller (rev 50)
00:11.6 Communication controller: VIA Technologies, Inc. AC'97 Modem Controller (rev 80)
00:12.0 Ethernet controller: VIA Technologies, Inc. VT6102 [Rhine-II] (rev 74)
01:00.0 VGA compatible controller: S3 Inc. VT8375 [ProSavage8 KM266/KL266]

machine is f-s amilo k7600

So, new Xorg is unusable in this machine. any ideas? must go back to 6.x series.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-09-11 14:51:56 UTC
Please, attach the xorg.conf and /var/log/Xorg.0.log here. Don't refer to links that expire in couple of days and make the bug useless.
Comment 2 Eero Volotinen 2006-09-11 14:57:22 UTC
Created attachment 96747 [details]
Comment 3 Eero Volotinen 2006-09-11 14:58:38 UTC
Created attachment 96748 [details]
Comment 4 Eero Volotinen 2006-09-11 14:59:53 UTC
It works about 1-2 minutes, if you don't do anything. If you start for example firefox, system freezes, only mouse works and screen is screwed or something..

I think this is bug in savage driver
Comment 5 Eero Volotinen 2006-09-11 15:35:46 UTC
This works fine with xorg 6.8-something, version to that I changed to get work done at company.
Comment 6 Joshua Baergen (RETIRED) gentoo-dev 2006-09-12 15:01:35 UTC
> (EE) Failed to load module "synaptics" (module does not exist, 0)

For one thing, you'll need to re-emerge the synaptics driver after emerging 7.0.

> (EE) SAVAGE(0): DRI isn't enabled

If X still doesn't start, add 'Option "NoAccel" "true"' to your savage config and try again.
Comment 7 Joshua Baergen (RETIRED) gentoo-dev 2006-09-24 10:05:34 UTC
Let us know when you've tried the suggestions in comment #6.
Comment 8 Joshua Baergen (RETIRED) gentoo-dev 2006-09-25 15:12:36 UTC
Note to self: looks like may be related to this.
Comment 9 Eero Volotinen 2006-10-01 14:50:34 UTC
'Option "NoAccel" "true"' fixes problem, but video input is slow?

I am using xorg-x11 and latest masked savage driver from portage
Comment 10 Eero Volotinen 2006-10-01 14:51:55 UTC
Created attachment 98559 [details]
Comment 11 Eero Volotinen 2006-10-01 15:01:37 UTC
NOT WORKING EVEN WITH NOACCEL option, I was tired and used wrong driver.
Vesa works at least .. but it is very very slow..
Comment 12 Eero Volotinen 2006-10-01 23:49:54 UTC
Just tested, the same bug is in ubuntu.
Comment 13 Eero Volotinen 2006-10-02 01:57:16 UTC
Looks like upstream bug, can someone report it to upstream?
Comment 14 Eero Volotinen 2006-10-02 08:55:07 UTC
Looks like this works if using vanilla kernel 2.6.18 and it integrated dri

Comment 15 Eero Volotinen 2006-10-02 20:55:30 UTC