Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 146871 - dev-util/gambas-2.7.0 version bump request
Summary: dev-util/gambas-2.7.0 version bump request
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
: 151516 185858 189010 205463 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-09-08 12:58 UTC by Tiziano Müller (RETIRED)
Modified: 2011-04-05 12:47 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
gambas-1.9.42.ebuild (gambas-1.9.42.ebuild,3.42 KB, text/plain)
2006-09-23 07:40 UTC, Tiziano Müller (RETIRED)
Details
gambas-1.9.50.ebuild (Update) (gambas-1.9.50.ebuild,2.50 KB, text/plain)
2007-08-15 15:56 UTC, GarulfoUnix
Details
Update to version 1.9.91 (gambas-1.9.91.ebuild,2.50 KB, text/plain)
2007-11-14 10:24 UTC, GarulfoUnix
Details
(Please Fix it, read comment) Version Bump to 2.2.1 (gambas-2.2.1.ebuild,2.53 KB, text/plain)
2008-03-07 14:34 UTC, Sebastián Magrí
Details
Version Bump, Sandbox problems persist (gambas-2.3.0.ebuild,2.05 KB, text/plain)
2008-03-17 08:40 UTC, Sebastián Magrí
Details
gambas-2.5.0.ebuild NOT FOR USE (gambas-2.5.0.ebuild,2.70 KB, text/plain)
2008-04-11 18:35 UTC, Boian Berberov
Details
gambas-2.5.0.ebuild (gambas-2.5.0.ebuild,4.19 KB, text/plain)
2008-04-18 17:07 UTC, Boian Berberov
Details
files/gambas-2.5.0-gcc-libffi-path.patch (gambas-2.5.0-gcc-libffi-path.patch,386 bytes, patch)
2008-04-18 17:10 UTC, Boian Berberov
Details | Diff
files/gambas-2.5.0-help-path.patch (gambas-2.5.0-help-path.patch,755 bytes, patch)
2008-04-18 17:11 UTC, Boian Berberov
Details | Diff
files/gambas-2.5.0-mimetype-registration.patch (gambas-2.5.0-mimetype-registration.patch,1.41 KB, patch)
2008-04-18 17:12 UTC, Boian Berberov
Details | Diff
files/gambas-2.5.0-sdl.patch (gambas-2.5.0-sdl.patch,624 bytes, patch)
2008-04-18 17:13 UTC, Boian Berberov
Details | Diff
files/gambas-2.7.0-help-path.patch (gambas-2.7.0-help-path.patch,915 bytes, patch)
2008-06-21 11:31 UTC, Richard Westwell
Details | Diff
gambas-2.7.0.ebuild (gambas-2.7.0.ebuild,3.97 KB, text/plain)
2008-06-21 11:34 UTC, Richard Westwell
Details
gambas-2.21.0.ebuild (gambas-2.21.0.ebuild,9.81 KB, text/plain)
2010-08-02 12:58 UTC, lalebarde
Details
patches for gambas 2.20.0, 2.20.2, 2.21.0 (gambas-2.20-to-21.patches.bz2,3.64 KB, patch)
2010-08-02 13:09 UTC, lalebarde
Details | Diff
gambas-2.20.2.ebuild (gambas-2.20.2.ebuild,9.76 KB, text/plain)
2010-08-02 13:13 UTC, lalebarde
Details
gambas-2.20.0.ebuild (gambas-2.20.0.ebuild,9.66 KB, text/plain)
2010-08-02 13:13 UTC, lalebarde
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Tiziano Müller (RETIRED) gentoo-dev 2006-09-08 12:58:19 UTC
There are new version out for the stable and the devel branch:
stable: 1.0.17
devel:  1.9.41
Comment 1 Tiziano Müller (RETIRED) gentoo-dev 2006-09-23 01:53:25 UTC
For the stable version it is sufficient to copy the ebuild.
Comment 2 Tiziano Müller (RETIRED) gentoo-dev 2006-09-23 07:40:52 UTC
Created attachment 97857 [details]
gambas-1.9.42.ebuild

A revised ebuild for version 1.9.42
Comment 3 Tiziano Müller (RETIRED) gentoo-dev 2006-09-23 07:46:53 UTC
The attached ebuild has new USE-flags, new dependencies, etc.
Comment 4 Tiziano Müller (RETIRED) gentoo-dev 2006-09-24 02:01:57 UTC
The attached ebuild works for version 1.9.43 too.
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-10-15 16:29:33 UTC
*** Bug 151516 has been marked as a duplicate of this bug. ***
Comment 6 Mickey 2006-10-15 16:55:13 UTC
(In reply to comment #1)
> For the stable version it is sufficient to copy the ebuild.
> (In reply to comment #1)
> For the stable version it is sufficient to copy the ebuild.
> 

Not really, it  would need work to patch the tarball probably. Not confident enough to really mean it. But here is a  report what happens when trying to jump the  1.0.14  ebuild  to 1.0.17:


 # ebuild /home/me/ebuilds/dev-util/gambas/gambas-1.0.17.ebuild   digest
 * gambas-1.0.17.tar.bz2 RMD160 ;-) ...                                   [ ok ] * gambas-1.0.17.tar.bz2 SHA1 ;-) ...                                     [ ok ] * gambas-1.0.17.tar.bz2 SHA256 ;-) ...                                   [ ok ] * gambas-1.0.17.tar.bz2 size ;-) ...                                     [ ok ]>>> Creating Manifest for /home/me/ebuilds/dev-util/gambas
  digest.assumed                 1
   digest-gambas-1.9.44::gambas2-1.9.44.tar.bz2
localhost me # emerge gambas Calculating dependencies... done!

>>> Emerging (1 of 1) dev-util/gambas-1.0.17 to /
 * gambas-1.0.17.tar.bz2 MD5 ;-) ...                                      [ ok ] * gambas-1.0.17.tar.bz2 RMD160 ;-) ...                                   [ ok ] * gambas-1.0.17.tar.bz2 SHA1 ;-) ...                                     [ ok ] * gambas-1.0.17.tar.bz2 SHA256 ;-) ...                                   [ ok ] * gambas-1.0.17.tar.bz2 size ;-) ...                                     [ ok ] * checking ebuild checksums ;-) ...                                      [ ok ] * checking auxfile checksums ;-) ...                                     [ ok ] * checking miscfile checksums ;-) ...                                    [ ok ] * checking gambas-1.0.17.tar.bz2 ;-) ...                                 [ ok ]>>> Unpacking source...
>>> Unpacking gambas-1.0.17.tar.bz2 to /var/tmp/portage/gambas-1.0.17/work

 * Cannot find $EPATCH_SOURCE!  Value for $EPATCH_SOURCE is:
 *
 *   /home/me/ebuilds/dev-util/gambas/files/gambas-1.0.6-configure-CFLAGS.patch
 *   ( gambas-1.0.6-configure-CFLAGS.patch )


!!! ERROR: dev-util/gambas-1.0.17 failed.
Call stack:
  ebuild.sh, line 1546:   Called dyn_unpack
  ebuild.sh, line 708:   Called src_unpack
  gambas-1.0.17.ebuild, line 34:   Called epatch '/home/me/ebuilds/dev-util/gambas/files/gambas-1.0.6-configure-CFLAGS.patch'
  eutils.eclass, line 198:   Called die

!!! Cannot find $EPATCH_SOURCE!
!!! If you need support, post the topmost build error, and the call stack if relevant.

!!! This ebuild is from an overlay: '/home/me/ebuilds'
Comment 7 Mickey 2006-10-15 16:58:40 UTC
Also copying the patch to files probably would make a version mismatching.
Comment 8 Mickey 2006-10-15 17:36:27 UTC
The  following has resolved the problem. Following information is meant to make sense to the average user.

1.  Go to your portage directory normally ( /usr/portage) copy  over to your gambas portdir overlaysubfolder (you  should know this if you use gentoo) the following ebuild: /usr/portage/dev-util/gambas/gambas-1.0.14.ebuild
 
2. copy to the files folder (into your portdir overlay gambas subfolder) the following files:

Makefile.am-1.0_rc2
gambas-1.0.6-configure-CFLAGS.patch

You should now have:  /usr/portage/dev-util/gambas/gambas-1.0.14.ebuild renamed to in  your  portdir  overlay to:  /usr/portage/dev-util/gambas/gambas-1.0.17.ebuild

3. Type in: ebuild /usr/portage/dev-util/gambas/gambas-1.0.17.ebuild digest

4. emerge  gambas or emerge -pv gambas  emerge -av gambas  (add any other options if you like) To see what will be done before  commiting.
 
Comment 9 Daniel Black (RETIRED) gentoo-dev 2007-08-04 23:46:28 UTC
*** Bug 185858 has been marked as a duplicate of this bug. ***
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2007-08-15 15:37:22 UTC
*** Bug 189010 has been marked as a duplicate of this bug. ***
Comment 11 GarulfoUnix 2007-08-15 15:56:13 UTC
Created attachment 128187 [details]
gambas-1.9.50.ebuild (Update)
Comment 12 Nicolas Lalevee 2007-10-13 11:54:48 UTC
FYI, I just tested the 1.9.90, using the 1.9.50 attached ebuild, it builds nicely, and start successfully.
Comment 13 Nicolas Lalevee 2007-10-13 12:05:18 UTC
and for the record :

Portage 2.1.3.9 (default-linux/x86/2007.0/desktop, gcc-4.1.2, glibc-2.5-r4, 2.6.22-gentoo-r8 i686)
=================================================================
System uname: 2.6.22-gentoo-r8 i686 Intel(R) Core(TM)2 CPU T7200 @ 2.00GHz
Timestamp of tree: Wed, 10 Oct 2007 14:00:01 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r5
dev-python/pycrypto: 2.0.1-r6
sys-apps/baselayout: 1.12.9-r2
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -march=i686 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages metadata-transfer nostrip parallel-fetch sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://213.186.33.38/gentoo-distfiles/ http://213.186.33.37/gentoo-distfiles/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://ftp.club-internet.fr/pub/mirrors/gentoo http://gentoo.modulix.net/gentoo/"
LC_ALL="fr_FR.UTF-8"
LINGUAS="fr"
MAKEOPTS="-j5"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/gentopia /usr/portage/local/layman/sunrise /usr/portage/local/dev"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="3dnow X a52 aac aalib accessibility acl acpi aiglx alsa apache2 apm arts asf audiofile bash-completion berkdb bitmap-fonts branding browserplugin bzip2 bzlib cairo cdda cddb cdparanoia cdr cli cracklib crypt cups curl daap dba dbus dga directfb dmi doc dri dts dv dvb dvd dvdr dvdread emboss encode esd evo examples exif expat fam fbcon ffmpeg firefox flac flash fortran fpx freetype ftp gcj gd gdbm gif gimpprint glut gpm graphviz gstreamer gtk gtk2 hal iconv icq idn ieee1394 imagemagick ipv6 isdnlog java javascript jbig jikes jpeg jpeg2k junit kde kdexdeltas kerberos lcms ldap libcaca live lm_sensors mad maildir matroska mbox mhash midi mikmod ming mmx mng mp3 mpeg mudflap musepack musicbrainz mysql nas ncurses network nls nptl nptlonly nsplugin ogg opengl openmp oss pam pcmcia pcre pdf perl php png portaudio posix ppds pppd python qt3 qt3support qt4 quicktime rdesktop readline real reflection samba sasl scanner sdl seamonkey session slp source speex spell spl sqlite sse sse2 ssl svg svga sysfs tcltk tcpd tetex theora threads tiff truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vcd vhosts videos vorbis wifi win32codecs wmf x86 xine xinerama xml xorg xpm xprint xsl xv xvid xvmc zeroconf zip zlib zsh-completion" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="fr" USERLAND="GNU" VIDEO_CARDS="nvidia vesa vga nv"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 14 GarulfoUnix 2007-11-14 10:24:09 UTC
Created attachment 135953 [details]
Update to version 1.9.91

This is the lastest development version before the final version of Gambas. 1.9.91 is a Realease Candidate version. To emerge it, don't forget to add into /etc/make.conf :
FEATURES="-sandbox -usersandbox"
Comment 15 Jakub Moc (RETIRED) gentoo-dev 2008-01-12 13:58:26 UTC
*** Bug 205463 has been marked as a duplicate of this bug. ***
Comment 16 lalebarde 2008-02-10 09:25:28 UTC
Citation : To emerge it, don't forget to add into /etc/make.conf :
FEATURES="-sandbox -usersandbox"

Why ? Isn't it risky/unsafe ? What is the justification please ?
Comment 17 Dennis Schridde 2008-02-21 12:23:36 UTC
Version 2.1 has been released (please update summary).
Comment 18 Sebastián Magrí 2008-03-07 14:34:30 UTC
Created attachment 145486 [details]
(Please Fix it, read comment) Version Bump to 2.2.1

Added dev-libs/libffi as a build dependency as emerge gives me configure error without it.

The last section of make gives me this error:

Registering Gambas executable mimetype
ACCESS DENIED  open_wr:   /usr/share/icons/hicolor/.xdg-icon-resource-dummy
touch: no se puede efectuar `touch' sobre «/usr/share/icons/hicolor/.xdg-icon-resource-dummy»: Permiso denegado
ACCESS DENIED  open_wr:   /usr/kde/3.5/share/mimelnk/application/x-gambas.desktop
/usr/bin/xdg-mime: line 983: /usr/kde/3.5/share/mimelnk//application/x-gambas.desktop: Permiso denegado
grep: /usr/kde/3.5/share/mimelnk//application/x-gambas.desktop: No existe el fichero o el directorio
rm: no se puede borrar «/usr/kde/3.5/share/mimelnk//application/x-gambas.desktop»: No existe el fichero o el directorio
make[3]: *** [install-exec-local] Error 1
make[3]: Leaving directory `/var/tmp/portage/dev-util/gambas-2.2.1/work/gambas2-2.2.1/main'
make[2]: *** [install-am] Error 2
make[2]: Leaving directory `/var/tmp/portage/dev-util/gambas-2.2.1/work/gambas2-2.2.1/main'
make[1]: *** [install-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/dev-util/gambas-2.2.1/work/gambas2-2.2.1/main'
make: *** [install-recursive] Error 1
 *
 * ERROR: dev-util/gambas-2.2.1 failed.
 * Call stack:
 *               ebuild.sh, line   49:  Called src_install
 *             environment, line 2481:  Called die
 * The specific snippet of code:
 *       make DESTDIR="${D}" install || die;
 *  The die message:
 *   (no error message)
 *
 * If you need support, post the topmost build error, and the call stack if relevant.
 * A complete build log is located at '/var/tmp/portage/dev-util/gambas-2.2.1/temp/build.log'.
 * The ebuild environment file is located at '/var/tmp/portage/dev-util/gambas-2.2.1/temp/environment'.
 * This ebuild is from an overlay: '/usr/local/portage/'
 *
--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-11680.log"

open_wr:   /usr/share/icons/hicolor/64x64/mimetypes/application-x-gambas.png
symlink:   /usr/share/icons/hicolor/64x64/mimetypes/gnome-mime-application-x-gambas.png
open_wr:   /usr/share/icons/hicolor/.xdg-icon-resource-dummy
open_wr:   /usr/share/icons/hicolor/.icon-theme.cache
open_wr:   /usr/share/mime/packages/application-x-gambas.xml
open_wr:   /usr/kde/3.5/share/mimelnk/application/x-gambas.desktop
--------------------------------------------------------------------------------
Comment 19 Sebastián Magrí 2008-03-07 14:50:55 UTC
Sorry so much... it builds fine with the recommended features added...

Please change the keywords from -amd64 to ~amd64 as i am testing it..

My emerge info:

Portage 2.1.4.4 (default-linux/amd64/2007.0, gcc-4.1.2, glibc-2.6.1-r0, 2.6.23-gentoo-r6 x86_64)
=================================================================
System uname: 2.6.23-gentoo-r6 x86_64 Mobile AMD Sempron(tm) Processor 3500+
Timestamp of tree: Sun, 02 Mar 2008 18:16:01 +0000
ccache version 2.4 [enabled]
app-shells/bash:     3.2_p17-r1
dev-java/java-config: 1.3.7, 2.1.4
dev-lang/python:     2.4.4-r6
dev-python/pycrypto: 2.0.1-r6
dev-util/ccache:     2.4-r7
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.18-r1
sys-devel/gcc-config: 1.4.0-r4
sys-devel/libtool:   1.5.26
virtual/os-headers:  2.6.23-r3
ACCEPT_KEYWORDS="amd64"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -mtune=k8 -Os -pipe -msse3"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-march=k8 -mtune=k8 -Os -pipe -msse3"
DISTDIR="/usr/portage/distfiles"
FEATURES="ccache distlocks metadata-transfer parallel-fetch sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://distfiles.gentoo.org"
LANG="es_ES.UTF-8"
LC_ALL="es_ES.UTF-8"
LDFLAGS="-Wl,-O1 -s"
LINGUAS="es"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/enlightenment /usr/portage/local/layman/gnash-cvs /usr/local/portage"
SYNC="rsync://rsync.samerica.gentoo.org/gentoo-portage"
USE="X a52 aac aalib acl acpi alsa amd64 apache2 apm arts audiofile avahi berkdb bitmap-fonts bzip2 cairo cddb cdparanoia cdr cli cracklib crypt cups dbus dga dri dts dvb dvd dvdread esd fat ffmpeg firefox flac foomaticdb fortran ftp fuse gdbm gif gimp gnutls gpm gtk hal iconv imagemagick inquisitio ipv6 isdnlog jack java jpeg kde kdm kerberos konqueror ladspa lame libcaca lm_sensors mad madwifi midi mmx mp3 mpeg msn mudflap musepack ncurses networkmanager nls nptl nptlonly nsplugin ogg openal opengl openmp pam pcre pdf perl php png portage posix pppd pulseaudio python qt3 qt4 readline reflection reiserfs rss ruby scanner session spell spl sse sse2 ssl subversion svg tcl tcpd theora timidity tk truetype-fonts type1-fonts unicode vcd vorbis wifi wxwindows xcomposite xine xorg xscreensaver xv xvid zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="actions alias auth_basic authn_alias authn_anon authn_dbm authn_default authn_file authz_dbm authz_default authz_groupfile authz_host authz_owner authz_user autoindex cache dav dav_fs dav_lock deflate dir disk_cache env expires ext_filter file_cache filter headers include info log_config logio mem_cache mime mime_magic negotiation rewrite setenvif speling status unique_id userdir usertrack vhost_alias" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="es" USERLAND="GNU" VIDEO_CARDS="ati radeon"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 20 Sebastián Magrí 2008-03-17 08:40:00 UTC
Created attachment 146379 [details]
Version Bump, Sandbox problems persist

The Access Violation issue have to be fixed to have the new version in Portage, probably it could be done by patching the Makefiles.

The following access violations:

--------------------------- ACCESS VIOLATION SUMMARY ---------------------------
LOG FILE = "/var/log/sandbox/sandbox-29355.log"

open_wr:   /usr/share/icons/hicolor/64x64/mimetypes/application-x-gambas.png
symlink:   /usr/share/icons/hicolor/64x64/mimetypes/gnome-mime-application-x-gambas.png (symlink to /usr/share/icons/hicolor/64x64/mimetypes/application-x-gambas.png)
open_wr:   /usr/share/icons/hicolor/.xdg-icon-resource-dummy
open_wr:   /usr/share/icons/hicolor/.icon-theme.cache
open_wr:   /usr/share/mime/packages/application-x-gambas.xml
open_wr:   /usr/kde/3.5/share/mimelnk/application/x-gambas.desktop
--------------------------------------------------------------------------------

Are probably caused by the following section of the file main/Makefile.am

        @if test x"$(XDG_UTILS)" != x; then \
                echo "Registering Gambas executable mimetype"; \
                $(INSTALL) -d $(DESTDIR)$(gbdatadir)/icons; \
                cp -f $(srcdir)/mime/application-x-gambas.png $(DESTDIR)$(gbdatadir)/icons; \
                xdg-icon-resource install --context mimetypes --size 64 $(DESTDIR)$(gbdatadir)/icons/appli$
                xdg-mime install $(srcdir)/mime/application-x-gambas.xml; \
        fi

Please if anyone knows how to fix it attach the patch...

Upstream has also been informed about the issue...
Comment 21 Boian Berberov 2008-04-10 18:30:28 UTC
I have been trying 2.5.0 and so far I have not seen any violations.  Will they show up when using ebuild instead of emerge?
Comment 22 Sebastián Magrí 2008-04-10 19:17:32 UTC
Boian could you paste your emerge --info??? I've already tryed with 2.5.0 but it's still giving me troubles...
Comment 23 Boian Berberov 2008-04-11 18:35:58 UTC
Created attachment 149425 [details]
gambas-2.5.0.ebuild NOT FOR USE

I do not think that would help you, yet.  I have not tried to emerge.  I have just looked at how the software compiles and tried to make a new ebuild, which I am attaching.  To everyone, this ebuild it NOT FOR USE.  It is only informative.

You need to compile gcc (I have 4.2) with the libffi USE flag for it to work.  The check for that is not in the ebuild yet.  Also, not every "--enable-" is set for emake so that is why it may not be showing any violations.
Comment 24 Boian Berberov 2008-04-18 17:07:44 UTC
Created attachment 150193 [details]
gambas-2.5.0.ebuild

A better, working, ebuild.  Still incomplete, but if anyone tries it, post here if it is working for you.
Comment 25 Boian Berberov 2008-04-18 17:10:17 UTC
Created attachment 150194 [details, diff]
files/gambas-2.5.0-gcc-libffi-path.patch
Comment 26 Boian Berberov 2008-04-18 17:11:31 UTC
Created attachment 150195 [details, diff]
files/gambas-2.5.0-help-path.patch
Comment 27 Boian Berberov 2008-04-18 17:12:25 UTC
Created attachment 150197 [details, diff]
files/gambas-2.5.0-mimetype-registration.patch
Comment 28 Boian Berberov 2008-04-18 17:13:42 UTC
Created attachment 150199 [details, diff]
files/gambas-2.5.0-sdl.patch
Comment 29 Julien 2008-05-25 18:35:14 UTC
gambas-2.6.0 bump please ? It's out since 10 May
Comment 30 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-06-05 23:07:10 UTC
*** Bug 185858 has been marked as a duplicate of this bug. ***
Comment 31 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-06-05 23:21:11 UTC
Due to the number of users CC'd on this bug and the current issues[1] with the two latest versions in the tree. I would like to put a (working) version of gambas in the tree.

I don't use gambas but the user submitted ebuild for 2.5.0 looks good to me. I'm intrigued by the "v41 kernel check needed" and the ewarn statement at the end. Can anyone tell me what is up with those?

Additionally, if anyone writes a working ebuild for 2.6.0, I will review that too. I am not so much interested in the later version that are in this bug and, consequently, will not review them.

@dev-zero: Any interest in picking this up? I'm looking at it from a treecleaner perspective to (eventually) remove the b0rked versions.

Thanks all!

[1]: see bug #130950 & bug #157670
Comment 32 Boian Berberov 2008-06-11 19:56:03 UTC
I am sorry.  I have been away and that is why there is no 2.6 version of the ebuild.

About "v4l kernel check needed," I was not sure if the ebuild needed to check for the V4L support and warn or fail if it was missing and the v4l USE flag was enabled.  I was looking at ebuilds that fail or warn the user if the kernel is compiled a certain way and I was not sure if this was applicable here.

About the ewarn statement at the end; the icons for the GUI component are not created properly or at all, at least from what I can see in the KDE menu.  Gambas appears to also register MIME types for its files and that does not work either.

I will not have much time to work on 2.6 for at least two or three weeks so someone else might have to do it.
Comment 33 Richard Westwell 2008-06-21 11:31:47 UTC
Created attachment 157893 [details, diff]
files/gambas-2.7.0-help-path.patch

patch for the 2.7.0 release
Comment 34 Richard Westwell 2008-06-21 11:34:53 UTC
Created attachment 157895 [details]
gambas-2.7.0.ebuild

this is almost a direct copy of the 2.5.0 ebuild apart from a few tabs / change in a patch
ebuild for 2.7.0
this seems to work but I haven't done any form of testing
Comment 35 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-06-26 13:10:16 UTC
(In reply to comment #34)
> Created an attachment (id=157895) [edit]
> gambas-2.7.0.ebuild
> 
> this is almost a direct copy of the 2.5.0 ebuild apart from a few tabs / change
> in a patch
> ebuild for 2.7.0
> this seems to work but I haven't done any form of testing
> 

Compiles fine.

I'm real close to adding this package for you guys. However it seems like qt3 is a non-optional dep. Does anyone else agree?
%% gambas2
ERROR: #27: Cannot load component 'gb.qt': cannot find library file

(rebuilding now with USE=qt3, but I must be off to work)

Comment 36 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2008-06-26 23:33:18 UTC
(In reply to comment #35)
> Compiles fine.
> 
> I'm real close to adding this package for you guys. However it seems like qt3
> is a non-optional dep. Does anyone else agree?
> %% gambas2
> ERROR: #27: Cannot load component 'gb.qt': cannot find library file
> 
> (rebuilding now with USE=qt3, but I must be off to work)

With USE=qt3, gambas works. Nice work. I'll commit this and close the bug. Please open a new bug for any other issues. I didn't test with USE=opengl -qt3 because I don't want to install ~mesa..Won't work out so nice on my laptop here.

I also moved all DEPENDs to RDPEND because if you make a bin package of this app, you will want all those libraries with it ;) 

Closing bug now, please open new bugs if there are issues. Thanks!
Comment 37 lalebarde 2010-08-02 12:55:47 UTC
Hi guys, here is gambas-2.21.0 :
1) Add kde-sunset to your overlays : layman -a kde-sunset
2) Put the gambas-2.21.0.ebuild file in your gambas overlay, and the above patches in the files subdirectory
3) Make the manifest
4) eix-sync or whatever fits to you
5) emerge gambas
6) enjoy
I have only tested with the Gravity example project. I can just say it works better than in gambas 2.20.0
Comment 38 lalebarde 2010-08-02 12:58:24 UTC
Created attachment 241061 [details]
gambas-2.21.0.ebuild
Comment 39 lalebarde 2010-08-02 13:09:50 UTC
Created attachment 241071 [details, diff]
patches for gambas 2.20.0, 2.20.2, 2.21.0

tar xjvf gambas-2.20-to-21.patches.bz2
Comment 40 lalebarde 2010-08-02 13:12:08 UTC
For information, I got the ebuild and patches for 2.20.0 here : http://code.google.com/p/wavilen/source/detail?r=4

I have added also gambas-2.20.0.ebuild and gambas-2.20.2.ebuild
Comment 41 lalebarde 2010-08-02 13:13:26 UTC
Created attachment 241073 [details]
gambas-2.20.2.ebuild
Comment 42 lalebarde 2010-08-02 13:13:53 UTC
Created attachment 241075 [details]
gambas-2.20.0.ebuild
Comment 43 Jan Marten Simons 2011-04-05 12:47:40 UTC
What about adding this into sunrise overlay? It would be nice to have an easy way to install gambas2 on gentoo. (of course finding a maintainer would be even better).