Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 146797 - ERROR: media-gfx/gimp-2.2.12 failed
Summary: ERROR: media-gfx/gimp-2.2.12 failed
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-09-07 22:54 UTC by lant
Modified: 2007-03-05 17:06 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

emerge --info (env,2.59 KB, text/plain)
2006-09-19 06:13 UTC, lant
emerge -v gimp (media-gfx-gimp-2.2.12-20060919-130131.log,11.41 KB, text/plain)
2006-09-19 08:07 UTC, lant
emerge -v librsvg (gnome-base-librsvg-2.14.4-20060919-145955.log,98.92 KB, text/plain)
2006-09-19 08:08 UTC, lant
emerge -v gimp config.log (config.log,76.63 KB, text/plain)
2006-09-19 08:49 UTC, lant

Note You need to log in before you can comment on or make changes to this bug.
Description lant 2006-09-07 22:54:40 UTC
# error occures with different packages, not only GIMP

!!! ERROR: media-gfx/gimp-2.2.8-r1 failed.
Call stack:, line 1543:   Called dyn_compile, line 938:   Called src_compile
  gimp-2.2.8-r1.ebuild, line 115:   Called econf '--disable-default-binary' '--with-x' '--enable-mmx' '--enable-sse' '--disable-altivec' '--disable-gtk-doc' '--enable-python' '--disable-print' '--with-libpng' '--with-libjpeg' '--with-libexif' '--disable-mp' '--without-libtiff' '--without-libmng' '--without-aa' '--disable-lcms' '--disable-gtkhtml' '--disable-svg' '--disable-debug', line 539:   Called die
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-09-08 00:28:21 UTC
Reopen with actual errors and emerge --info if 2.2.12 doesn't work for you. We are lacking paranormal skills, sorry.

Comment 2 lant 2006-09-19 06:13:59 UTC
Created attachment 97402 [details]
emerge --info
Comment 3 lant 2006-09-19 06:17:52 UTC
# tried gimp-2.2.12, but it tells the same:

!!! ERROR: media-gfx/gimp-2.2.12 failed.
Call stack:, line 1543:   Called dyn_compile, line 938:   Called src_compile
  gimp-2.2.12.ebuild, line 108:   Called econf '--disable-default-binary' '--with-x' '--enable-mmx' '--enable-sse' '--disable-altivec' '--disable-gtk-doc' '--enable-python' '--disable-print' '--with-libpng' '--with-libjpeg' '--with-libexif' '--disable-mp' '--without-libtiff' '--without-libmng' '--without-aa' '--without-lcms' '--without-gtkhtml2' '--without-librsvg' '--disable-debug', line 539:   Called die
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-09-19 07:12:44 UTC
You didn't post any error. Try again.
Comment 5 lant 2006-09-19 07:37:14 UTC
(In reply to comment #4)
> You didn't post any error. Try again.
The problem is that emerge fails on _some_ packages with the same error message; often another version of package emerges successefully, but sometimes (as with Gimp) not
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-09-19 07:54:58 UTC
You didn't post any error. Post the lines above, not the completely useless final message that tells you to post the *topmost* ebuild error.
Comment 7 lant 2006-09-19 08:07:37 UTC
Created attachment 97419 [details]
emerge -v gimp
Comment 8 lant 2006-09-19 08:08:15 UTC
Created attachment 97420 [details]
emerge -v librsvg
Comment 9 lant 2006-09-19 08:14:09 UTC
entire logs of recent packages I tried to emerge attached. 
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-09-19 08:27:46 UTC
> !! Please attach the following file when filing a report to
> !!! /var/tmp/portage/gimp-2.2.12/work/gimp-2.2.12/config.log

Do it... (and, don't mix two unrelated ebuilds in one bug).

Comment 11 lant 2006-09-19 08:49:39 UTC
Created attachment 97424 [details]
emerge -v gimp config.log

excuse me for stupidness and annoying you...
Comment 12 lant 2006-09-19 09:08:35 UTC
oops, i forgot to change status
Comment 13 Jakub Moc (RETIRED) gentoo-dev 2006-09-19 09:19:14 UTC
/usr/lib/gcc/i386-pc-linux-gnu/3.4.4/../../../ undefined reference to `cairo_scaled_font_text_extents'
/usr/lib/gcc/i386-pc-linux-gnu/3.4.4/../../../ undefined reference to `cairo_scaled_font_get_ctm'

Run revdep-rebuild and try again.
Comment 14 lant 2007-03-05 17:06:26 UTC
recently i returned to this problem and solved it by the following steps:

1. run "equery belongs /usr/lib/" because "/usr/lib/gcc/i386-pc-linux-gnu/3.4.4/../../../" is a "/usr/lib/"
2. emerge x11-libs/pango
3. emerge media-gfx/gimp

so the problem was in x11-libs/pango package