Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 1465 - VIM 6.1 Borked.
Summary: VIM 6.1 Borked.
Status: RESOLVED DUPLICATE of bug 1531
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 All
: High normal (vote)
Assignee: Seemant Kulleen (RETIRED)
Depends on:
Reported: 2002-04-02 01:11 UTC by Ryan Wehler
Modified: 2006-08-05 04:32 UTC (History)
4 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Ryan Wehler 2002-04-02 01:11:54 UTC
emerge app-editors/vim gives

LOG FILE = "/tmp/sandbox-vim-6.1-xxx.log"

chmod: /dev/vc/1
chmod: /dev/vc1

Emerge aborting on /usr/portage/app-editors/vim/vim-6.1.ebuild
Comment 1 Seemant Kulleen (RETIRED) gentoo-dev 2002-04-02 03:59:37 UTC
emerge the latest portage (1.8.10) and try this again.

I have been unable to duplicate it at all on my system, and the oneother person
who reported  the problem can not duplicate it either.
Comment 2 Ryan Wehler 2002-04-02 09:24:39 UTC
VIM works just fine via a SSH install, so if you aren't at the actual computer 
using one of the tty's it works just fine..

Comment 3 Eric Sison 2002-04-02 23:54:59 UTC
i'm getting the same ACCESS VIOLATION message on a fresh Gentoo install + emerge
KDE. updated to portage 1.8.11 and emerged VIM again but got the same error.
Comment 4 Matt Matthews 2002-04-03 11:14:32 UTC
Install of Gentoo 1.0 (stage 3 type install) yesterday and emerged gnome (and
all that implies). Was ready to get back to using X when I emerged vim and hit
this bug (just as initial bug reporter listed it, AFAICT). Version of portage is

Used ebuild as follows:
emerge vim [dies as per this bug]
ebuild vim-6.1.ebuild install [installs, this step had been done by emerge
before it died]
ebuild vim-6.1.ebuild package [to save all the work into a package]
emerge --usepkg vim [install using binary package we just built]

That worked. Since the order of steps I just outlined should at least be *close*
to what emerge vim would do by itself, it seems like a real bug to me. But I
have no idea why.
Comment 5 Sean Bobb 2002-04-04 04:56:05 UTC
I ran into this problem a few days ago and thought that the ebuild was telling 
me that I had the wrong permissions on /dev/vc/1, so I changed the permissions 
and retried the ebuild.
It installed without a problem.
Comment 6 Seemant Kulleen (RETIRED) gentoo-dev 2002-04-04 05:21:43 UTC
ok wait -- what did you change the permissions to?
Comment 7 Seemant Kulleen (RETIRED) gentoo-dev 2002-04-05 03:59:23 UTC
I had created a -r1 ebuild which predicted a write in the sandbox.  It felt
wrong, and now I am closer to knowing why.  Can all of you who had this problem
upgrade your following files please:


And if anyone is not using xdm or gdm (or kdm) as a login manager (ie if you are
startx'ing) please inform me immediately, we need to talk!
Comment 8 Seemant Kulleen (RETIRED) gentoo-dev 2002-04-05 04:00:14 UTC
Sean Bob,

Read this bug report, I need info!
Comment 9 Sean Bobb 2002-04-05 19:22:32 UTC
Sorry Seemant,

I tried connecting to this site for about 6 hours last night (I live in 
Taiwan, GMT+8) but I was unable to get through to anything @

Anyways, I added read and write permissions for group and others:
chmod 666 /dev/vc/1 
but this reverted back to 600 after I logged out and back in again. Although, 
VIM is still working fine.

As for login managers, I don't use an X-based login manager; I only use startx 
when I need X.

Sean Bobb
Comment 10 Seemant Kulleen (RETIRED) gentoo-dev 2002-04-05 20:51:42 UTC
Sean Bob,

Thanks for the info. Actually, you were quite quick to respond. was
in fact down for about 6 hours last night, so you're ok :)
Comment 11 Seemant Kulleen (RETIRED) gentoo-dev 2002-04-11 01:10:07 UTC

*** This bug has been marked as a duplicate of 1531 ***
Comment 12 David McCabe 2002-09-28 01:09:10 UTC
I beleive I have found the (real) solution!
Simply add root (or whoever you have emerging things) to the 'tty' group.

Just change line 6 (on my mostly new system) of /etc/group to: