Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 146219 - net-misc/linux-igd-0.95 (version bump)
Summary: net-misc/linux-igd-0.95 (version bump)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All All
: Highest normal (vote)
Assignee: No maintainer - Look at https://wiki.gentoo.org/wiki/Project:Proxy_Maintainers if you want to take care of it
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 101924 119862
  Show dependency tree
 
Reported: 2006-09-03 23:36 UTC by andcycle-gentoo.bugs
Modified: 2007-01-22 06:02 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
net-misc/linux-igd-0.95.ebuild (linux-igd-0.95.ebuild,1.23 KB, text/plain)
2006-09-06 07:54 UTC, Sergey Belyashov
Details
files/linux-igd-0.95-install.patch (linux-igd-0.95-install.patch,1.05 KB, patch)
2006-09-06 07:55 UTC, Sergey Belyashov
Details | Diff
files/linux-igd-0.95-iptables-path.patch (linux-igd-0.95-iptables-path.patch,463 bytes, patch)
2006-09-06 07:58 UTC, Sergey Belyashov
Details | Diff
files/upnpd.confd (upnpd.confd,68 bytes, text/plain)
2006-09-06 07:58 UTC, Sergey Belyashov
Details
files/upnpd.initd (upnpd.initd,667 bytes, text/plain)
2006-09-06 07:59 UTC, Sergey Belyashov
Details
net-misc/linux-igd-0.95.ebuild (linux-igd-0.95.ebuild,1.23 KB, text/plain)
2006-09-07 02:23 UTC, Sergey Belyashov
Details
net-misc/linux-igd-0.95.ebuild (alternate) (linux-igd-0.95.ebuild,1.11 KB, text/plain)
2006-09-27 09:38 UTC, Todd Wright
Details
files/upnpd.initd (alt) (upnpd.initd,737 bytes, text/plain)
2006-09-27 09:42 UTC, Todd Wright
Details
files/upnpd.confd (alt) (upnpd.confd,248 bytes, text/plain)
2006-09-27 09:44 UTC, Todd Wright
Details
net-misc/linux-igd-0.95.ebuild (alternate) (linux-igd-0.95.ebuild,1.11 KB, text/plain)
2006-09-27 10:09 UTC, Todd Wright
Details

Note You need to log in before you can comment on or make changes to this bug.
Description andcycle-gentoo.bugs 2006-09-03 23:36:44 UTC
linux-igd just get moveing again, hopeful a new ebuild

http://linux-igd.sourceforge.net/

[quote]
08-16-06
This comes little late now, but as of August 13th we have had a new 0.95 version of linux-igd! ...
[/quote]
Comment 1 Sergey Belyashov 2006-09-06 07:54:19 UTC
Created attachment 96174 [details]
net-misc/linux-igd-0.95.ebuild
Comment 2 Sergey Belyashov 2006-09-06 07:55:46 UTC
Created attachment 96175 [details, diff]
files/linux-igd-0.95-install.patch
Comment 3 Sergey Belyashov 2006-09-06 07:58:00 UTC
Created attachment 96176 [details, diff]
files/linux-igd-0.95-iptables-path.patch
Comment 4 Sergey Belyashov 2006-09-06 07:58:47 UTC
Created attachment 96178 [details]
files/upnpd.confd
Comment 5 Sergey Belyashov 2006-09-06 07:59:56 UTC
Created attachment 96179 [details]
files/upnpd.initd


This is my version of linux-igd-0.95.ebuild.
It works fine for me (x86).
Comment 6 Sergey Belyashov 2006-09-07 02:23:52 UTC
Created attachment 96266 [details]
net-misc/linux-igd-0.95.ebuild

I change dependecy ">=net-misc/libupnp-1.3.1" to ">=net-misc/upnp-1.3.1"
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2006-09-27 08:47:41 UTC
*** Bug 149315 has been marked as a duplicate of this bug. ***
Comment 8 Todd Wright 2006-09-27 09:38:51 UTC
Created attachment 98245 [details]
net-misc/linux-igd-0.95.ebuild (alternate)

This alternate ebuild doesnt include the patches, but adds a few things such as installing /etc/upnpd.conf, (I think that was missed) installing the man page, etc, and removing some clutter in /etc/linuxigd.  Heres the list: (compared to 0.92)

 - daemon moved to /usr/sbin          (its a system app)
 - config file now installed in /etc
 - conf.d file now installed in /etc/conf.d
 - man page[s] now installed in man
 - clutter removed from /etc/linuxigd
 - new upstream option ALLOW_MULTICAST configured in conf.d and actioned in
init.d
 - updated postinst message to reflect current state of linux-igd install
Comment 9 Todd Wright 2006-09-27 09:42:57 UTC
Created attachment 98247 [details]
files/upnpd.initd (alt)

The alternate version of files/upnpd.initd includes support for the upstream option ALLOW_MULTICAST in conf.d
Comment 10 Todd Wright 2006-09-27 09:44:31 UTC
Created attachment 98248 [details]
files/upnpd.confd (alt)

The alternate version of files/upnpd.confd includes support for the upstream option ALLOW_MULTICAST which is actioned in files/upnpd.initd
Comment 11 Todd Wright 2006-09-27 10:09:39 UTC
Created attachment 98249 [details]
net-misc/linux-igd-0.95.ebuild (alternate)

Fixed the postinst message to point to INSTALL.gz (README.gz doesnt exist)
Comment 12 Todd Wright 2006-09-27 10:19:44 UTC
Ok, Im a little slow. I see now that most of the install changes I did in the alternate ebuild are done in the attached install patch. Just a different approach I guess.

Not sure about the iptables-path patch though... On my system iptables is in /usr/sbin/iptables, as per the unmodified conf file.
Comment 13 Keith Constable 2006-10-04 05:24:36 UTC
Now, correct me if I'm wrong, but the patch from comment 2 won't help anything since the ebuild is using einstall.  Shouldn't we replace einstall with "make ROOT=${D} install"?  If so, I feel it would be easier to use Todd's approach.

Oh, and on my system:
# which iptables
/sbin/iptables

So, I'd need the iptables path patch.  Wouldn't it just be better, though, just to use dosed?  It's only one line.
Comment 14 Conrad Kostecki gentoo-dev 2006-10-07 12:28:08 UTC
So witch version should now I use?
Please Help!
Comment 15 Keith Constable 2006-10-08 07:10:41 UTC
(In reply to comment #14)
> So witch version should now I use?
> Please Help!

I don't mean to sound like a pompous ass, but if you can't decide which to use on your own, perhaps you should wait until one of them is committed to portage.

BTW, I've got linux-igd-0.95 working perfectly with net-misc/libupnp-1.4.1 (the newer fork of upnp).
Comment 16 Conrad Kostecki gentoo-dev 2006-11-01 04:40:11 UTC
(In reply to comment #15)
> (In reply to comment #14)
> > So witch version should now I use?
> > Please Help!
> I don't mean to sound like a pompous ass, but if you can't decide which to use
> on your own, perhaps you should wait until one of them is committed to portage.

LOL, then I can wait 10 Years until it gets to Portage ;)
Comment 17 Alec Warner archtester Gentoo Infrastructure gentoo-dev Security 2007-01-22 06:02:19 UTC
Bumped, thanks for reporting.