Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 145188 - app-text/enchant needs symlinks for ispell and hunspell/myspell
Summary: app-text/enchant needs symlinks for ispell and hunspell/myspell
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: GNOME Office (OBSOLETE)
Depends on: 230971
  Show dependency tree
Reported: 2006-08-26 08:51 UTC by James Le Cuirot
Modified: 2008-07-18 20:29 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---

diff for enchant-1.2.5 that knows where ispell and myspell are (enchant.diff,708 bytes, patch)
2006-08-31 08:11 UTC, Leonardo Ferreira Fontenelle
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description James Le Cuirot gentoo-dev 2006-08-26 08:51:32 UTC
I was trying to get spell checking working in AbiWord on my slightly minimalist iMac system. For some reason, enchant was failing to find any dictionaries despite aspell and aspell-en being emerged. I'm not sure why that wasn't working (enchant + aspell works fine on my main system) but when I tried to use enchant againt hunspell instead, it still wouldn't work. An strace revealed that it was searching for dictionaries in /usr/share/enchant/ispell and /usr/share/enchant/myspell instead of /usr/share/ispell and /usr/share/myspell. These locations can be changed at compile time using --with-ispell-dir and --with-myspell-dir but I just created symlinks instead, which worked fine.
Comment 1 Leonardo Ferreira Fontenelle 2006-08-31 07:00:11 UTC
Same for myspell. Enchant can use myspell dictionaries out-of-the-box, just can't find them. For individual use, a link to /usr/share/myspell works fine, but at distribution level a --with-myspell-dir would be perfect (from enchant(1)).
Comment 2 Leonardo Ferreira Fontenelle 2006-08-31 08:11:53 UTC
Created attachment 95561 [details, diff]
diff for enchant-1.2.5 that knows where ispell and myspell are

Added ispell and myspell. The man page doesn't say anything about hspell, and I don't have uspell to test. The patched enchant works with pt_BR myspell/hunspell dict and with en_US but not pt_BR dictionary.
Comment 3 Giacomo Perale 2008-02-11 01:27:53 UTC
Hi. I spent almost one hour trying to understand why enchant refused to work, until I discovered that it couldn't find the dictionaries and then I found this bug.

This should be fixed ASAP, it's still apply to enchant 1.3.0
Comment 4 Serkan Kaba (RETIRED) gentoo-dev 2008-07-18 20:29:54 UTC
Fixed in 1.4.2