Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 14392 - netpbm refuses to compile on an ultra5
Summary: netpbm refuses to compile on an ultra5
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All All
: High normal (vote)
Assignee: Sparc Porters
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2003-01-22 15:18 UTC by Colin Morey (RETIRED)
Modified: 2006-02-04 06:05 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Colin Morey (RETIRED) gentoo-dev 2003-01-22 15:18:23 UTC
all available ebuilds at current time,
netpbm-10.11.4.ebuild
netpbm-9.12-r3.ebuild
netpbm-9.12-r4.ebuild
Produce a segmentation fault when trying to compile ppmpat.c

ouput is as follows,

gcc -c -I../shhopt -I/usr/include -pedantic -mcpu=ultrasparc -mtune=ultrasparc
-O3 -pipe -falign-functions=4 -fprefetch-loop-arrays -ffast-math
-fomit-frame-pointer -Wall -Wno-uninitialized  -o ppmpat.o
/var/tmp/portage/netpbm-9.12-r3/work/netpbm-9.12/ppm/ppmpat.c
/var/tmp/portage/netpbm-9.12-r3/work/netpbm-9.12/ppm/ppmpat.c: In function
`sq_assign_colors':
/var/tmp/portage/netpbm-9.12-r3/work/netpbm-9.12/ppm/ppmpat.c:882: internal
error: Segmentation fault
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugs.gentoo.org/> for instructions.
make[1]: *** [ppmpat.o] Error 1
make[1]: Leaving directory
`/var/tmp/portage/netpbm-9.12-r3/work/netpbm-9.12/ppm'
make: *** [ppm] Error 2


system information:
gcc:-> gcc version 3.2.1 20021207 (Gentoo Linux 3.2.1-20021207)
Uname -a: -> Linux <hostname> 2.4.20-sparc-r2 #6 Tue Jan 21 15:43:09 GMT 2003
sparc64 sun4u TI UltraSparc IIi GNU/Linux

CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O3 -pipe -falign-functions=4
-fprefetch-loop-arrays -ffast-math -fomit-frame-pointer"

^^I don't recall setting that lot, so I believe it crept in via a system update
at some point, will try compiling with CFLAGS="-mcpu=ultrasparc
-mtune=ultrasparc -O2"
Comment 1 Colin Morey (RETIRED) gentoo-dev 2003-01-22 18:24:09 UTC
Tried with,
CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O3" - failed
CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O2" - failed
CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc -O"  - failed
Comment 2 Colin Morey (RETIRED) gentoo-dev 2003-01-22 18:50:35 UTC
CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc" appears to have worked!
this is -=> media-libs/netpbm-9.12-r3
Comment 3 Colin Morey (RETIRED) gentoo-dev 2003-01-23 00:55:44 UTC
netpbm-9.12-r3.ebuild
netpbm-9.12-r4.ebuild
are also fine with CFLAGS="-mcpu=ultrasparc -mtune=ultrasparc"
Comment 4 Jason Wever (RETIRED) gentoo-dev 2003-05-12 22:57:42 UTC
Sorry for the lateness in the reply, my bugzilla queries weren't picking this up.  Is this still a problem for you?
Comment 5 Jason Wever (RETIRED) gentoo-dev 2003-05-13 08:53:09 UTC
I tested this and it was still failing.  I updated netpbm-9.12-r4.ebuild to filter out -O flags and committed to portage.  netpbm-10.11.5-r2.ebuild works fine for me. 
Comment 6 Jason Wever (RETIRED) gentoo-dev 2003-08-17 07:30:58 UTC
Closing