Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 143903 - samba-3.0.23d version bump
Summary: samba-3.0.23d version bump
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High enhancement (vote)
Assignee: Gentoo's SAMBA Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-14 10:50 UTC by Chris Smith
Modified: 2007-02-06 12:37 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
samba-3.0.23b.ebuild (samba-3.0.23b.ebuild,7.87 KB, text/plain)
2006-08-14 10:59 UTC, Chris Smith
Details
new pachset for samba-3.0.23b.ebuild (samba-3-gentoo-0.3.15.tar.bz2,15.22 KB, application/x-tbz)
2006-08-14 11:04 UTC, Chris Smith
Details
samba-3.0.23b.ebuild rev 1.2 (samba-3.0.23b.ebuild,7.75 KB, text/plain)
2006-08-16 12:06 UTC, Chris Smith
Details
updated the new 0.3.15 patchset (samba-3-gentoo-0.3.15.tar.bz2,15.40 KB, application/x-tbz)
2006-08-28 15:01 UTC, Chris Smith
Details
samba-3.0.23b.ebuild rev 1.3 (samba-3.0.23b.ebuild,7.80 KB, text/plain)
2006-08-28 15:06 UTC, Chris Smith
Details
samba-3.0.23b.ebuild rev. 1.4 (samba-3.0.23b.ebuild,7.80 KB, text/plain)
2006-08-30 13:31 UTC, Chris Smith
Details
samba-3.0.23c.ebuild rev1.1 (samba-3.0.23c.ebuild,7.75 KB, text/plain)
2006-09-01 11:28 UTC, Chris Smith
Details
samba-3.0.23c.ebuild rev1.1 (samba-3.0.23c.ebuild,7.75 KB, text/plain)
2006-09-01 11:29 UTC, Chris Smith
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Chris Smith 2006-08-14 10:50:18 UTC
samba-3.0.23b version bump
Comment 1 Chris Smith 2006-08-14 10:59:28 UTC
Created attachment 94258 [details]
samba-3.0.23b.ebuild

This ebuild needs new a patch set plus an additional patch.

I've taken out the ebuild lines that build rpctorture, which throws off errors and in the words of a samba developer: "rpctorture is a utility that has not been touched for years now. What do you need it for?"

This patch is needed: http://www.samba.org/~jerry/patches/samba-3.0.23b-lookup_name_smbconf_v2.patch to prevent problems with those using the smbpasswd backend. place it in the files dir.
Comment 2 Chris Smith 2006-08-14 11:04:24 UTC
Created attachment 94259 [details]
new pachset for samba-3.0.23b.ebuild

Removed the extrabins patch - no need to build rpctorture.

Some fixups for the smb.conf.example file for chamges such as failover backends being no longer available and the deprecation of "printer admin".

Place in distfiles.
Comment 3 Chris Smith 2006-08-16 12:06:18 UTC
Created attachment 94413 [details]
samba-3.0.23b.ebuild rev 1.2

Eliminated the http://www.samba.org/~jerry/patches/samba-3.0.23b-lookup_name_smbconf_v2.patch. Recommend to not use the smbpasswd backend as the workaround.

Fixed the "cannot stat ... pam_winbind.so" error, apparently it is in the bin directory after compiling and not the nsswitch directory. This may be a bug in previous releases as well.

Moved the dolib/dosyn with nsswitch/libnss_wins.so inside "if use winbind" as libnss_wins.so does not get built unless winbind is specified. (I don't think that should be the case but that's it works right now).

Chris
Comment 4 Chris Smith 2006-08-28 15:01:29 UTC
Created attachment 95328 [details]
updated the new 0.3.15 patchset

Put the extrabins patch back in as only the ebuild was involved in building rpctorture. Now smbtorture will build as before.
Another edit to the example smb.conf file.
Comment 5 Chris Smith 2006-08-28 15:06:15 UTC
Created attachment 95329 [details]
samba-3.0.23b.ebuild rev 1.3

This ebuild applies the fixes from http://samba.org/~jerry/patches/patch-3.0.23b-3.0.23c-gwc-1.diffs.gz

You will need to download the patch, gunzip it, and place it in the FILESDIR.
If you don't want this patch use the previous rev 1.2 ebuild.
Comment 6 Guillermo Gutierrez 2006-08-29 08:42:07 UTC
(First time poster, some-what long time samba user)There appears to be a problem with the ebuild. It starts to fail when it tries to download the patch set. It keeps giving the message "No digest files found."
Comment 7 Chris Smith 2006-08-29 09:13:34 UTC
(In reply to comment #6)
> (First time poster, some-what long time samba user)There appears to be a
> problem with the ebuild. It starts to fail when it tries to download the patch
> set. It keeps giving the message "No digest files found."
> 

You have to manually download the patchset from here and place it in the distfiles dir. You also need to build the digest (ebuild ebuildname.ebuild digest). Only official ebuild/patchsets etc. are going to do this for you automatically.

Comment 8 Guillermo Gutierrez 2006-08-29 09:55:45 UTC
ah, yes. that did it. I copied the b->c patch into the files directory but didn't think to copy the patchset into the distfiles folder.

It works. :)

thanks,

Guillermo
Comment 9 Chris Smith 2006-08-30 13:31:52 UTC
Created attachment 95511 [details]
samba-3.0.23b.ebuild rev. 1.4

This ebuild requires http://samba.org/~jerry/patches/patch-3.0.23b-3.0.23c-gwc-2.diffs.gz to be gunzipped and placed in FILESDIR.

Latest patchset for bleeding edge Samba users. Test if you can/want as the Samba devs may release this as 3.0.23c if no new serious problems are found.

Chris
Comment 10 Chris Smith 2006-09-01 11:28:21 UTC
Created attachment 95662 [details]
samba-3.0.23c.ebuild rev1.1

Hot off the presses - Samba 3.0.23c
uses the updated 0.3.15 patchset available here
Comment 11 Chris Smith 2006-09-01 11:29:14 UTC
Created attachment 95663 [details]
samba-3.0.23c.ebuild rev1.1

Hot off the presses - Samba 3.0.23c
uses the updated 0.3.15 patchset available here
Comment 12 Chris Smith 2006-09-01 11:31:12 UTC
(In reply to comment #11)
> Created an attachment (id=95663) [edit]
> samba-3.0.23c.ebuild rev1.1
> 
> Hot off the presses - Samba 3.0.23c
> uses the updated 0.3.15 patchset available here
> 

Comment 11 was a dupoe of comment 10, thought the send didn't succeed.
Comment 13 Conrad Kostecki 2006-09-13 14:29:20 UTC
Could be add MySQL Support?
Comment 14 Guillaume Castagnino 2006-09-20 09:52:11 UTC
This ebuild works very well and solves some nasty bugs of 3.0.23a.

Please Bump !
Thanks !
Comment 15 Conrad Kostecki 2006-09-25 04:30:36 UTC
Samba 3.0.23c works fine! We should bump it!
Comment 16 Conrad Kostecki 2006-11-10 05:50:20 UTC
Gentoo Devs, are you there? ;)
Comment 17 Chris Smith 2006-11-15 15:46:59 UTC
For samba 3.0.23d rename this ebuild to samba-3.0.23d.ebuild and update the digest.

Chris
Comment 18 Gerald 2006-11-22 14:28:03 UTC
Works fine for me with v3.0.23d (renamed to samba-3.0.23d.ebuild as suggested).

Compiles and works as expected in both x86 and amd64 architectures.

Please get this into portage ASAP, it has been allmost 4 months without any update to the samba ebuilds in portage (which is somewhat ridiculous given the popularity of this package).
Comment 19 SpanKY gentoo-dev 2006-12-16 19:26:03 UTC
thanks, now in portage !
Comment 20 Chris Smith 2006-12-17 13:58:36 UTC
Thanks!

But I still don't see the point of trying to build and install rpctorture when it doesn't build (and therefore doesn't install), and is apparently of little to no use (which is why I removed it from my ebuilds). See: http://thread.gmane.org/gmane.network.samba.general/81908/focus=81908

Chris
Comment 21 SpanKY gentoo-dev 2006-12-17 19:18:22 UTC
i'm not a samba maintainer, i'm just sniping bugs while someone takes over ... you can make your case to the new guy

personally i dont think it matters one way or the other
Comment 22 Doug Goldstein gentoo-dev 2006-12-17 20:38:25 UTC
Chris: You want to proxy maintain this ebuild? I'd be willing to work with you. Shoot me an e-mail @ cardoe@gentoo.org