Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 142855 - vmware-modules-1.0.0.13 does not compile with KBUILD_OUTPUT
Summary: vmware-modules-1.0.0.13 does not compile with KBUILD_OUTPUT
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo VMWare Bug Squashers [disabled]
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 137422
  Show dependency tree
 
Reported: 2006-08-04 22:39 UTC by Georgi Georgiev
Modified: 2006-08-08 12:36 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
vmware-mod.eclass.kbuild-output.patch (vmware-mod.eclass.patch,920 bytes, patch)
2006-08-04 22:42 UTC, Georgi Georgiev
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Georgi Georgiev 2006-08-04 22:39:46 UTC
steps to reproduce:

1. set KBUILD_OUTPUT =/var/tmp/linux-build/$(VERSION).$(PATCHLEVEL).$(SUBLEVEL)$(EXTRAVERSION)-$(MYEXT) in /usr/src/linux/Makefile

2. emerge vmware-modules

* Actual results:

>>> Compiling source in /var/tmp/portage/vmware-modules-1.0.0.13/work ...
 * Preparing vmmon module
*** Your sources installation is broken:
*** /usr/src/linux/include/.. does not contain .config file
*** vmmon/vmnet build may fail, or built vmmon/vmnet may crash.

*** Hit ENTER to continue, or ^C to stop build.

* expected results... the ebuild proceeding

As background, I'd like to mention that I had the modules and the application (vmware-workstation) split in my personal overlay. I have always had KBUILD_OUTPUT set and I have never had this problem. So, the solution I am offering below has been tested for at least vmware-workstaiton since 5.0.0.13124.

Ah, I'll just attach the patch after posting the bug.
Comment 1 Georgi Georgiev 2006-08-04 22:42:45 UTC
Created attachment 93479 [details, diff]
vmware-mod.eclass.kbuild-output.patch

This fixes the problem for the vmware-mod eclass. Tested for vmware-modules-1.0.0.13 only and there is a good chance that it doesn't work for the other module version. Please consider applying the patch even if only conditionally for vmmon and vmnet.
Comment 2 Mike Auty gentoo-dev 2006-08-05 05:56:34 UTC
Hi Georgi,

Thanks for highlighting the problem.  A simpler solution would be to add KBUILD_OUTPUT=${KV_OUT_DIR}, into the BUILD_TARGETS line which should have the same effect.

I've added this to the vmware testing overlay, so if you'd like to test it for me please use the ebuilds (and more specifically eclass) in there.  If it all works, please let me know and I'll make the appropriate updates to the main tree...  5:)
Comment 3 Georgi Georgiev 2006-08-05 06:11:52 UTC
You guys surely know what you're doing. Your solution is simpler and it surely works (just checked it). Feel free to bump $PORTAGE whenever you feel like it.
Comment 4 Mike Auty gentoo-dev 2006-08-05 06:49:18 UTC
Georgi,

I'm not intending to bump the package, since it will fail to install for those who have KBUILD_OUTPUT set, and won't affect those who don't.  However, I'll mention it on this bug when I add the changes into portage...  5:)
Comment 5 Mike Auty gentoo-dev 2006-08-08 12:36:02 UTC
This is now in the CVS, and should be with the mirrors in about an hour.  Please re-open this bug if you still experience the problem...  5:)