Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 142669 - sys-kernel/hardened-sources-2.6.16-r11 can't find e100 cards on DL360
Summary: sys-kernel/hardened-sources-2.6.16-r11 can't find e100 cards on DL360
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Hardened (show other bugs)
Hardware: All Linux
: High critical (vote)
Assignee: The Gentoo Linux Hardened Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-08-03 09:14 UTC by Calum
Modified: 2008-02-27 20:08 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Calum 2006-08-03 09:14:45 UTC
Not sure if this is a hardened issue, or a general kernel issue. Please move if necessary.

Upgrading a Compaq DL360 G1 to linux-2.6.16-hardened-r11, and (using the same .config, after looking through menuconfig) booting into it, it didn't see the on-board e100 networks cards.

lspci from old kernel:
00:00.0 Host bridge: Broadcom CNB20LE Host Bridge (rev 06)
00:00.1 Host bridge: Broadcom CNB20LE Host Bridge (rev 06)
00:01.0 RAID bus controller: LSI Logic / Symbios Logic 53C1510 (rev 02)
00:03.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC 215IIC [Mach64 GT IIC] (rev 7a)
00:04.0 System peripheral: Compaq Computer Corporation Advanced System Management Controller
00:0f.0 ISA bridge: Broadcom OSB4 South Bridge (rev 51)
00:0f.1 IDE interface: Broadcom OSB4 IDE Controller
03:04.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 08)
03:05.0 Ethernet controller: Intel Corporation 82557/8/9 [Ethernet Pro 100] (rev 08)

lspci from new:
00:00.0 Host bridge: Broadcom CNB20LE Host Bridge (rev 06)
00:00.1 Host bridge: Broadcom CNB20LE Host Bridge (rev 06)
00:01.0 RAID bus controller: LSI Logic / Symbios Logic 53C1510 (rev 02)
00:03.0 VGA compatible controller: ATI Technologies Inc 3D Rage IIC 215IIC [Mach64 GT IIC] (rev 7a)
00:04.0 System peripheral: Compaq Computer Corporation Advanced System Management Controller
00:0f.0 ISA bridge: Broadcom OSB4 South Bridge (rev 51)
00:0f.1 IDE interface: Broadcom OSB4 IDE Controller


dmesg showed that the driver had been loaded:
e100: Intel(R) PRO/100 Network Driver, 3.5.10-k2-NAPI
e100: Copyright(c) 1999-2005 Intel Corporation

but it didn't show the next two lines that it had found them:
e100: Intel(R) PRO/100 Network Driver, 3.3.6-k2-NAPI
e100: Copyright(c) 1999-2004 Intel Corporation
e100: eth0: e100_probe: addr 0xc6fff000, irq 5, MAC addr 00:02:A5:E9:52:52
e100: eth1: e100_probe: addr 0xc6dff000, irq 7, MAC addr 00:02:A5:E9:52:51


I couldn't spend much more time on finding this out, as the server was offline.

Any ideas why this is?
I've got the .config from the old and the new, and the dmesg from old and new.

Thanks.
Comment 1 Calum 2007-04-16 09:17:14 UTC
Is there any news on this?

It seems that the e100 driver just doesn't detect any network cards in a HP DL360 any more.

I can't believe that other people aren't having this problem.

I have confirmed it on a second machine, built with linux-2.6.18-hardened-r6


You can see the difference:

grep e100 /var/log/kern.log

Apr 16 09:27:55 mboxdb kernel:  BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
Apr 16 09:27:55 mboxdb kernel: e100: Intel(R) PRO/100 Network Driver, 3.5.10-k2-NAPI
Apr 16 09:27:55 mboxdb kernel: e100: Copyright(c) 1999-2005 Intel Corporation
Apr 16 09:42:29 mboxdb kernel:  BIOS-e820: 00000000fee00000 - 00000000fee10000 (reserved)
Apr 16 09:42:29 mboxdb kernel: e100: Intel(R) PRO/100 Network Driver, 3.3.6-k2-NAPI
Apr 16 09:42:29 mboxdb kernel: e100: Copyright(c) 1999-2004 Intel Corporation
Apr 16 09:42:29 mboxdb kernel: e100: eth0: e100_probe: addr 0xc6fff000, irq 5, MAC addr 00:02:A5:E8:07:D5
Apr 16 09:42:29 mboxdb kernel: e100: eth1: e100_probe: addr 0xc6dff000, irq 7, MAC addr 00:02:A5:E8:07:D4
Apr 16 09:42:30 mboxdb kernel: e100: eth0: e100_watchdog: link up, 100Mbps, half-duplex


The 9.27 boot was the new kernel, and the 9.42 boot was the old kernel again.
Comment 2 Calum 2007-04-16 09:52:18 UTC
I've also just compiled linux-2.6.20-hardened-r2, and it still doesn't detect the network cards.

Apr 16 10:43:08 mboxdb kernel: e100: Intel(R) PRO/100 Network Driver, 3.5.17-k2-NAPI
Apr 16 10:43:08 mboxdb kernel: e100: Copyright(c) 1999-2006 Intel Corporation
Apr 16 10:43:08 mboxdb kernel: LXT970: Registered new driver
Apr 16 10:43:08 mboxdb kernel: LXT971: Registered new driver

Apr 16 10:43:09 mboxdb rc-scripts: network interface eth0 does not exist
Comment 3 solar (RETIRED) gentoo-dev 2007-04-16 14:40:43 UTC
Please try vanilla-sources and see if the problem continues using the same kernel.config. If that works then please try gentoo-sources.
Comment 4 Calum 2007-04-16 15:26:37 UTC
OK. I can't do this too much, as it requires a reboot to test it out, but vanilla sources (2.6.19.7) are fine.

I will try Gentoo sources soon, but I think, as I originally filed this under "Hardened" that it's a hardened problem.

I have lots of DL360s here, with twin e100 NICs, and most of them run gentoo-sources, apart from a few that run hardened.

So, assume that it's Hardened that's the problem.
Comment 5 Calum 2007-04-18 08:42:38 UTC
OK. As I suspected, it's the hardened patches.


2.6.19-gentoo-r5 works
linux-2.6.19.7 works

linux-2.6.20-hardened-r2 and
linux-2.6.18-hardened-r6 don't.

However,
linux-2.6.11-hardened-r14 does.
Comment 6 Christian Heim (RETIRED) gentoo-dev 2007-04-29 15:31:17 UTC
I don't have a DL380, but I do have a Fujitsu Siemens box utilizing the e100 driver, and it works perfectly fine with 2.6.20-r2. I'd like you to test that version, and REOPEN this bug if its still an issue for you.
Comment 7 Calum 2007-05-03 03:50:28 UTC
Can I refer you to my previous comment (with bits highlighted that you might have missed? :) )


OK. As I suspected, it's the hardened patches.


2.6.19-gentoo-r5 works
linux-2.6.19.7 works

*****linux-2.6.20-hardened-r2***** and
linux-2.6.18-hardened-r6 don't.

However,
linux-2.6.11-hardened-r14 does.
Comment 8 Christian Heim (RETIRED) gentoo-dev 2007-05-03 10:36:03 UTC
(In reply to comment #7)
> Can I refer you to my previous comment (with bits highlighted that you might
> have missed? :)

Sure you can, problem is; I can't reproduce it here with a box utilizing that driver. Have you seen my request in #c6 about testing a newer version of hardened-sources ?
Comment 9 Kevin F. Quinn (RETIRED) gentoo-dev 2007-05-03 20:02:39 UTC
(In reply to comment #8)
> (In reply to comment #7)
> > Can I refer you to my previous comment (with bits highlighted that you might
> > have missed? :)
> 
> Sure you can, problem is; I can't reproduce it here with a box utilizing that
> driver. Have you seen my request in #c6 about testing a newer version of
> hardened-sources ?

Erm, he quite clearly said he'd tried 2.6.20-hardened-r2...
Comment 10 Calum 2007-05-03 22:21:48 UTC
Thanks Kev. I wondered if I'd written something wrongly.

To summarize:

* It's hardened > 2.6.11-hardened-r14 that is the problem.
* Vanilla, and Gentoo sources up to the latest are fine.

Ergo: it's a hardened patch that's been added since 2.6.11-r14 that is the problem.
Comment 11 Christian Heim (RETIRED) gentoo-dev 2007-06-02 20:46:41 UTC
Maybe pipacs can be of help, I sure as hell don't know here to look.
Comment 12 PaX Team 2007-11-01 20:11:01 UTC
(In reply to comment #11)
> Maybe pipacs can be of help, I sure as hell don't know here to look.

what is the PCI access method set to? if it's BIOS, can you guys try out the 'direct' one? also posting .config should always be a start when discussing kernel bugs. i'd like to see this reproduced with PaX test patch alone, preferably the latest version for 2.6.23.
Comment 13 Kerin Millar 2008-02-27 20:08:51 UTC
Calum, please ateempt to reproduce the problem in the latest version of hardened-sources, 2.6.23-r8 and also respond to comment 12. In the meantime, I'm switching the status of the bug to NEEDINFO.