Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 142584 (ati-dri) - x11-drivers/ati-drivers ebuilds put dri libraries in wrong place + install broken env.d entry
Summary: x11-drivers/ati-drivers ebuilds put dri libraries in wrong place + install br...
Status: RESOLVED FIXED
Alias: ati-dri
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Highest major (vote)
Assignee: X11 External Driver Maintainers
URL:
Whiteboard:
Keywords:
: 136371 142143 142862 151507 155457 162066 166318 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-08-02 14:10 UTC by Navin Kumar
Modified: 2009-09-30 10:59 UTC (History)
32 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Navin Kumar 2006-08-02 14:10:03 UTC
Direct rendering is not functioning in Xorg 7.1 with the newest ati drivers, because the driver can not find the appropriate library for dri.

Extracted from Xorg.0.log:

drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: Searching for BusID PCI:1:0:0
drmOpenDevice: node name is /dev/dri/card0
drmOpenDevice: open result is 9, (OK)
drmOpenByBusid: drmOpenMinor returns 9
drmOpenByBusid: drmGetBusid reports PCI:1:0:0
(EE) AIGLX error: dlopen of /usr/lib/dri/atiogl_a_dri.so failed (/usr/lib/dri/atiogl_a_dri.so: cannot open shared object file: No such file or directory)
(EE) AIGLX: reverting to software rendering

Upon examination of the emerge process, I found that this file is in /usr/lib/xorg/modules/dri, and not in appropriate path as before.  Is there a module path I am supposed to set, or is this an actual issue with the ebuild, because it looks like the paths have changed between versions of Xorg?

Output of emerge --info
Portage 2.1.1_pre4-r1 (default-linux/x86/2006.0, gcc-3.4.6/vanilla, glibc-2.4-r3, 2.6.17.7 i686)
=================================================================
System uname: 2.6.17.7 i686 Intel(R) Pentium(R) M processor 1400MHz
Gentoo Base System version 1.12.4
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://gentoo.mirrors.pair.com/ ftp://gentoo.cites.uiuc.edu/pub/gentoo/"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/local/overlays/migration-overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X Xaw3d aac acpi alsa apache2 arts avi bash-completion berkdb bitmap-fonts bluetooth cdr cli crypt cups dlloader dri dvd eds emboss encode esd exif foomaticdb fortran gdbm gif glitz gpm gstreamer gtk gtk2 imlib ipv6 irda isdnlog java joystick jpeg kde kerberos libg++ libwww mad mikmod mmx motif mp3 mpeg mysql ncurses nls nptl nptlonly ogg opengl oss pam pcre pdflib perl png pppd python qt qt3 qt4 quicktime readline reflection ruby sdl session speex spell spl sse sse2 ssl svg tcpd threads tiff truetype truetype-fonts type1-fonts udev usb vorbis xinerama xml xml2 xmms xorg xv zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_synaptics kernel_linux userland_GNU video_cards_radeon video_cards_fglrx video_cards_vesa"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Joël 2006-08-02 14:45:35 UTC
Same here.

And further, after doing this in /usr/lib:
   ln -s xorg/modules/dri dri

I get:

(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering

WTH?
Comment 2 Sonny Lander 2006-08-03 10:11:19 UTC
(In reply to comment #1)
I did this:
ln -s xorg/modules/dri/fglrx_dri.so dri/fglrx_dri.so
And i have the same __driCreateNewScreen_20050727) error...

I found a comment on http://www.ubuntuforums.org/showthread.php?t=225354&page=2 that says he fixed it, can't make head or tails of it.. :(
Comment 3 Joël 2006-08-03 10:41:44 UTC
I don't know what he actually did...

One thing is sure though:

joel@vaio-z1 ~ $ ls -l /usr/lib/opengl/*/*/libGL.so.1.2
-rwxr-xr-x 1 root root 783132 2006-08-03 00:25 /usr/lib/opengl/ati/lib/libGL.so.1.2
-rwxr-xr-x 1 root root 478532 2006-07-29 23:16 /usr/lib/opengl/xorg-x11/lib/libGL.so.1.2

joel@vaio-z1 ~ $ grep driCreateNewScreen /usr/lib/opengl/*/*/libGL.so.1.2
Binary file /usr/lib/opengl/xorg-x11/lib/libGL.so.1.2 matches

So, really there's no "driCreateNewScreen" symbol in ATI's libGL. What to do next ?
Comment 4 Joël 2006-08-03 10:43:59 UTC
Oops sorry, my bad, I did this *after* reverting to older xorg-x11 and ati-drivers 8.26.18...

Can someone try it with newest xorg-x11 & ati-drivers ?
Comment 5 Navin Kumar 2006-08-03 10:46:56 UTC
(In reply to comment #2)
> (In reply to comment #1)
> I did this:
> ln -s xorg/modules/dri/fglrx_dri.so dri/fglrx_dri.so
> And i have the same __driCreateNewScreen_20050727) error...
> I found a comment on http://www.ubuntuforums.org/showthread.php?t=225354&page=2
> that says he fixed it, can't make head or tails of it.. :(


I checked further in the thread, and he says he ignores this particular error, and it says he doesn't have any problems (which is obviously wrong in our case). So no use there... :(
Comment 6 Sonny Lander 2006-08-03 10:58:16 UTC
(In reply to comment #4)

cronos dri # grep driCreateNewScreen /usr/lib/opengl/*/*/libGL.so.1.2
Binary file /usr/lib/opengl/xorg-x11/lib/libGL.so.1.2 matches

I don't think it works with ati's libGL, running fglrx 8.27.10 with xorg-server-1.1.1-r1 (xgl overlay)
Comment 7 FieldySnuts 2006-08-03 18:29:37 UTC
Same issues here. This is with the symlink to the dri so thingy:

grep -e "(WW)" -e "(EE)" /var/log/Xorg.0.log | less
        (WW) warning, (EE) error, (NI) not implemented, (??) unknown.
(WW) fglrx(0): board is an unknown third party board, chipset is supported
(WW) fglrx(0): Specified desktop setup not supported: 8
(WW) fglrx(0): Option "VendorName" is not used
(WW) fglrx(0): Option "ModelName" is not used
(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_
dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering

My favorite being the "third party board" bit.

Portage 2.1.1_pre4-r1 (default-linux/x86/2006.0, gcc-3.4.6/vanilla, glibc-2.3.6-r4, 2.6.17.7-ifc i686)
=================================================================
System uname: 2.6.17.7-ifc i686 Intel(R) Pentium(R) M processor 1.86GHz
Gentoo Base System version 1.6.15
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: 2.0.0_rc1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium-m -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/NX/etc /usr/NX/home /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/lib/mozilla/defaults/pref /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-Os -march=pentium-m -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distcc distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.ussg.iu.edu/pub/linux/gentoo http://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.mirrors.tds.net/gentoo http://mirror.datapipe.net/gentoo"
LINGUAS="en"
MAKEOPTS="-j3"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="x86 3dnow X a52 alsa apache2 apm avi berkdb bitmap-fonts bzip2 cdr chroot cli crypt dlloader dri dv dvd dvdr dvdread eds emboss encode ffmpeg flac foomaticdb fortran gdbm gif gpm gstreamer gtk gtk2 hal imlib isdnlog jpeg kde kdeenablefinal libg++ libwww mad mikmod mmx motif mp3 mpeg ncurses network nls ogg opengl oss pam pcre pdflib perl png pppd pwdb python qt qt3 qt4 quicktime readline reflection sdl session spell spl sse ssl theora tiff truetype truetype-fonts type1-fonts udev usb vorbis xml xml2 xmms xorg xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_synaptics kernel_linux linguas_en userland_GNU video_cards_ati video_cards_radeon video_cards_fglrx"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 8 gapon 2006-08-04 10:38:50 UTC
same problem... :/
Comment 9 FieldySnuts 2006-08-04 10:43:25 UTC
-r1 does it as well.
Comment 10 Christian Samsel 2006-08-05 10:49:14 UTC
with links like that everything works fine.

# pwd 
/usr/lib/dri 
# ls -la 
insgesamt 6287 
drwxr-xr-x   2 root root     208  5. Aug 16:39 . 
drwxr-xr-x 135 root root  107040  5. Aug 16:44 .. 
lrwxrwxrwx   1 root root      41  5. Aug 16:39 atiogl_a_dri.so -> /usr/lib/xorg/modules/dri/atiogl_a_dri.so 
lrwxrwxrwx   1 root root      38  5. Aug 16:39 fglrx_dri.so -> /usr/lib/xorg/modules/dri/fglrx_dri.so
Comment 11 Navin Kumar 2006-08-05 11:10:53 UTC
(In reply to comment #10)
> with links like that everything works fine.
> 
> # pwd 
> /usr/lib/dri 
> # ls -la 
> insgesamt 6287 
> drwxr-xr-x   2 root root     208  5. Aug 16:39 . 
> drwxr-xr-x 135 root root  107040  5. Aug 16:44 .. 
> lrwxrwxrwx   1 root root      41  5. Aug 16:39 atiogl_a_dri.so ->
> /usr/lib/xorg/modules/dri/atiogl_a_dri.so 
> lrwxrwxrwx   1 root root      38  5. Aug 16:39 fglrx_dri.so ->
> /usr/lib/xorg/modules/dri/fglrx_dri.so
> 

I've tried those links, and I still get the driCreateNewScreen bug though.
Comment 12 Leif Walsh 2006-08-25 15:02:33 UTC
(In reply to comment #10)
> with links like that everything works fine.
> 
> # pwd 
> /usr/lib/dri 
> # ls -la 
> insgesamt 6287 
> drwxr-xr-x   2 root root     208  5. Aug 16:39 . 
> drwxr-xr-x 135 root root  107040  5. Aug 16:44 .. 
> lrwxrwxrwx   1 root root      41  5. Aug 16:39 atiogl_a_dri.so ->
> /usr/lib/xorg/modules/dri/atiogl_a_dri.so 
> lrwxrwxrwx   1 root root      38  5. Aug 16:39 fglrx_dri.so ->
> /usr/lib/xorg/modules/dri/fglrx_dri.so
> 

The best way to do the links is this:
 # cd /usr/lib/dri
 # ln -s ../xorg/modules/dri/fglrx_dri.so fglrx_dri.so
 # ln -s ../xorg/modules/dri/atiogl_a_dri.so atiogl_a_dri.so
Just to have relative paths.

However, I'm still getting the driCreateNewScreen problem.
Comment 13 Petter Häggholm 2006-08-27 17:33:49 UTC
Just adding my voice to the general lament. X.org 7.1, xorg-server 1.1.1, ati-drivers 8.27.10-r1, __driCreateNewScreen error with symlinks.
Comment 14 Andrej Kacian (RETIRED) gentoo-dev 2006-09-07 07:59:22 UTC
The same happens with ati-drivers-8.28.8, on xorg-server-1.1.1 as well.

fglrx_dri.so gets installed to /usr/lib/xorg/modules/dri/, while it's expected by xorg at /usr/lib/dri. Even after symlinking that file, there's the now-infamous

(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering
Comment 15 Jack Kelly 2006-09-13 17:48:28 UTC
Just adding myself to the CC list.

I masked xorg-server-7.1 by putting the following into /etc/portage/package.mask/X:

>x11-base/xorg-x11-7.0-r1
>x11-base/xorg-server-1.0.2-r7
>x11-drivers/xf86-input-keyboard-1.0.1.3
>x11-drivers/xf86-input-mouse-1.0.4

Not optimal, but at least X works now.
Comment 16 Joël 2006-09-23 10:06:07 UTC
The unresolved symbol error still happens with ati drivers 8.29.6 (using renamed 8.28.8 ebuild).

It seems (at least some) non-gentoo people have this problem too.

This prevents AIGLX from working... and forces use of Xgl as a workaround :-(
Comment 17 Olivier Lahaye 2006-09-28 09:46:45 UTC
/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727 error comes from tha fact that ATI proprietary drivers don't support AIGLX (in fact they do not support the GLX_EXT_texture_from_pixmap.

Only driver 9;x will support that.
Comment 18 James Ward 2006-09-28 10:30:49 UTC
Interesting.  Anyone know when ati will release version 9 (AIGLX compatible) drivers?
Comment 19 Chris Gianelloni (RETIRED) gentoo-dev 2006-09-28 12:12:32 UTC
AIGLX was never advertized to work with this version of the binary ATI drivers (or any released versions, for that matter).
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2006-10-15 14:47:31 UTC
*** Bug 151507 has been marked as a duplicate of this bug. ***
Comment 21 przem 2006-10-18 15:08:28 UTC
same thing :(
anybody know when they plan to release version 9?
Comment 22 Paolo Pedroni 2006-10-30 09:08:53 UTC
After creating the symlinks I have a different undefined symbol from the rest of you. My error is the following:

(EE) AIGLX error: dlopen of /usr/lib64/dri/fglrx_dri.so failed (/usr/lib64/dri/fglrx_dri.so: undefined symbol: _glapi_add_entrypoint)
(EE) AIGLX: reverting to software rendering

With ati-drivers-8.29.6, xorg-server-1.1.1-r1, emerge --info as follows
Portage 2.1.1-r1 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.4-r3, 2.6.18-gentoo-r1 x86_64)
=================================================================
System uname: 2.6.18-gentoo-r1 x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 4600+
Gentoo Base System version 1.12.5
Last Sync: Mon, 30 Oct 2006 10:00:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.3 [enabled]
app-admin/eselect-compiler: [Not Present]
dev-java/java-config: 1.3.7, 2.0.30
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r4
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O3 -pipe -fomit-frame-pointer"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-march=k8 -O3 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoaddcvs autoconfig ccache collision-protect distcc distlocks fixpackages metadata-transfer sandbox sfperms strict test userfetch userpriv usersandbox"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/ http://gentoo.mirror.solnet.ch http://gentoo.inode.at/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ http://ftp.snt.utwente.nl/pub/os/linux/gentoo http://ftp.du.se/pub/os/gentoo"
LC_ALL="it_IT.UTF-8"
LINGUAS="it"
MAKEOPTS="-j11"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 X Xaw3d a52 aalib acpi alsa arts audiofile bash-completion berkdb bitmap-fonts bluetooth bzip2 cairo caps cdparanoia cdr cli cracklib crypt cups curl dbus dga dio dlloader dri dvd dvdr dvdread elibc_glibc emboss encode exif expat fam fbcon ffmpeg fftw firefox flac foomaticdb fortran ftp gd ggi gif glut gmp gnutls gphoto2 gpm gstreamer gtk2 hal iconv idn imagemagick imlib input_devices_evdev input_devices_joystick input_devices_keyboard input_devices_mouse isdnlog java javascript jbig jikes joystick jpeg jpeg2k kde kdeenablefinal kernel_linux lcms libcaca libg++ linguas_it lm_sensors lua mad maildir matroska mikmod mng motif mozilla mp3 mpeg mpi ncurses nls nptl nptlonly nsplugin offensive ogg openal opengl oss pam pcre pdf perl png posix ppds pppd python qt3 quicktime readline reflection samba sasl scanner sdl session sockets sox speex spell spl ssl svg symlink sysvipc tcl tcltk tcpd theora threads tiff tk truetype truetype-fonts type1-fonts udev unicode usb userland_GNU v4l vcd video_cards_fglrx videos vorbis wmf xine xml xml2 xorg xosd xpm xv xvid zlib"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 23 Jonathan Adamczewski 2006-11-08 19:01:47 UTC
http://ati.cchtml.com/show_bug.cgi?id=367

The missing __driCreateNewScreen symbol is a bug in the driver.  It'll need to be fixed upstream.

The dri .so files not being found is something that does need to be fixed.
Comment 24 Jonathan Adamczewski 2006-11-08 19:25:08 UTC
For reference, adding

    Option "AIGLX" "false"

to Section SeverLayout will prevent X from trying to start AIGLX.
Comment 25 Jakub Moc (RETIRED) gentoo-dev 2006-11-10 14:13:51 UTC
*** Bug 142862 has been marked as a duplicate of this bug. ***
Comment 26 Jakub Moc (RETIRED) gentoo-dev 2006-11-17 04:23:30 UTC
*** Bug 155457 has been marked as a duplicate of this bug. ***
Comment 27 Michele Schiavo 2006-11-17 15:27:30 UTC
New ATI's driver released!

is working !!
Comment 28 Michele Schiavo 2006-11-17 15:29:39 UTC
I'm sorry but it's a little joke.
I hope noone will close my account,
but i hope someone of x11-drivers can understand this big problem for all the people having ATI graphics cards without AIGLX.
Comment 29 Jakub Moc (RETIRED) gentoo-dev 2006-12-12 12:34:15 UTC
*** Bug 142143 has been marked as a duplicate of this bug. ***
Comment 30 Wesley Pegden 2007-01-08 05:13:49 UTC
no news/progress on this, right?
Comment 31 Joshua Baergen (RETIRED) gentoo-dev 2007-01-14 22:37:51 UTC
*** Bug 162066 has been marked as a duplicate of this bug. ***
Comment 32 Jakub Moc (RETIRED) gentoo-dev 2007-01-14 22:42:53 UTC
*** Bug 136371 has been marked as a duplicate of this bug. ***
Comment 33 Rob Hess 2007-01-17 02:14:51 UTC
I am having the same problem:

(EE) AIGLX error: dlsym for __driCreateNewScreen_20050727 failed (/usr/lib/dri/fglrx_dri.so: undefined symbol: __driCreateNewScreen_20050727)
(EE) AIGLX: reverting to software rendering

I am using ati-drivers-8.32.5.  Just wanted to add myself to the CC list.
Comment 34 Jakub Moc (RETIRED) gentoo-dev 2007-01-22 17:48:22 UTC
*** Bug 163272 has been marked as a duplicate of this bug. ***
Comment 35 Jakub Moc (RETIRED) gentoo-dev 2007-01-22 17:49:51 UTC
Like, ping?! Anyone still maintaining ati-drivers? If not, then package.mask the thing please.
Comment 36 Michele Schiavo 2007-01-23 11:39:12 UTC
I think the porblem still in closed source ATI drivers, not the emerge.

from https://a248.e.akamai.net/f/674/9206/0/www2.ati.com/drivers/linux/linux_8.33.6.html


Known Issues

The following section provides a brief description of known issues associated with the latest version of ATI Catalyst™ Linux software suite. These issues include:

    * Attempting to install the ATI Catalyst™ Linux software suite on distributions that have updated certain 3D components outside of the stock XOrg 6.8.2 may result in the driver not initializing 3D applications properly. Further details can be found in topic number 737-20868 
Comment 37 Marien Zwart (RETIRED) gentoo-dev 2007-02-05 11:44:31 UTC
As far as I know no current ebuilds install in the wrong location anymore. The missing symbols on AIGLX are an upstream problem. I do not understand what is meant with the env.d problem mentioned in the bug summary. Closing this NEEDINFO, since I do not think there is anything left for gentoo to fix here, but please reopen if I misunderstood.
Comment 38 Roberto Castagnola 2007-02-05 12:29:10 UTC
(In reply to comment #37)
> I do not understand what is
> meant with the env.d problem mentioned in the bug summary.

It's related to comment #14 from bug 162066 (closed as duplicate of this one)
Comment 39 FieldySnuts 2007-02-05 15:41:53 UTC
Still seeing these issues with (obviously bleeding edge versions) vanilla kernel 2.6.20 (hey at least they finally fixed the breakage of external modules), and ati-drivers-8.33.6, and xorg-server-1.2.0.

Following comment #24 only resulted in extremely slow 3d, so while I can use ati-drivers it's not actually very useful at this point.

Is this all due to upstream?

Also, what further info (NEEDINFO) is required here?

Portage 2.1.2-r7 (default-linux/x86/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.20 i686)
=================================================================
System uname: 2.6.20 i686 Intel(R) Pentium(R) M processor 1.86GHz
Gentoo Base System version 1.12.6
Timestamp of tree: Mon, 05 Feb 2007 14:20:01 +0000
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [enabled]
ccache version 2.4 [enabled]
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.20
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-Os -march=pentium-m -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/NX/etc /usr/NX/home /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-Os -march=pentium-m -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distcc distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.chem.wisc.edu/gentoo/ ftp://gentoo.mirrors.tds.net/gentoo http://mirror.datapipe.net/gentoo"
LINGUAS="en"
MAKEOPTS="-j7"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="3dnow X a52 alsa berkdb bitmap-fonts bzip2 cairo cdr chroot cli cracklib crypt dbus dlloader dri dv dvd dvdr dvdread eds emboss encode fam ffmpeg firefox flac fortran gdbm gif gpm gtk gtk2 hal iconv isdnlog jpeg kde kdeenablefinal libg++ mad midi mikmod mmx mp3 mpeg ncurses network nls nptl nptlonly ogg opengl oss pam pcre pdflib perl png ppds pppd pwdb python qt3 qt4 quicktime readline reflection sdl session spell spl sse ssl svg theora tiff truetype truetype-fonts type1-fonts udev unicode usb vorbis win32codecs x86 xml xml2 xorg xv xvid zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse synaptics" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en" USERLAND="GNU" VIDEO_CARDS="ati radeon fglrx"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS

Comment 40 Alon Bar-Lev gentoo-dev 2007-02-06 18:39:46 UTC
It still put the invalid environment setting...
/etc/env.d/09ati:
LIBGL_DRIVERS_PATH="$LIBGL_DRIVERS_PATH::/usr/lib/xorg/modules/dri"

This breaks radeon or any other DRI on system, see bug#162066.
Comment 41 Jakub Moc (RETIRED) gentoo-dev 2007-02-08 07:42:29 UTC
(In reply to comment #37)
> I do not understand what is
> meant with the env.d problem mentioned in the bug summary. Closing this
> NEEDINFO, since I do not think there is anything left for gentoo to fix here,
> but please reopen if I misunderstood.

As noted in Comment #40 above, the wrong env.d file installed by ati-drivers completely kills DRI, pretty serious issue that's been ignored for ages. (Also it shouldn't use any variables there, they won't get expanded.)
Comment 42 Marien Zwart (RETIRED) gentoo-dev 2007-02-10 01:29:24 UTC
Short version: the experimental ebuild I committed as 8.33.6-r2 (package.masked for testing) should fix this. If you sync in about an hour you can unpmask this one to test. Make sure you get cvs 1.2, my first commit was broken (you will get an error about a missing glx extension in Xorg.0.log if you use the first version).

It installs even more env.d entries though, and whether the new driver location is the right one is debatable.

Longer explanation:

opengl applications link to /usr/lib/libGL.so. This is a symlink managed by eselect which can point to mesa's or ati's libGL (or a different one of course, but that's not relevant here). If it is mesa's it will try to load an extension module like r300_dri.so from the location /usr/$(get_libdir)/dri/ or from a location in LIBGL_DRIVERS_PATH if this is set. If LIBGL_DRIVERS_PATH is set the hardcoded standard location is not searched.

So for mesa to work LIBGL_DRIVERS_PATH must be either unset or include /usr/$(get_libdir)/dri/.

If libGL.so is ati's it will do approximately the same thing (I assume this libGL.so is based on mesa), but the hardcoded path is different: it looks in /usr/X11R6/lib/modules/dri on x86 and on amd64 for the 32 bit ABI and in /usr/X11R6/lib64/modules/dri for actual 64 bit amd64. It uses the same LIBGL_DRIVERS_PATH mechanism to override the builtin location.

The builtin location does not work very well on gentoo. First, if xorg-x11 is installed /usr/X11R6 will be a symlink to ../usr. This means /usr/X11R6/lib is actually /usr/lib and /usr/X11R6/lib64 is /usr/lib64. As far as I know most (all?) gentoo amd64 multilib systems have /usr/lib as a symlink to /usr/lib64 or vice versa. So the 32 bit and 64 bit libGL.so end up searching for their drivers in the same directory, meaning we cannot get both 32 bit and 64 bit direct rendering working at the same time without setting LIBGL_DRIVERS_PATH. This is bug #101539.

The 8.33.6-r2 ebuild "fixes" this by installing its dri modules into the same directory mesa uses (/usr/$(get_libdir)/dri) and setting LIBGL_DRIVERS_PATH to that location. For mesa this is almost a noop: the only change should be that the 32 bit libGL now also looks in the 64 bit libdir and vice versa. For ati's libGL this setting is required to override its builtin default which is nonsensical on gentoo's multilib.

A better fix might be to have eselect opengl install/remove the /etc/env.d file setting LIBGL_DRIVERS_PATH when it changes libGL.so. I will probably try that approach in the near future, but for now this *should* suffice (it is not perfect: it will break if mesa changes its module directory and when you somehow install mesa for more/different multilib abis than ati-drivers (I do not know if that is actually possible though)).
Comment 43 Jakub Moc (RETIRED) gentoo-dev 2007-02-11 11:34:00 UTC
*** Bug 166318 has been marked as a duplicate of this bug. ***
Comment 44 Ákos Maróy 2007-02-11 11:50:30 UTC
I was told to use ati-drivers-8.33.6-r2 to fix this issue, but it's package masked, and is also blocking ati-drivers-extra-8.33.6 :(

what is AIGLX anyway?
Comment 45 Ákos Maróy 2007-02-11 11:51:47 UTC
moreover, this is what I get with ati-drivers-8.33.6-r2 on amd64:

 * Preparing fglrx module
make -C /usr/src/linux M=/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x modules
make[1]: Entering directory `/usr/src/linux-2.6.18-gentoo-r6'
  CC [M]  /var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.o
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:529: warning: initialization from incompatible pointer type
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'firegl_stub_open':
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:652: warning: assignment discards qualifiers from pointer target type
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'firegl_put_user_ptr':
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1421: warning: cast from pointer to integer of different size
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1421: warning: cast from pointer to integer of different size
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1421: warning: cast from pointer to integer of different size
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:1421: warning: cast from pointer to integer of different size
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function '__ke_unregister_ioctl32_conversion':
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:2664: warning: 'return' with a value, in function returning void
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c: In function 'KAS_ExecuteAtLevel':
/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/firegl_public.c:4506: warning: 'flags' may be used uninitialized in this function
  LD [M]  /var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.o
  Building modules, stage 2.
  MODPOST
  CC      /var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.mod.o
  LD [M]  /var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/work/common/lib/modules/fglrx/build_mod/2.6.x/fglrx.ko
make[1]: Leaving directory `/usr/src/linux-2.6.18-gentoo-r6'
 * Building fgl_glxgears
fgl_glxgears.c:70:22: error: GL/glATI.h: No such file or directory

!!! ERROR: x11-drivers/ati-drivers-8.33.6-r2 failed.
Call stack:
  ebuild.sh, line 1614:   Called dyn_compile
  ebuild.sh, line 971:   Called qa_call 'src_compile'
  environment, line 4073:   Called src_compile
  ati-drivers-8.33.6-r2.ebuild, line 169:   Called die

!!! fgl_glxgears build failed
!!! If you need support, post the topmost build error, and the call stack if relevant.
!!! A complete build log is located at '/var/tmp/portage/x11-drivers/ati-drivers-8.33.6-r2/temp/build.log'.

Comment 46 Marien Zwart (RETIRED) gentoo-dev 2007-02-22 22:26:10 UTC
This should be fixed in 8.34.8. Remember to source /etc/profile to get the env var set. Please reopen if this is still an issue.
Comment 47 Thomas 2009-03-26 19:10:49 UTC
Interesting, that noone talks about this any longer.  I came across this problem a week ago with the recent ATI open source drivers on an ATI 9600 and didn't find any help anywhere.  Grepping the mesa sources, this is what i found out:

__driCreateNewScreen_20050727 is a method defined in mesa-7.0 and earlier, but not defined in recent mesa versions.  However, even recent ATI drivers rely on it; this is probably why mesa 7.x is still masked.  Thus, the solution is: don't update mesa beyond what is considered stable. ;-)