Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 141097 - media-libs/libgphoto2-2.2.1-r1 ebuild fails during test
Summary: media-libs/libgphoto2-2.2.1-r1 ebuild fails during test
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Graphics Project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks: 193933
  Show dependency tree
 
Reported: 2006-07-19 17:38 UTC by Drake Wyrm
Modified: 2010-03-28 01:00 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Drake Wyrm 2006-07-19 17:38:55 UTC
While attempting to emerge media-libs/libgphoto2-2.2.1-r1, I get the following
error during the test phase:

<snip>
Making check in tests
make[1]: Entering directory `/var/tmp/portage/libgphoto2-2.2.1-r1/work/libgphoto2-2.2.1/tests'
make  test-camera-list check-camera-list.sh
make[2]: Entering directory `/var/tmp/portage/libgphoto2-2.2.1-r1/work/libgphoto2-2.2.1/tests'
if i686-pc-linux-gnu-gcc -DHAVE_CONFIG_H -I. -I. -I..  -I.. -I../libgphoto2_port/libgphoto2_port -I../libgphoto2_port -I../libgphoto2 -I../libgphoto2 -DLOCALEDIR=\"/usr/share/locale\" -DCAMLIBS=\"/usr/lib/libgphoto2/2.2.1\" -Wall -Wmissing-declarations -Wmissing-prototypes -g   -march=athlon-tbird -O3 -pipe -MT test-camera-list.o -MD -MP -MF ".deps/test-camera-list.Tpo" -c -o test-camera-list.o test-camera-list.c; \
then mv -f ".deps/test-camera-list.Tpo" ".deps/test-camera-list.Po"; else rm -f ".deps/test-camera-list.Tpo"; exit 1; fi
/bin/sh ../libtool --tag=CC --mode=link i686-pc-linux-gnu-gcc  -march=athlon-tbird -O3 -pipe -Wall -g  -o test-camera-list  test-camera-list.o ../libgphoto2/libgphoto2.la ../libgphoto2_port/libgphoto2_port/libgphoto2_port.la -lexif -lm    
i686-pc-linux-gnu-gcc -march=athlon-tbird -O3 -pipe -Wall -g -o .libs/test-camera-list test-camera-list.o  ../libgphoto2/.libs/libgphoto2.so ../libgphoto2_port/libgphoto2_port/.libs/libgphoto2_port.so /usr/lib/libexif.so -lm
creating test-camera-list
make[2]: `check-camera-list.sh' is up to date.
make[2]: Leaving directory `/var/tmp/portage/libgphoto2-2.2.1-r1/work/libgphoto2-2.2.1/tests'
make  check-TESTS
make[2]: Entering directory `/var/tmp/portage/libgphoto2-2.2.1-r1/work/libgphoto2-2.2.1/tests'
/bin/sh: ./check-camera-list.sh: Permission denied
FAIL: check-camera-list.sh
===================================================
1 of 1 tests failed
Please report to gphoto-devel@lists.sourceforge.net
===================================================
make[2]: *** [check-TESTS] Error 1
make[2]: Leaving directory `/var/tmp/portage/libgphoto2-2.2.1-r1/work/libgphoto2-2.2.1/tests'
make[1]: *** [check-am] Error 2
make[1]: Leaving directory `/var/tmp/portage/libgphoto2-2.2.1-r1/work/libgphoto2-2.2.1/tests'
make: *** [check-recursive] Error 1
make: Leaving directory `/var/tmp/portage/libgphoto2-2.2.1-r1/work/libgphoto2-2.2.1'

The interesting line is "/bin/sh: ./check-camera-list.sh: Permission denied".
Permission is denied because, for some reason, make is failing to make
check-camera-list.sh executible.

# ls -l check-camera-list.sh
-rw-r--r-- 1 root root 1257 Jul 19 17:15 check-camera-list.sh

This only happens when `make check` is called from portage. I can delete that
file and rebuild it, and it get the correct permissions.

# rm check-camera-list.sh
# make check-camera-list.sh
Creating check-camera-list.sh
# ls -l check-camera-list.sh 
-rwx------ 1 root root 1257 Jul 19 17:19 check-camera-list.sh

I can duplicate the odd behavior by setting an odd umask, however.

# umask 0133
# rm check-camera-list.sh
# make check-camera-list.sh
Creating check-camera-list.sh
# ls -l check-camera-list.sh 
-rw-r--r-- 1 root root 1257 Jul 19 17:20 check-camera-list.sh

My `emerge --info` info:

Gentoo Base System version 1.6.15
Portage 2.1-r1 (default-linux/x86/2006.0, gcc-3.4.6, glibc-2.3.6-r4, 2.6.17-gentoo-r3 i686)
=================================================================
System uname: 2.6.17-gentoo-r3 i686 AMD Athlon(tm) processor
app-admin/eselect-compiler: [Not Present]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CFLAGS="-march=athlon-tbird -O3 -pipe"
CHOST="i686-pc-linux-gnu"
CXXFLAGS="-march=athlon-tbird -O3 -pipe"
DISTDIR="/var/cache/distfiles"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict test"
MAKEOPTS="-j2 -w"
PKGDIR="/usr/share/packages/portage"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
SYNC="rsync://rsync.namerica.gentoo.org/gentoo-portage"
USE="x86 3dnow X aalib acl alsa bash-completion berkdb bzip2 cjk crypt dga directfb doc esd fbcon flac gdbm gif gnome gpm gtk gtk2 ipv6 java jpeg ldap mad mbox mmx mpeg mysql ncurses nls offensive ogg oggvorbis opengl oss pam perl png python readline sdl skey slang ssl svga tcl tcltk tcpd tetex tiff tk truetype unicode xv zlib elibc_glibc input_devices_evdev input_devices_jamstudio input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_fbdev video_cards_r128 video_cards_vesa"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Alastair Tse (RETIRED) gentoo-dev 2006-07-20 04:31:59 UTC
ebuild test seems to work for me with no errors, and the script gets created properly with the write execute bits set. Could it be your sfperms in your make.conf?
Comment 2 Alastair Tse (RETIRED) gentoo-dev 2006-07-20 04:49:46 UTC
actually, i take that back, i re-ran the tests a couple of times and removing my tmp work directory and the problem appeared. investigating further
Comment 3 Alastair Tse (RETIRED) gentoo-dev 2006-07-20 06:05:23 UTC
I think there is a problem with chown failing when make check is run, not with the umask. I'm going to disable the tests unless a patch is submitted
Comment 4 Matthias Schwarzott gentoo-dev 2007-05-18 20:41:47 UTC
I cannot reproduce this problem.
Do you can reproduce it on every try?
Is this problem solved in newer versions of libgphoto2 (in 2.3.1-r4)?
Comment 5 Drake Wyrm 2007-05-19 06:49:37 UTC
Well, the ebuild is test-restricted in 2.3.1-r4, so that's probably why it's presently irreproducible.
Comment 6 Lars Weiler (RETIRED) gentoo-dev 2007-09-30 20:00:14 UTC
How about asking arches to stabilise media-libs/libgphoto2-2.3.1-r4?
Comment 7 Gilles Dartiguelongue gentoo-dev 2007-10-03 22:42:23 UTC
disabled tests for 2.2 as well to allow work on digikam to go on, I'll fill a stabilization bug for 2.3 soon.