Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 140896 - xine-ui-0.99.5_pre20060716 crashes
Summary: xine-ui-0.99.5_pre20060716 crashes
Status: RESOLVED DUPLICATE of bug 161913
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Media-video project
: 155877 (view as bug list)
Depends on:
Reported: 2006-07-18 03:45 UTC by Sawk
Modified: 2007-03-16 19:11 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---

xine with --bug-report flag enabled (BUG-REPORT.TXT,7.20 KB, text/plain)
2006-12-02 14:47 UTC, Pythagoras Mayrhofer

Note You need to log in before you can comment on or make changes to this bug.
Description Sawk 2006-07-18 03:45:21 UTC
(gdb) run
Starting program: /usr/bin/xine 
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
(no debugging symbols found)
[Thread debugging using libthread_db enabled]
[New Thread -1208510800 (LWP 27559)]
This is xine (X11 gui) - a free video player v0.99.5.
(c) 2000-2004 The xine Team.
[New Thread -1209095264 (LWP 27568)]
X Error of failed request:  BadAtom (invalid Atom parameter)
  Major opcode of failed request:  18 (X_ChangeProperty)
  Atom id in failed request:  0x0
  Serial number of failed request:  186
  Current serial number in output stream:  189

Program exited with code 01.


Portage 2.1.1_pre3-r1 (default-linux/x86/2006.0, gcc-4.1.1/vanilla, glibc-2.4-r3, 2.6.17-gentoo i686)
System uname: 2.6.17-gentoo i686 Intel(R) Celeron(R) CPU 2.60GHz
Gentoo Base System version 1.12.1
ccache version 2.4 [enabled]
app-admin/eselect-compiler: 2.0.0_rc2-r1
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r2
dev-util/confcache:  [Not Present]
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.17
sys-devel/gcc-config: [Not Present]
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
CFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/eselect/compiler /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo"
CXXFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
FEATURES="autoconfig ccache distcc distlocks fixpackages metadata-transfer sandbox sfperms strict"
USE="x86 X aac alsa apm asf avi bash-completion berkdb bitmap-fonts cairo cdparanoia cli crypt cups curl custom-cflags dga directfb dlloader dri dvb dvd dvdr eds emboss encode esd fbcon ffmpeg firefox flac foomaticdb fortran gdbm gif glitz gpm gstreamer gtk gtk2 i8x0 imlib infopipe isdnlog java javascript jce jpeg kdeenablefinal kdehiddenvisibility libg++ libsamplerate libwww live logitech-mouse lzo mad matroska mikmod mmx motif moznocompose moznoirc moznomail moznoxft mp3 mpeg musepack musicbrainz mythtv ncurses nls nptl nptlonly nsplugin nvidia ogg opengl openssh oss pam pcre pdflib perl png pop pppd python qt3 qt4 quicktime readline real reflection rtc sdl session sndfile speex spell spl sse sse2 ssl tcpd tga theora timidity truetype truetype-fonts type1-fonts udev usb vcd vorbis win32codecs xml xmms xorg xprint xv zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_joystick kernel_linux linguas_it userland_GNU video_cards_nvidia"
Comment 1 Avuton Olrich 2006-11-18 12:59:20 UTC
I'm getting this same bug; any way we can get an xine-ui bump soon?

sbh@rocket Desktop % xine outerspace85.wmv
This is xine (X11 gui) - a free video player v0.99.5-[DEBUG].
(c) 2000-2004 The xine Team.
videowin: display is using xinerama with 2 screens
videowin: going to assume we are using the first screen.
videowin: size of the first screen is 1600x1200.
videowin: Xinerama fullscreen parameters: X_origin=0 Y_origin=0 Width=3200 Height=1200
pixel_aspect: 1.000000
X Error of failed request:  BadWindow (invalid Window parameter)
  Major opcode of failed request:  3 (X_GetWindowAttributes)
  Resource id in failed request:  0x360036d
  Serial number of failed request:  3166
  Current serial number in output stream:  3167

Comment 2 Avuton Olrich 2006-11-18 13:56:46 UTC
I have confirmed that xine-cvs fixes this problem, still get a warning (a one liner) but it doesn't crash and seems to work fine.
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-11-21 12:31:44 UTC
*** Bug 155877 has been marked as a duplicate of this bug. ***
Comment 4 Pythagoras Mayrhofer 2006-12-02 14:47:37 UTC
Created attachment 103240 [details]
xine with --bug-report flag enabled

this is what i get when starting xine
Comment 5 Michael Kedzierski 2007-01-12 00:44:15 UTC
I get the exact same output from GDB as comment #1.

Here is my emerge --info:
Portage 2.1.2_rc4-r7 (default-linux/amd64/2006.1/desktop, gcc-4.1.1, glibc-2.4-r4, 2.6.17-emission8-ycros x86_64)
System uname: 2.6.17-emission8-ycros x86_64 AMD Athlon(tm) 64 X2 Dual Core Processor 3800+
Gentoo Base System version 1.12.8
Last Sync: Thu, 11 Jan 2007 02:30:01 +0000
distcc 2.18.3 x86_64-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-java/java-config: 1.3.7, 2.0.31
dev-lang/python:     2.3.5-r3, 2.4.3-r4
dev-python/pycrypto: 2.0.1-r5
dev-util/confcache:  0.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.60
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.16.1-r3
sys-devel/gcc-config: 1.3.14
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-march=athlon64 -O3 -pipe -funroll-loops -fomit-frame-pointer"
CONFIG_PROTECT="/etc /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/java-config/vms/ /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-march=athlon64 -O3 -pipe -funroll-loops -fomit-frame-pointer"
FEATURES="autoconfig distlocks metadata-transfer parallel-fetch sandbox sfperms strict"
LINGUAS="en pl ja"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTDIR_OVERLAY="/usr/local/portage /home/ycros/portage /usr/portage/local/layman/zugaina /usr/portage/local/layman/stuart-desktop"
USE="X a52 aac accessibility acl acpi aim alsa amd64 amr aotuv apache2 apm arts artworkextra audiofile avahi bash-completion berkdb bidi bitmap-fonts bjam bmg bonjour boo browserplugin buttons bzip2 bzlib c++ cairo canvas caps cdparanoia cdr cegui cg cjk cli cracklib crypt css ctype cups curl curlwrappers daap dbus devil dhcp djvu dlloader dmx doc dpms dri dts dv dvd dvdr dvdread ecore eds emboss encode esd ethereal evo exif expat extensions faac faad fam fame fbcon ffmpeg fftw firefox flac fluidsynth font-server fortran freetype ftp gaim galago gdbm geoip gif gimpprint glitz gnokii gnome gnutls gpm graphviz gstreamer gtk gtk2 hal howl httpd iconv icq icu idl ieee1394 imap immqt-bc inkjar innodb ipv6 isdnlog jabber jack jack-tmpfs java javascript jce jpeg jpeg2k jython kde kdeenablefinal ladcca lcms ldap libg++ libsamplerate libvisual live lm_sensors logitech-mouse mad maildir matroska mbox mdns mikmod mime mjpeg mmap mng mod mono mozdevelop mozsha1 mozsvg mozxmlterm mp3 mp4 mpeg mpi mplayer mppe-mppc msn musepack musicbrainz ncurses nethack network nfs nls nntp no-seamonkey nptl nptlonly nsplugin numeric nvidia nvtv offensive ogg oggvorbis ole openal opengl oscar oss pam pcntl pcre pdf perl php pic pie png posix postscript povray ppds pppd ps pyste python qt3 qt4 quicktime rdesktop readline reflection rtc samba sasl screen screenshot sdl session shared sharedmem silc smp sndfile sockets softmmu sox speex spell spl sql ssl stream subversion svg sysvipc t1lib tcpd tetex tga theora tidy tokenizer truetype truetype-fonts type1-fonts udev unicode v4l v4l2 vcd vhosts videos visualization vorbis webservices wifi wmf wxwindows x264 xanim xchatdccserver xerces-c xface xinerama xml xmlrpc xorg xosd xprint xrandr xscreensaver xsl xv xvid xvmc yv12 zeo zeroconf zlib" ALSA_CARDS="ali5451 als4000 atiixp atiixp-modem bt87x ca0106 cmipci emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="mouse keyboard evdev" KERNEL="linux" LINGUAS="en pl ja" USERLAND="GNU" VIDEO_CARDS="nvidia"
Comment 6 Pacho Ramos gentoo-dev 2007-03-03 22:49:36 UTC
Have you tried with media-video/xine-ui-0.99.5_pre20070303 ?
Comment 7 Jakub Moc (RETIRED) gentoo-dev 2007-03-16 19:11:38 UTC

*** This bug has been marked as a duplicate of bug 161913 ***