Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 140 - Xfree86 not Installing/Compiling
Summary: Xfree86 not Installing/Compiling
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: x86 Linux
: Highest normal (vote)
Assignee: Mikael Hallendal (hallski) (RETIRED)
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2002-01-12 07:49 UTC by Greg Horne
Modified: 2003-02-04 19:42 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Greg Horne 2002-01-12 07:49:00 UTC
When installing / compiling the XFree86 packages, an error occurs stating that 
the end of file has been found before the logical end of file.  The error arises 
whenever I attempt to emerge the kde-base or gnome-base.  Obviously, this 
situation is critical as it limits Gentoo Linux to a console only distribution 
for me at this point in time.
Comment 1 Martin Schlemmer (RETIRED) gentoo-dev 2002-01-12 10:37:14 UTC
Free space problem ?
Comment 2 Greg Horne 2002-01-15 17:26:06 UTC
There is plenty of HD space available per the 'df' command.  The failure seems 
to occur when the package labelled 'xc' is being compiled - or at least that is 
the last package name I see before the errors commence.
Comment 3 Greg Horne 2002-01-19 16:56:48 UTC
Here is the error message I receive trying to emerge x11-base/xfree (for 
example).

make[5]: *** [gamma_gl.o] Error 1
make[5]: Leaving directory 
`/var/tmp/portage/xfree-4.1.0-r6/work/xc/lib/GL/mesa/src/drv/gamma
...
!!! emerge aborting on /usr/portage/x11-base/xfree/xfree-4.1.0-r6.ebuild .


Plus a slew of other error messages.  Hopefully, the above error will provide 
some insight.  BTW, I am installing Gentoo GNU/Linux on a Compaq Presario 3555 
(64 MB RAM, 10 GD HD - 5 GB allocated to partition /, 128 MB Swap partition, 20 
MB Boot partition, with the balance allocated to partition /home).
Comment 4 Mikael Hallendal (hallski) (RETIRED) gentoo-dev 2002-01-19 17:22:14 UTC
can you paste what actually went wrong. That means a couple of rows above what
you just pasted.
Comment 5 Greg Horne 2002-01-19 22:11:32 UTC
Unfortunately, the screen output scrolled off screen and the make [5]: *** 
[gamma.o] Error 1 line was the top line visible.  The USE variable in 
/etc/make.conf is the default string as installed by Gentoo GNU/Linux.
Comment 6 Mikael Hallendal (hallski) (RETIRED) gentoo-dev 2002-01-20 03:10:41 UTC
sorry, I can't help you if I don't know what's wrong. All I can say is that it
merges fine for everyone else, so, I'm pretty left with nothing to go on here.
Comment 7 Mikael Hallendal (hallski) (RETIRED) gentoo-dev 2002-01-23 03:32:24 UTC
haven't gotten any other reports and initial filer seems to have solved it since
he doesn't reply.