Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 139292 - After upgrade to python-2.4 portage stops working because of "missing" pycropto
Summary: After upgrade to python-2.4 portage stops working because of "missing" pycropto
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Core system (show other bugs)
Hardware: All Linux
: High major (vote)
Assignee: Gentoo Linux bug wranglers
Depends on:
Reported: 2006-07-05 04:39 UTC by Honza
Modified: 2006-07-05 07:45 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

Log of python-updater (python-update.log,10.35 KB, text/plain)
2006-07-05 05:26 UTC, Honza

Note You need to log in before you can comment on or make changes to this bug.
Description Honza 2006-07-05 04:39:52 UTC
I upgraded python to python-2.4.2 and then portage complains about something with pycrypto on every emerge.
For example, output of "emerge pycrypto":

Calculating dependencies ... done!
>>> Emerging (1 of 1) dev-python/pycrypto-2.0.1-r5 to /
>>> Creating Manifest for /usr/portage/dev-python/pycrypto
Traceback (most recent call last):
  File "/usr/bin/emerge", line 3524, in ?
  File "/usr/bin/emerge", line 2056, in merge
  File "/usr/lib/portage/pym/", line 2958, in doebuild
    digestgen(aalist, mysettings, overwrite=0, myportdb=mydbapi)
  File "/usr/lib/portage/pym/", line 2341, in digestgen
    assumeDistHashesAlways=("assume-digests" in mysettings.features))
  File "/usr/lib/portage/pym/", line 431, in create
    self.fhashdict[mytype][f] = perform_multiple_checksums(self.pkgdir+f, self.hashes)
  File "/usr/lib/portage/pym/", line 166, in perform_multiple_checksums
    raise portage_exception.DigestException, x+" hash function not available (needs dev-python/pycrypto)"
portage_exception.DigestException: 'RMD160 hash function not available (needs dev-python/pycrypto)'

(Additional question: howto correctly switch back to python-2.3 ? Is changing /usr/bin/python symlink enough ?)
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-07-05 04:48:40 UTC
Run python-updater like the ebuild told you...
Comment 2 Honza 2006-07-05 05:24:26 UTC
Already tried. (To long to post here, I'll try to attach it. It tried to emerge pycrypto too.)

So ?

What's that "Creating Manifest" anyway ? Isn't manifest supposed to already exists ?

Maybee there is some other problem - I'm updating my amd64 instalation, maybee it has some obsolete packages, but which ? I switched make.profile (from 2004), upgraded portage, did emerge metadata and emerge sync just in case and now I'm upgrading everything from glsa ... which includes python. I should had do =python-2.3* instead ...
Comment 3 Honza 2006-07-05 05:26:07 UTC
Created attachment 90958 [details]
Log of python-updater
Comment 4 Honza 2006-07-05 05:28:44 UTC
Note: if I change /usr/bin/python to point to python-2.3, portage seems to work, but after emerge pycrypto and changing back no change. Should I try to python-updater which python-2.3 ?
Comment 5 Honza 2006-07-05 05:29:28 UTC
Comment 6 Jakub Moc (RETIRED) gentoo-dev 2006-07-05 05:34:18 UTC
Well, sorry. Upgrade from 2004.x is not supported by amd64 any more, you are on your own here really. You had plenty of time to do it before, fresh reinstall is what's recommended now. 

Don't know how you did upgrade anyway, seems you did it manually in a completely wrong order. You can try FEATURES="-strict" emerge -1 pycrypto' and see if it helps. 
Comment 7 Honza 2006-07-05 05:49:28 UTC
What, you mean there is something needed besides changing that symlink ?

Are you sure it is reason of my problems ? You know, python-updater really CAN'T help if emerge don't work ...

BTW, emerge info:
Gentoo Base System version 1.4.16
*** Deprecated use of action 'info', use '--info' instead
Portage 2.1-r1 (default-linux/amd64/2006.0, gcc-3.4.3, glibc-, 2.6.12-gentoo-r8-64 x86_64)
System uname: 2.6.12-gentoo-r8-64 x86_64 AMD Athlon(tm) 64 Processor 3000+
dev-lang/python:     2.3.5-r2, 2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/gcc-config: 1.3.9
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
CFLAGS="-O2 -pipe -mtune=athlon64"
CONFIG_PROTECT="/etc /usr/lib/X11/xkb /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/"
CONFIG_PROTECT_MASK="/etc/env.d /etc/gconf /etc/terminfo"
CXXFLAGS="-O2 -pipe -mtune=athlon64"
FEATURES="autoconfig digest distlocks metadata-transfer sandbox sfperms"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
USE="amd64 3dnowex X Xaw3d aalib acpi alsa apache2 apm audiofile avi berkdb bitmap-fonts browserplugin bzip2 bzlib caps cdr cli crypt cups curl dbase dbm dbx dga directfb divx4linux dlloader doc dri dvd dvdr eds emboss encode esd ethereal exif fbcon flac flash foomaticdb fortran gd gdbm ggi gif gnome gpm gstreamer gtk gtk2 iconv imagemagick imlib innodb ipv6 isdnlog java jpeg lcms lesstif libcaca libwww lirc lzw lzw-tiff mad mailwrapper mbox mcal memlimit mhash mikmod mime ming mmap mmx2 mng motif mozilla mp3 mpeg multislot mysql ncurses nls nptl offensive oggvorbis openal opengl oss pam pcntl pcre pdflib perl php plotutils png posix pppd python qt qt3 qt4 quicktime readline reflection rtc samba sdl session shared sharedmem slang sndfile snmp sockets spell spl sqlite ssl sysvipc tcpd tetex theora tiff truetype truetype-fonts type1-fonts unicode usb v4l v4l2 vhosts videos wmf xml xorg xosd xpm xv xvid zlib elibc_glibc input_devices_keyboard input_devices_mouse input_devices_evdev kernel_linux userland_GNU"
Comment 8 Honza 2006-07-05 05:54:00 UTC
HA. -strict didn't worked, but changing python from 2.3 to 2.4 in middle of emerge pycrypto worked.
Comment 9 Jakub Moc (RETIRED) gentoo-dev 2006-07-05 05:59:47 UTC
As said, upgrading from 2004 profiles is not supported, you'll hit tons more problems (like Bug 132135) etc.
Comment 10 Honza 2006-07-05 06:09:12 UTC
Thanks for warning. I'll try it anyway.

And I still think the python problem is unrelated.
Comment 11 Honza 2006-07-05 07:45:15 UTC
Do you have some test which can say "ok, you have upgraded correctly", or will you simply say that every bug I encounter on my amd64 instalation (I have also several i386 ones which I upgrade more often) is because I missed something ? Like, am I safe when I can do emerge system ?

(Note: I switched /lib* symlinks, made some new and I'm compiling glibc-2.3.6 now)