Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 137820 - courier-authlib will not compile without gdbm
Summary: courier-authlib will not compile without gdbm
Status: RESOLVED DUPLICATE of bug 113975
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-24 05:37 UTC by Zeth
Modified: 2006-06-24 05:38 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Zeth 2006-06-24 05:37:25 UTC
Hello,

As discussed in the forums, 
http://forums.gentoo.org/viewtopic-t-463393.html

Emerging courier-autlib without gdbm fails. This is true of at least version 0.58 and 0.57-r2, which are both marked stable.

I found this on x86, other users report it on AMD64 (see forum post).

When you then use gdbm, it works fine.

The default behaviour is for courier-autlib to be emerged -gdbm, which will not work.   

Best Wishes,
Zeth


make[3]: Entering directory `/var/tmp/portage/courier-authlib-0.58/work/courier-authlib-0.58/bdbobj'
Compiling bdbobj.c
Compiling bdbobj2.c
Compiling bdbobj3.c
Compiling testbdb.C
Linking libbdbobj.la
Linking testbdb
./.libs/libbdbobj.a(bdbobj.o): In function `.L13':
bdbobj.c:(.text+0x17f): undefined reference to `db_create'
collect2: ld returned 1 exit status
make[3]: *** [testbdb] Error 1
make[3]: Leaving directory `/var/tmp/portage/courier-authlib-0.58/work/courier-authlib-0.58/bdbobj'
make[2]: *** [all] Error 2
make[2]: Leaving directory `/var/tmp/portage/courier-authlib-0.58/work/courier-authlib-0.58/bdbobj'
make[1]: *** [all-recursive] Error 1
make[1]: Leaving directory `/var/tmp/portage/courier-authlib-0.58/work/courier-authlib-0.58'
make: *** [all] Error 2

!!! ERROR: net-libs/courier-authlib-0.58 failed.
Call stack:
  ebuild.sh, line 1540:   Called dyn_compile
  ebuild.sh, line 940:   Called src_compile
  courier-authlib-0.58.ebuild, line 101:   Called die

!!! Compile problem
!!! If you need support, post the topmost build error, and the call stack if relevant.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-06-24 05:38:43 UTC

*** This bug has been marked as a duplicate of 113975 ***