Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 135927 - Returning developer: William L. Thomson Jr (wltjr)
Summary: Returning developer: William L. Thomson Jr (wltjr)
Status: RESOLVED INVALID
Alias: None
Product: Gentoo Developers/Staff
Classification: Unclassified
Component: New Developers (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Recruiting Team
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-07 07:27 UTC by Josh Nichols (RETIRED)
Modified: 2018-04-08 21:21 UTC (History)
7 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
irc log from session with a recruiter spanning 2hrs (deleted)
2011-03-09 21:16 UTC, William L. Thomson Jr.
Details
irc log of #gentoo-comrel (2015-02-17.log,43.31 KB, text/x-log)
2015-02-22 17:15 UTC, William L. Thomson Jr.
Details
irc log of #gentoo-comrel (2015-02-18.log,50.30 KB, text/x-log)
2015-02-22 17:15 UTC, William L. Thomson Jr.
Details
irc log of #gentoo-comrel (2015-02-19.log,46.25 KB, text/x-log)
2015-02-22 17:16 UTC, William L. Thomson Jr.
Details
irc log #gentoo-comrel (gentoo-comrel-log.txt,103.42 KB, text/plain)
2015-02-22 17:58 UTC, Andreas K. Hüttel
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Josh Nichols (RETIRED) gentoo-dev 2006-06-07 07:27:17 UTC
William has been working on maintaining www-servers/tomcat and a number of other packages in our experimental overlays over the past several months. We would like to bring him on board the Java team to continue this work, as well as help out with other Java packages.
Comment 1 Josh Nichols (RETIRED) gentoo-dev 2006-07-21 12:51:38 UTC
The candidate has completed both quizes, and I'll be doing the final review tomorrow sometime.
Comment 2 William L. Thomson Jr. (RETIRED) gentoo-dev 2006-09-03 18:50:25 UTC
So far so good, I seem to be a dev? In secret though, would be great if I could get an annoucement. Also I seem to be nameless on the java project page, and mia on developer list page. No rush, just to mention it "officially". Otherwise seem to be all set. Thanks, and off to commit and squash bugs.
Comment 3 Petteri Räty (RETIRED) gentoo-dev 2006-09-09 06:47:02 UTC
(In reply to comment #2)
> So far so good, I seem to be a dev? In secret though, would be great if I could
> get an annoucement. Also I seem to be nameless on the java project page, and
> mia on developer list page. No rush, just to mention it "officially". Otherwise
> seem to be all set. Thanks, and off to commit and squash bugs.
> 

The java project page you can modify as you have commit access now. I think the developer page is manually synced so you need to poke someone from infra.
Comment 4 Bryan Østergaard (RETIRED) gentoo-dev 2006-09-09 16:34:17 UTC
Roll-call updated and new-dev announcement sent twice! :) Let's hope it doesn't get eaten this time.
Comment 5 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-09-05 01:42:46 UTC
William,

it is the decision of the devrel team that your Gentoo access be suspended for 15 days.
We hope this will allow you to step back, review your actions, stress out, recharge your
batteries and refocus on what's important for you on Gentoo.

We've reached this decision after you've ignored the warning in
http://archives.gentoo.org/gentoo-nfp/msg_719a7281c357a6f1e5f15dea219ccb03.xml and kept
replying to the thread in a tone not according to the CoC.
Following the procedures set on the policy [1] and after receiving a request by antarus
to moderate your posts on the -nfp mailing list, musikc with NeddySeagoon's agreement
asked infra to implement the moderation. You've then sent a mail that was not approved
by the list moderators and later decided to subscribe with a new email address [2] to
circumvent the moderation of your posts.
This suspension was agreed upon by calchan, fox2mike, jmbsvicetto, rane, tsunam, and
musikc. fmccor also agreed with the decision.

 [1] - http://www.gentoo.org/proj/en/council/coc.xml#doc_chap3
       "The proctors will attempt to resolve the problem by talking to involved parties,
     potentially issuing warnings if appropriate." "If the problem repeats itself, there
     are various options open to the proctors, including temporary or permanent suspension
     of a person's ability to post to mailing lists"

 [2] - new account subscription confirmed by robbat2 and admitted by wltjr on
     http://archives.gentoo.org/gentoo-nfp/msg_7ef33e6807214587fdb825bebe590887.xml

infra,

please process this bug accordingly
Comment 6 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-09-05 04:55:00 UTC
processed some time ago, just didn't update the bug till now.
Comment 7 Petteri Räty (RETIRED) gentoo-dev 2008-09-05 15:08:08 UTC
From a mail from him "and my request for retirement denied or ignored." so reopening for retirement.
Comment 8 Łukasz Damentko (RETIRED) gentoo-dev 2008-09-07 20:16:32 UTC
William's request wasn't ignored. We (undertakers) have even mailed him with an explanation why he won't be processed right away.

We decided to wait two weeks with processing his retirement until his suspension period ends. We've given him that time to cool off and think it over again instead of rushing it and allowing him to make the decision in the heat of the moment (he wrote his resignation seconds after he was informed about being suspended).

If he still wishes to leave Gentoo after two weeks, we will comply with that. 

For now, let's all calm down and just wait a bit.
Comment 9 solar (RETIRED) gentoo-dev 2008-09-07 21:39:55 UTC
Thanks Łukasz. This really should more or less be a semi official policy with 
retirements (two weeks to a month), if not already to prevent rash decisions
and wasted infra/retirement efforts.
Comment 10 Łukasz Damentko (RETIRED) gentoo-dev 2008-09-09 13:45:11 UTC
Infra, please process Williams retirement.
Comment 11 Christina Gianelloni (RETIRED) gentoo-dev 2008-09-09 17:35:56 UTC
(In reply to comment #10)
> Infra, please process Williams retirement.

This may seem confusing in light of comment #8. Wltjr emailed us (devrel and some others) on the 5th stating to retire him, he quit. 
Rane made his comment on the 7th. 
Wltjr emailed us (devrel and some others) again on the 8th stating that he would not come back and to retire him. He stated that he had thought it over for a while and slept on the decision, he still will not be coming back. He also made a good point about how prolonging his retirement will further delay finding new package maintainers, ultimately hurting everyone.

Please proceed with the normal retirement process. If wltjr wishes to come back some time in the future he can talk to us about doing so, for now he wishes to go.
Comment 12 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-10-30 10:14:51 UTC
Infra-processed for cvs/dev/lists/bugs/ldap.
Sorry about the delay, was due to RL and having to also rewrite some LDAP scripts.

planet, forums: your turn.
Comment 13 Wernfried Haas (RETIRED) gentoo-dev 2008-10-30 11:35:45 UTC
Forums done.
Comment 14 Steve Dibb (RETIRED) gentoo-dev 2008-10-30 15:57:08 UTC
planet done
Comment 15 Łukasz Damentko (RETIRED) gentoo-dev 2008-10-30 16:53:40 UTC
- Retired on IRC
- Removed from proj/ pages
- Removed from herds.xml
- Reassigned all remaining bugs
Comment 16 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2008-11-21 04:08:45 UTC
rane/jmbsvicetto: wltjr is still in lots of metadata.xml entries, please fix.
Comment 17 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-11-21 09:57:42 UTC
Robin,

I forgot to process his retirement. I'll do it later today.
Comment 18 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2008-12-08 03:47:37 UTC
- removed from metadata.xml.

List of orphaned packages (mail to be sent later):
dev-db/firebird
dev-db/flamerobin
mail-filter/assp

Closing as there seems to be nothing else to do here.
Comment 19 Alistair Bush (RETIRED) gentoo-dev 2010-03-28 01:24:13 UTC
wltjr is coming back :)
Comment 20 Alistair Bush (RETIRED) gentoo-dev 2010-03-28 01:26:36 UTC
Recruiters.  Please welcome back wltjr.  Tomcat is been slowly disintegrating after his departure and now needs some love and care.
Comment 21 Alistair Bush (RETIRED) gentoo-dev 2010-06-11 07:57:32 UTC
Seems that wltjr has lost interest in waiting.  So does that mean we close this as WONTFIX?
Comment 22 Petteri Räty (RETIRED) gentoo-dev 2010-06-11 08:09:19 UTC
(In reply to comment #21)
> Seems that wltjr has lost interest in waiting.  So does that mean we close this
> as WONTFIX?
> 

CANTFIX is what we have been using but doesn't matter that much.
Comment 23 Krzysztof Pawlik (RETIRED) gentoo-dev 2010-12-21 21:44:48 UTC
William is interested in rejoining Gentoo and continue his work on Tomcat.
Comment 24 William L. Thomson Jr. 2011-02-16 16:21:37 UTC
Found this to be of interest, coming from a council member, lead recruiter, and java team lead. Since Gentoo is all about stupid formalities and like to use bugs to track stuff. I will go ahead and pass on some interesting comments here.

From #gentoo-java 2011-02-13

< Arfrever> Betelgeuse, Caster: I wasn't ignoring bug #354421. I was planning to fix it soon, after some more urgent bugs.
<@Betelgeuse> Arfrever: ignoring == no comments

Thus its clear recruiting is ignoring my bug for what ever reason. Since in over a year still not a single comment from anyone associated with recruiting. With the exception of comment #22, which is responding to a withdraw of interest, closing bug.

Now I have been in touch with Thomas Sachau who I hope will have time to process me in the next month or so. Clearly this shows how fubar'd Gentoo's policies are wrt to returning developers.

Not to mention all the rest of the fubar around Gentoo, evident from the history on this bug.... Gentoo was much better off when it had less stupid policies, and a more open door, easier, faster process for new developers, much less any returning developers....

After all years have gone by, and no one else is doing the work. I can't see how that is good for Gentoo at all. If anyone care? :)
Comment 25 Petteri Räty (RETIRED) gentoo-dev 2011-02-16 16:51:27 UTC
(In reply to comment #24)
> 
> Thus its clear recruiting is ignoring my bug for what ever reason. Since in
> over a year still not a single comment from anyone associated with recruiting.
> With the exception of comment #22, which is responding to a withdraw of
> interest, closing bug.
> 

Why should there have been a comment during the time this bug was closed? Interesting conclusions you are drawing from a comment I made about a bug that users are actively hitting. In that case immediate action is expected but we do not have such policies in place for recruitment but of course some comments about status would be better than months of silence. Before this point in time you have not made it to the top of the queue and I don't see any reason to treat you differently from anyone else in the queue. In the interest of collecting more general feedback on the issue at hand I started a thread on the gentoo-project about returning developers.

> 
> Not to mention all the rest of the fubar around Gentoo, evident from the
> history on this bug.... Gentoo was much better off when it had less stupid
> policies, and a more open door, easier, faster process for new developers, much
> less any returning developers....
> 

The basic structure of the process was pretty much the same as it is now when I joined back in 2005. Are you referring to the early years of the project?

Comment 26 William L. Thomson Jr. 2011-02-17 03:26:57 UTC
(In reply to comment #25)
>
> Why should there have been a comment during the time this bug was closed?

Who said anything about no comments when bug was closed? Common sense would say the complaint is more towards, the months the bug spent open, twice now, with no comment...

I hope all recruits aren't treated that way.

> Interesting conclusions you are drawing from a comment I made about a bug that
> users are actively hitting.

Not a big deal, just felt it ironic, and since others are big on documenting stuff on bugs, I figured why not.

> In that case immediate action is expected but we do
> not have such policies in place for recruitment but of course some comments
> about status would be better than months of silence.

Who said anything about immediate action? Some acknowledgement from recruiting would be nice, either comment on bug, contact with someone etc. I just happened across another, Tommy.

> Before this point in time
> you have not made it to the top of the queue and I don't see any reason to
> treat you differently from anyone else in the queue.

Back to the queue thing, and I do not expect to be prioritized in any way. We were here with the queue thing a year ago when it was 20, or what ever. The fact that there is a queue at all identifies some problem. If the delay is on the recruits end that's one thing, but it should never be on Gentoo's end!

Also with regard to processing recruits, it requires what maybe 2hrs max of a recruiters time per recruit. Which it should not even take that long for quiz review and otherwise. The rest is passed on to infra, short of bug update, announcement, etc.

Thus take that amount of time, multiple it by any amount in the queue, even 20. I can't see how it would take months to clear out a queue like that. I am sure developers easily contribute ~40 hours or more a month. If they can't maybe they should not be part of recruiting.

Or if recruiting is having problems, recruit more recruiters....

> In the interest of collecting more general feedback on the issue at hand I 
> started a thread on the gentoo-project about returning developers.

Wonderful! That's showing some leadership. Might have been nice close to a year ago when the topic first came up. Though I am kinda shocked the topic has not come up before.
 
> The basic structure of the process was pretty much the same as it is now when 
> I joined back in 2005. Are you referring to the early years of the project?

Yes probably the years before all the policies. That point of view in part comes from a not to distance conversation I had with my old gentoo recruiter kloeri.

Comment 27 William L. Thomson Jr. 2011-03-09 21:14:48 UTC
Gentoo is so screwed up. I am closing my bug and moving on. I am also going to attach a log from the 2hrs I just wasted with a recruiter and didn't even make it past question 10b on the first quiz. Despite the FACT that I was a developer before and didn't spend 2hrs with kloeri, and we finished review of two quizzes.

Completely unacceptable and quite typical of Gentoo!!!
Comment 28 William L. Thomson Jr. 2011-03-09 21:16:49 UTC
Created attachment 265365 [details]
irc log from session with a recruiter spanning 2hrs
Comment 29 Petteri Räty (RETIRED) gentoo-dev 2011-03-09 21:29:35 UTC
Restricting visibility of the bug because quiz contents are talked in the attachment.
Comment 30 Petteri Räty (RETIRED) gentoo-dev 2011-03-10 00:10:51 UTC
(In reply to comment #29)
> Restricting visibility of the bug because quiz contents are talked in the
> attachment.

Infra please clean the attachment so that we can open this bug to the public again.
Comment 31 William L. Thomson Jr. 2011-03-10 00:14:03 UTC
Log will just be posted/hosted else where.
Comment 32 Jorge Manuel B. S. Vicetto Gentoo Infrastructure gentoo-dev 2011-03-10 02:10:11 UTC
(In reply to comment #31)
> Log will just be posted/hosted else where.

If you do so, you'll be disrespecting the recruiting process. As you know, the answers to the quizzes are not meant to be public.
Comment 33 Christian Ruppert (idl0r) gentoo-dev 2011-03-10 04:35:13 UTC
The content of attachment 265365 [details] has been deleted by
    Christian Ruppert (idl0r) <idl0r@gentoo.org>
without providing any reason.

The token used to delete this attachment was generated at 2011-03-10 04:35:05 UTC.
Comment 34 William L. Thomson Jr. 2011-03-10 20:46:50 UTC
(In reply to comment #32)
> (In reply to comment #31)
> > Log will just be posted/hosted else where.
> 
> If you do so, you'll be disrespecting the recruiting process.

Given how disrespectful recruiters have been to me through out this entire process. I do not feel I owe them any respect. I have not been shown any, and therefore will respond in kind.

The recruiting process, at least for returning developers, is seriously flawed!

> As you know, the answers to the quizzes are not meant to be public.

How do I know this? Is there any document saying such? Did I agree to any non-disclosure? Is there any disclaimers on the quizzes or anywhere as to such?

Keeping things from the public is hardly the way a FOSS distribution should go. that is complete the wrong stance to take. Even if someone copies every answer, that does them no good as a new developer. They themselves will have major problems if they don't know the stuff. Sure potential for them to wreak havoc exists, but thats not been the case. Gentoo used to have a much more open door policy, that has since closed, and become fraught with bureaucracy.

There is nothing wrong with publishing the answers to any quiz. The answers should all be documented and publicly available. Just via other means.

However this is not the case with the log I attached. We barely covered 10 questions on the first quiz. Thats hardly giving up any useful information that other new developers could really find of use. We did not even discuss every one of the 10 questions, just how far we made it in 2 hours. Which is not acceptable for it to take 2hrs to cover the first 10 questions on the first quiz. With either a new developer or a returning developer.

Though in theory a returning developer should take considerably less time to process than a new dev. If the people doing the review are cooperative and have knowledge of the returning developers skill, and their recent contributions and activity. Which was not the case, even when I was bring stuff up in review.

The log needs to be public because its exposing major problems in the Gentoo Recruiters project and the recruiting process in general. Having been through the process before. I cannot believe how its been drug out, and requires so much more time than it did before. I can't understand how it took less time when I knew less, and had no experience, than it does when I know more, and have had years of experience. It just defies logic, and thats because the problem is not on my end, but on the recruiting side of things.

There is nothing being done to qualify or screen those who want to become recruiters. Thus far it seems those that are responsible for such, clearly lack the necessary abilities to get it done in a timely manner. Much less the need all around to get as many new developers on board as fast as possible.

Or worse standing in the way of those who will close many bugs, have a fair amount of commits, and immediately start making a difference in improving Gentoo. Which Gentoo has suffered considerably since I left in many ways. More bugs open, more packages not being maintained, no tax return for the foundation, no newsletter, list goes on and on....

What is recruiting doing to address those issues? Standing in the way and creating obstacles is surely not a way to move the project forward or get work that hasn't been done for years done today!
Comment 35 William L. Thomson Jr. 2011-03-10 20:48:24 UTC
Also fair warning, I am about to post to -project, because I have been driven to such. I will make the log publicly available and considering making my quizzes available entirely with answers. Both past quizzes and present ones.

Its really sad things had to come to this, it could have been very different and should have been!
Comment 36 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2011-03-10 21:16:31 UTC
(In reply to comment #30)
> (In reply to comment #29)
> > Restricting visibility of the bug because quiz contents are talked in the
> > attachment.
> 
> Infra please clean the attachment so that we can open this bug to the public
> again.

infra's job is done...
Comment 37 Robin Johnson archtester Gentoo Infrastructure gentoo-dev Security 2011-03-11 23:03:19 UTC
(In reply to comment #34)
> How do I know this? Is there any document saying such? Did I agree to any
> non-disclosure? Is there any disclaimers on the quizzes or anywhere as to such?
From the recruiters page, http://www.gentoo.org/proj/en/devrel/recruiters/, section 5:
"Please do not attach quiz answers or encryption keys to the bug -- these should be emailed to recruiters. The new developer and all mentors should be CCed on the bug to keep everybody in the loop. "

recruiters: Please add the no-email comment to the top of the actual quizzes.
Comment 38 William L. Thomson Jr. 2011-03-11 23:10:57 UTC
(In reply to comment #37)
> (In reply to comment #34)
> > How do I know this? Is there any document saying such? Did I agree to any
> > non-disclosure? Is there any disclaimers on the quizzes or anywhere as to such?
> From the recruiters page, http://www.gentoo.org/proj/en/devrel/recruiters/,
> section 5:
> "Please do not attach quiz answers or encryption keys to the bug -- these
> should be emailed to recruiters. The new developer and all mentors should be
> CCed on the bug to keep everybody in the loop. "

Nothing of the sort was ever added to the bug. I simply added a log of a 2hr review session that didn't even cover every question up to the point we stopped at. Its not even a complete review of a single quiz and no one can use that information to their benefit.

Most all information for the quizzes is already available else where. Which requires them to read to learn the information. If someone wants to sit and read a 2hr log to pillage information to help with quizzes. Then I think they earned that knowledge they gathered. No different than reading it from some document.

I never attached any quiz or quiz answers. Nor where the answers I wrote provided in the log. This is all just a bunch of crap. There are serious problems internally in Gentoo. I added the log so others could be aware of those problems. However people are going out of their way to silence me, and hide the problems from others. Because I doubt if more knew about the situation, they would find it acceptable.

Its quite a joke what Gentoo has become. Things just keep getting worse and worse. But after all that has gone on, and how others have driven me to action I would never have taken otherwise. I will be making the quizzes public, both sets, from the first time I did them, and the second time. Along with the log from the review session, and likely a copy of this bug. Since I am sure at some point access to it will be changed or something.

Its really sad things had to come to this. Instead of people just getting out of the way or being helpful in any way. I would have had several commits, worked many bugs, and helped Gentoo move forward, not backward....
Comment 39 William L. Thomson Jr. 2011-03-11 23:17:57 UTC
(In reply to comment #37)
> (In reply to comment #34)
> > How do I know this? Is there any document saying such? Did I agree to any
> > non-disclosure? Is there any disclaimers on the quizzes or anywhere as to such?
> From the recruiters page, http://www.gentoo.org/proj/en/devrel/recruiters/,

You missed my point, there is nothing saying that the quiz answers are private and confidential. I did not agree to any non-disclosure. If I want to take the quizzes and make them public I can surely do so. Post them on the net else where just not on this bug. That was my point, which also stands for the review session. Which was done in a public IRC channel.

The document referenced above says nothing about logs of a review session. Thus I did not breach or violate any policy by attaching such to my developer bug.
Comment 40 William L. Thomson Jr. 2011-03-15 21:35:42 UTC
Its pretty amazing that after all the mistakes made by devrel and infra during the chaos that lead to my departure from Gentoo, after resigning from the board of trustees. Devrel had to make yet another mistake, by failing to lift bans they put in place, not just after 15 days, but after more than 2 years....

Completely unacceptable and the list of reasons why devrel should not exist, continues to grow. If a process cannot be done correctly, and followed up to ensure that it is done correctly. Then it should be avoided entirely in the first place.

Which given all gentoos problems, time after time the case is made why devrel should simply not exist. I found it rather interesting one of the cons listed on distro watch regarding gentoo was about the frequent infighting amongst developers. Which given the existence of devrel, which few if any other projects have a similar entity. Is good reason why Gentoo should not even have devrel. Its not fixing any problems, but creating new ones that require others time to resolve.

Every experience I have ever had with devrel has been a bad one. I am not sure I have ever spoke to anyone who had a good experience with devrel. That has to count for something.
Comment 41 Petteri Räty (RETIRED) gentoo-dev 2011-03-15 21:58:50 UTC
(In reply to comment #40)
> 
> Which given all gentoos problems, time after time the case is made why devrel
> should simply not exist. I found it rather interesting one of the cons listed
> on distro watch regarding gentoo was about the frequent infighting amongst
> developers. Which given the existence of devrel, which few if any other
> projects have a similar entity. Is good reason why Gentoo should not even have
> devrel. Its not fixing any problems, but creating new ones that require others
> time to resolve.
> 

I found out there are similar bodies elsewhere after querying through the distributions mailing list:

http://lists.freedesktop.org/archives/distributions/2011-March/000551.html
http://ev.kde.org/workinggroups/cwg.php
http://fedoraproject.org/wiki/Community_working_group
Comment 42 William L. Thomson Jr. 2011-03-16 01:32:35 UTC
(In reply to comment #41)
> (In reply to comment #40)
> > 
> > Which given all gentoos problems, time after time the case is made why devrel
> > should simply not exist. I found it rather interesting one of the cons listed
> > on distro watch regarding gentoo was about the frequent infighting amongst
> > developers. Which given the existence of devrel, which few if any other
> > projects have a similar entity. Is good reason why Gentoo should not even have
> > devrel. Its not fixing any problems, but creating new ones that require others
> > time to resolve.
> > 
> 
> I found out there are similar bodies elsewhere after querying through the
> distributions mailing list:
> 

Doesn't seem to be a response on the first one yet
> http://lists.freedesktop.org/archives/distributions/2011-March/000551.html


These two are much closer to userrel than devrel.
> http://ev.kde.org/workinggroups/cwg.php
> http://fedoraproject.org/wiki/Community_working_group

I would suggest looking at like Debian or FreeBSD. Not sure about FreeBSD, but Debian should have one of the largest if not the largest all vounteer developer staff. A good deal of Fedora developers are paid RedHat employees, and that is a corporate run distro, bit different. KDE and Freedesktop are both FOSS projects, but not sure they have as many developers as Debian or FreeBSD.

Debian is really the one to look at, given their structure is closest to Gentoo. Not to mention things Gentoo could only hope for such as Debconf ;)
Comment 43 Andreas K. Hüttel archtester gentoo-dev 2015-02-22 16:00:30 UTC
To: wlt@obsidian-studios.com
CC: comrel, fordfrog


William, 

you've recently started the recruiting process to become a Gentoo developer again. As ComRel team lead, I am vetoing this. The reasons can be found below. If you want, you can request a full ComRel team vote on the issue.

First of all, I'm not concerned about your technical knowledge or capabilities. Second, whatever happened around 2007/2008 is primarily not my problem; this was before I joined Gentoo. The influence of it was that discussing the ability to cooperate with others should also be part of the recruiting process.

Sadly, instead of just bringing up your fruitful cooperation with the java team, the additional results were your long sermons on #gentoo-comrel, and these are what I am basing the decision on. Several selected quotes can be found below; full logs can be provided on request. Since pointless drama and socially unacceptable behaviour in the Gentoo community has repeatedly driven off potential contributors to Gentoo in the past and is still doing it, I think that you would not be a productive addition, even taking your technical skills into account. The last thing we need right now is someone calling names and exploding over the mailing lists if things are not going his way.

A copy of this mail will be pasted in the dev bug.

Kind regards, 
Andreas Hüttel


[16:09:23] <jlec> Of course we like to see your contributions, but 
technical aspect aren't everything
[16:09:27] <wltjr> jlec: ok never mind, thanks for being the same as 
others
[16:09:34] <wltjr> jlec: bye
[16:10:56] <jlec> wltjr: that behaviour you are showing right now is 
on spot with the concerns of the team. You should start prooving the 
oposite.
[16:12:38] <wltjr> jlec: dude I care less you have things so twisted

[17:13:24] <wltjr> gentoo has become pussified for real, does no one 
have thick skin? can't see through some bs for technical value? 
tantrums anti-social behavior immaturity etc is what tech is known 
for, go into the security world and it gets WORSE

[17:31:29] <wltjr> kensington: people do not behave good in general
[17:31:33] <wltjr> that is against mankind
[17:31:56] <wltjr> again gentoo can pee in the wind, try to make 
everyone play nice, but that is not a realistic goal and does nothing 
to accomplish technical things

[17:34:20] <wltjr> kensington: gentoo needs me more than I need 
gentoo, its only people involved with gentoo, that have not worked 
with me, that likely would not once I was a developer, that seem to 
think I need gentoo for some reason, when its the other way around 
for real


-- 
Andreas K. Huettel
Gentoo Linux developer (council, comrel, perl, libreoffice)
dilfridge@gentoo.org
http://www.akhuettel.de/
Comment 44 William L. Thomson Jr. 2015-02-22 17:10:13 UTC
Its really amazing how then and now COMREL/DEVREL can't let things go. Let me state this VERY clearly.

Comrel/devrel IS responsible for driving away more talent than ANY bad behaviour.

I expect FULL logs to be attached to the bug not out of context snippets to MAKE YOUR CASE....

I had dropped this matter as once again I was driven away by Comrel/devrel. My contributions will not go to Gentoo as they have not in 7+ years. Nor has ANYONE else show up to do the work. Work that should have been done 7 years ago is NOT being done now.

What Comrel/Devrel completely misses is its that this entire situation they caused. If you provided accurate full logs, where I was RUDELY silenced in comrel, a COMMUNITY, and DEVELOPER relations channel. It was stated quite clearly.

There was NEVER a single issue with me as a developer. Ever issue came after I resigned form the board. Then per devrel's actions, I was so turned off to Gentoo, I RETIRED.

Let me repeat, I RESIGNED as a TRUSTEE.
Because of devrel, I RETIRED as a DEVELOPER.

Its because of the problems that happened afterward and have continued for 7+ years I have not returned. This is a problem with comrel/devel.

Comrel/Devreal IS KILLING GENTOO!!!!!

I had planned to let all this go. However as others mentioned on other bugs I have worked in the last year. They would like this taken to -project.

I had wanted to return silently, without drama, and to get back to work. I have had this goal for 7+ years now. Comrel/Devrel has done NOTHING to assist with this.

I will post to -project, I will make noise. I will make this a much larger issue and show the REAL problem with Gentoo. Its NOT bad attitudes, its people choosing to KEEP people out of a community project.

You can say what ever about attitude. The attitude and stance of comrel/devrel is VERY disrespectful, very controlling, its limiting and hurting gentoo VERY badly.

The attitude and perceived bad behaviour is 100% a result of the toxic atmosphere created by comrel/devrel. Clearly the situation they caused in 2008 was not handled correctly. If devrel/comrels actions were correct in 2008, then why has it not improved things? Things are still neglected and not touched 7+ years later. The bad attitude remains 7+ years later.

Has ANYTHING with the attitude of recruiters, recruiting, comrel/devrel changed in 7+ years. Are there still the same members holding on to issues THEY created from the past. Ones that commented on this bug and still have a PERSONAL gripe.

This is NOT coming from the larger Gentoo community. This is coming from a handful of people. Less people EVER had issue with me in Gentoo than VOTED for me as a Trustee.

People simple fear my return, for exposing the harm they have done to gentoo over the years. The positive changes I might bring, and all the rest. They want to keep their toys to themselves.

In the REAL world and the BUSINESS world you frequently work with people with bad attitudes, who are rude, insulting etc. You DEAL with it as a grown up. You do not expect everyone to play nice. That is NOT how the world works. Even in some areas politicians get in fist fights. I have no idea what fantasy Gentoo comrel/devrel is living in.

For the last time, there was NEVER an issue with me when I was a developer. Every issue is a RESULT of action devrel took in 2008 they needed not. They created the problem, NOT the resolution. Thus 7+ years later the problem remains. The bad attitude I got from dealing with devrel in 2008 remains now. It was NEVER there prior to my interaction with devrel in 2008.

That FACT was confirmed by Jorge Manuel B. S. Vicetto in IRC in comrel the other day before HE silenced me.

HE is the one commenting on devrels action in 2008. I would go so far as to say he specifically IS the problem. Since HE is the ONLY remaining member of devrel from 2008. He has done more harm to Gentoo than good. He should be suspended and removed.

Many on comrel/devrel then and now have NO human relations experience. I highly doubt any have those types of roles or positions in life. They are NOT doing a good job for gentoo. At best they are HR and process applications. 

When it comes to conflict resolution, they make things FAR worse than better. I am a perfect case example of that. Someone who was contributing, helping the foundation in major ways was driven away for 7+ years. Ask yourself why?

Did I retire and stop contributing to gentoo because of bad attitudes? Or was it because of actions taken by devrel/comrel that hurt gentoo.

comrel/devrel does destructive things to HURT Gentoo, I will have a bad attitude. Comrel/devrel does constructive things to HELP Gentoo, I will have a great attitude. Its a simple equation.

You can say what ever you want about bad attitudes, that is not way a TREMENDOUS amount of packages are without maintainer, outdated, or in poor shape. That is comrel/devrels fault and making, NOT bad attitudes....

Now to post to -project and really make this way more drama for all. Why because of Comrel/devrel once again. You all could not have commented on this bug. I let things go as I had in 2008 days ago. My developer bug was NEVER re-opened. My mentor never even requested anything from Comrel/devrel. This is more proof how they like to continue picking at a scap till it bleeds. They won't let things heal.

Comrel/Devrel IS THE PROBLEM THEN AND NOW...... Name change does not change the toxicity of that body and its toxic effect on Gentoo.
Comment 45 William L. Thomson Jr. 2015-02-22 17:15:38 UTC
Created attachment 397244 [details]
irc log of #gentoo-comrel
Comment 46 William L. Thomson Jr. 2015-02-22 17:15:59 UTC
Created attachment 397246 [details]
irc log of #gentoo-comrel
Comment 47 William L. Thomson Jr. 2015-02-22 17:16:19 UTC
Created attachment 397248 [details]
irc log of #gentoo-comrel
Comment 48 Andreas K. Hüttel archtester gentoo-dev 2015-02-22 17:58:56 UTC
Created attachment 397252 [details]
irc log #gentoo-comrel
Comment 49 William L. Thomson Jr. 2015-06-10 19:34:10 UTC
Proper status is WONTFIX not CANTFIX, as this is a choice. It was WONTFIX before, as further proof that CANTFIX is incorrect.
Comment 50 William L. Thomson Jr. 2018-04-08 21:21:41 UTC
There is no reason for bug 618254 not to be open. All others against me are open. I officially and formally request that bug be made publicly visible. There is no reason to keep such hidden. If anything it is bad against me, thus it is my choice.