Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 135923 - x11-drivers/ati-drivers and x11-drivers/xf86-video-ati - weird image rendering problems with www-client/firefox
Summary: x11-drivers/ati-drivers and x11-drivers/xf86-video-ati - weird image renderin...
Status: RESOLVED NEEDINFO
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: Normal normal (vote)
Assignee: Luca Barbato
URL: http://www.newsfeedmaker.com/tests/bu...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-07 07:16 UTC by Honza
Modified: 2013-07-11 20:59 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
Archive with test case (bug135923-testcase.tar.gz,1.63 KB, application/octet-stream)
2013-07-11 20:49 UTC, Honza
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Honza 2006-06-07 07:16:06 UTC
I upgraded firefox to 1.5 and noticed that some background images in table are rendered incorrectly. I tried firefox 1.0 and there were same error. I remembered firefox upgrade also upgraded gtk+ to 2.8.12. Upgrade of gtk+ to 2.8.18 didn't help. Then I downgraded gtk+ to gtk+-2.6.10 and problem is gone. I didn't noticed any other problem yet, so I suppose the 2.8.6 requirement on firefox-1.5 is not really needed - can you add info why it was added ?

Problematic image is http://www.newsfeedmaker.com/graphics/nfmaker/ram_top.png and code used

<table cellpadding="0" cellspacing="0" border="0" align="center">
<tr><td><img src="/graphics/nfmaker/ram_tl.png" alt="" width="4" height="4"></td>
<td background="/graphics/nfmaker/ram_top.png" height="4"><img src="/graphics/nfmaker/ram_top.png" width="1" height="4" alt=""></td>
<td><img src="/graphics/nfmaker/ram_tr.png" alt="" width="4" height="4"></td></tr>
<tr><td background="/graphics/nfmaker/ram_left.png" width="4"><img src="/graphics/nfmaker/ram_left.png" width="4" height="1" alt=""></td>
<td align="center" valign="top"> .... 

Note that ram_left.png have same error, while ram_bottom.png and ram_right.png are rendering correctly - even if in same place. In img tag all images are rendered correctly. Converting from png to gif didn't help, adding one white pixel on top did, converting to jpg also helped but is unacceptable. Also maybee table needs some minimal size for bug to occur (I have it around whole page).

Portage 2.0.54-r2 (default-linux/x86/2005.1, gcc-3.3.6, glibc-2.3.5-r2, 2.6.14-gentoo-r2 i686)
=================================================================
System uname: 2.6.14-gentoo-r2 i686 AMD Athlon(tm) 
Gentoo Base System version 1.6.13
dev-lang/python:     2.3.5-r2, 2.4.2
dev-python/pycrypto: [Not Present]
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.12
sys-devel/autoconf:  2.13, 2.59-r6
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.15.92.0.2-r10, 2.16.1-r2
sys-devel/libtool:   1.5.20
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mcpu=athlon -march=i686 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/lib/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/bind"
CONFIG_PROTECT_MASK="/etc/gconf /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -mcpu=athlon -march=i686 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo http://ftp.sh.cvut.cz/MIRRORS/gentoo/gentoo/ http://www.mirror.ac.uk/sites/www.ibiblio.org/gentoo/ http://gentoo.oregonstate.edu http://www.ibiblio.org/pub/Linux/distributions/gentoo"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="x86 3dnow 3dnowext X Xaw3d aalib alsa apache2 apm arts audiofile avi berkdb bitmap-fonts bzip2 caps cdr cli crypt cups curl dga divx4linux doc dri dts emboss encode erandom esd exif expat flac foomaticdb fortran fpx gcj gd gdbm gif glut gmp gpm graphviz gstreamer gtk gtk2 imagemagick imlib innodb ipv6 isdnlog java jbig jpeg lcms lesstif libcaca libg++ libwww live lzo mad mailwrapper mbox mcal memlimit mhash mikmod mmx mmxext mng motif mozilla mp3 mpeg multislot mysql ncurses network nls ogg oggvorbis opengl oss pam pcre pdflib perl php pic png pppd python qt quicktime readline real recode reflection samba sdl session snmp spell spl sqlite sse ssl svga tcpd tetex theora tiff truetype truetype-fonts type1-fonts udev unicode usb userlocales vhosts videos vorbis wmf xgetdefault xml xml2 xmms xorg xosd xv xvid zlib userland_GNU kernel_linux elibc_glibc"
Unset:  CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTAGE_RSYNC_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-06-07 07:28:48 UTC
I can't see any images there, sorry. Not really obvious what you mean. I tried in opera and still only see a blank page.
Comment 2 Honza 2006-06-07 07:42:19 UTC
Images where ? The link I provided - http://www.newsfeedmaker.com/graphics/nfmaker/ram_top.png - is directly to image (and that image is 1x4, so it's not much noticeable). I can't point you to page where I spotted problem, it's still beta. If you want, I can create test case, but I forgot to do it before I downgraded gtk+ so I should probably switch gtk+'s again ...
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-06-07 07:49:14 UTC
(In reply to comment #2)
> Images where ? The link I provided -
> http://www.newsfeedmaker.com/graphics/nfmaker/ram_top.png - is directly to
> image (and that image is 1x4, so it's not much noticeable).

Well, so are we supposed to buy a microscope to find the issue, or what? I'm sorry  but there's absolutely nothing visible on the page. Please reopen if you are able to provide a better example. I really can't spot what's rendered incorrectly when the image is invisible.
Comment 4 Honza 2006-06-07 08:23:50 UTC
OK, I see it will be simpler to make the test case that to explain it ... the image itself is rendered correctly, problem is when this image is used as background in page.

On http://www.newsfeedmaker.com/tests/bug135923.php you can see the HTML of test case around two images, top one showing correct (gtk-2.6) rendering and bottom one showing incorrect (gtk-2.8) rendering.

I repeat: the active test case is that box around these images. Both images looks same in both cases.
Comment 5 Honza 2006-10-09 04:20:49 UTC
x11-libs/gtk+-2.8.19 didn't help either. Weird is, I don't see this problem on different computer with gtk+-2.8.12 ... any idea what difference might be important ? That computer have mostly older version of everything possible ...
Comment 6 Honza 2006-12-12 01:14:19 UTC
Now the problem seems fixed. After upgrade to firefox 1.5.0.8, gtk+-2.10.6, pango-1.10.3, cairo-1.2.4 and glib-2.12.4-r1, I mean. So, gtk 2.8 might still be broken ... should I test it, or is gentoo not attempting to have "stabler" version ? (Which reminds me, I have some problems with gtk+-1.2.10-r12 installing ...)
Comment 7 Honza 2006-12-15 09:30:48 UTC
Damn. It's back. And I don't think I changed anything ... especially I didn't upgrade any package.
Comment 8 Christian Marie (RETIRED) gentoo-dev 2006-12-22 06:22:45 UTC
Works for me, reopen if you can reproduce with 1.5.0.9
Comment 9 Honza 2007-02-16 10:12:27 UTC
In 1.5.0.9 (or maybee some other package as stated in comment #6 have influence) it's definitely better in a "worse reproducible" way. I can reproduce it on http://www.newsfeedmaker.com/tests/bug135923.php by viewing it, switch to other tab and return back. Also, I still see it most times on http://www.newsfeedmaker.com/make_advanced.php (the page I originally spotted this error, but it was in developement then), but not consistently on all places.
 It seems to get worse the more I test it, but that can be only sensation ...
Comment 10 Honza 2007-07-27 11:59:38 UTC
Note that in firefox 2.0.0.4 problem still remains (with gtk+ 2.10.9, pango 1.14.9, cairo 1.2.6, xorg-server 1.1.1-r4 and mesa 6.5.1-r1). I suppose problem may be in combination of some acceleration in gtk+ (pango ? cairo ?) with my video card (ATI Technologies Inc Radeon RV250/Radeon 9000) or it's driver. Also, I don't really expect this to be solved until someone other experience it (preferably on as different setup as possible), but I still hope this bugreport catch someone ...
Comment 11 Raúl Porcel (RETIRED) gentoo-dev 2007-12-07 11:13:40 UTC
What about now?
Comment 12 Honza 2007-12-10 09:36:12 UTC
Firefox 2.0.0.11, gtk+ 2.10.9, pango 1.16.4, cairo 1.4.6, xorg-server 1.3.0.0-r1, mesa 6.5.2-r1 problem still here (and reproducibility went up, it seems). Should I upgrade something ?
Comment 13 Raúl Porcel (RETIRED) gentoo-dev 2007-12-10 17:51:07 UTC
Try with latest gtk+.
Comment 14 Honza 2007-12-11 09:31:44 UTC
Upgraded. gtk+-2.12.1-r2, pango-1.18.3, cairo-1.4.12 and problem is still here.
Comment 15 Nirbheek Chauhan (RETIRED) gentoo-dev 2009-05-01 20:47:38 UTC
Let's try this one more time -- still around with latest stable? What about latest unstable?
Comment 16 Honza 2009-05-04 09:10:21 UTC
To my surprise, the bug DID survive physical change of computer including graphics card and numerous package upgrades, including to mozilla-firefox 3.0.8, x11-libs/gtk+-2.14.7-r2, x11-libs/cairo-1.8.6-r1, x11-drivers/xf86-video-ati-6.12.1-r1, x11-libs/pango-1.22.4, dev-libs/glib-2.18.4-r1, x11-libs/libX11-1.1.5, media-libs/mesa-7.3-r1, media-libs/libpng-1.2.35 and of course numerous other probably non-related.

On the other hand, the firefox DOES still depend on libstdc++.so.5, which probably mean I did not upgraded all libraries ...

I can continue with updating, but I would really appreciate some hint on what should I try to upgrade first. (I will not do emerge world or something as big. I can't afford the machine to stop working.) All who can't reproduce it: can you post some of your configuration? Did someone with ATI (I have ATI Technologies Inc RV370 secondary [Sapphire X550 Silent] currently) tried it?

BTW, test case republished.

Portage 2.1.6.11 (default/linux/x86/2008.0/desktop, gcc-3.4.6-hardened, glibc-2.5-r4, 2.6.27-gentoo-r8-32 i686)
=================================================================
System uname: Linux-2.6.27-gentoo-r8-32-i686-AMD_Athlon-tm-_64_X2_Dual_Core_Processor_4200+-with-glibc2.3.2
Timestamp of tree: Sun, 03 May 2009 21:45:02 +0000
app-shells/bash:     3.2_p17
dev-java/java-config: 1.3.7-r1, 2.1.7
dev-lang/python:     2.4.4-r14, 2.5.2-r7
dev-python/pycrypto: 2.0.1-r8
sys-apps/baselayout: 1.12.11.1
sys-apps/sandbox:    1.2.18.1-r2
sys-devel/autoconf:  2.13, 2.61-r2
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1, 1.10.1
sys-devel/binutils:  2.15.92.0.2-r10, 2.16.1-r3, 2.18-r3
sys-devel/gcc-config: 1.3.13-r3
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.21
ACCEPT_KEYWORDS="x86"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -mcpu=athlon -march=i686 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/share/X11/xkb /usr/share/config /var/bind"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php4/ext-active/ /etc/php/apache2-php5/ext-a
ctive/ /etc/php/cgi-php4/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php4/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebu
ild /etc/terminfo /etc/texmf/language.dat.d /etc/texmf/language.def.d /etc/texmf/updmap.d /etc/texmf/web2c /etc/udev/rules.d"
CXXFLAGS="-O2 -mcpu=athlon -march=i686 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="distlocks fixpackages parallel-fetch protect-owned sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo http://ftp.sh.cvut.cz/MIRRORS/gentoo/gentoo/ http://www.mirror.ac.uk/sites/www.ibibl
io.org/gentoo/ http://gentoo.oregonstate.edu http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LDFLAGS="-Wl,-O1"
LINGUAS="en cs en_GB"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_CONFIGROOT="/"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/
distfiles --exclude=/local --exclude=/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="3dnow 3dnowext X Xaw3d aalib acl acpi alsa apache2 apm avi berkdb bluetooth branding bzip2 cairo caps cdr cli cracklib crypt cups curl dbu
s dga divx4linux djvu doc dri dvd dvdr dvdread emboss encode erandom esd evo exif expat fam firefox flac fortran fpx gcj gd gdbm gif gnutls gpm
 graphviz gstreamer gtk hal iconv imagemagick imlib innodb ipv6 isdnlog java jbig jpeg lcms ldap lesstif libcaca libnotify libwww live logrotat
e lua lzo mad mailwrapper mbox mcal memlimit mhash midi mikmod mmx mmxext mng motif mozilla mp3 mpeg mudflap multislot mysql ncurses network nl
s nptl ogg oggvorbis openal opengl openmp oss pam pcntl pcre pdf pdflib perl pic png postscript ppds pppd python qt qt3 qt3support qt4 quicktim
e readline reflection samba sdl session snmp spell spl sqlite sse ssl startup-notification svg svga sysfs tcpd tetex theora tiff truetype unico
de usb userlocales vhosts videos vorbis win32codecs wmf x264 x86 xgetdefault xml xorg xosd xulrunner xv xvid zlib" ALSA_CARDS="ali5451 als4000 
atiixp atiixp-modem bt87x ca0106 cmipci emu10k1 emu10k1x ens1370 ens1371 es1938 es1968 fm801 hda-intel intel8x0 intel8x0m maestro3 trident usb-
audio via82xx via82xx-modem ymfpci" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfl
oat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="access auth auth_dbm auth_anon auth_digest alia
s file-cache echo charset-lite cache disk-cache mem-cache ext-filter case_filter case-filter-in deflate mime-magic cern-meta expires headers us
ertrack unique-id proxy proxy-connect proxy-ftp proxy-http info include cgi cgid dav dav-fs vhost-alias speling rewrite log_config logio env se
tenvif mime status autoindex asis negotiation dir imap actions userdir so filter unique_id authz_host auth_basic authn_dbd authn_file authz_own
er authz_user charset_lite dbd mem_cache" APACHE2_MPMS="prefork" ELIBC="glibc" INPUT_DEVICES="evdev keyboard mouse" KERNEL="linux" LCD_DEVICES=
"bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="en cs en_GB" USERLAND="GNU" VIDEO_CARDS="radeon nv vesa fbdev"
Unset:  CPPFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, FFLAGS, INSTALL_MASK, LANG, LC_ALL, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS, PORTAGE_RSYNC_EXT
RA_OPTS
Comment 17 Honza 2009-05-06 10:02:35 UTC
Updated to firefox-3.0.10, updated lots of packages depending on libstdc++.so.5 (for example aspell or gtkmm) and noticed that the binary which depended on libstdc++.so.5 was not the current one :-). Bug still there.

While compilling glibmm I hit the spp bug. It's visible in emerge --info, but maybe I should point out that I'm using hardened compiler for most compiling.
Comment 18 Jory A. Pratt gentoo-dev 2009-07-20 06:04:14 UTC
If the hardened team could comment would be appreciated.
Comment 19 Honza 2009-07-31 10:05:13 UTC
Note: just to confirm, I've tried to switch X to vesa. The bug didn't appear. That's argument for my statement "I suppose problem may be in combination of some acceleration in gtk+ (pango ? cairo ?) with my video card (ATI Technologies Inc Radeon RV250/Radeon 9000) or it's driver." from comment 10. Doesn't rule out the possibility that the mentioned acceleration code (wherever it is) would work correctly if not compiled hardened.
If I've known where that code is I would've try to compile it normally ...
Comment 20 Justin Lecher gentoo-dev 2010-03-02 08:20:30 UTC
Isn't this bug a little outdated?
Comment 21 .:deadhead:. 2010-07-31 07:56:42 UTC
I encountered the same problem:

AMD64
Ati Mobility Radeon HD4570
atidrivers

The problem started when I updated to ati-driver-10.7: firefox, thunderbird and pidgin started rendering badly parts of the UI.

Now I switched to OSS radeonhd drivers and the problem disappeared. I still have to switch back to the stable ati-driver-10.6 but I'm confident that the problem relies in the interaction between ati-driver10.7 and gtk.

I'm not on hardened profile.

[ebuild   R   ] net-libs/xulrunner-1.9.2.8  USE="alsa dbus ipc java startup-notification -custom-optimization -debug -gnome -libnotify -system-sqlite -wifi" 0 kB
[ebuild   R   ]  x11-libs/gtk+-2.18.9  USE="cups jpeg jpeg2k tiff (-aqua) -debug -doc -test -vim-syntax -xinerama" 0 kB
[ebuild   R   ]   x11-libs/pango-1.26.2  USE="X -debug -doc -test" 0 kB
[ebuild   R   ]    x11-libs/cairo-1.8.10  USE="X glitz opengl svg (-aqua) -cleartype -debug -directfb -doc -lcdfilter -xcb" 0 kB

Portage 2.1.8.3 (default/linux/amd64/10.0, gcc-4.4.3, glibc-2.11.2-r0, 2.6.33-gentoo-r2 x86_64)
=================================================================
System uname: Linux-2.6.33-gentoo-r2-x86_64-Pentium-R-_Dual-Core_CPU_T4300_@_2.10GHz-with-gentoo-1.12.13
Timestamp of tree: Fri, 30 Jul 2010 16:45:01 +0000
app-shells/bash:     4.0_p37
dev-java/java-config: 2.1.11
dev-lang/python:     2.6.5-r2, 3.1.2-r3
dev-util/cmake:      2.8.1-r2
sys-apps/baselayout: 1.12.13
sys-apps/sandbox:    1.6-r2
sys-devel/autoconf:  2.13, 2.65
sys-devel/automake:  1.9.6-r3, 1.10.3, 1.11.1
sys-devel/binutils:  2.20.1-r1
sys-devel/gcc:       4.3.4, 4.4.3-r2
sys-devel/gcc-config: 1.4.1
sys-devel/libtool:   2.2.6b
virtual/os-headers:  2.6.30-r1
ABI="amd64"
ACCEPT_KEYWORDS="amd64"
ACCEPT_LICENSE="*"
ACCEPT_PROPERTIES="*"
ALSA_CARDS="hda-intel"
ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol"
APACHE2_MODULES="authz_host dir mime log_config alias rewrite autoindex  auth_basic authn_file authz_user"
ARCH="amd64"
ASFLAGS_x86="--32"
AUTOCLEAN="yes"
CAMERAS="ptp2 directory"
CBUILD="x86_64-pc-linux-gnu"
CDEFINE_amd64="__x86_64__"
CDEFINE_x86="__i386__"
CFLAGS="-march=native -O2 -pipe"
CFLAGS_x86="-m32"
CHOST="x86_64-pc-linux-gnu"
CHOST_amd64="x86_64-pc-linux-gnu"
CHOST_x86="i686-pc-linux-gnu"
CLEAN_DELAY="5"
COLLISION_IGNORE="/lib/modules"
CONFIG_PROTECT="/etc /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/ca-certificates.conf /etc/env.d /etc/env.d/java/ /etc/fonts/fonts.conf /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/sandbox.d /etc/terminfo"
CVS_RSH="ssh"
CXXFLAGS="-march=native -O2 -pipe"
DEFAULT_ABI="amd64"
DISPLAY=":0"
DISTDIR="/usr/portage/distfiles"
EDITOR="/usr/bin/vim"
ELIBC="glibc"
EMERGE_DEFAULT_OPTS="-tDv --with-bdeps y"
EMERGE_WARNING_DELAY="10"
EPREFIX=""
EROOT="/"
FEATURES="assume-digests distlocks fixpackages news parallel-fetch protect-owned sandbox sfperms strict unmerge-logs unmerge-orphans"
FETCHCOMMAND="/usr/bin/curl -L --retry 5 -o ${DISTDIR}/${FILE} ${URI}"
GCC_SPECS=""
GDK_USE_XFT="1"
GENTOO_MIRRORS="http://mirror.switch.ch/ftp/mirror/gentoo/ http://distfiles.gentoo.org"
HOME="/root"
INFOPATH="/usr/share/info:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.20.1/info:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.3/info"
INPUT_DEVICES="synaptics evdev"
JAVAC="/etc/java-config-2/current-system-vm/bin/javac"
JAVA_HOME="/etc/java-config-2/current-system-vm"
JDK_HOME="/etc/java-config-2/current-system-vm"
KERNEL="linux"
LANG="it_IT.UTF-8"
LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text"
LC_COLLATE="C"
LDFLAGS="-Wl,-O1 -Wl,--as-needed"
LDFLAGS_x86="-m elf_i386"
LESS="-R -M --shift 5"
LESSOPEN="|lesspipe.sh %s"
LIBDIR_amd64="lib64"
LIBDIR_amd64_fbsd="lib64"
LIBDIR_ppc="lib32"
LIBDIR_ppc64="lib64"
LIBDIR_sparc32="lib32"
LIBDIR_sparc64="lib64"
LIBDIR_x86="lib32"
LIBDIR_x86_fbsd="lib32"
LIBGL_DRIVERS_PATH="/usr/lib64/dri:/usr/lib32/dri"
LINGUAS="it"
LOGNAME="root"
MAKEOPTS="-j3"
MANPATH="/etc/java-config-2/current-system-vm/man:/usr/local/share/man:/usr/share/man:/usr/share/binutils-data/x86_64-pc-linux-gnu/2.20.1/man:/usr/share/gcc-data/x86_64-pc-linux-gnu/4.4.3/man:/etc/java-config/system-vm/man/:/usr/lib64/php5/man/"
MM_CHARSET="UTF-8"
MULTILIB_ABIS="amd64 x86"
MULTILIB_STRICT_DENY="64-bit.*shared object"
MULTILIB_STRICT_DIRS="/lib32 /lib /usr/lib32 /usr/lib /usr/kde/*/lib32 /usr/kde/*/lib /usr/qt/*/lib32 /usr/qt/*/lib /usr/X11R6/lib32 /usr/X11R6/lib"
MULTILIB_STRICT_EXEMPT="(perl5|gcc|gcc-lib|binutils|eclipse-3|debug|portage)"
NETBEANS="apisupport cnd groovy gsf harness ide identity j2ee java mobility nb php profiler soa visualweb webcommon websvccommon xml"
OPENGL_PROFILE="xorg-x11"
PAGER="/usr/bin/most"
PATH="/usr/local/sbin:/usr/local/bin:/usr/sbin:/usr/bin:/sbin:/bin:/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.4.3"
PKGDIR="/usr/portage/packages"
PORTAGE_ARCHLIST="ppc x86-openbsd ppc-openbsd ppc64 x86-winnt x86-fbsd ppc-aix alpha arm x86-freebsd s390 amd64 arm-linux x86-macos x64-openbsd ia64-hpux hppa x86-netbsd amd64-linux ia64-linux x86 sparc-solaris x64-freebsd sparc64-solaris x86-linux x64-macos sparc m68k-mint ia64 mips ppc-macos x86-interix hppa-hpux amd64-fbsd x64-solaris mips-irix m68k sh x86-solaris sparc-fbsd"
PORTAGE_BINHOST_CHUNKSIZE="3000"
PORTAGE_BIN_PATH="/usr/lib64/portage/bin"
PORTAGE_COMPRESS_EXCLUDE_SUFFIXES="css gif htm[l]? jp[e]?g js pdf png"
PORTAGE_CONFIGROOT="/"
PORTAGE_DEBUG="0"
PORTAGE_DEPCACHEDIR="/var/cache/edb/dep"
PORTAGE_ELOG_CLASSES="warn error log"
PORTAGE_ELOG_MAILFROM="portage@localhost"
PORTAGE_ELOG_MAILSUBJECT="[portage] ebuild log for ${PACKAGE} on ${HOST}"
PORTAGE_ELOG_MAILURI="root"
PORTAGE_ELOG_SYSTEM="save"
PORTAGE_FETCH_CHECKSUM_TRY_MIRRORS="5"
PORTAGE_FETCH_RESUME_MIN_SIZE="350K"
PORTAGE_GID="250"
PORTAGE_INST_GID="0"
PORTAGE_INST_UID="0"
PORTAGE_PYM_PATH="/usr/lib64/portage/pym"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages"
PORTAGE_RSYNC_RETRIES="3"
PORTAGE_SYNC_STALE="30"
PORTAGE_TMPDIR="/var/tmp"
PORTAGE_VERBOSE="1"
PORTAGE_WORKDIR_MODE="0700"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/var/lib/layman/lu_zero /usr/local/portage"
PRELINK_PATH_MASK="/usr/lib64/libfreebl3.so:/usr/lib64/libnssdbm3.so:/usr/lib64/libsoftokn3.so"
PROFILE_ONLY_VARIABLES="ARCH ELIBC KERNEL USERLAND"
PWD="/root"
PYTHONDONTWRITEBYTECODE="1"
QEMU_SOFTMMU_TARGETS="i386 x86_64"
QEMU_USER_TARGETS="i386 x86_64"
RESUMECOMMAND="/usr/bin/curl -L -C - --retry 5 -o ${DISTDIR}/${FILE} ${URI}"
ROOT="/"
ROOTPATH="/opt/bin:/usr/x86_64-pc-linux-gnu/gcc-bin/4.4.3"
RPMDIR="/usr/portage/rpm"
RUBY_TARGETS="ruby18"
SHELL="/bin/bash"
SHLVL="1"
STAGE1_USE="multilib nptl nptlonly unicode"
SYMLINK_LIB="yes"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
TERM="xterm"
TMP="/tmp/.private/root"
TMPDIR="/tmp/.private/root"
USE="64bit 7zip X a52 aac acl acpi alsa amd64 asf audiofile bash-completion bzip2 cairo cdda cddb cdparanoia cdr cli cracklib css cups curl curlwrappers dbus djvu dri dts dv dvd dvdr dvdread encode exif faac faad fam ffmpeg firefox flac foomaticdb ftp geoip gif gpm gs hal hunspell iconv idn imagemagick imap inotify ithreads jabber java jbig jpeg jpeg2k kde lcms libsamplerate live logitech-mouse lzma mad maildir matroska midi mmx mng modules mp3 mp4 mpeg mplayer mudflap multilib musepack ncurses network network-cron nls nocxx nptl nptlonly nsplugin ogg openexr opengl oscar pam pcre pdf php plotutils png posix pppd qt3support qt4 quicktime rar readline reflection samba sdl semantic-desktop session smp sndfile speex spl sse sse2 sse3 ssl ssse3 startup-notification svg sysfs taglib theora threads tiff truetype unicode usb utempter vcd vhosts vorbis wavpack webdav wicd wma wmf x264 xcb xine xorg xpm xulrunner xv xvid zlib" ALSA_CARDS="hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mmap_emul mulaw multi null plug rate route share shm softvol" APACHE2_MODULES="authz_host dir mime log_config alias rewrite autoindex  auth_basic authn_file authz_user" CAMERAS="ptp2 directory" ELIBC="glibc" INPUT_DEVICES="synaptics evdev" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="it" QEMU_SOFTMMU_TARGETS="i386 x86_64" QEMU_USER_TARGETS="i386 x86_64" RUBY_TARGETS="ruby18" USERLAND="GNU" VIDEO_CARDS="fglrx radeonhd" XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account" 
USER="root"
USERLAND="GNU"
USE_EXPAND="ALSA_CARDS ALSA_PCM_PLUGINS APACHE2_MODULES APACHE2_MPMS CAMERAS CROSSCOMPILE_OPTS DVB_CARDS ELIBC FCDSL_CARDS FOO2ZJS_DEVICES FRITZCAPI_CARDS INPUT_DEVICES KERNEL LCD_DEVICES LINGUAS LIRC_DEVICES MISDN_CARDS NETBEANS_MODULES NGINX_MODULES_HTTP NGINX_MODULES_MAIL QEMU_SOFTMMU_TARGETS QEMU_USER_TARGETS RUBY_TARGETS SANE_BACKENDS USERLAND VIDEO_CARDS XTABLES_ADDONS"
USE_EXPAND_HIDDEN="CROSSCOMPILE_OPTS ELIBC KERNEL USERLAND"
USE_ORDER="env:pkg:conf:defaults:pkginternal:env.d"
VBOX_APP_HOME="/opt/VirtualBox"
VIDEO_CARDS="fglrx radeonhd"
XAUTHORITY="/root/.xauthVaWzlx"
XDG_CONFIG_DIRS="/etc/xdg"
XDG_DATA_DIRS="/usr/local/share:/usr/share"
XTABLES_ADDONS="quota2 psd pknock lscan length2 ipv4options ipset ipp2p iface geoip fuzzy condition tee tarpit sysrq steal rawnat logmark ipmark dhcpmac delude chaos account"
XZ_OPT="--memory=max"
_="/usr/bin/emerge"
bash4="4.0.37(2)-release"

Comment 22 .:deadhead:. 2010-07-31 08:23:55 UTC
I have also found this :

http://wiki.archlinux.org/index.php/ATI_Catalyst#Black.2Fgrey.2Fwhite_boxes.2Fartifacts_mainly_in_firefox.2Fthunderbird

But I haven't tried yet.
Comment 23 junkmail 2010-08-08 20:01:42 UTC
Same problem for me. ati-drivers-10.7 is unusable, large blank lines, especially when mousing over a link, that go away if you minimise or click somewhere off the Firefox window.

Putting Option "XAANoOffscreenPixmaps" "true" in the xorg.conf device section makes no difference. Problem not present in ati-drivers-10.5
Comment 24 Magnus Granberg gentoo-dev 2010-08-08 23:31:44 UTC
Looks like it is not a hardened problem.
Comment 25 Honza 2010-08-09 09:28:13 UTC
Note that I'm seeing the problem with free drivers (x11-drivers/xf86-video-ati) and is not making the firefox unusable (in fact, I still didn't notice any other case except the original image) ... still might be related. Maybe gtk+ (pango ? cairo ?) is making use of some assumption which is not true for some graphics card/driver combination.

(Also: current package versions: firefox 3.6.4, gtk+ 2.18.9, cairo 1.8.8, x11-drivers/xf86-video-ati-6.12.4,  x11-libs/pango-1.24.5-r1, dev-libs/glib-2.22.4, x11-libs/libX11-1.2.2, media-libs/mesa-7.3-r1)
Comment 26 junkmail 2010-08-09 21:59:55 UTC
(In reply to comment #25)
OK, my problem must be different from yours then, it occurs in x11-drivers/ati-drivers-10.7 but not 10.5
Looks like an upstream problem actually, see also: http://www.phoronix.com/forums/showthread.php?t=24879&page=2
Comment 27 .:deadhead:. 2010-09-04 14:36:33 UTC
I solved executing :

# aticonfig --set-pcs-str=DDX,ForceXAA,TRUE

as root. 

The "XAANoOffscreenPixmaps" option was useless, and untill I forced XAA it wasn't activated: in fact I was getting in the logs `(WW) fglrx(0): Option "XAANoOffscreenPixmaps" is not used`

my 0,02€
Comment 28 Jory A. Pratt gentoo-dev 2010-09-06 12:48:28 UTC
related to ati-drivers, nothing mozilla can do.
Comment 29 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-07-08 15:51:54 UTC
Does anyone still experience this? Which version of ati-drivers is this?
Comment 30 Honza 2013-07-11 08:08:07 UTC
(In reply to Tom Wijsman (TomWij) from comment #29)
> Does anyone still experience this? Which version of ati-drivers is this?

What do you mean, ati-drivers? I clearly stated it's happening with free open source drivers (x11-drivers/xf86-video-ati).

... I'll try to dig out the example (which disappeared from net meanwhile) and check if it's happening, but I don't have access to that original computer and video card anymore.
Comment 31 Chí-Thanh Christopher Nguyễn gentoo-dev 2013-07-11 08:35:35 UTC
Ok, if you still see the issue please reopen this bug.
Comment 32 Tom Wijsman (TomWij) (RETIRED) gentoo-dev 2013-07-11 08:36:40 UTC
Please (ask to) reopen this bug if someone can reproduce, thank you.

Most if not all versions listed in this bug are no longer in the Portage tree...
Comment 33 Honza 2013-07-11 20:49:31 UTC
Created attachment 353114 [details]
Archive with test case

Instead of putting it on another semi-permanent server, I simply saved the test case as HTML + images. I can't test it anymore but it shouldn't make any difference ...
Comment 34 Honza 2013-07-11 20:59:16 UTC
... and no, I'm not able to reproduce this on this computer. I'm not sure if newer release of some package fixed it or if it's simply not happening on more modern graphics cards like ATI RV730 PRO / Radeon HD 4650, but I still have firefox 3.6.x here (3.6.20) so it probably wasn't firefox :). I'll be back in case I find computer where it still appears.