Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 13576 - gcc 2.95.3-r8 fails
Summary: gcc 2.95.3-r8 fails
Status: RESOLVED DUPLICATE of bug 13589
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 All
: High normal (vote)
Assignee: Martin Schlemmer (RETIRED)
URL:
Whiteboard:
Keywords:
: 13640 (view as bug list)
Depends on:
Blocks:
 
Reported: 2003-01-09 09:32 UTC by Martin Holzer (RETIRED)
Modified: 2005-07-17 13:06 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
log of 'emerge gcc &> logfile' (gcc-2.95.3-r8.log,14.19 KB, text/plain)
2003-01-11 09:05 UTC, jochem prins
Details
strace of emerge gcc (gcc-2.95.3-r8.strace,216.51 KB, text/plain)
2003-01-11 09:06 UTC, jochem prins
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Martin Holzer (RETIRED) gentoo-dev 2003-01-09 09:32:07 UTC
make[3]: `iostream.list' is up to date.
make[3]: Leaving directory `/var/tmp/portage/gcc-2.95.3-r8/work/build/i686-pc-
linux-gnu/libio'
test x"yes" != xyes || \
  /var/tmp/portage/gcc-2.95.3-r8/work/build/gcc/xgcc -B/var/tmp/portage/gcc-
2.95.3-r8/work/build/gcc/ -B/usr/i686-pc-linux-gnu/bin/ -c -march=i686  -pipe -
fvtable-thunks -D_GNU_SOURCE -fno-implicit-templates -I/var/tmp/portage/gcc-
2.95.3-r8/work/gcc-2.95.3/libstdc++ -I/var/tmp/portage/gcc-2.95.3-r8/work/gcc-
2.95.3/libstdc++/stl -I../libio -I/var/tmp/portage/gcc-2.95.3-r8/work/gcc-
2.95.3/libstdc++/../libio -nostdinc++ -D_IO_MTSAFE_IO -
fpic /var/tmp/portage/gcc-2.95.3-r8/work/gcc-2.95.3/libstdc++/cstringi.cc -o 
pic/cstringi.o
Assembler messages:
FATAL: can't create pic/cstringi.o: No such file or directory
touch stamp-picdir
test x"yes" != xyes || \
  /var/tmp/portage/gcc-2.95.3-r8/work/build/gcc/xgcc -B/var/tmp/portage/gcc-
2.95.3-r8/work/build/gcc/ -B/usr/i686-pc-linux-gnu/bin/ -c -march=i686  -pipe -
fvtable-thunks -D_GNU_SOURCE -fno-implicit-templates -I/var/tmp/portage/gcc-
2.95.3-r8/work/gcc-2.95.3/libstdc++ -I/var/tmp/portage/gcc-2.95.3-r8/work/gcc-
2.95.3/libstdc++/stl -I../libio -I/var/tmp/portage/gcc-2.95.3-r8/work/gcc-
2.95.3/libstdc++/../libio -nostdinc++ -D_IO_MTSAFE_IO -
fpic /var/tmp/portage/gcc-2.95.3-r8/work/gcc-2.95.3/libstdc++/stdexcepti.cc -o 
pic/stdexcepti.o
/var/tmp/portage/gcc-2.95.3-r8/work/gcc-2.95.3/libstdc++/cstringi.cc:7: output 
pipe has been closed
make[2]: *** [cstringi.o] Error 1
make[2]: *** Waiting for unfinished jobs....
/var/tmp/portage/gcc-2.95.3-r8/work/build/gcc/xgcc -B/var/tmp/portage/gcc-
2.95.3-r8/work/build/gcc/ -B/usr/i686-pc-linux-gnu/bin/ -c -march=i686  -pipe -
fvtable-thunks -D_GNU_SOURCE -fno-implicit-templates -I/var/tmp/portage/gcc-
2.95.3-r8/work/gcc-2.95.3/libstdc++ -I/var/tmp/portage/gcc-2.95.3-r8/work/gcc-
2.95.3/libstdc++/stl -I../libio -I/var/tmp/portage/gcc-2.95.3-r8/work/gcc-
2.95.3/libstdc++/../libio -nostdinc++ -D_IO_MTSAFE_IO /var/tmp/portage/gcc-
2.95.3-r8/work/gcc-2.95.3/libstdc++/stdexcepti.cc
make[2]: *** Waiting for unfinished jobs....
make[2]: Leaving directory `/var/tmp/portage/gcc-2.95.3-r8/work/build/i686-pc-
linux-gnu/libstdc++'
make[1]: *** [all-target-libstdc++] Error 2
make[1]: Leaving directory `/var/tmp/portage/gcc-2.95.3-r8/work/build'
make: *** [bootstrap-lean] Error 2

!!! ERROR: sys-devel/gcc-2.95.3-r8 failed.
!!! Function src_compile, Line 73, Exitcode 2
!!! (no error message)

sv24 linc #

Portage 2.0.46-r4 (default-1.0, gcc-2.95.3, glibc-2.2.5-r2,2.2.5-r7)
=================================================================
System uname: 2.4.19-gentoo-r10 i686 Celeron (Coppermine)
USE="x86 oss 3dnow apm avi crypt cups encode jpeg kde libg++ mikmod mpeg 
ncurses pdflib qtmt quicktime spell truetype xml2 xmms arts berkdb esd gdbm gif 
gnome-libs gpm guile imlib java ldap libwww motif mysql opengl pam perl png 
python qt readline slang snmp tcpd tiff X gtk gnome mmx dga alsa xv nls dvd sdl 
oggvorbis tcltk svga -ssl"
ARCH="x86"
COMPILER=""
CHOST="i686-pc-linux-gnu"
CFLAGS="-march=i686 -O3 -pipe -fomit-frame-pointer"
CXXFLAGS="-march=i686 -O3 -pipe -fomit-frame-pointer"
ACCEPT_KEYWORDS="x86"
CONFIG_PROTECT="/etc /var/qmail/control /usr/share/config /usr/kde/2/share/confi
g /usr/kde/3/share/config /usr/kde/3/share/config:/usr/X11R6/lib/X11/xkb:/usr/sh
are/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/env.d"
MAKEOPTS="-j2"
JDK_HOME="/opt/blackdown-jdk-1.3.1"
JAVA_HOME="/opt/blackdown-jdk-1.3.1"
AUTOCLEAN="yes"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
GENTOO_MIRRORS="http://192.168.1.4/gentoo"
Comment 1 Martin Holzer (RETIRED) gentoo-dev 2003-01-10 10:53:42 UTC
*** Bug 13640 has been marked as a duplicate of this bug. ***
Comment 2 jochem prins 2003-01-11 09:03:28 UTC
I cannot emerge the same gcc-version either. I've included logs of the following
process:
- strace -o gcc.2.95.3-r8 emerge gcc-2.95.3-r8
- emerge gcc-2.95 &> gcc-2.95.3-r8.log

using currently:
gcc-2.95.3-r7
portage-2.0.46-r4
gentoo-sources-2.4.19-r10  
linux-headers-2.4.18

### Stripped down /etc/make.conf
USE="X oav -gtk -gnome alsa -kde -qt -3dnow -apm -arts cdr -cups dvd -encode
ipv6 mailbox -motif-qtmt sasl samba xv"
CHOST="i586-pc-linux-gnu"
CFLAGS="-march=pentium -O3 -pipe -fomit-frame-pointer"
CXXFLAGS="${CFLAGS}"
ACCEPT_KEYWORDS="~x86"
PORTDIR_OVERLAY="/usr/local/portage"
MAKEOPTS="-j 4"
AUTOCLEAN="no"
FEATURES="sandbox ccache buildpkg"
NOCOLOR="true"
Comment 3 jochem prins 2003-01-11 09:05:49 UTC
Created attachment 7192 [details]
log of 'emerge gcc &> logfile'
Comment 4 jochem prins 2003-01-11 09:06:34 UTC
Created attachment 7193 [details]
strace of emerge gcc
Comment 5 Martin Schlemmer (RETIRED) gentoo-dev 2003-01-11 09:45:27 UTC
Enouth free space Martin ?  Maybe include a more complete log.
Comment 6 Martin Holzer (RETIRED) gentoo-dev 2003-01-12 06:54:38 UTC
more than 40 gigs of free space
Comment 7 Martin Holzer (RETIRED) gentoo-dev 2003-01-12 07:46:30 UTC
after the 5th try it worked without any changes

now please tell me what this was 

i've make a new install on my notebook 3 days ago (iso 1.2) gcc-2.95.3-r8 went 
there fine the first time

here upgrading from -r7 to -r8 having problems and now works ????


btw why don't we use 2.95.4 ?
Comment 8 Martin Schlemmer (RETIRED) gentoo-dev 2003-01-12 14:31:06 UTC
Not official, although there is such an CVS branch if I remember correctly.
Do you overclock or anything ?
Comment 9 Martin Holzer (RETIRED) gentoo-dev 2003-01-12 14:56:44 UTC
this is not overclocked or anything

this system running perfectly since installed 2 months ago, it's my developer 
machine a celeron 1100 with 256 mb ram

why i'm asking about 2.95.4 ? cause debian 3.0 stable uses it
gcc version 2.95.4 20011002 (Debian prerelease)
Comment 10 Martin Schlemmer (RETIRED) gentoo-dev 2003-01-16 03:20:11 UTC
Martin, please set your CFLAGS properly for gcc2, and comment the gcc2_flags
call in the ebuild, and see if that fixes.
Comment 11 Paul Slinski 2003-01-16 07:54:57 UTC
If this will save some cycles...
In the case of my system, the CFLAGS are not gcc3 specific and the build still
dies. BUt what the hell, try it anyway.

[snip]
CFLAGS="-march=i686 -O3 -pipe -fomit-frame-pointer"
[snip]
Comment 12 Martin Holzer (RETIRED) gentoo-dev 2003-01-17 04:54:22 UTC
-r8 seems to have a bug
when i emerge -r7, avifile could compile fine

with -r8 i get the -fno-rtti bug

any ideas ?

(this is a transmeta picture book, not may developer machine)
Comment 13 Martin Schlemmer (RETIRED) gentoo-dev 2003-01-17 05:41:36 UTC
Update gcc-config to version 1.3.0 maybe ?  Did the commenting of the 'gcc2_flags'
line work ?
Comment 14 Martin Holzer (RETIRED) gentoo-dev 2003-01-18 14:18:46 UTC
okey very well 
i'm now trying commenting of the 'gcc2_flags'

Comment 15 Martin Holzer (RETIRED) gentoo-dev 2003-01-18 15:46:04 UTC
commenting of the 'gcc2_flags' doesn't work

now trying gcc-config-1.3.0
Comment 16 Martin Holzer (RETIRED) gentoo-dev 2003-01-18 17:44:25 UTC
perfect

gcc-config 1.3.0 fixes the -fno-rtti bug
Comment 17 Martin Schlemmer (RETIRED) gentoo-dev 2003-01-19 14:25:52 UTC
We can close this as depend on bug #13589 ?
Comment 18 Martin Holzer (RETIRED) gentoo-dev 2003-01-19 15:37:18 UTC
yeah azarah you could do so
Comment 19 Martin Schlemmer (RETIRED) gentoo-dev 2003-01-19 18:30:17 UTC
Dup.

*** This bug has been marked as a duplicate of 13589 ***