Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 135700 - Restoring backup?
Summary: Restoring backup?
Alias: None
Product: [OLD] Docs on
Classification: Unclassified
Component: New Documentation (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Docs Team
Depends on:
Reported: 2006-06-05 18:02 UTC by Nick
Modified: 2006-06-06 20:09 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Nick 2006-06-05 18:02:41 UTC
The first code block in modular-x-howto.xml is for backing-up -- a laudable purpose, but reminds me of an article in an april issue of a magazine on write-only memory -- how do I restore?

PS. I've found the .tbz2 file: tar-x..f *.tbz2, or is there an option to quickpkg/emerge?
Comment 1 Nick 2006-06-05 18:36:46 UTC

# Stored paths seem to be relative (./etc/*)
cd /
tar -xjvpf /usr/portage/packages/All/<pkg>.tbz2
Comment 2 nm (RETIRED) gentoo-dev 2006-06-05 20:50:07 UTC
Please read "man emerge" thoroughly, it covers how to reinstall binaries you created using quickpkg; a simple emerge -k =packageversion would suffice. Not a documentation bug; "man emerge" is standard stuff.
Comment 3 Nick 2006-06-06 17:20:13 UTC
Thank you for your help.
I have read 'man emerge', though it is not (and not meant to be IMHO) bedtime reading, more likely a reference document: It is easier to verify a piece of information is present in a document, than it is to find it without prior knowledge of the correct answer.

'man emerge' does not mention restoring, reinstalling or quickpkg, and I was not looking for 'binaries' but 'packages' due to the naming of quickpkg.  May I suggest that 'package' shouldn't be used for ebuilds, as an ebuild encapsulates only the required knowledge: or at least should always be qualified with ebuild/binary when it doesn't apply to both (thus: quickbinpkg): nomenclature can be very powerful -- to mislead as well as inform.

I hope you can understand that, faced with a .tbz2 file, I first thought of using tar, but realised that portage would not be informed, which is why I hoped that quickpkg would have a reciprical mode like tar -x.  I also tried emerge packageversion.tbz2 but emerge said it was broken and might not work.

I have tried emerge -k '=packageversion' including the needed '', but, failing to find the corresponding ebuild (I've synced and tried to install modular X), it merely states "there are no ebuilds" without looking for a binary package.  I then tried emerge -K '=packageversion' which did find the binary but couldn't find x11-misc/ttmkfdir.  Apparently this has moved to x11-apps/.  I added
x11-misc/ttmkfdir	x11-apps/ttmkfdir
to /etc/portage/profile/virtuals and finally found the solution.

I agree that it is not a documentation bug, but there is an omission which can be easily and usefully rectified.
Comment 4 nm (RETIRED) gentoo-dev 2006-06-06 19:57:56 UTC
(In reply to comment #3)
quickpkg creates a binary file of the given package; in this case, it creates the binary for monolithic xorg-6.8.x. Running emerge -K does *not* attempt to merge an ebuild, but instead looks for the package name and version you specify.

It sounds like you should have synced first in order to catch the x11-misc/ to x11-apps/ category move.

So where's the "omission" you refer to?
Comment 5 nm (RETIRED) gentoo-dev 2006-06-06 20:08:57 UTC
(In reply to comment #3)
Did you make sure you updated to the latest stable monolithic Xorg and ttfmkdir versions?

You should have emerge --synced and run fixpackages at least once. Please see "man make.conf" to enable fixpackages in FEATURES, so that syncing is effective.

(thanks to @antarus for the help)
Comment 6 nm (RETIRED) gentoo-dev 2006-06-06 20:09:29 UTC
Closing properly.