Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 135546 - xorg-x11-7.0-r1 should have more specific dependencies
Summary: xorg-x11-7.0-r1 should have more specific dependencies
Status: RESOLVED DUPLICATE of bug 1343
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-06-04 11:46 UTC by Harm Geerts
Modified: 2006-06-04 12:22 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Harm Geerts 2006-06-04 11:46:19 UTC
I've just updated my system to x11-base/xorg-x11-7.1 and encountered several problems that prevent X from starting. (evdev mouse fails + nvidia-glx driver warning)
I want to switch back to x11-base/xorg-x11-7.0-r1 but this ebuild is using ">=" to control dependency versions.

Right now the x11-base/xorg-x11-7.0-r1 dependency ">=x11-base/xorg-server-1.0.1" is satisfied by "x11-base/xorg-server-1.1.0" (and any other future release that will enter portage)

The meta ebuild should use more specific dependencies to allow downgrading of xorg-x11 and it's dependencies.

Portage 2.1_rc4-r1 (default-linux/amd64/2005.0, gcc-4.1.1, glibc-2.4-r3, 2.6.16-gentoo-r8 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r8 x86_64 AMD Athlon(tm) 64 Processor 3500+
Gentoo Base System version 1.12.0
ccache version 2.4 [enabled]
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     2.4-r1
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.16
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=athlon64 -mtune=athlon64 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-march=athlon64 -mtune=athlon64 -O2 -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.easynet.nl/mirror/gentoo/ ftp://ftp.snt.utwente.nl/pub/os/linux/gentoo http://distfiles.gentoo.org http://www.ibiblio.org/pub/Linux/distributions/gentoo"
LANG="en_US.UTF-8"
LINGUAS="en nl"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/etc/portage/overlay /etc/portage/xgl-coffee"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="amd64 X alsa avi bash-completion berkdb bitmap-fonts bzip2 cjk cli crypt dvdr dvdread eds emboss flac foomaticdb fortran gif gpm gstreamer gtk gtk2 hal imlib isdnlog jpeg kde kdeenablefinal kdehiddenvisibility lzw lzw-tiff mp3 mpeg ncurses nls nptl nptlonly ogg opengl pam pcre pdflib perl pic png pppd python qt quicktime readline reflection sdl session spl ssl tcpd tiff truetype truetype-fonts type1-fonts unicode usb vorbis xcomposite xml xml2 xorg xpm xv zlib elibc_glibc input_devices_evdev input_devices_keyboard kernel_linux linguas_en linguas_nl userland_GNU video_cards_nvidia"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-06-04 11:50:09 UTC
Portage can't do ranged dependencies, sorry (see Bug 33545). There's enough blockers as it is, p.mask it if you don't like it, like anything else.


*** This bug has been marked as a duplicate of 1343 ***
Comment 2 Harm Geerts 2006-06-04 12:10:29 UTC
This has nothing to do with ranges as described in that bug.
This has to do with depending on specific versions instead of ranges.

dependency as it is now: ">=x11-base/xorg-server-1.0.1"
While it should be: "=x11-base/xorg-server-1.0*"

portage *can* do this
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-06-04 12:22:52 UTC
(In reply to comment #2)
> This has nothing to do with ranges as described in that bug.
> This has to do with depending on specific versions instead of ranges.
> 
> dependency as it is now: ">=x11-base/xorg-server-1.0.1"
> While it should be: "=x11-base/xorg-server-1.0*"
> 
> portage *can* do this

No, it can't... It will cause upgrade/downgrade loops since portage doesn't respect the dependencies of installed packages (see Bug 48195). Also, lots of the dependencies have been moved to xorg-server for 7.1 (all the drivers).

Please, don't request such stuff. If you don't like something, p.mask it and don't install it. You can downgrade just fine, p.mask the unwanted xorg-server version and its dependencies. 

The xorg-x11 dependencies are correct as it is, it's a metabuild.



*** This bug has been marked as a duplicate of 1343 ***