Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 135238 - net-nds/openldap-2.3.24 fails to compile w/ USE="kerberos"
Summary: net-nds/openldap-2.3.24 fails to compile w/ USE="kerberos"
Status: VERIFIED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: x86 Linux
: Highest major (vote)
Assignee: LDAP Herd
URL:
Whiteboard:
Keywords:
: 135281 135605 135662 136487 138917 139299 140849 144726 149373 149682 150074 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-06-02 00:44 UTC by Timo Gurr (RETIRED)
Modified: 2006-10-11 13:55 UTC (History)
35 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
remove-smbk5pwd.patch (remove-smbk5pwd.patch,1.05 KB, patch)
2006-09-30 16:15 UTC, Serkan Hosca
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description Timo Gurr (RETIRED) gentoo-dev 2006-06-02 00:44:44 UTC
Following error message occurs when trying to emerge openldap-2.3.24 with this useflags:
[ebuild     U ] net-nds/openldap-2.3.24 [2.3.23] USE="berkdb crypt gdbm ipv6 kerberos perl readline ssl tcpd -debug -minimal -odbc -overlays -samba -sasl -slp" 0 kB


 * Building contributed smbk5pwd
../../../libtool --mode=compile gcc -O2 -march=i686 -pipe -fomit-frame-pointer                             -DDO_KRB5 -I../../../include -I../../../servers/slapd   -c smbk5pwd.c
mkdir .libs
 gcc -O2 -march=i686 -pipe -fomit-frame-pointer -DDO_KRB5 -I../../../include -I.                           ./../../servers/slapd -c smbk5pwd.c  -fPIC -DPIC -o .libs/smbk5pwd.o
smbk5pwd.c:45:25: error: kadm5/admin.h: No such file or directory
smbk5pwd.c:46:17: error: hdb.h: No such file or directory
smbk5pwd.c:56: error: expected '=', ',', ';', 'asm' or '__attribute__' before 'c                           onf'
smbk5pwd.c:57: error: expected '=', ',', ';', 'asm' or '__attribute__' before '*                           ' token
smbk5pwd.c: In function 'k5key_chk':
smbk5pwd.c:275: error: 'krb5_salt' undeclared (first use in this function)
smbk5pwd.c:275: error: (Each undeclared identifier is reported only once
smbk5pwd.c:275: error: for each function it appears in.)
smbk5pwd.c:275: error: expected ';' before 'salt'
smbk5pwd.c:276: error: 'hdb_entry' undeclared (first use in this function)
smbk5pwd.c:276: error: expected ';' before 'ent'
smbk5pwd.c:291: error: 'Key' undeclared (first use in this function)
smbk5pwd.c:291: error: expected ';' before 'ekey'
smbk5pwd.c:296: error: 'ent' undeclared (first use in this function)
smbk5pwd.c:299: error: 'salt' undeclared (first use in this function)
smbk5pwd.c:306: error: 'ekey' undeclared (first use in this function)
smbk5pwd.c:309: error: 'db' undeclared (first use in this function)
smbk5pwd.c:317: error: 'krb5_keyblock' has no member named 'keyvalue'
smbk5pwd.c:318: error: 'krb5_keyblock' has no member named 'keyvalue'
smbk5pwd.c: In function 'smbk5pwd_exop_passwd':
smbk5pwd.c:363: error: 'hdb_entry' undeclared (first use in this function)
smbk5pwd.c:363: error: expected ';' before 'ent'
smbk5pwd.c:375: error: 'ent' undeclared (first use in this function)
smbk5pwd.c:396: error: 'db' undeclared (first use in this function)
smbk5pwd.c:405: error: 'Key' undeclared (first use in this function)
smbk5pwd.c: In function 'smbk5pwd_modules_init':
smbk5pwd.c:789: error: expected '=', ',', ';', 'asm' or '__attribute__' before '                           *' token
smbk5pwd.c:789: error: invalid type argument of 'unary *'
smbk5pwd.c:829: error: 'KADM5_ADMIN_SERVICE' undeclared (first use in this funct                           ion)
smbk5pwd.c:832: error: 'conf' undeclared (first use in this function)
smbk5pwd.c:835: error: 'db' undeclared (first use in this function)
make: *** [smbk5pwd.lo] Fehler 1

!!! ERROR: net-nds/openldap-2.3.24 failed.
Call stack:
  ebuild.sh, line 1539:   Called dyn_compile
  ebuild.sh, line 939:   Called src_compile
  openldap-2.3.24.ebuild, line 319:   Called die

!!! failed to compile smbk5pwd module
!!! If you need support, post the topmost build error, and the call stack if rel                           evant.


# emerge --info
Portage 2.1_rc3-r5 (default-linux/x86/2006.0, gcc-4.1.1, glibc-2.4-r3, 2.6.16-gentoo-r3 i686)
=================================================================
System uname: 2.6.16-gentoo-r3 i686 AMD Athlon(TM) XP 2600+
Gentoo Base System version 1.12.0
dev-lang/python:     2.4.3-r1
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r5
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc"
CONFIG_PROTECT_MASK="/etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-O2 -march=i686 -pipe -fomit-frame-pointer"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://pandemonium.tiscali.de/pub/gentoo/"
LANG="de_DE@euro"
LINGUAS="de"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlay"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 3dnow apache2 apm arts avi berkdb bitmap-fonts cli crypt cups dri eds emboss encode esd foomaticdb fortran gdbm gif gpm gstreamer gtk2 imlib ipv6 isdnlog jpeg libg++ libwww mad mikmod mmx motif mp3 mpeg ncurses nls nptl nptlonly ogg opengl oss pam pcre pdflib perl png pppd python quicktime readline reflection sdl session spell spl ssl tcpd truetype truetype-fonts type1-fonts udev vorbis xml xmms xorg xv zlib elibc_glibc kernel_linux linguas_de userland_GNU"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-06-02 02:24:16 UTC
Yes, see Bug 134010, Comment #12. This doesn't work w/ mit-krb5.
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-06-02 08:52:49 UTC
*** Bug 135281 has been marked as a duplicate of this bug. ***
Comment 3 Jakub Moc (RETIRED) gentoo-dev 2006-06-05 02:18:29 UTC
*** Bug 135605 has been marked as a duplicate of this bug. ***
Comment 4 Jakub Moc (RETIRED) gentoo-dev 2006-06-05 10:49:08 UTC
*** Bug 135662 has been marked as a duplicate of this bug. ***
Comment 5 Jakub Moc (RETIRED) gentoo-dev 2006-06-11 14:53:26 UTC
*** Bug 136487 has been marked as a duplicate of this bug. ***
Comment 6 Dave 2006-06-11 15:08:52 UTC
I'm getting this error with "samba"
Comment 7 Alexander Wessel 2006-06-28 06:40:09 UTC
(In reply to comment #1)
> Yes, see Bug 134010, Comment #12. This doesn't work w/ mit-krb5.

Well, maybe the use flag should be ignored (with a warning perhaps), if mit-krb5 is installed, instead of having the ebuild crash...

Or even a simple warning that the ebuild will crash, would help. As-is it can never go stable, IMHO.

Why does it have virtual/krb5 in its RDEPEND anyway, if mit-krb5 won't do? If I get it right the only other (x86) provider of virtual/krb5 is app-crypt/heimdal, so RDEPENDing on heimdal directly should prevent this error in the first place, or am I missing something?

Cheers,
Alexander >>Flexx<< Wessel
Comment 8 Jakub Moc (RETIRED) gentoo-dev 2006-07-02 15:02:51 UTC
*** Bug 138917 has been marked as a duplicate of this bug. ***
Comment 9 Seemant Kulleen (RETIRED) gentoo-dev 2006-07-02 15:11:43 UTC
Samba and Kerberos teams: please have a look at this bug.
Comment 10 Jakub Moc (RETIRED) gentoo-dev 2006-07-02 16:18:08 UTC
Compiles just fine w/ heimdal and USE="kerberos samba"... As said, this doesn't work w/ mit-krb5. 
Comment 11 Jakub Moc (RETIRED) gentoo-dev 2006-07-05 06:03:48 UTC
*** Bug 139299 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Moc (RETIRED) gentoo-dev 2006-07-18 00:20:49 UTC
*** Bug 140849 has been marked as a duplicate of this bug. ***
Comment 13 William Keaney 2006-07-18 04:28:06 UTC
This is becoming a larger problem: openldap won't build against mit-krb5, but nfs-utils will _only_ build against mit-krb5 - none of the other krb5 implementations will work.  This impasse is blocking an update on my system.  
It isn't just a problem with the ebuilds - the source code itself is at fault.  I tried altering the nfs-utils.ebuild to accept heimdal and it failed miserably.
Comment 14 Alexey Maximov 2006-07-24 06:37:33 UTC
specially for LAZY samba and openldap team:

just put this files from mit-krb5 to /usr/include/kadm5/

amazing ~ # ls -al /usr/include/kadm5/
total 128
drwxr-xr-x   2 root root   131 2006-07-24 20:26 .
drwxr-xr-x 168 root root 24576 2006-07-24 20:33 ..
-rw-r--r--   1 root root  4801 2004-06-26 06:23 adb.h
-rw-r--r--   1 root root 24124 2005-03-23 05:53 admin.h
-rw-r--r--   1 root root  2741 2001-06-21 20:44 admin_internal.h
-rw-r--r--   1 root root  3211 2001-07-26 02:02 admin_xdr.h
-rw-r--r--   1 root root 29480 2004-06-25 03:08 alt_prof.c
-rw-r--r--   1 root root  8765 2001-02-19 05:00 kadm_rpc.h
-rw-r--r--   1 root root  3710 2001-07-08 19:24 server_internal.h
amazing ~ #                                                               


recompile openldap. it works now.

need to fix mit-krb5 packages !
Comment 15 David Robins 2006-07-25 23:39:22 UTC
(In reply to comment #14)
> specially for LAZY samba and openldap team:
> 
> just put this files from mit-krb5 to /usr/include/kadm5/
> 
> amazing ~ # ls -al /usr/include/kadm5/
[snip]
> 
> recompile openldap. it works now.

No it doesn't; I re-emerged mit-krb5 to make sure it was up to date, copied the files, and emerged openldap, and it failed at:

 * Building contributed smbk5pwd
../../../libtool --mode=compile gcc -O3 -march=pentium4 -fomit-frame-pointer -pipe -DDO_SAMBA -DDO_KRB5 -I../../../include -I../../../servers/slapd   -c smbk5pwd.c
mkdir .libs
 gcc -O3 -march=pentium4 -fomit-frame-pointer -pipe -DDO_SAMBA -DDO_KRB5 -I../../../include -I../../../servers/slapd -c smbk5pwd.c  -fPIC -DPIC -o .libs/smbk5pwd.o
In file included from smbk5pwd.c:45:
/usr/include/kadm5/admin.h:43:20: k5-int.h: No such file or directory
/usr/include/kadm5/admin.h:45:28: kadm5/kadm_err.h: No such file or directory
/usr/include/kadm5/admin.h:46:27: kadm5/adb_err.h: No such file or directory
/usr/include/kadm5/admin.h:47:39: kadm5/chpass_util_strings.h: No such file or directory
In file included from smbk5pwd.c:45:
/usr/include/kadm5/admin.h:167: error: syntax error before "krb5_tl_data"
[snip many more errors from smbk5pwd.c]
make: *** [smbk5pwd.lo] Error 1

!!! ERROR: net-nds/openldap-2.3.24-r2 failed.
Call stack:
  ebuild.sh, line 1545:   Called dyn_compile
  ebuild.sh, line 940:   Called src_compile
  openldap-2.3.24-r2.ebuild, line 320:   Called die

!!! failed to compile smbk5pwd module
!!! If you need support, post the topmost build error, and the call stack if relevant.
Comment 16 Alexey Maximov 2006-08-03 02:05:30 UTC
solution to fix UDEV + LDAP (udev hangs at boot)

# /etc/conf.d/local.start

# This is a good place to load any misc programs
# on startup (use &>/dev/null to hide output)

mount -n --bind /etc/nsswitch.conf.ldap /etc/nsswitch.conf
mount -n --bind /etc/pam.d/system-auth.ldap /etc/pam.d/system-auth
pkill -HUP nscd


# /etc/conf.d/local.stop

# This is a good place to unload any misc.
# programs you started above.
# For example, if you are using OSS and have
# "/usr/local/bin/soundon" above, put
# "/usr/local/bin/soundoff" here.

umount -fl /etc/nsswitch.conf
umount -fl /etc/pam.d/system-auth
pkill -HUP nscd
Comment 17 Alexey Maximov 2006-08-03 02:12:25 UTC
(In reply to comment #14)
> specially for LAZY samba and openldap team:
> 
> just put this files from mit-krb5 to /usr/include/kadm5/
> 
> amazing ~ # ls -al /usr/include/kadm5/
> total 128
> drwxr-xr-x   2 root root   131 2006-07-24 20:26 .
> drwxr-xr-x 168 root root 24576 2006-07-24 20:33 ..
> -rw-r--r--   1 root root  4801 2004-06-26 06:23 adb.h
> -rw-r--r--   1 root root 24124 2005-03-23 05:53 admin.h
> -rw-r--r--   1 root root  2741 2001-06-21 20:44 admin_internal.h
> -rw-r--r--   1 root root  3211 2001-07-26 02:02 admin_xdr.h
> -rw-r--r--   1 root root 29480 2004-06-25 03:08 alt_prof.c
> -rw-r--r--   1 root root  8765 2001-02-19 05:00 kadm_rpc.h
> -rw-r--r--   1 root root  3710 2001-07-08 19:24 server_internal.h
> amazing ~ #                                                               
> 
> 
> recompile openldap. it works now.
> 
> need to fix mit-krb5 packages !
> 

(In reply to comment #15)
> (In reply to comment #14)
> > specially for LAZY samba and openldap team:
> > 
> > just put this files from mit-krb5 to /usr/include/kadm5/
> > 
> > amazing ~ # ls -al /usr/include/kadm5/
> [snip]
> > 
> > recompile openldap. it works now.
> 
> No it doesn't; I re-emerged mit-krb5 to make sure it was up to date, copied the
> files, and emerged openldap, and it failed at:
> 

please show me
ls -al /usr/include/kadm5/

I have only files there and all recompiled fine! :-))))))))
Comment 18 Alexey Maximov 2006-08-03 02:14:24 UTC
also make

locate k5-int.h

where is it ?

or equery f mit-krb5
Comment 19 William Keaney 2006-08-18 21:19:32 UTC
It's been over two months now.  Are we any closer to a solution?  The files posted by Alexey aren't present on my system, so I can't test that workaround.  
This problem is still blocking updates.
Comment 20 Jakub Moc (RETIRED) gentoo-dev 2006-08-22 02:00:53 UTC
*** Bug 144726 has been marked as a duplicate of this bug. ***
Comment 21 Ashu Tiwary 2006-09-05 20:10:19 UTC
Problem still exists on a fresh install of Gentoo 2006.1
Comment 22 Daniel Lin 2006-09-10 23:37:51 UTC
On a brand-new 2006.1 install, compiling (but not merging) Heimdal and
copying the headers to /usr/include/heimdal makes OpenLDAP compile.
Comment 23 Özgür ERİŞEN 2006-09-20 01:58:03 UTC
if you set "net-fs/nfs-utils -kerberos" then you can use heimdal as kerberos 5 implementation. Than openldap can be compiled and installed. 
echo "net-fs/nfs-utils -kerberos" >> /etc/portage/package.use
emerge --unmerge mit-krb5 && emerge virtual/krb5 && emerge openldap 
:)
nfs-utils ebuild does not consider heimdal as kerberos 5 implementation so that it is required to remove kerberos flag from this ebuild :(

In NFS faq it is stated that NFS4 kerberos support is not working :( but it seems it is a bit outdated. It states only Fedora Core 2 has NFS4 with kerberos authantication 
:( 
Comment 24 William Keaney 2006-09-20 07:02:51 UTC
Now for the really ironic bit - heimdal uses the 'ldap' USE flag.  So if you have ldap in your USE flags, portage will emerge openldap first; but openldap needs heimdal; but heimdal needs openldap ;)  So, use 'USE="-ldap" emerge heimdal && emerge openldap && emerge heimdal" to get around it.
Comment 25 Nathan Sullivan 2006-09-20 16:43:09 UTC
exactly what ive done on all my systems :)
Comment 26 William Keaney 2006-09-20 16:47:05 UTC
Yes, this worked like a charm for me.  Thanks!!
Comment 27 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2006-09-21 03:21:41 UTC
do i need to highlight that all these hacks are rather awful and we probably could do with an official solution?
Ie: make mit-krb5 and heidemial co-exist peacefully somehow (package-config magic? )
or do something like changing the ebuild so it will download the needed krb5 and compile the needed stuff & headers before hand and put them so only openldap can get it somehow. 

Users shouldn't really have to read bugs.gentoo.org for software marked stable ;)

Just suggestions. 
Comment 28 Kent Fredric (IRC: kent\n) (RETIRED) gentoo-dev 2006-09-21 03:23:15 UTC
er... ignore that remark about stable, catted the wrong file :S
Comment 29 Serkan Hosca 2006-09-25 08:15:01 UTC
I think smbk5pwd should be a separate ebuild.
Comment 30 Fredric Johansson 2006-09-27 06:35:20 UTC
this still causes problem with version 2.3.27
Will this be fixed for this version?
Comment 31 Thomas Heinz 2006-09-27 13:57:57 UTC
fetchmail is another tool which cannot cope with heimdal. What solution do you consider feasible?

a) Make fetchmail and others work with heimdal (can also be read as: make heimdal
   work with fetchmail and co)
b) Make openldap work with mit-krb5
c) Allow mit-krb5 and heimdal to coexist somehow
d) ?
Comment 32 Christian Faulhammer (RETIRED) gentoo-dev 2006-09-28 00:10:15 UTC
*** Bug 149373 has been marked as a duplicate of this bug. ***
Comment 33 Alon Bar-Lev (RETIRED) gentoo-dev 2006-09-28 05:14:30 UTC
How could it made stable with known problem?
Comment 34 Doron Fediuck 2006-09-28 06:15:36 UTC
Hi Guys,
We're having a frustrated debate regarding this issue.
See- http://forums.gentoo.org/viewtopic-t-502179-highlight-openldap.html
Current ststus is masking openldap, which is very sad.

krb5 and heimdal collision is quite serious, since there
are people who need to re-compile hugh stuff now. Please try
to come up with a better solution. People can not simply remove krb5
without spending many hours afterwards.

Thanks,
Doron.
Comment 35 D Wollmann 2006-09-29 09:19:17 UTC
Is all this kerberose tomfoolery for the purpose of supporting storage of kerberos data in tree? If so, do we even have a non-broken krb5 schema? The last I read about this, the schema was totally borked and had been pulled from the openldap tree.
Comment 36 Serkan Hosca 2006-09-30 16:15:05 UTC
Created attachment 98480 [details, diff]
remove-smbk5pwd.patch

no its because of smbk5pwd in the openldap ebuild, which enables the user to let openldap update both the ldap, nt and lanman password without the need of a third party tool (or samba itself) doing so, but it only works/builds with heimdal not mit-krb5. i have removed the part where it builds smbk5pwd from the ebuild and it works fine.
Comment 37 Selth 2006-09-30 17:15:27 UTC
I've been looking at the ebuild.
It seems removing the samba useflag would have the same result.
I've gave it a try, it worked fine.
Comment 38 Jakub Moc (RETIRED) gentoo-dev 2006-09-30 23:06:22 UTC
*** Bug 149682 has been marked as a duplicate of this bug. ***
Comment 39 Jakub Moc (RETIRED) gentoo-dev 2006-09-30 23:12:17 UTC
Erm, folks - how about nuking the samba nonsense in the ebuild until it works?
Comment 40 Codo 2006-10-04 01:58:15 UTC
(In reply to comment #39)
> Erm, folks - how about nuking the samba nonsense in the ebuild until it works?
> 

If the openLDAP team only supports heimdal, then yes, I think it should be masked.  I am $ USE="-samba" emerge openldap just now... How come you support heimdal and not mit-krb5???
Comment 41 Jakub Moc (RETIRED) gentoo-dev 2006-10-04 02:09:44 UTC
(In reply to comment #40)
> (In reply to comment #39)
> > Erm, folks - how about nuking the samba nonsense in the ebuild until it works?
> > 
> 
> If the openLDAP team only supports heimdal, then yes, I think it should be
> masked.  I am $ USE="-samba" emerge openldap just now... How come you support
> heimdal and not mit-krb5???

Uh eh? I'm not suggesting any masking, what I've said is that the smpk5pwd snippet should be either removed altogether until a solution is found, or it's compilation made conditional on has_version app-crypt/heimdal and spit out a warning that it won't be compiled if case people don't have heimdal, instead of ebuild bombing out or instead of forcing heimdal and blockers on people.
Comment 42 Markus Ullmann (RETIRED) gentoo-dev 2006-10-04 04:54:54 UTC
Moved it to its own useflag now and set dependencies accordingly
Comment 43 Jakub Moc (RETIRED) gentoo-dev 2006-10-04 10:26:01 UTC
*** Bug 150074 has been marked as a duplicate of this bug. ***
Comment 44 Christian Assfalg 2006-10-11 13:18:50 UTC
I do wonder, too, if this is ever going to be fixed somehow?

Even if I manually unpack krb5-1.4.3 and copy over the header files, there are still those errors:

In file included from smbk5pwd.c:45:
/usr/include/kadm5/admin.h:43:20: error: k5-int.h: No such file or directory
/usr/include/kadm5/admin.h:45:28: error: kadm5/kadm_err.h: No such file or directory
/usr/include/kadm5/admin.h:46:27: error: kadm5/adb_err.h: No such file or directory
/usr/include/kadm5/admin.h:47:39: error: kadm5/chpass_util_strings.h: No such file or directory

k5-int.h is there, but the rest of the Header-Files (which are in the Includes of /usr/include/kadm5/admin.h !), I can not even find anywhere in the mit-krb5 files.

Sysinfos:
EntGentoo01 krb5-1.4.3 # equery list mit-krb5
[ Searching for package 'mit-krb5' in all categories among: ]
 * installed packages
[I--] [  ] app-crypt/mit-krb5-1.4.3-r3 (0)
EntGentoo01 krb5-1.4.3 # equery list openldap
[ Searching for package 'openldap' in all categories among: ]
 * installed packages
[I--] [  ] net-nds/openldap-2.3.24-r1 (0)
EntGentoo01 krb5-1.4.3 # emerge -pv openldap mit-krb5

These are the packages that would be merged, in order:

Calculating dependencies... done!
[ebuild     U ] net-nds/openldap-2.3.27 [2.3.24-r1] USE="berkdb crypt gdbm ipv6 kerberos perl readline samba ssl tcpd -debug -minimal -odbc -overlays -sasl (-selinux) -slp" 0 kB
[ebuild   R   ] app-crypt/mit-krb5-1.4.3-r3  USE="ipv6 -doc -krb4 -static -tcl" 0 kB

Total size of downloads: 0 kB
EntGentoo01 krb5-1.4.3 #

Currently recompiling with krb5-int.h also in place, though I do not expect it to work.

Cheers,
Christian
Comment 45 Jakub Moc (RETIRED) gentoo-dev 2006-10-11 13:55:56 UTC
Maybe you should emerge --sync?