Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 135040 - dev-games/ode-0.5-r4 fails to compile with gcc-4.1.1
Summary: dev-games/ode-0.5-r4 fails to compile with gcc-4.1.1
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Games (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Gentoo Games
: 135061 (view as bug list)
Depends on: 136357
Blocks: 117482
  Show dependency tree
Reported: 2006-05-31 06:21 UTC by Andrei Slavoiu
Modified: 2006-08-10 09:49 UTC (History)
3 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Andrei Slavoiu 2006-05-31 06:21:12 UTC
g++ -c -Wall -fno-rtti -fno-exceptions -Wall -fomit-frame-pointer -ffast-math -march=athlon64 -ggdb -O2 -pipe -fPIC -Iinclude -IOPCODE  -DdTRIMESH_ENABLED -DdNODEBUG -O1 -o OPCODE/OPC_AABBTree.o OPCODE/OPC_AABBTree.cpp
OPCODE/OPC_AABBTree.h: In constructor ‘Opcode::AABBTreeNode::AABBTreeNode()’:
OPCODE/OPC_AABBTree.h:88: warning: ‘Opcode::AABBTreeNode::mNbPrimitives’ will be initialized after
OPCODE/OPC_AABBTree.h:87: warning:   ‘udword* Opcode::AABBTreeNode::mNodePrimitives’
OPCODE/OPC_AABBTree.cpp:56: warning:   when initialized here
OPCODE/OPC_AABBTree.cpp: In destructor ‘Opcode::AABBTreeNode::~AABBTreeNode()’:
OPCODE/OPC_AABBTree.cpp:78: warning: unused variable ‘Neg’
OPCODE/OPC_AABBTree.cpp: In member function ‘bool Opcode::AABBTreeNode::Subdivide(Opcode::AABBTreeBuilder*)’:
OPCODE/OPC_AABBTree.cpp:295: error: cast from ‘Opcode::AABBTreeNode*’ to ‘udword’ loses precision
OPCODE/OPC_AABBTree.cpp:309: error: cast from ‘Opcode::AABBTreeNode*’ to ‘udword’ loses precision
OPCODE/OPC_AABBTree.h: In constructor ‘Opcode::AABBTree::AABBTree()’:
OPCODE/OPC_AABBTree.h:134: warning: ‘Opcode::AABBTree::mTotalNbNodes’ will be initialized after
OPCODE/OPC_AABBTree.h:132: warning:   ‘Opcode::AABBTreeNode* Opcode::AABBTree::mPool’
OPCODE/OPC_AABBTree.cpp:373: warning:   when initialized here
make: *** [OPCODE/OPC_AABBTree.o] Error 1
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-05-31 10:59:56 UTC
*** Bug 135061 has been marked as a duplicate of this bug. ***
Comment 2 Piotr Jaroszyński (RETIRED) gentoo-dev 2006-06-05 08:53:44 UTC
works for me, so maybe add some details...
Comment 3 Piotr Jaroszyński (RETIRED) gentoo-dev 2006-06-05 09:19:20 UTC
ok, from the duplicate i see it's amd64 bug(plz set the flag...) so i won't be able to help.
Comment 4 Andrei Slavoiu 2006-06-05 11:10:10 UTC
Ok, changed hardware to AMD64 as it looks like it's a 64 bit specific issue.
Comment 5 Matteo Azzali (RETIRED) gentoo-dev 2006-06-08 06:27:52 UTC
Please check also bug #134866 and bug #135328 , seem the same identical bug
(cast from .... loses precision  on AMD64 systems)
Comment 6 Matteo Azzali (RETIRED) gentoo-dev 2006-06-08 06:36:24 UTC
also bug #134672 has the same error but this time for x86. 
(maybe this can help finding clues?)
Comment 7 Hanno Zysik (geki) 2006-06-11 15:48:48 UTC
JFYI, ODE 0.6 is released which seems to fix x86_64 issues.
Comment 8 Bernard Cafarelli gentoo-dev 2006-06-17 08:58:25 UTC
Indeed, I "solved" this compilation problem by using ode 0.6.0 ebuild from bug #136357

Works fine for me!
Comment 9 Tupone Alfredo gentoo-dev 2006-06-19 14:32:28 UTC
version 0.6 is in portage and is gcc-4.1 friendly
Comment 10 Andrei Slavoiu 2006-08-10 09:49:21 UTC