Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 13472 - KDE with xft2 does not display fonts correctly
Summary: KDE with xft2 does not display fonts correctly
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] KDE (show other bugs)
Hardware: All Linux
: High normal with 1 vote (vote)
Assignee: Gentoo KDE team
: 14794 18670 (view as bug list)
Depends on:
Reported: 2003-01-07 23:20 UTC by naanyaar2000
Modified: 2004-07-12 06:51 UTC (History)
11 users (show)

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description naanyaar2000 2003-01-07 23:20:51 UTC
The latest version of the kde-base/kde requires a re-emerge of qt with xft2
(basically on an emerge -pu --deep world).  After this, fonts in konsole are
completely messed up.  There are large gaps between glyphs and it does not look
like the default "fixed" font.

After a lot of hair pulling and googling, this was found to be the cause. 
Apparently fonts are being loaded by freetype; however, freetype cannot load
compressed pcf files.  Since the "fixed" fonts are in this format (in
/usr/lib/X11/fonts/misc), they are not loaded and are substituted with another
font, causing the display problem.

- uncompress the files corresponding to the "fixed" font.  In my case,
- do 'ft-cache'
- fix up fonts.dir in /usr/lib/X11/fonts/misc to reflect the uncompressed files

This gets back the 'fixed' font, thankfully.
Comment 1 Hannes Mehnert (RETIRED) gentoo-dev 2003-01-08 16:05:42 UTC
which version of media-libs/fontconfig is merged? this bug should be fixed in 2.1. 
Comment 2 naanyaar2000 2003-01-08 16:39:11 UTC
*  media-libs/fontconfig
      Latest version available: 2.1
      Latest version installed: 2.1

FYI, I have a gentoo 1.2 install that has been rsync'ed and emerged -u --deep
world regularly.

Just curious, what was the nature of the fix?

Comment 3 Hannes Mehnert (RETIRED) gentoo-dev 2003-01-12 15:02:56 UTC
sorry, i meant freetype, not fontconfig. 
iirc, freetype can use zipped fonts since 2.1.3. which version do you have? 
Comment 4 naanyaar2000 2003-01-12 22:59:44 UTC
I have freetype 2.1.2-r2. 2.1.3-r2 is marked as "~x86" in the ebuild (rsync'ed
today morning).

Comment 5 paidhi 2003-01-13 03:04:31 UTC

I have the same font problem (Gentoo 1.4rc2, kde-3.0.5a, qt-3.1.0-r1, xft-2.0.1).
Emerge freetype 2.1.3-r2 didn't fix the problem for me. Is there anything
special to do after emerging the new freetype version?

Meanwhile the tip with uncompressing the files in /usr/lib/X11/fonts/misc did
solve this for me. BTW: The command above should be fc-cache, instead of ft-cache.

Comment 6 Andrew Minter 2003-01-20 18:22:35 UTC
Emerge freetype 2.1.3-r2 didn't fix the problem for me either, perhaps we need
to emerge qt and/or kdebase again?
Comment 7 Andrew Minter 2003-01-20 18:36:50 UTC
Duh! I forgot to re-emerge fontconfig, freetype 2.1.3-r2 does indeed solve the
Comment 8 Ryan May 2003-01-25 23:17:25 UTC
I can confirm that the latest freetype fixed this issue for me as well.
Comment 9 Hannes Mehnert (RETIRED) gentoo-dev 2003-01-27 10:22:43 UTC
ok, so anyone still has this problem? seems to be fixed for at least 2 persons :) 
if it persist, please reemerge fontconfig and freetype. 
Comment 10 Andrew Minter 2003-01-27 10:48:41 UTC
I believe we've agreed the problem is that freetype 2.1.2 can't handle
compressed PCF fonts and that this is fixed on 2.1.3. Before this can be closed
freetype-2.1.3-r2 needs to be unmasked!
Comment 11 Ricardo Ferreira 2003-01-29 09:31:40 UTC
Just to report the re-emerging of fontconfig fixed this for me. I just noticed this 
problem when i unmerged all previous kde versions from my system and kept 
only 3.1 
Comment 12 Joe Roberts 2003-01-30 19:35:41 UTC
Emerging the new freetype and fontconfig fixed SOME of my fonts (the fixed ones).  That is good.  I am not sure if this is part of the same problem, but I can't use any .bdf fonts either - some screenshots are here:

These fonts used to work perfectly.  The situation has changed slightly from that forum posts - now the bdf fonts (specifically Neep), don't show up at all in the "font example" fields in the dialogues to select fonts.  They show up in the font lists, but they cannot, apparently, be displayed.  They show up fine in  Windowmaker.

I had hoped that re-emerging fontconfig and the latest freetype would fix that problem; it hasn't.  Wouldn't care too much except this is the font I use for *everything*.
Comment 13 Hannes Mehnert (RETIRED) gentoo-dev 2003-01-30 20:45:58 UTC
20220521: please take a look at bug #10998, maybe you've also encountered this bug? 
there is also bug #14794, which i haven't looked at yet, but it is also a font-related problem. 
Comment 14 Hunter Ware 2003-02-07 14:50:27 UTC
I found another solution. Since the xft package was dragged in for my by 
the most recent qt update, I decided to go back to the old qt and 
unmerge the xft package. That version of qt refused to emerge the first 
time, complaining in fact that it couldn't find xft. I knew that it had worked 
fine before without xft so I did:  
 emerge unmerge qt xft  
 emerge -e /usr/portage/x11-libs/qt/qt-3.1.0-r1.ebuild  
 This built fine and I have my fonts back =) I hope that this helps pinpoint 
the problem to people more familiar with the internals of xft, freetype, 
and qt.  I did verify that I can re-cause the problem by upgrading again.  I 
then refixed my problems as above. 
Comment 15 dominik.thiel 2003-02-12 14:29:42 UTC
I seem to have had the same problem ( look @ #14794 )

I only emerged xfree-4.2.99 which solved the problem too, dunno why:-)
Comment 16 Hannes Mehnert (RETIRED) gentoo-dev 2003-02-25 17:50:13 UTC
Hunter Ware: maybe you needed also the following 
emerge fontconfig freetype xft 
emerge qt kdelibs 
anyway, this bug can be closed, or are there any objections? 
Comment 17 Hannes Mehnert (RETIRED) gentoo-dev 2003-02-25 17:53:55 UTC
sorry, only read last 3 comments, we still need to 
mark freetype-2.1.3-r2 stable before this bug is solved. 
foser: any objections? or who is our font guy? 
Comment 18 foser (RETIRED) gentoo-dev 2003-02-25 18:43:08 UTC
hmm looks fine to me, but you should at least notify azarah if you mark it stable.
Comment 19 Hunter Ware 2003-02-25 18:58:38 UTC
I don't know how this stuff works exactly but I wonder if you wanna mark the bug solved unless 
a >=freetype-2.1.3 is unmasked... 
Comment 20 Hannes Mehnert (RETIRED) gentoo-dev 2003-02-25 19:29:00 UTC
Azarah: any objections? maybe after the freeze? 
Comment 21 dominik.thiel 2003-02-28 16:26:00 UTC
After emerging xfree-4.3.0 the problem appeared again!
Remerging freetype, fontconfig and xft didnt help. Tomorrow i'll try remerging qt and kdelibs (as suggested by hannes above, sorry, only whooping 350mhz;) )
Comment 22 dominik.thiel 2003-03-02 06:11:57 UTC
Remerging freetype, fontconfig, xft2, qt and kdelibs didnt solve the problem. What more can I try?
Comment 23 Matthew Humphrey 2003-03-08 17:19:35 UTC
I updated to 2.1.3-r2 and re-emerged fontconfig (2.1). This fixed *some* of the fonts, but not all. For example, the following fonts seem to have problems:

Fangsong Ti
Song Ti
Comment 24 Michael Kurnik 2003-03-09 11:45:14 UTC
       I am have just installed Gentoo (rc2) for the first time. I decided to go and unmask and  
install Xfree86 4.3 along with all it's dependencies. Things seemed to work ok for ahwile except  
for a few minor font problems but now I am having problems in KDE with irregularlly spaced  
fonts and some fonts simply having vanished from the font selection dialogs even though when  
I check in KDE Font Installer they are still present. I have reason to believe the above bug is  
NOT fixed yet. my version of freetype is :freetype-2.1.3-r2 my version of fontconfig is:  
fontconfig-2.1-r1. Unless I read incorrectly these problems were supposed to have been solved  
using above versions. This seems to not be the case. Mind you I had no earlier version of X  
installed on my system. These version are what were installed along with X when I first  
installed XFree86 4.3.  
Anybody able to help me on this? It is driving me NUTS! 
Comment 25 Seemant Kulleen (RETIRED) gentoo-dev 2003-03-09 19:18:30 UTC
<RagnaRoC> it seems I have discovered a bug that others have been bit by but as to the fix for it not truly certain...please look at all this....
<RagnaRoC> <DanielS> RagnaRoC: Downgrade your fontconfig to anything less than 2.1.90.
<RagnaRoC> [09:29:38] <DanielS> 2.1.90 has some, um, fun issues. :)
<RagnaRoC> [09:31:08] <RagnaRoC> Um....i am just using whatever got installed along with Xfree86 4.3...don't knwo a thing about any of that..
<RagnaRoC> [09:31:12] <RagnaRoC> what kinda issues?
<RagnaRoC> [09:32:10] <DanielS> It's screwed.
<RagnaRoC> <DanielS> Hmmm.
<RagnaRoC> [09:32:52] <DanielS> Well, we've seen the same on Debian, and it's all due to fontconfig 2.1.90.
<RagnaRoC> DanielS> I don't know how to roll back in Gentoo, but that's what you need to do
<RagnaRoC> <DanielS> Trust me, I know what the issue is. :)
<RagnaRoC> [09:37:05] <RagnaRoC> so this is all related to the new xfree86 4.3 release?
<RagnaRoC> ] <DanielS> 01:47 < DanielS> RagnaRoC: Inconsistent font selection (some X11 core fonts excluded?), monospacing seems to have gone to hell, other random
<RagnaRoC> [10:04:56] <DanielS>                  brokenness.
<RagnaRoC> and then kerframil gave me this link...........
<RagnaRoC> I am still reading through it
<RagnaRoC> not sure exactly what to remerge with to truly solve it without breaking other things at same time
<RagnaRoC> Thre are a number of different ideas on ways to do this
Comment 26 Michael Kurnik 2003-03-09 23:25:09 UTC
Well folks back again I am....The IRC conversation posted by seemant above was me 
(RagnaRoC) talking to another in #Xfree86 via the server about these problems 
in this thread. 
 For what it is worth I have tried remerging freetype and fontconfig..and maybe one other.prg 
(Not sure off top my head at the moment) but no luck as of yet. Font handling in KDE/X still 
quite broken. .  :( 
 What version of fontconfig is currently on the portage tree? I saw 2.1-r1 (I think this is 
masked?) this has not helped me any. 
Comment 27 Bram 2003-03-12 12:58:52 UTC
I never used KDE so I was a bit annoyed when I emerged and compiled it all on my (slow) Powerbook G3.
After reading all of this stuff and on the forums, I tried to emerge fontconfig and some other fonts.
The ungzipping worked but that's very messy and makes your fontdirs huge.
So I looked at the freetype website and saw that there was a new version, 2.1.4rc2.
Made an ebuild out of that, recompiled, nada.
After playing around for a while, decided to link /usr/lib/libfreetype* /usr/X11R6/lib and it worked!

KDE is a nice improvement for migrating from redmond.
Here are my current version numbers (in no particular order):
[ebuild   R  ] media-libs/fontconfig-2.1-r1
[ebuild    UD] x11-libs/qt-3.1.0-r3 [3.1.1-r2]
[ebuild   R  ] x11-base/xfree-4.3.0-r1
[ebuild   R  ] kde-base/kde-3.1
[ebuild    UD] media-libs/freetype-2.1.3-r2 [2.1.4-r2]

(I guess that qt version works on PPC)
Comment 28 Francisco León 2003-04-06 20:53:32 UTC
Serius bug people
I have the latest versions of xft freetype fontconfig and xfree 4.3, and i cant see all these fonts:
All the "Fixed" ones
All the "terminal" ones

Comment 29 Francisco León 2003-04-06 21:11:52 UTC
Comment #27 worked perfectly!
I deleted all libfreetype files from /usr/X11R6/lib and then did the symlink
Thanks Bram!
Symlinking alone WONT fix it unless you delete the files first. (because it will create bad links)
Comment 30 Francisco León 2003-04-07 09:27:20 UTC
see bug 18666 for other font issues in kde: some fonts look
l   i    k   e      t    h    i    s 
Comment 31 Michele Balistreri (RETIRED) gentoo-dev 2003-04-14 11:04:05 UTC
*** Bug 14794 has been marked as a duplicate of this bug. ***
Comment 32 Michele Balistreri (RETIRED) gentoo-dev 2003-04-14 12:00:05 UTC
*** Bug 18670 has been marked as a duplicate of this bug. ***
Comment 33 Paul de Vrieze (RETIRED) gentoo-dev 2003-04-21 16:09:19 UTC
I just added a suggestion to bug
Try whether it works. Note that in some cases the ebuild for xfree fucked up the file permissions of the font files (at least with me)
Comment 34 Paul de Vrieze (RETIRED) gentoo-dev 2003-05-02 07:23:43 UTC
Please try to remerge qt and see if that fixes the problems
Comment 35 Caleb Tennis (RETIRED) gentoo-dev 2003-05-28 23:27:04 UTC
Paul's last comment for test request was a few weeks ago.  Closing as TEST-REQUEST. 
Comment 36 Caleb Tennis (RETIRED) gentoo-dev 2003-09-27 10:50:56 UTC
see above comment
Comment 37 Eric Shattow 2004-07-11 18:19:18 UTC
More brokeness.   xft is blocked by xorg-x11 (which i use).    Default fonts do not show up properly in most Qt apps, unless you grab the app window by its window handle and drag it around on screen.

also works is if i set up a large gnome-terminal scrolling lots of text behind the active Qt window.

also works is if the Qt app allows me to change its font to something other than the default font, and change the size too.   some other fonts appear broken as well, but i cannot list them because they do not show up in the combo boxes/menus.
Comment 38 foser (RETIRED) gentoo-dev 2004-07-12 06:51:03 UTC
open a new bug, this is a really old one.