Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 133898 - net-nds/openldap-2.3.23 slapadd aborted: "Assertion ... failed"
Summary: net-nds/openldap-2.3.23 slapadd aborted: "Assertion ... failed"
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Other
: High normal (vote)
Assignee: LDAP Herd
URL:
Whiteboard:
Keywords:
: 134148 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-05-20 13:41 UTC by Daniel
Modified: 2006-07-17 13:02 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description Daniel 2006-05-20 13:41:47 UTC
slapadd fails importing a dump using new style of configuration
"-F /path/.../slapd.d"

slapadd -v -F /etc/openldap/slapd.d -l /root/200605191201.ldif
slapadd: ldif.c:416: r_enum_tree: Assertion `itmp.bv_val[ 0 ] != '-'' failed.
Aborted


using "oldstyle" configuration file "slapd.conf" instead worked fine:
slapadd -v -f /etc/openldap/slapd.conf -l /root/200605191201.ldif


previously converting oldstyle to slapd.d configuration worked just fine:
slaptest -f slapd.conf -F slapd.d
bdb_db_open: Warning - No DB_CONFIG file found in directory /var/lib/openldap-data/te.st: (2)
Expect poor performance for suffix dc=te,dc=st.
config file testing succeeded



emerge --info:

Portage 2.0.54-r2 (default-linux/x86/2006.0, gcc-3.3.6, glibc-2.3.6-r3, 2.6.15-gentoo-r1 i686)
=================================================================
System uname: 2.6.15-gentoo-r1 i686 Intel(R) Pentium(R) M processor 1.80GHz
Gentoo Base System version 1.6.14
ccache version 2.3 [enabled]
dev-lang/python:     2.3.5-r2, 2.4.2
dev-python/pycrypto: [Not Present]
dev-util/ccache:     2.3
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.3/env /usr/kde/3.3/share/config /usr/kde/3.3/shutdown /usr/kde/3.4/env /usr/kde/3.4/share/config /usr/kde/3.4/shutdown /usr/kde/3/share/config /usr/lib/X11/xkb /usr/share/config /var/bind /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-O2 -march=pentium4 -fomit-frame-pointer -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig ccache distlocks sandbox sfperms strict"
GENTOO_MIRRORS="ftp://ftp.tu-clausthal.de/pub/linux/gentoo/ ftp://sunsite.informatik.rwth-aachen.de/pub/Linux/gentoo http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ ftp://linux.rz.ruhr-uni-bochum.de/gentoo-mirror/ http://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.uni-erlangen.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp.wh2.tu-dresden.de/pub/mirrors/gentoo ftp://ftp.join.uni-muenster.de/pub/linux/distributions/gentoo ftp://ftp6.uni-muenster.de/pub/linux/distributions/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo/ http://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/ ftp://ftp-stud.fht-esslingen.de/pub/Mirrors/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/overlays/gentoo-de"
SYNC="rsync://rsync.de.gentoo.org/gentoo-portage"
USE="x86 X a52 aac aalib acpi alsa apache2 apm arts audiofile avi bash-completion bcmath berkdb bitmap-fonts bzip2 bzlib cdb cdparanoia cdr cli cpdflib crypt ctype cups curl curlwrappers dedicated directfb dri dvd dvdr eds emboss encode esd ethereal exif expat fam fbcon ffmpeg flash foomaticdb fortran freetds freetype ftp gd gif gpm gps gstreamer gtk2 iconv icq ieee1394 imagemagick imlib ipv6 isdnlog jabber java javascript jpeg kde lcms ldap libg++ libwww lirc lm_sensors mad mcal mhash mikmod milter mime ming mmx mng motif mp3 mpeg mysql ncurses nls nptl offensive ogg opengl oss pam pcntl pcre pdflib perl php png posix pppd python qt quicktime readline recode reflection ruby sasl sdl session sharedext slang slp snmp sockets socks5 spell spl sse sse2 ssl svg svga svgalib symlink tcltk tcpd threads tidy tiff truetype truetype-fonts type1-fonts udev unicode usb vhosts vorbis wmf xml xml2 xmlrpc xmms xorg xpm xsl xv xvid zlib dvb_cards_ttpci userland_GNU kernel_linux elibc_glibc"
Unset:  ASFLAGS, CTARGET, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS, PORTAGE_RSYNC_OPTS
Comment 1 Markus Ullmann (RETIRED) gentoo-dev 2006-05-20 16:21:54 UTC
Upstream already patched their new version, waiting until it is available, masking 2.3.23 for now

Thanks for reporting :)
Comment 2 Jakub Moc (RETIRED) gentoo-dev 2006-05-23 13:56:00 UTC
*** Bug 134148 has been marked as a duplicate of this bug. ***
Comment 3 Carsten Lohrke (RETIRED) gentoo-dev 2006-06-01 15:21:15 UTC
(In reply to comment #1)
> masking 2.3.23 for now

You masked whole openldap and therefore broke the tree. I commented the mask out for now.
Comment 4 Markus Ullmann (RETIRED) gentoo-dev 2006-07-17 13:02:22 UTC
As we have 2.3.24 in tree which has this fixed, resolving