Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 133607 - rc-update -show broken runlevels entries
Summary: rc-update -show broken runlevels entries
Status: RESOLVED DUPLICATE of bug 103275
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] baselayout (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo's Team for Core System packages
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-17 08:58 UTC by MpJin
Modified: 2006-05-22 23:28 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description MpJin 2006-05-17 08:58:07 UTC
I noticed that "rc-update -show" gives this output :

 * Broken runlevel entry: /etc/runlevels/boot/keymaps
 * Broken runlevel entry: /etc/runlevels/boot/clock
 * Broken runlevel entry: /etc/runlevels/boot/localmount
 * Broken runlevel entry: /etc/runlevels/boot/consolefont
 * Broken runlevel entry: /etc/runlevels/boot/modules
 * Broken runlevel entry: /etc/runlevels/boot/hostname
 * Broken runlevel entry: /etc/runlevels/boot/net.lo
 * Broken runlevel entry: /etc/runlevels/boot/urandom
 * Broken runlevel entry: /etc/runlevels/boot/checkroot
 * Broken runlevel entry: /etc/runlevels/boot/rmnologin
 * Broken runlevel entry: /etc/runlevels/boot/bootmisc
 * Broken runlevel entry: /etc/runlevels/boot/checkfs
 * Broken runlevel entry: /etc/runlevels/default/local
 * Broken runlevel entry: /etc/runlevels/default/netmount
 * Broken runlevel entry: /etc/runlevels/nonetwork/local
 * Broken runlevel entry: /etc/runlevels/battery/local
 * Broken runlevel entry: /etc/runlevels/battery/netmount
               acpid | battery      default
           alsasound |         boot
            bootmisc |         boot
             checkfs |         boot
           checkroot |         boot
               clock |         boot
            coldplug |         boot
         consolefont |         boot
            cpufreqd | battery      default
               cupsd |              default
                dbus | battery      default
                hald | battery      default
            hostname |         boot

and son on...

I dont know exactly when this issue appeared, but a problem with my system clock made me search for a fix (I had no problem with the clock before noticing this). 
I'm using sys-apps/baselayout-1.12.0_pre19-r2.

If I use ls -l on /etc/runlevels/boot i get this :

lrwxrwxrwx 1 root root 21 Dec 23 18:40 alsasound -> /etc/init.d/alsasound
lrwxrwxrwx 1 root root 36 Dec 23 18:40 bootmisc -> /tmp/stage1root//etc/init.d/bootmisc
lrwxrwxrwx 1 root root 35 Dec 23 18:40 checkfs -> /tmp/stage1root//etc/init.d/checkfs
lrwxrwxrwx 1 root root 37 Dec 23 18:40 checkroot -> /tmp/stage1root//etc/init.d/checkroot
lrwxrwxrwx 1 root root 33 Dec 23 18:40 clock -> /tmp/stage1root//etc/init.d/clock
lrwxrwxrwx 1 root root 20 Dec 23 18:40 coldplug -> /etc/init.d/coldplug
lrwxrwxrwx 1 root root 39 Dec 23 18:40 consolefont -> /tmp/stage1root//etc/init.d/consolefont
lrwxrwxrwx 1 root root 36 Dec 23 18:40 hostname -> /tmp/stage1root//etc/init.d/hostname
lrwxrwxrwx 1 root root 35 Dec 23 18:40 keymaps -> /tmp/stage1root//etc/init.d/keymaps
lrwxrwxrwx 1 root root 38 Dec 23 18:40 localmount -> /tmp/stage1root//etc/init.d/localmount
lrwxrwxrwx 1 root root 35 Dec 23 18:40 modules -> /tmp/stage1root//etc/init.d/modules
lrwxrwxrwx 1 root root 34 Dec 23 18:40 net.lo -> /tmp/stage1root//etc/init.d/net.lo
lrwxrwxrwx 1 root root 37 Dec 23 18:40 rmnologin -> /tmp/stage1root//etc/init.d/rmnologin
lrwxrwxrwx 1 root root 35 Dec 23 18:40 urandom -> /tmp/stage1root//etc/init.d/urandom

My emerge --info :

Portage 2.1_rc1-r1 (default-linux/x86/2006.0, gcc-3.4.5, glibc-2.3.6-r3, 2.6.16-gentoo-r7 i686)
=================================================================
System uname: 2.6.16-gentoo-r7 i686 Intel(R) Pentium(R) M processor 1.86GHz
Gentoo Base System version 1.12.0_pre19
distcc 2.18.3 i686-pc-linux-gnu (protocols 1 and 2) (default port 3632) [disabled]
dev-lang/python:     2.3.5-r2, 2.4.2
dev-python/pycrypto: 2.0.1-r5
dev-util/ccache:     [Not Present]
dev-util/confcache:  [Not Present]
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r1
sys-devel/binutils:  2.16.1
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r2
ACCEPT_KEYWORDS="x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-march=pentium-m -O3 -fomit-frame-pointer -funroll-loops -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /usr/share/texmf/dvipdfm/config/ /usr/share/texmf/dvips/config/ /usr/share/texmf/tex/generic/config/ /usr/share/texmf/tex/platex/config/ /usr/share/texmf/xdvi/ /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/splash /etc/terminfo /etc/env.d"
CXXFLAGS="-march=pentium-m -O3 -fomit-frame-pointer -funroll-loops -pipe"
DISTDIR="/usr/portage/distfiles"
FEATURES="autoconfig distlocks metadata-transfer sandbox sfperms strict"
GENTOO_MIRRORS="http://kim/gentoo/ ftp://ftp.free.fr/mirrors/ftp.gentoo.org/ http://linux.rz.ruhr-uni-bochum.de/download/gentoo-mirror/ http://gentoo.mirror.sdv.fr ftp://ftp.tu-clausthal.de/pub/linux/gentoo/"
MAKEOPTS="-j2"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude='/distfiles' --exclude='/local' --exclude='/packages'"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage /usr/portage/local/layman/vmware /usr/portage/local/layman/gentopia /usr/portage/local/layman/xgl-coffee-testing"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="x86 X aac aalib acpi alsa asf avahi avi beagle berkdb bitmap-fonts bzip2 cdr cli crypt cups dbus dri dts dvd dvdr eds emboss encode evolution ffmpeg firefox flac foomaticdb fortran gd gdbm gif gimp glitz gmail gnome gpm gstreamer gtk gtk2 hal imagemagick imlib isdnlog java jpeg kde lcms libg++ libwww logrotate mad mikmod mmx mng mono motif mp3 mpeg musicbrainz nautilus ncurses nls nptl nptlonly nsplugin nvidia ogg opengl oss pam pcmcia pcre pdf pdflib perl pic png pop ppds pppd python qt quicktime readline real reflection samba scanner sdl session spell spl sse sse2 ssl subversion svg tcpd threads tiff truetype truetype-fonts type1-fonts udev usb visualization vorbis win32codecs wv xcomposite xine xml xmms xorg xscreensaver xv zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux userland_GNU video_cards_nv video_cards_nvidia video_cards_vesa"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LANG, LC_ALL, LDFLAGS, LINGUAS, PORTAGE_RSYNC_EXTRA_OPTS
Comment 1 SpanKY gentoo-dev 2006-05-22 23:15:26 UTC

*** This bug has been marked as a duplicate of 114923 ***
Comment 2 SpanKY gentoo-dev 2006-05-22 23:28:29 UTC
wrong dupe
Comment 3 SpanKY gentoo-dev 2006-05-22 23:28:57 UTC

*** This bug has been marked as a duplicate of 103275 ***