Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 133128 - gentoo-sources 2.6.16-r7 breaks cpu scaling?
Summary: gentoo-sources 2.6.16-r7 breaks cpu scaling?
Status: VERIFIED UPSTREAM
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Kernel Bug Wranglers and Kernel Maintainers
URL: http://bugzilla.kernel.org/show_bug.c...
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-12 08:45 UTC by Jeremy Olexa (darkside) (RETIRED)
Modified: 2007-01-10 03:49 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments
gentoo-sources 2.6.16-r7 kernel config (config,35.88 KB, text/plain)
2006-05-12 09:04 UTC, Jeremy Olexa (darkside) (RETIRED)
Details
full dmesg output (new.dmesg,28.94 KB, text/plain)
2006-05-18 14:22 UTC, Jeremy Olexa (darkside) (RETIRED)
Details
disabled crypt testing, dmesg output after clearing it and reboot (dmesg.nocrypt,16.81 KB, text/plain)
2006-05-18 15:24 UTC, Jeremy Olexa (darkside) (RETIRED)
Details
2.6.17_rc4 config (config,35.57 KB, text/plain)
2006-05-20 13:32 UTC, Jeremy Olexa (darkside) (RETIRED)
Details
dmesg output for 2.6.17_rc4 (vanilla_dmesg,15.26 KB, text/plain)
2006-05-20 13:33 UTC, Jeremy Olexa (darkside) (RETIRED)
Details
gentoo-sources 2.6.15-r1 config (config,36.07 KB, text/plain)
2006-05-20 14:31 UTC, Jeremy Olexa (darkside) (RETIRED)
Details
2.6.15 dmesg output (2.6.15-r1.dmesg,28.91 KB, text/plain)
2006-05-20 14:32 UTC, Jeremy Olexa (darkside) (RETIRED)
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-12 08:45:52 UTC
After upgrading from 2.6.15 to 2.6.16 I found that there appears to be a bug in the kernel regarding cpu_freq

Upon boot I get the message that "cpufreqd needs CONFIG_CPU_FREQ compiled into the kernel." Of course this is built in.

I also get these errors:
% sudo modprobe acpi-cpufreq 
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.16-gentoo-r7/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device
% sudo modprobe acpi_cpufreq 
FATAL: Error inserting acpi_cpufreq (/lib/modules/2.6.16-gentoo-r7/kernel/arch/i386/kernel/cpu/cpufreq/acpi-cpufreq.ko): No such device
% ls /lib/modules/2.6.16-gentoo-r7/kernel/arch/i386/kernel/cpu/cpufreq/
acpi-cpufreq.ko  speedstep-ich.ko  speedstep-lib.ko  speedstep-smi.ko

Kernel config is located here: http://www-users.cs.umn.edu/~olexa/config

Please let me know if you need anymore information. I had no problems with 2.6.15, but I am trying to resolve other issues that I hope that this kernel would help with..now this. Thanks for your help.
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-05-12 08:47:54 UTC
Please, don't refer to external links, attach the config here.

http://bugs.gentoo.org/attachment.cgi?bugid=133128&action=enter
Comment 2 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-12 09:04:45 UTC
Created attachment 86655 [details]
gentoo-sources 2.6.16-r7 kernel config
Comment 3 Daniel Drake (RETIRED) gentoo-dev 2006-05-15 08:41:31 UTC
Please attach dmesg output after trying to load those modules
Comment 4 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-18 12:08:59 UTC
There was no dmesg output after attempting to load the acpi-cpufreq module. From looking at other bug reports I would have to guess that acpi is fixed in 2.6.17, I will try 2.6.17 vanilla after it becomes stable and report back. I am using 2.5.15-r1 gentoo sources now to take advantage of acpi.
Comment 5 Daniel Drake (RETIRED) gentoo-dev 2006-05-18 12:36:17 UTC
The fact that nothing might not be produced after you load them wasn't the point I was trying to get at. We need to see dmesg output.

Also, we only wait for newer kernels to come out as a last resort. With your help, we want to fix 2.6.16 in the tree. The first thing to do is show us some logs. The next thing is to test the latest development kernel, currently 2.6.17-rc4.
Comment 6 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-18 14:21:34 UTC
Ok, I am back in 2.6.16-gentoo-r7 so I can help you help me (and others).

I am attaching a dmesg that I cleared out before rebooting, so this is the entire log.

Please let me know what else you will need to troubleshoot this.
Comment 7 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-18 14:22:53 UTC
Created attachment 87015 [details]
full dmesg output
Comment 8 Daniel Drake (RETIRED) gentoo-dev 2006-05-18 14:43:56 UTC
That dmesg dump is missing lots of interesting content due to the verbose crypto testing. Please disable CONFIG_CRYPTO_TEST and try again.
Comment 9 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-18 15:24:37 UTC
Created attachment 87021 [details]
disabled crypt testing, dmesg output after clearing it and reboot
Comment 10 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-20 13:31:06 UTC
It is rather interesting that cpu throttling is still not available with vanilla 2.6.17_rc4. When booting I get a message "cpufeqd reuires CONFIG_CPU_FREQ in the kernel" I have double checked that it is checked in the the kernel config and everything appears to be right? Is there a bigger problem upstream?
Comment 11 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-20 13:32:49 UTC
Created attachment 87145 [details]
2.6.17_rc4 config
Comment 12 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-20 13:33:58 UTC
Created attachment 87146 [details]
dmesg output for 2.6.17_rc4
Comment 13 Daniel Drake (RETIRED) gentoo-dev 2006-05-20 14:03:46 UTC
Thanks. Is it also possible to see dmesg and .config from 2.6.15?
Comment 14 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-20 14:31:47 UTC
Created attachment 87149 [details]
gentoo-sources 2.6.15-r1 config
Comment 15 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-20 14:32:32 UTC
Created attachment 87150 [details]
2.6.15 dmesg output
Comment 16 Daniel Drake (RETIRED) gentoo-dev 2006-05-21 08:45:37 UTC
Ok, thanks. Yes, it seems to be an upstream bug/regression. Please file a bug report at http://bugzilla.kernel.org for this and post the new URL here. In your report:

Mention that 2.6.15 worked, 2.6.16 fails, 2.6.17-rc4 is still broken
Explain that the problem appears to be the acpi-cpufreq module refusing to load
Include dmesg and config from 2.6.17-rc4

Comment 17 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-05-21 14:08:02 UTC
After some searching I found that there is allready a bug in the bugzilla for the linux kernel and a fix is "in the works"

http://bugzilla.kernel.org/show_bug.cgi?id=6474
Comment 18 Daniel Drake (RETIRED) gentoo-dev 2006-05-21 14:42:55 UTC
Thanks, will keep an eye on that.
Comment 19 Jeremy Olexa (darkside) (RETIRED) archtester Gentoo Infrastructure gentoo-dev Security 2006-06-06 17:06:31 UTC
It looks like there is a new driver/module upstream. Let me know what version of gentoo-sources/vanilla-sources to test and I can confim for you. I am not sure what version the code fix will first show up in.
Comment 20 Daniel Drake (RETIRED) gentoo-dev 2007-01-10 03:49:18 UTC
upstream bug is closed