Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 133058 - curl-7.15.1-r1 krb4 forces kth-krb while mit-krb5 +krb4 might be available
Summary: curl-7.15.1-r1 krb4 forces kth-krb while mit-krb5 +krb4 might be available
Status: RESOLVED DUPLICATE of bug 2272
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Gentoo Linux bug wranglers
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-05-11 13:03 UTC by ibm
Modified: 2006-05-11 13:56 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description ibm 2006-05-11 13:03:16 UTC
curl +krb4 automatically pulls in kth-krb, while I think that mit-krb5 with +krb4 would be a valid way to satisfy the dependency. note that kerberos depends on virtual/krb5 which can be satisfied with mit-krb5.

I'd supply a patch, but I don't know how to express the dependency of "mit-krb5 compiled with +krb4"
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-05-11 13:11:56 UTC
(In reply to comment #0)
> I'd supply a patch, but I don't know how to express the dependency of "mit-krb5
> compiled with +krb4"

There's no way to express such dependency (yet). 



*** This bug has been marked as a duplicate of 2272 ***
Comment 2 ibm 2006-05-11 13:56:43 UTC
(In reply to comment #1)
> (In reply to comment #0)
> > I'd supply a patch, but I don't know how to express the dependency of "mit-krb5
> > compiled with +krb4"
> 
> There's no way to express such dependency (yet). 

Well, it could be done how e.g. evolution does it, i.e. depend on virtual/krb5 (and in this case || kth-krb) and if mit-krb5 is detected, fail if kth-krb is not around and it wasn't compiled with krb4.

But really it would be ideal if this could be done directly as a dependency.