Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 132556 - wvstreams-4.2.2-r1: -Wl,--as-needed fix + cleanup
Summary: wvstreams-4.2.2-r1: -Wl,--as-needed fix + cleanup
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: [OLD] Library (show other bugs)
Hardware: All Linux
: High normal (vote)
Assignee: Alin Năstac (RETIRED)
Depends on:
Blocks: as-needed
  Show dependency tree
Reported: 2006-05-07 05:38 UTC by TGL
Modified: 2006-05-10 12:11 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---

files/wvstreams-4.2.2-as-needed.patch (wvstreams-4.2.2-as-needed.patch,1.64 KB, patch)
2006-05-07 05:38 UTC, TGL
Details | Diff
wvstreams-4.2.2-ebuild.patch (wvstreams-4.2.2-ebuild.patch,1.74 KB, patch)
2006-05-07 05:39 UTC, TGL
Details | Diff

Note You need to log in before you can comment on or make changes to this bug.
Description TGL 2006-05-07 05:38:03 UTC
wvstreams-4.2.2 doesn't compile with -Wl,--as-needed, because its weird Makefiles system puts some .so libs in the linker arguments, before the objects using them (and thus they are skipped).  And also, the way the configure script puts -lqt-mt in LDFLAGS was making Qt detection to silently fail (the coresponding lib was not built despite USE="qt"). The attached "wstreams-4.2.2-as-needed.patch" fixes both this issues.

I will also attach an ebuild patch which applies the previous one, and in addition cleanups a few things:
 - "tcltk" USE flag is not useful in this package: it will only add libtcl to the linked libs (for people who don't use --as-needed at least), but nothing uses it because the rules which trigger building the tcl bindings (and other swig-based bindings) are disabled in  So i have dropped everything related to tcl/swig from the ebuild (i guess nothing in Portage was using it, since obviously it would not have worked). Sure, the other way around would have been to uncomment the said rules in and see what happens, but i've not tried that.
 - removed "gtk" from IUSE, since it is not used
 - moved autoconf from src_compile to src_unpack, since i think that's where it belongs (no need to rerun it on every "ebuild ... compile")
Comment 1 TGL 2006-05-07 05:38:49 UTC
Created attachment 86352 [details, diff]
Comment 2 TGL 2006-05-07 05:39:06 UTC
Created attachment 86353 [details, diff]
Comment 3 Alin Năstac (RETIRED) gentoo-dev 2006-05-10 12:11:27 UTC
fixed in 4.2.2-r2.
good job!