Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 132029 - monkeystudio (new ebuild)
Summary: monkeystudio (new ebuild)
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: New packages (show other bugs)
Hardware: All Linux
: Normal enhancement (vote)
Assignee: Qt Bug Alias
URL: http://sourceforge.net/projects/monke...
Whiteboard:
Keywords: EBUILD
: 247689 290842 (view as bug list)
Depends on:
Blocks:
 
Reported: 2006-05-02 09:01 UTC by Andy Gebauer
Modified: 2012-07-03 17:23 UTC (History)
5 users (show)

See Also:
Package list:
Runtime testing required: ---


Attachments
First ebuild release (qt4ds-1.0.0_rc2-r3.ebuild,1.29 KB, text/plain)
2006-05-02 09:02 UTC, Andy Gebauer
Details
QT4DS-1.5.0 ebuild (qt4ds-1.5.0.ebuild,1.54 KB, text/plain)
2006-05-11 04:03 UTC, Andy Gebauer
Details
monkeystudio-1.8.4.0.ebuild (monkeystudio-1.8.4.0.ebuild,822 bytes, text/plain)
2010-10-29 19:53 UTC, Vladimir
Details

Note You need to log in before you can comment on or make changes to this bug.
Description Andy Gebauer 2006-05-02 09:01:50 UTC
A new ebuild for the QT4 IDE
QT4DS

Compilation, merging, icon merging and menu entry is working.

Translation and doc isn't working, don't know why.
Must test in the next days
Comment 1 Andy Gebauer 2006-05-02 09:02:35 UTC
Created attachment 85998 [details]
First ebuild release
Comment 2 Andy Gebauer 2006-05-11 04:03:57 UTC
Created attachment 86602 [details]
QT4DS-1.5.0 ebuild

A new version of qt4ds was released. This is the updated ebuild.
All, also the doc and the translations are working.
Comment 3 Nox P@sNox 2006-05-19 00:18:01 UTC
Hi,

I'm P@sNox, the main developer of Qt4DS Monkey.
Please use sourceforge to report bugs, feedback and all u want.

I need feedback from Mac users ( really !! )

Thanks, P@sNox,
Comment 4 Stefan Schweizer (RETIRED) gentoo-dev 2006-06-25 15:33:09 UTC
tha homepage an the name has changed
Comment 5 Tiziano Müller gentoo-dev 2006-06-25 15:40:59 UTC
Well, a new ebuild for version 1.5.1 is now in gentoo-sunrise overlay, available at http://gentoo-sunrise.org/svn/sunrise/dev-util/monkeystudio
Comment 6 Christian Lemke 2007-08-04 09:34:25 UTC
I use Qt 4.3.0-r2 and monkeystudio-1.5.2 (ebuild from sunrise) does not compile:

g++ -c -pipe -O2 -march=prescott -pipe -D_REENTRANT -Wall -W -DQT_NO_DEBUG -DQT_SCRIPT_LIB -DQT_XML_LIB -DQT_GUI_LIB -DQT_CORE_LIB -DQT_SHARED -I/usr/share/qt4/mkspecs/linux-g++ -I. -I/usr/include/qt4/QtAssistantClient -I/usr/include/qt4/QtAssistant -I/usr/include/qt4/QtDesigner -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtCore -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtGui -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtXml -I/usr/include/qt4/QtScript -I/usr/include/qt4/QtScript -I/usr/include/qt4 -I. -Isrc -Isrc/ui -Isrc/3rdparty/TextEditor/src -Isrc/3rdparty/TextEditor/src/ui -Ibuild/.moc -I/usr/include -Ibuild/.ui -o build/.o/unix/MDIText.o src/MDIText.cpp
/usr/include/qt4/QtGui/qsyntaxhighlighter.h: In member function »void QSyntaxHighlighter::qt_check_for_QOBJECT_macro(const T&) const [with T = CppSyntaxHighlighter]«:
/usr/include/qt4/QtCore/qobject.h:411:   instantiated from »T qobject_cast(QObject*) [with T = CppSyntaxHighlighter*]«
src/MDIChild.cpp:63:   instantiated from here
/usr/include/qt4/QtGui/qsyntaxhighlighter.h:48: Fehler: void-Wert nicht ignoriert wie es sein sollte
make: *** [build/.o/unix/MDIChild.o] Fehler 1
make: *** Warte auf noch nicht beendete Prozesse...



# emerge --info
Portage 2.1.3.3 (default-linux/x86/2006.1, gcc-4.2.0, glibc-2.6-r0, 2.6.22-gentoo-r1 i686)
=================================================================
System uname: 2.6.22-gentoo-r1 i686 Intel(R) Core(TM)2 CPU 6600 @ 2.40GHz
Gentoo Base System release 1.12.10
Timestamp of tree: Sat, 04 Aug 2007 07:20:01 +0000
dev-java/java-config: 1.3.7, 2.0.33-r1
dev-lang/python:     2.4.4-r4
dev-python/pycrypto: 2.0.1-r6
sys-apps/sandbox:    1.2.18.1
sys-devel/autoconf:  2.13, 2.61-r1
sys-devel/automake:  1.4_p6, 1.5, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2, 1.10
sys-devel/binutils:  2.17-r1
sys-devel/gcc-config: 1.3.16
sys-devel/libtool:   1.5.24
virtual/os-headers:  2.6.22-r2
ACCEPT_KEYWORDS="x86 ~x86"
AUTOCLEAN="yes"
CBUILD="i686-pc-linux-gnu"
CFLAGS="-O2 -march=prescott -mfpmath=sse -pipe"
CHOST="i686-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/share/X11/xkb /usr/share/config /var/www/localhost/htdocs"
CONFIG_PROTECT_MASK="/etc/env.d /etc/env.d/java/ /etc/gconf /etc/php/apache2-php5/ext-active/ /etc/php/cgi-php5/ext-active/ /etc/php/cli-php5/ext-active/ /etc/revdep-rebuild /etc/splash /etc/terminfo /etc/texmf/web2c"
CXXFLAGS="-O2 -march=prescott -mfpmath=sse -pipe"
DISTDIR="/mnt/D/distfiles"
FEATURES="distlocks sandbox sfperms strict unmerge-orphans userfetch"
GENTOO_MIRRORS="http://ftp.tu-ilmenau.de/Mirrors/gentoo http://mirrors.sec.informatik.tu-darmstadt.de/gentoo"
LANG="de_DE@euro"
LC_ALL="de_DE@euro"
LDFLAGS="-Wl,-O1 -Wl,-z,now -Wl,--as-needed"
LINGUAS="de en"
MAKEOPTS="-j6"
PKGDIR="/usr/portage/packages"
PORTAGE_RSYNC_EXTRA_OPTS="--exclude-from=/etc/portage/rsync_excludes"
PORTAGE_RSYNC_OPTS="--recursive --links --safe-links --perms --times --compress --force --whole-file --delete --delete-after --stats --timeout=180 --exclude=/distfiles --exclude=/local --exclude=/packages --filter=H_**/files/digest-*"
PORTAGE_TMPDIR="/var/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/portage/local/layman/lila-theme /usr/portage/local/layman/zugaina /usr/portage/local/layman/sunrise /usr/portage/local/layman/gentoo-de /usr/portage/local/layman/xwing /usr/portage/local/layman/vmware /usr/local/portage"
SYNC="rsync://rsync.europe.gentoo.org/gentoo-portage"
USE="X aac acpi alsa arts bash-completion berkdb bitmap-fonts branding bzip2 cairo cdinstall cdparanoia cdr cli cracklib crypt cups d dbus doc dri dts dv dvd dvdr dvdread encode exif expat fbcon ffmpeg fuse gdbm gif glut gmp gphoto2 gpm hal iconv idn imagemagick ipv6 isdnlog java jikes jpeg jpeg2k kde kdeenablefinal kdehiddenvisibility libg++ lm_sensors mad matroska midi mmx mng mp3 mudflap musepack mysql ncurses nls nptl nptlonly nvidia ogg opengl openmp pam pcre pdf perl pertty png ppds pppd python qt3 qt4 rdesktop readline reflection samba sasl scanner sdl session slang source spl sqlite sqlite3 sse sse2 ssl svga tcpd theora threads tiff truetype truetype-fonts type1-fonts usb vcd vim-syntax vorbis win32codecs x86 xine xml xorg xprint xv xvid xvmc zlib" ALSA_CARDS="emu10k1 hda-intel" ALSA_PCM_PLUGINS="adpcm alaw asym copy dmix dshare dsnoop empty extplug file hooks iec958 ioplug ladspa lfloat linear meter mulaw multi null plug rate route share shm softvol" ELIBC="glibc" INPUT_DEVICES="keyboard mouse" KERNEL="linux" LCD_DEVICES="bayrad cfontz cfontz633 glk hd44780 lb216 lcdm001 mtxorb ncurses text" LINGUAS="de en" USERLAND="GNU" VIDEO_CARDS="v4l nvidia nv"
Unset:  CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, PORTAGE_COMPRESS, PORTAGE_COMPRESS_FLAGS
Comment 7 Jeroen Roovers gentoo-dev 2008-11-20 22:50:17 UTC
*** Bug 247689 has been marked as a duplicate of this bug. ***
Comment 8 Jeroen Roovers gentoo-dev 2008-11-22 16:46:20 UTC
*** Bug 247689 has been marked as a duplicate of this bug. ***
Comment 9 Markos Chandras (RETIRED) gentoo-dev 2009-06-29 18:38:22 UTC
I will take that on behalf of Qt herd
Comment 10 Vladimir 2010-10-29 19:53:58 UTC
Created attachment 252513 [details]
monkeystudio-1.8.4.0.ebuild

Here is a new .ebuild for Monkey Studio 1.8.4.0
Comment 11 Michael Palimaka (kensington) gentoo-dev 2012-04-02 19:50:40 UTC
I just pushed 1.9.0.1 to sunrise and the QT overlay.
Comment 12 Mike Gilbert gentoo-dev 2012-04-02 20:07:07 UTC
*** Bug 290842 has been marked as a duplicate of this bug. ***
Comment 13 Michael Palimaka (kensington) gentoo-dev 2012-07-03 17:23:22 UTC
This is now in the tree, thanks everyone!

+  03 Jul 2012; Michael Palimaka <kensington@gentoo.org> +metadata.xml,
+  +monkeystudio-1.9.0.2.ebuild:
+  Initial commit wrt bug #132029. Thanks to Andy Gebauer, Vladimir, and everyone
+  in Sunrise.