Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bug 1316 - Pam-0.75-r4 couldn't find a file
Summary: Pam-0.75-r4 couldn't find a file
Alias: None
Product: Portage Development
Classification: Unclassified
Component: Unclassified (show other bugs)
Hardware: All Linux
: Normal major (vote)
Assignee: Martin Schlemmer (RETIRED)
Depends on:
Reported: 2002-03-23 06:34 UTC by Bram Voorzaat
Modified: 2011-10-30 22:19 UTC (History)
0 users

See Also:
Package list:
Runtime testing required: ---


Note You need to log in before you can comment on or make changes to this bug.
Description Bram Voorzaat 2002-03-23 06:34:39 UTC
During the installation process [ emerge system ] pam-0.75-r4 didn't compile, 
because it can't find /var/lib/portage/pam-0.75-
Comment 1 Daniel Robbins (RETIRED) gentoo-dev 2002-03-23 12:05:36 UTC
It worked for me and a few other people.  Could you try doing an emerge rsync 
and try building it again?
Comment 2 Martin Schlemmer (RETIRED) gentoo-dev 2002-03-24 03:14:37 UTC
What version of gcc ?
Comment 3 Bram Voorzaat 2002-03-24 03:46:34 UTC
I have just done everything according to the 'Build from scratch'-instructions 
at , so I don't have a special version of 
GCC. In make.conf, I selected all USE-options, including the optional lines. 
Because I have an AMD Athlon processor, I selected the i686 architecture. 

When I go to the /var/tmp/portage/pam-0.75-r4/work/Linux-PAM-
0.75/modules/pam_userdb directory and run make, it says it is 'skipping this 
module on this platform'. Disabling the berkdb USE-flag in make.conf does not 
solve this problem.
Comment 4 Bram Voorzaat 2002-03-24 07:40:42 UTC
Oops, it actually says "This module will not be compiled on this system"
Comment 5 Bram Voorzaat 2002-03-24 13:21:02 UTC
Ok, by running 'emerge db' prior to 'emerge system', I solved this problem. 
However, I don't know why 'db' doesn't get installed automatically, because it 
is defined as a dependency in pam-0.75-r4.ebuild