Gentoo Websites Logo
Go to: Gentoo Home Documentation Forums Lists Bugs Planet Store Wiki Get Gentoo!
Bugzilla DB migration completed. Please report issues to Infra team via email via infra@gentoo.org or IRC
Bug 131505 - emerge emacs-cvs-22.0.50-r2 aborts with segmentation fault
Summary: emerge emacs-cvs-22.0.50-r2 aborts with segmentation fault
Status: RESOLVED FIXED
Alias: None
Product: Gentoo Linux
Classification: Unclassified
Component: Current packages (show other bugs)
Hardware: AMD64 Linux
: High normal (vote)
Assignee: Emacs project
URL:
Whiteboard:
Keywords:
Depends on:
Blocks:
 
Reported: 2006-04-27 13:30 UTC by José Romildo Malaquias
Modified: 2019-11-18 15:39 UTC (History)
1 user (show)

See Also:
Package list:
Runtime testing required: ---


Attachments

Note You need to log in before you can comment on or make changes to this bug.
Description José Romildo Malaquias 2006-04-27 13:30:36 UTC
emerge emacs-cvs fails with a segmentation fault:

# emerge -v emacs-cvs
Calculating dependencies... done!
>>> Emerging (1 of 1) app-editors/emacs-cvs-22.0.50-r2 to /
[...]
(cd lisp; make -w bootstrap EMACS=../src/bootstrap-emacs)
make[2]: Entering directory `/small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp'
wd=/small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp; subdirs=`(cd $wd; find . -type d -print)`; for file in $subdirs; do case $file in */Old | */RCS | */CVS | */CVS/* | */.* | */.*/* | */=* ) ;; *) wins="$wins $wd/$file" ;; esac; done; \
	for file in $wins; do \
	   /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/../update-subdirs $file; \
	done;
wd=/small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp; subdirs=`(cd $wd; find . -type d -print)`; for file in $subdirs; do case $file in */Old | */RCS | */CVS | */CVS/* | */.* | */.*/* | */=* ) ;; *) wins="$wins $wd/$file" ;; esac; done; \
	echo Directories: $wins; \
	../src/bootstrap-emacs -batch --no-site-file --multibyte -l autoload --eval '(setq generated-autoload-file "/small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/loaddefs.el")' -f batch-update-autoloads $wins
Directories: /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/. /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./erc /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./net /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./url /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./calc /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./gnus /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./mail /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./mh-e /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./play /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./term /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./emulation /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./international /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./calendar /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./eshell /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./emacs-lisp /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./textmodes /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./progmodes /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./language /small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/./obsolete
/bin/sh: line 2:  3462 Segmentation fault      ../src/bootstrap-emacs -batch --no-site-file --multibyte -l autoload --eval '(setq generated-autoload-file "/small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp/loaddefs.el")' -f batch-update-autoloads $wins
make[2]: *** [autoloads] Error 139
make[2]: Leaving directory `/small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs/lisp'
make[1]: *** [bootstrap-build] Error 2
make[1]: Leaving directory `/small/tmp/portage/emacs-cvs-22.0.50-r2/work/emacs'
make: *** [bootstrap] Error 2

!!! ERROR: app-editors/emacs-cvs-22.0.50-r2 failed.
Call stack:
  ebuild.sh, line 1525:   Called dyn_compile
  ebuild.sh, line 928:   Called src_compile
  emacs-cvs-22.0.50-r2.ebuild, line 125:   Called die

!!! make emacs bootstrap failed
!!! If you need support, post the topmost build error, and the call stack if relevant.




# emerge --info
Gentoo Base System version 1.12.0_pre18
Portage 2.1_pre9-r4 (default-linux/amd64/2006.0, gcc-3.4.6, glibc-2.4-r1, 2.6.16-gentoo-r4 x86_64)
=================================================================
System uname: 2.6.16-gentoo-r4 x86_64 AMD Athlon(tm) 64 Processor 3000+
dev-lang/python:     2.4.2-r1
sys-apps/sandbox:    1.2.17
sys-devel/autoconf:  2.13, 2.59-r7
sys-devel/automake:  1.4_p6, 1.5, 1.6.3, 1.7.9-r1, 1.8.5-r3, 1.9.6-r2
sys-devel/binutils:  2.16.1-r2
sys-devel/libtool:   1.5.22
virtual/os-headers:  2.6.11-r3
ACCEPT_KEYWORDS="amd64 ~amd64"
AUTOCLEAN="yes"
CBUILD="x86_64-pc-linux-gnu"
CFLAGS="-march=k8 -O2 -pipe"
CHOST="x86_64-pc-linux-gnu"
CONFIG_PROTECT="/etc /usr/kde/2/share/config /usr/kde/3.5/env /usr/kde/3.5/share/config /usr/kde/3.5/shutdown /usr/kde/3/share/config /usr/share/X11/xkb /usr/share/config /var/qmail/control"
CONFIG_PROTECT_MASK="/etc/eselect/compiler /etc/gconf /etc/revdep-rebuild /etc/terminfo /etc/texmf/web2c /etc/env.d"
CXXFLAGS="-march=k8 -O2 -pipe"
DISTDIR="/usr/local/portage/distfiles"
FEATURES="autoconfig buildpkg collision-protect distlocks metadata-transfer multilib-strict sandbox sfperms strict usersandbox"
GENTOO_MIRRORS="http://distfiles.gentoo.org http://distro.ibiblio.org/pub/linux/distributions/gentoo"
LANG="en_US.ISO-8859-1"
LINGUAS="en pt_BR fr de"
MAKEOPTS="-j2"
PKGDIR="/usr/local/portage/packages.amd64"
PORTAGE_TMPDIR="/small/tmp"
PORTDIR="/usr/portage"
PORTDIR_OVERLAY="/usr/local/portage"
SYNC="rsync://rsync.gentoo.org/gentoo-portage"
USE="amd64 3dnowex X Xaw3d a52 aac aalib alsa avi berkdb bitmap-fonts bzip2 cdr cli crypt cups divx4linux dlloader dri dts dvd dvdr dvdread emacs emboss encode fam fbcon ffmpeg firefox foomaticdb gd gif gnome gpm gtk gtk2 imagemagick imap imlib isdnlog javascript jpeg kde kdeenablefinal libcaca lirc lzw lzw-tiff mad matroska mbox mp3 mpeg ncurses nls nptl nptlonly nsplugin nvidia ogg opengl pam pcre pdflib plotutils png ppds pppd python qt readline reflection samba sdl session spell spl ssl svg tcpd tetex tiff truetype truetype-fonts type1-fonts usb v4l v4l2 vcd vorbis wmf xface xml xml2 xorg xpm xv xvmc zlib elibc_glibc input_devices_keyboard input_devices_mouse kernel_linux linguas_en linguas_pt_BR linguas_fr linguas_de userland_GNU video_cards_nvidia video_cards_nv video_cards_v4l video_cards_vesa"
Unset:  ASFLAGS, CTARGET, EMERGE_DEFAULT_OPTS, INSTALL_MASK, LC_ALL, LDFLAGS
Comment 1 Jakub Moc (RETIRED) gentoo-dev 2006-04-27 13:35:04 UTC
Can you reproduce the problem, i.e. - does it fail again at *exactly* the same spot?
Comment 2 José Romildo Malaquias 2006-04-28 05:09:30 UTC
Yes, the problem is reproducible. Currently I cannot emerge emacs-cvs. Compilations always stops with the same error, at the same spot.
Comment 3 José Romildo Malaquias 2006-04-28 05:10:26 UTC
The problem is reproducible.
Comment 4 Matthew Kennedy (RETIRED) gentoo-dev 2006-04-28 08:03:30 UTC
Jos
Comment 5 Matthew Kennedy (RETIRED) gentoo-dev 2006-04-28 08:03:30 UTC
José, please try the following and report results back to this bug.  Edit /usr/portage/app-editors/emacs-cvs/emacs-cvs-22.0.50-r2.ebuild, goto the src_compile() function, and insert a line

    export SANDBOX_ON=0

Right after the opening brace (ie. insert it as the 1st line in the function).
Comment 6 José Romildo Malaquias 2006-04-28 14:09:30 UTC
With
export SANDBOX_ON=0
Comment 7 José Romildo Malaquias 2006-04-28 14:11:40 UTC
With "export SANDBOX_ON=0" emacs-cvs emerges successfully.
Comment 8 Matthew Kennedy (RETIRED) gentoo-dev 2006-04-28 22:03:56 UTC
Thanks for testing this and replying so soon.  I will reinsert export SANDBOX_ON=0 for the emacs-cvs ebuild.